VSA (R&S FSW-K70)
Contents
  • Welcome to the Vector Signal Analysis Application
  • Measurements and Result Displays
  • 200Measurement Basics
  • Configuration
  • Analysis
  • I/Q Data Import and Export
  • How to Perform Vector Signal Analysis
  • Measurement Examples
  • Optimizing and Troubleshooting the Measurement
  • Remote Commands for VSA
  • List of Commands
Top


Welcome to the Vector Signal Analysis Application

VSA (R&S FSW-K70) > Welcome to the Vector Signal Analysis Application
Welcome to the Vector Signal Analysis Application

The R&S FSW-K70 is a firmware application that adds functionality to perform Vector Signal Analysis (VSA) to the R&S FSW.

The VSA application performs vector and scalar measurements on digitally modulated single-carrier signals. To perform the measurements it converts RF signals into the complex baseband.

It can also use the optional Digital Baseband interface (R&S FSW-B17 option) to analyze I/Q signals already delivered to the complex baseband.

The VSA application features:

  • Flexible modulation analysis from MSK to 1024QAM
  • Numerous standard-specific default settings
  • Various graphical, numerical and statistical evaluations and result displays
  • Spectrum analyses of the measurement and error signal
  • Flexible burst search for the analysis of complex signal combinations, short bursts or signal mix

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

(http://www2.rohde-schwarz.com/product/FSW.html).

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the VSA Application
  • Understanding the Display Information


Starting the VSA Application

VSA (R&S FSW-K70) > Welcome to the Vector Signal Analysis Application > Starting the VSA Application
Starting the VSA Application

The VSA application adds a new application to the R&S FSW.

To activate the VSA application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "VSA" item.

    The R&S FSW opens a new measurement channel for the VSA application.

For details see "Applications and Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the VSA "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (as well as the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

VSA (R&S FSW-K70) > Welcome to the Vector Signal Analysis Application > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during analyzer operation. All different information areas are labeled. They are explained in more detail in the following sections.

1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area
5 = Diagram footer with diagram-specific information, depending on measurement application
6 = Instrument status bar with error messages, progress bar and date/time display
MSRA/MSRT operating mode

In MSRA and MSRT operating mode, additional tabs and elements are available. A colored background of the screen behind the measurement channel tabs indicates that you are in MSRA/MSRT operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Channel bar information

In VSA application, the R&S FSW shows the following settings:

Information displayed in the channel bar in VSA application
Ref Level | Reference level
Freq | Center frequency for the RF signal
Mod | Modulation type, if no standard is active (or default standard is changed)
Res Len | Result Length
SR | Symbol Rate
Att | Mechanical and electronic RF attenuation
Offset | Reference level offset
Cap Len | Capture Length (instead of result length for capture buffer display), see "Capture Length Settings"
Input | Input type of the signal source, see "Input Settings"
Burst | Burst search active (see "Enabling Burst Searches")
Pattern | Pattern search active (see "Enabling Pattern Searches")
Stat Count | Statistics count for averaging and other statistical operations, see "Statistic Count"; cannot be edited directly
Capt Count | Capture count; the current number of captures performed if several captures are necessary to obtain the number of results defined by "Statistics Count"; cannot be edited directly
SGL | The sweep is set to single sweep mode.

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer or trigger settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in VSA application
1 = Window name
2 = Result type
3 = Data source type
4 = Trace color
5 = Displayed signal for Meas&Ref data source: M (Meas) or R (Ref)
6 = Trace mode
Diagram area

The diagram area displays the results according to the selected result displays (see "Measurements and Result Displays").

Diagram footer information

The diagram footer (beneath the diagram) contains the start and stop symbols or time of the evaluation range.

Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


Measurements and Result Displays

VSA (R&S FSW-K70) > Measurements and Result Displays
Measurements and Result Displays

Various different result displays for VSA measurements are available. Which result types are available depends on the selected data source. You can define which part of the measured signal is to be evaluated and displayed.

The determined result and evaluation ranges are included in the result displays (where useful) to visualize the basis of the displayed values and traces.

For background information on the result and evaluation ranges see "Measurement Ranges".)

Contents
  • Evaluation Data Sources in VSA
  • Result Types in VSA
  • Common Parameters in VSA


Evaluation Data Sources in VSA

VSA (R&S FSW-K70) > Measurements and Result Displays > Evaluation Data Sources in VSA
Evaluation Data Sources in VSA

All data sources for evaluation available for VSA are displayed in the evaluation bar in SmartGrid mode. The data source determines which result types are available (see table "Available result types depending on data source").

For details on selecting the data source for evaluation see "Display and Window Configuration".

In diagrams in the frequency domain (Spectrum transformation, see "Result Type Transformation") the usable I/Q bandwidth is indicated by vertical blue lines.

└ Capture Buffer
└ Measurement & Reference Signal
└ Symbols
└ Error Vector
└ Modulation Errors
└ Modulation Accuracy
└ Equalizer


Capture Buffer

VSA (R&S FSW-K70) > Measurements and Result Displays > Evaluation Data Sources in VSA > Capture Buffer
Capture Buffer

The captured I/Q data

In capture buffer result diagrams the result ranges are indicated by green bars along the time axis. The currently displayed result range is indicated by a blue bar.

Result ranges for a burst signal

Note: Tip: You can use the capture buffer display to navigate through the available result ranges (using "Select Result Rng" softkey), and analyze the individual result ranges in separate windows.
You can change the position of the result range quickly and easily by dragging the blue bar representing the result range to a different position in the capture buffer.

The default result type is "Magnitude Absolute".

The following result types are available:
  • "Magnitude Absolute"
  • "Real/Imag (I/Q)"
  • "Frequency Absolute"
  • "Vector I/Q"
Remote command:

LAY:ADD? '1',BEL,MTAB(see LAYout:​ADD[:​WINDow]?)


Measurement & Reference Signal

VSA (R&S FSW-K70) > Measurements and Result Displays > Evaluation Data Sources in VSA > Measurement & Reference Signal
Measurement & Reference Signal

The measurement signal or the ideal reference signal (or both)

The default result type is "Magnitude Relative".

The following result types are available:
  • "Magnitude Absolute"
  • "Magnitude Relative"
  • "Phase Wrap"
  • "Phase Unwrap"
  • "Frequency Absolute"
  • "Frequency Relative"
  • "Real/Imag (I/Q)"
  • "Eye Diagram Real (I)"
  • "Eye Diagram Imag (Q)"
  • "Eye Diagram Frequency"
  • "Constellation I/Q"
  • "Vector I/Q"
  • "Constellation Frequency"
  • "Vector Frequency"
Remote command:

LAY:ADD? '1',BEL,REF(see LAYout:​ADD[:​WINDow]?)


Symbols

VSA (R&S FSW-K70) > Measurements and Result Displays > Evaluation Data Sources in VSA > Symbols
Symbols

The detected symbols (i.e. the detected bits) displayed in a table;

The default result type is a hexadecimal symbol table.

Other formats for the symbol table are available, but no other result types (see "Symbol Table").

Remote command:

LAY:ADD? '1',BEL, SYMB(see LAYout:​ADD[:​WINDow]?)


Error Vector

VSA (R&S FSW-K70) > Measurements and Result Displays > Evaluation Data Sources in VSA > Error Vector
Error Vector

The modulated difference between the complex measurement signal and the complex reference signal:

Modulation (measurement signal - reference signal)

For example: EVM = Mag(meas - ref)

The default result type is "EVM".

The following result types are available:
  • "Error Vector Magnitude (EVM)"
  • "Real/Imag (I/Q)"
  • "Vector I/Q"
Remote command:

LAY:ADD? '1',BEL,EVEC(see LAYout:​ADD[:​WINDow]?)


Modulation Errors

VSA (R&S FSW-K70) > Measurements and Result Displays > Evaluation Data Sources in VSA > Modulation Errors
Modulation Errors

The difference between the modulated complex samples in the measurement and the modulated reference signal:

Modulation (measurement signal) - Modulation (reference signal)

For example: Magnitude Error = Mag(meas) - Mag(ref)

The default result type is "Magnitude Error".

The following result types are available:
  • "Magnitude Absolute"
  • "Phase Error"
  • "Frequency Error Absolute"
  • "Frequency Error Relative"
Remote command:

LAY:ADD? '1',BEL,MERR(see LAYout:​ADD[:​WINDow]?)


Modulation Accuracy

VSA (R&S FSW-K70) > Measurements and Result Displays > Evaluation Data Sources in VSA > Modulation Accuracy
Modulation Accuracy

Paraeters that characterize the accuracy of modulation.

The default result type is "Result Summary".

The following result types are available:
  • "Result Summary"
  • "Bit Error Rate (BER)"

The results of a modulation accuracy measurement can be checked for violation of defined limits automatically. If limit check is activated and the measured values exceed the limits, those values are indicated in red in the result summary table. If limit check is activated and no values exceed the limits, the checked values are indicated in green.

Remote command:

LAY:ADD? '1',BEL,MACC(see LAYout:​ADD[:​WINDow]?)


Equalizer

VSA (R&S FSW-K70) > Measurements and Result Displays > Evaluation Data Sources in VSA > Equalizer
Equalizer

Filter characteristics of the equalizer used to compensate for channel distortion and parameters of the distortion itself.

The default result type is "Frequency Response Magnitude".

The following result types are available:
  • "Impulse Response Magnitude"
  • "Impulse Response Phase"
  • "Impulse Response Real/Imag"
  • "Frequency Response Magnitude"
  • "Frequency Response Phase"
  • "Frequency Response Group Delay"
  • "Channel Frequency Response Magnitude"
  • "Channel Frequency Response Group Delay"
Remote command:

LAY:ADD? '1',BEL,EQU(see LAYout:​ADD[:​WINDow]?)


Result Types in VSA

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA
Result Types in VSA

The available result types for a window depend on the selected evaluation data source.

The SCPI parameters in the following table refer to the CALC:FORM command, see CALCulate<n>:​FORMat.

Available result types depending on data source
Evaluation Data Source | Result Type | SCPI Parameter
Capture Buffer | Magnitude Absolute | MAGNitude
 | Real/Imag (I/Q) | RIMag
 | Frequency Absolute | FREQuency
 | Vector I/Q | COMP
 | Magnitude Overview Absolute | MOVerview
Meas & Ref Signal | Magnitude Absolute | MAGNitude
 | Magnitude Relative | MAGNitude
 | Phase Wrap | PHASe
 | Phase Unwrap | UPHase
 | Frequency Absolute | FREQuency
 | Frequency Relative | FREQuency
 | Real/Imag (I/Q) | RIMag
 | Eye Diagram Real (I) | IEYE
 | Eye Diagram Imag (Q) | QEYE
 | Eye Diagram Frequency | FEYE
 | Constellation I/Q | CONS
 | Constellation I/Q (Rotated) | RCON
 | Vector I/Q | COMP
 | Constellation Frequency | CONF
 | Vector Frequency | COVF
Symbols | Binary | -
 | Octal | -
 | Decimal | -
 | Hexadecimal | -
Error Vector | EVM | MAGNitude
 | Real/Imag (I/Q) | RIMag
 | Vector I/Q | COMP
Modulation Errors | Magnitude Error | MAGNitude
 | Phase Error | PHASe
 | Frequency Error Absolute | FREQuency
 | Frequency Error Relative | FREQuency
Modulation Accuracy | Bit Error Rate | BERate
 | Result Summary | RSUM
Equalizer | Impulse Response Magnitude | MAGNitude
 | Impulse Response Phase | UPHase
 | Impulse Response Real/Image | RIMag
 | Frequency Response Magnitude | MAGNitude
 | Frequency Response Phase | UPHase
 | Frequency Response Group Delay | GDELay
 | Channel Frquency Response Magnitude | MAGNitude
 | Channel Frequency Response Group Delay | GDELay

For details on selecting the data source and result types for evaluation see "Display and Window Configuration".

Remote command:

CALCulate<n>:​FORMat

Contents
  • Bit Error Rate (BER)
  • Channel Frequency Response Group Delay
  • Channel Frequency Response Magnitude
  • Constellation Frequency
  • Constellation I/Q
  • Constellation I/Q (Rotated)
  • Error Vector Magnitude (EVM)
  • Eye Diagram Frequency
  • Eye Diagram Imag (Q)
  • Eye Diagram Real (I)
  • Frequency Absolute
  • Frequency Relative
  • Frequency Error Absolute
  • Frequency Error Relative
  • Frequency Response Group Delay
  • Frequency Response Magnitude
  • Frequency Response Phase
  • Impulse Response Magnitude
  • Impulse Response Phase
  • Impulse Response Real/Imag
  • Magnitude Absolute
  • Magnitude Overview Absolute
  • Magnitude Relative
  • Magnitude Error
  • Phase Error
  • Phase Wrap
  • Phase Unwrap
  • Real/Imag (I/Q)
  • Result Summary
  • Symbol Table
  • Vector Frequency
  • Vector I/Q


Bit Error Rate (BER)

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Bit Error Rate (BER)
Bit Error Rate (BER)

A bit error rate (BER) measurement compares the transmitted bits with the determined symbol decision bits:

BER = error bits / number of analyzed bits

As a prerequisite for this measurement, the VSA application must know which bit sequences are correct, i.e. which bit sequences may occur. This knowledge must be provided as a list of possible data sequences in xml format, which is loaded in the VSA application (see "Known Data Files - Dependencies and Restrictions").

Auxiliary tool to create Known Data files

An auxiliary tool to create Known Data files from data that is already available in the VSA application is provided on the instrument free of charge. See "To create a Known Data file using the recording tool for sequences".

If such a file is loaded in the application, the BER result display is available.

Available for source types:

  • Modulation Accuracy

Note that this measurement may take some time, as each symbol decision must be compared to the possible data sequences one by one.

The BER measurement is an indicator for the quality of the demodulated signal. High BER values indicate problems such as:

  • inadequate demodulation settings
  • poor quality in the source data
  • false or missing sequences in the Known Data file
  • result range alignment leads to a mismatch of the input data with the defined sequences

A BER value of 0.5 means that for at least one measurement no matching sequence was found.

See also "Demodulation and Symbol Decisions"

The following information is provided in the BER result display:
  • Bit Error Rate: error bits / number of analyzed bits
  • Total # of Errors: number of detected bit errors (known data compared to symbol decisions)
  • Total # of Bits: number of analyzed bits

For each of these results, the following values are provided:

BER Result | Description
Current | Value for current result range
Minimum | Minimum "Current" value during the current measurement
Maximum | Maximum "Current" value during the current measurement
Accumulative | Total value over several measurements; for BER: Total # of Errors / Total # of Bits (similar to average function)
Remote commands:

LAY:ADD? '1',BEL,MACC

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM BER

to define the result type (see CALCulate<n>:​FORMat)

CALC:BER?

to query the results (see CALCulate<n>:​BERate)


Channel Frequency Response Group Delay

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Channel Frequency Response Group Delay
Channel Frequency Response Group Delay

The Frequency Response Group Delay of the channel is the derivation of phase over frequency for the original input signal. It is a measure of phase distortion.

Remote commands:

LAY:ADD? '1',BEL,EQU

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FEED 'XFR:DDEM:IRAT'

to define the channel frequency response result type (see CALCulate<n>:​FEED)

CALC:FORM GDEL

to define the group delay result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Equalizer")


Channel Frequency Response Magnitude

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Channel Frequency Response Magnitude
Channel Frequency Response Magnitude

The frequency response magnitude of the channel indicates which distortions occurred during transmission of the input signal. It is only determined if the equalizer is activated.

The bandwidth for which the channel transfer function can be estimated is not only limited by the usable I/Q bandwidth, but also by the bandwidth of the analyzed input signal. Areas with low reception power, e.g. at the filter edges, may suffer from less accurate estimation results.

Remote commands:

LAY:ADD? '1',BEL,EQU

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FEED 'XFR:DDEM:IRAT'

to define the channel frequency response result type (see CALCulate<n>:​FEED)

CALC:FORM MAGN

to define the magnitude result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Equalizer")


Constellation Frequency

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Constellation Frequency
Constellation Frequency

The instantaneous frequency of the source signal (without inter-symbol interference) as an X/Y plot; only the symbol decision instants are drawn and not connected.

Available for source types:
  • Meas & Ref Signal
Result display "Constellation Frequency"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM CONF

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Polar Diagrams")


Constellation I/Q

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Constellation I/Q
Constellation I/Q

The complex source signal (without inter-symbol interference) as an X/Y plot; only the (de-rotated) symbol decision instants are drawn and not connected

Available for source types:
  • Meas & Ref Signal
Constellation I/Q diagram for QPSK modulated signal
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM CONS

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Polar Diagrams")


Constellation I/Q (Rotated)

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Constellation I/Q (Rotated)
Constellation I/Q (Rotated)

The complex source signal as an X/Y plot; As opposed to the common Constellation I/Q display, the symbol decision instants, including the rotated ones, are drawn and not connected.

Available for source types:
  • Meas & Ref Signal
    This result type is only available for signals with a rotating modulation.
Result display "Constellation I/Q (Rotated)" vs. common "Constellation I/Q" for 3π/4-QPSK modulation
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM RCON

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Polar Diagrams")


Error Vector Magnitude (EVM)

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Error Vector Magnitude (EVM)
Error Vector Magnitude (EVM)

Displays the error vector magnitude as a function of symbols or time.

with t=n·TD and TD=the duration of one sampling period at the sample rate defined by the display points per symbol parameter (see "Display Points/Sym").

The normalization constant C is chosen according to the EVM normalization. By default C² is the mean power of the reference signal.

and

Note that k=0.5·n·T for Offset QPSK with inactive Offset EVM.

Result display "Error Vector Magnitude"
Available for source types:
  • Error Vector
Remote commands:

LAY:ADD? '1',BEL,EVEC

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM MAGN

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Eye Diagram Frequency

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Eye Diagram Frequency
Eye Diagram Frequency

The eye diagram of the currently measured frequencies and/or the reference signal. The time span of the data depends on the evaluation range (capture buffer).

Available for source types:
  • Meas & Ref Signal
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM FEYE

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Eye Diagram Imag (Q)

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Eye Diagram Imag (Q)
Eye Diagram Imag (Q)

The eye pattern of the quadrature (Q) channel; the x-axis range is from -1 to +1 symbols (MSK: -2 to +2)

Available for source types:
  • Meas & Ref Signal
Result display "Eye Diagram Imag (Q)"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM QEYE

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Eye Diagram Real (I)

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Eye Diagram Real (I)
Eye Diagram Real (I)

The eye pattern of the inphase (I) channel; the x-axis value range is from -1 to +1 symbols (MSK: -2 to +2)

Available for source types:
  • Meas & Ref Signal
Result display "Eye Diagram Real (I)"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM IEYE

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Frequency Absolute

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Frequency Absolute
Frequency Absolute

The instantaneous frequency of the signal source; the absolute value is displayed in Hz.

Available for source types:
  • Meas & Ref Signal
  • Capture Buffer
Meas&Ref signal:

with t=n·TD and TD=the duration of one sampling period at the sample rate defined by the display points per symbol parameter (see "Display Points/Sym").

Capture buffer:

When evaluating the capture buffer, the absolute frequency is derived from the measured phase, with TD=the duration of one sampling period at the sample rate (see "Sample Rate").

Note that this result display is based on an individual capture buffer range. If more than 256,000 samples are captured, overlapping ranges with a size of 256,000 each are created. Only one range at a time can be displayed in the Frequency Absolute result display. For details see "Capture Buffer Display".

To scroll through the samples in different ranges, use the "Sweep > Select Result Rng" function or - directly after a sweep - turn the rotary knob. When you scroll in the diagram, the right edge of the current range or the selected result range is displayed in the center of the next range, if possible.

This measurement is mainly of interest when using the MSK or FSK modulation, but can also be used for the PSK/QAM modulations. However, since these modulations can have transitions through zero in the I/Q plane, in this case you might notice uncritical spikes. This is due to the fact that the phase of zero (or a complex value close to zero) is of limited significance, but still influences the result of the instantaneous frequency measurement.

Result display "Frequency Absolute"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM FREQ

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Capture Buffer Results"/"Cartesian Diagrams")


Frequency Relative

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Frequency Relative
Frequency Relative

The instantaneous frequency of the signal source.

The results are normalized to the symbol rate (PSK and QAM modulated signals), the estimated FSK deviation (FSK modulated signals) or one quarter of the symbol rate (MSK modulated signals).

with t=n·TD and TD=the duration of one sampling period at the sample rate defined by the display points per symbol parameter (see "Display Points/Sym").

This measurement is mainly of interest when using the MSK or FSK modulation, but can also be used for the PSK/QAM modulations. However, since these modulations can have transitions through zero in the I/Q plane, in this case you might notice uncritical spikes. This is due to the fact that the phase of zero (or a complex value close to zero) has in fact limited significance, but still influences the result of the current frequency measurement.

Available for source types:
  • Meas & Ref Signal
Result display "Frequency Relative"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM FREQ

to define the result type (see CALCulate<n>:​FORMat)

DISP:TRAC:Y:MODE REL

to define relative values (see DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Frequency Error Absolute

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Frequency Error Absolute
Frequency Error Absolute

Displays the error of the instantaneous frequency in Hz of the measurement signal with respect to the reference signal as a function of symbols over time.

with t=n·TD and TD=the duration of one sampling period at the sample rate defined by the display points per symbol parameter (see "Display Points/Sym").

Note that this measurement does not consider a possible carrier frequency offset. This has already been compensated for in the measurement signal.

This measurement is mainly of interest when using the MSK or FSK modulation, but can also be used for the PSK/QAM modulations. However, since these modulations can have transitions through zero in the I/Q plane, in this case you might notice uncritical spikes. This is due to the fact that the phase of zero (or a complex value close to zero) has in fact limited significance, but still influences the result of the current frequency measurement.

Result display "Frequency Error Absolute"
Available for source types:
  • Modulation Errors
Remote commands:

LAY:ADD? '1',BEL,MERR

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM FREQ

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Frequency Error Relative

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Frequency Error Relative
Frequency Error Relative

Displays the error of the instantaneous frequency of the measurement signal with respect to the reference signal as a function of symbols over time.

The results are normalized to the symbol rate (PSK and QAM modulated signals), the estimated FSK deviation (FSK modulated signals) or one quarter of the symbol rate (MSK modulated signals).

with t=n·TD and TD=the duration of one sampling period at the sample rate defined by the display points per symbol parameter (see "Display Points/Sym").

This measurement is mainly of interest when using the MSK or FSK modulation, but can also be used for the PSK/QAM modulations. However, since these modulations can have transitions through zero in the I/Q plane, in this case you might notice uncritical spikes. This is due to the fact that the phase of zero (or a complex value close to zero) has in fact limited significance, but still influences the result of the current frequency measurement.

Result display "Frequency Error Relative"
Available for source types:
  • Modulation Errors
Remote commands:

LAY:ADD? '1',BEL,MERR

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM FREQ

to define the result type (see CALCulate<n>:​FORMat)

DISP:TRAC:Y:MODE REL

to define relative values (see DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Frequency Response Group Delay

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Frequency Response Group Delay
Frequency Response Group Delay

The Frequency Response Group Delay of the equalizer is the derivation of phase over frequency. It is a measure of phase distortion.

Available for source types:
  • Equalizer
Remote commands:

LAY:ADD? '1',BEL,EQU

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FEED 'XFR:DDEM:RAT'

to define the frequency response result type (see CALCulate<n>:​FEED)

CALC:FORM GDEL

to define the group delay result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Equalizer")


Frequency Response Magnitude

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Frequency Response Magnitude
Frequency Response Magnitude

Frequency response of the current equalizer to the input signal. Note that the frequency response of the equalizer is not a pure inverted function of the channel response, as both functions are calculated independantly. The frequency response is calculated by determining an optimal EVM for the input signal.

Available for source types:
  • Equalizer
Remote commands:

LAY:ADD? '1',BEL,EQU

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FEED 'XFR:DDEM:RAT'

to define the frequency response result type (see CALCulate<n>:​FEED)

CALC:FORM MAGN

to define the magnitude result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Equalizer")


Frequency Response Phase

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Frequency Response Phase
Frequency Response Phase

The frequency response phase of the equalizer is derived from the Frequency Response Magnitude.

Available for source types:
  • Equalizer
Remote commands:

LAY:ADD? '1',BEL,EQU

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FEED 'XFR:DDEM:RAT'

to define the frequency response result type (see CALCulate<n>:​FEED)

CALC:FORM UPH

to define the unwrapped phase result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Equalizer")


Impulse Response Magnitude

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Impulse Response Magnitude
Impulse Response Magnitude

The impulse response magnitude of the equalizer shows the filter in the time domain.

Available for source types:
  • Equalizer
Remote commands:

LAY:ADD? '1',BEL,EQU

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FEED 'XTIM:DDEM:IMP'

to define the impulse response result type (see CALCulate<n>:​FEED)

CALC:FORM MAGN

to define the magnitude result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Equalizer")


Impulse Response Phase

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Impulse Response Phase
Impulse Response Phase

The Impulse Response Phase is the derivation of the Impulse Response Magnitude.

Available for source types:
  • Equalizer
Remote commands:

LAY:ADD? '1',BEL,EQU

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FEED 'XTIM:DDEM:IMP'

to define the impulse response result type (see CALCulate<n>:​FEED)

CALC:FORM UPH

to define the phase result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Equalizer")


Impulse Response Real/Imag

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Impulse Response Real/Imag
Impulse Response Real/Imag

The Real/Imag diagram of the impulse response is a stem diagram. It displays the filter characteristics in the time domain for both the I and the Q branches individually. Using this information the equalizer is uniquely characterized and can be recreated by other applications.

Available for source types:
  • Equalizer
Remote commands:

LAY:ADD? '1',BEL,EQU

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FEED 'XTIM:DDEM:IMP'

to define the impulse response result type (see CALCulate<n>:​FEED)

CALC:FORM RIM

to define the real/image result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Equalizer")


Magnitude Absolute

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Magnitude Absolute
Magnitude Absolute

Magnitude of the source signal in an individual capture buffer range (max. 256,000 samples).

If more than 256,000 samples are captured, overlapping result ranges with a size of 256,000 samples each are created. Only one range at a time can be displayed in the Magnitude Absolute result display.

To scroll through the samples in different ranges, use the "Sweep > Select Result Rng" function or - directly after a sweep - turn the rotary knob. When you scroll in the diagram, the right edge of the current range or the selected result range is displayed in the center of the next range, if possible.

To display the entire capture buffer with all ranges in one diagram, use the "Magnitude Overview Absolute" result display.

Note that trace modes that calculate results for several sweeps (Average, MinHold, MaxHold) are applied to the individual ranges and thus may not provide useful results in this result display.

For more information on result ranges see "Capture Buffer Display".

In the Magnitude Absolute result display, the actual signal amplitude is displayed:

with t=n·TD and

TD=the duration of one sampling period at the defined sample rate defined by the display points per symbol parameter (see "Display Points/Sym")

Available for source types:
  • Capture Buffer
  • Meas & Ref Signal
    (Displays the actual signal amplitude for the selected evaluation range)
Result display "Magnitude Absolute" for capture buffer data
Remote commands:

LAY:ADD? '1',BEL,CBUF

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM MAGN

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA?

to query the trace results (see TRACe<n>[:​DATA] and "Capture Buffer Results")


Magnitude Overview Absolute

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Magnitude Overview Absolute
Magnitude Overview Absolute

Magnitude of the source signal in the entire capture buffer; the actual signal amplitude is displayed:

with t=n·TD and

TD=the duration of one sampling period at the sample rate defined by the display points per symbol parameter (see "Display Points/Sym")

Note that for very large numbers of samples (>25,000), the samples are mapped to 25,000 trace points using an autopeak detector for display. Thus, this result display is not suitable to detect transient effects or analyze individual symbols closely. For these purposes, use the "Magnitude Absolute" result display instead.

The Magnitude Overview Absolute is only available for the source type:
  • Capture Buffer
Result display "Magnitude Overview Absolute" for capture buffer data
Restrictions

Note the following restrictions that apply to this result display:

  • Only one trace is available
  • Only the trace modes "Clear/Write" and "View" are available.
    See also "Trace Settings".
Remote commands:

LAY:ADD? '1',BEL,CBUF

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM MOV

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA

to query the trace results (see TRACe<n>[:​DATA] and "Capture Buffer Results")


Magnitude Relative

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Magnitude Relative
Magnitude Relative

Magnitude of the source signal; the signal amplitude is scaled to the ideal reference signal

Available for source types:
  • Meas & Ref Signal
Result display "Magnitude Relative"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM MAGN

to define the result type (see CALCulate<n>:​FORMat)

DISP:TRAC:Y:MODE REL

to define relative values (see DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Magnitude Error

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Magnitude Error
Magnitude Error

Displays the magnitude error of the measurement signal with respect to the reference signal (as a function of symbols over time)

with t=n·TD and TD=the duration of one sampling period at the sample rate defined by the display points per symbol parameter (see "Display Points/Sym").

Result display "Magnitude Error"
Available for source types:
  • Modulation Errors
Remote commands:

LAY:ADD? '1',BEL,MERR

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM MAGN

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Phase Error

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Phase Error
Phase Error

Displays the phase error of the measuremente signal with respect to the reference signal as a function of symbols over time.

with t=n·TD and TD=the duration of one sampling period at the sample rate defined by the display points per symbol parameter (see "Display Points/Sym").

Result display "Phase Error"
Available for source types:
  • Modulation Errors
Remote commands:

LAY:ADD? '1',BEL,MERR

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM PHAS

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Phase Wrap

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Phase Wrap
Phase Wrap

The phase or argument of the signal; the display is limited to the phase value range of [-180°, 180°]

with t=n·TD and TD=the duration of one sampling period at the sample rate defined by the display points per symbol parameter (see "Display Points/Sym").

Available for source types:
  • Meas & Ref Signal
Result display "Phase Wrap"
Remote commands:

LAY:ADD? '1',BEL,REF

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM PHASe

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Phase Unwrap

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Phase Unwrap
Phase Unwrap

The phase of the signal; the display is not limited to [-180°, 180°].

Available for source types:
  • Meas & Ref Signal
Result display "Phase Unwrap"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM UPHase

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Real/Imag (I/Q)

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Real/Imag (I/Q)
Real/Imag (I/Q)

Real and imaginary part of the measurement or reference signal in separate measurement diagrams; the x-axis (scaled in time units or symbols) is identical for both diagrams.

Available for source types:
  • Capture Buffer
  • Meas & Ref Signal
  • Error Vector
Capture buffer display

Note that this result display is based on an individual capture buffer range. If more than 256,000 samples are captured, overlapping ranges with a size of 256,000 each are created. Only one range at a time can be displayed in the Real/Imag result display. For details see "Capture Buffer Display".

To scroll through the samples in different ranges, use the "Sweep > Select Result Rng" function or - directly after a sweep - turn the rotary knob. When you scroll in the diagram, the right edge of the current range or the selected result range is displayed in the center of the next range, if possible.

The scaling of the capture buffer depends on the input source:
  • Scaling is relative to the current reference level for RF input.
  • Scaling is relative to the full scale level for I/Q input.
Result display "Real/Imag (I/Q)"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM RIMag

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Cartesian Diagrams")


Result Summary

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Result Summary
Result Summary

The Modulation Accuracy results in a table. For details on the parameters see "Common Parameters in VSA".

Basis of evaluation

The majority of the values that are displayed in the Result Summary are calculated over the "Evaluation Range" (see "Evaluation Range Configuration"). They are evaluated according to the setting of the "Display Points/Sym" parameter. For example, if "Display Points/Symbol" is "1", only the symbol instants contribute to the result displayed in the result summary.

Results calculated over the evaluation range
PSK, MSK, QAM | FSK
EVM | Frequency Error
MER | Magnitude Error
Phase Error | Power
Magnitude Error |
Rho |
Power |

The following results that are based on internal estimation algorithms (see "Signal Model, Estimation and Modulation Errors") are calculated over the "Estimation range" (see also "Estimation").

Results calculated over the estimation range
PSK, MSK, QAM | FSK
Carrier Frequency Error | FSK Deviation Error
Symbol Rate Error | Symbol Rate Error
I/Q Offset | FSK Measurement Deviation
I/Q Imbalance | Carrier Frequency Error
Gain Imbalance | Carrier Frequency Drift
Quadrature Error |
Amplitude Droop |
Current value

In the "Current" column, the value evaluation for the current evaluation is displayed. For example, the EVM Peak value in the current sweep corresponds to the peak of the trace values within the evaluation range for the current sweep (as indicated by marker 1 in figure "Example for result summary with current EVM peak value marked").

Example for result summary with current EVM peak value marked

If you want to compare the trace values to the results of the Result Summary, make sure to match the displayed points per symbol of the trace and of the Result Summary. Refer to "Display Points/Sym" for details.

Mean value

In the "Mean" column, the linear mean of the values that are in the "Current" column is displayed. Note that if the values are in a logarithmic representation, e.g. the I/Q Offset, the linear values are averaged.

Peak value

In the "Peak" column, the maximum value that occurred during several evaluations is displayed. Note that when the value can be positive and negative, e.g. the phase error, the maximum absolute value (maintaining its sign) is displayed. The peak value of Rho is handled differently, since its minimum value represents the worst case. In that case, the minimum value is displayed.

Standard Deviation

The value for the standard deviation is calculated on the linear values and then converted to the displayed unit.

95-percentile

The 95-percentile value is based on the distribution of the current values. Since the phase error and the magnitude error can usually be assumed to be distributed around zero, the 95-Percentile for these values is calculated based on their absolute values. Again, the Rho value is handled differently. Here, the 5-Percentile is displayed, since the lowest Rho value represents the worst case.

Remote commands:

LAY:ADD? '1',BEL, MACC

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM RSUM

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA

to query the trace results (see TRACe<n>[:​DATA] and "Result Summary")

CALC:MARK:FUNC:DDEM:STAT:<parameter>

to query individual parameter values (see "Retrieving Parameter Values"

└ Result Summary - Individual Results


Result Summary - Individual Results

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Result Summary > Result Summary - Individual Results
Result Summary - Individual Results

The Result Summary can display either all or only a single modulation accuracy parameter. Only the most important parameters can be displayed individually, namely those for which modulation accuracy limits can be defined (see "Limit Value").

Individual results are selected for display by tapping the Result Summary table header. A "Table Configuration" dialog box is displayed in which you can select the parameter to be displayed.

By default, all parameters are displayed. If you select a specific parameter, the Result Summary display is replaced by the individual result display.

Result display for individual value in Result Summary

In addition to the current measurement value, the statistical results (see "Result Summary") and the peak limit value (see "Limit Value") for the selected parameter are displayed.

For details on the displayed results see "Common Parameters in VSA".

Remote command:

DISPlay[:​WINDow<n>]:​ITEM[:​LINE][:​VALue]


Symbol Table

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Symbol Table
Symbol Table

Symbol numbers are displayed as a table. Each symbol is represented by an entry in the table. The symbols can be displayed in binary, octal, hexadecimal or decimal format. Selected symbols (using markers) are highlighted by a blue frame.

Example:
Result display for "Symbols" in hexadecimal mode

If a pattern search is active, a found pattern is indicated by a green background in the symbol table. If, during demodulation, individual symbols do not match the pattern after all, these symbols are indicated by a red frame.

Remote commands:

LAY:ADD? '1',BEL, 'XTIM:DDEM:SYMB'

to define the required source type (see LAYout:​ADD[:​WINDow]?)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Symbols")


Vector Frequency

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Vector Frequency
Vector Frequency

The instantenous frequency of the source signal as an X/Y plot; all available samples (as defined by the display points per symbol parameter (see "Display Points/Sym")) are drawn and connected.

Available for source types:
  • Meas & Ref Signal
Result display for "Vector Frequency"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM COVF

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Polar Diagrams")


Vector I/Q

VSA (R&S FSW-K70) > Measurements and Result Displays > Result Types in VSA > Vector I/Q
Vector I/Q

The complex source signal as an X/Y plot; all available samples (as defined by the display points per symbol parameter, see "Display Points/Sym") are drawn and connected.

The scaling of the capture buffer depends on the input source:

  • Scaling is relative to the current reference level for RF input.
  • Scaling is relative to the full scale level for I/Q input.
Available for source types:
  • Capture Buffer
  • Meas & Ref Signal
  • Error Vector
Capture buffer display

Note that this result display is based on an individual capture buffer range. If more than 256,000 samples are captured, overlapping ranges with a size of 256,000 each are created. Only one range at a time can be displayed in the Vector I/Q result display. For details see "Capture Buffer Display".

To scroll through the samples in different ranges, use the "Sweep > Select Result Rng" function or - directly after a sweep - turn the rotary knob. When you scroll in the diagram, the right edge of the current range or the selected result range is displayed in the center of the next range, if possible.

Result display for "Vector I/Q"
Remote commands:

LAY:ADD? '1',BEL,MEAS

to define the required source type (see LAYout:​ADD[:​WINDow]?)

CALC:FORM COMP

to define the result type (see CALCulate<n>:​FORMat)

TRAC:DATA TRACE1

to query the trace results (see TRACe<n>[:​DATA] and "Polar Diagrams")


Common Parameters in VSA

VSA (R&S FSW-K70) > Measurements and Result Displays > Common Parameters in VSA
Common Parameters in VSA

Depending on the modulation type you are using, different signal parameters are determined during vector signal analysis.

Details concerning the calculation of individual parameters can be found in "Signal Model, Estimation and Modulation Errors" and "Formulae".

Parameters for PSK, QAM and MSK modulation
Parameter | Description | SCPI Parameter
EVM - RMS/Peak | Error Vector Magnitude | EVM
MER - RMS/Peak | Modulation Error Ratio | SNR
Phase Error - RMS/Peak | The phase difference between the measurement vector and the reference vector | PERR
Magnitude Error - RMS/Peak | The average (RMS) and peak magnitude error in %. The magnitude error is the difference of the measured magnitude to the magnitude of the reference signal. The magnitude error is normalized to the mean magnitude of the reference signal. | MERRor
Carrier Frequency Error | The mean carrier frequency offset in Hz | CFERror
Symbol Rate Error | Difference between the currently measured symbol rate and the defined symbol rate in ppm. (Only for PSK, QAM or UserQAM modulation and only if compensation for SRE is activated, see "Demodulation - Compensation") | SRER
Rho |  | RHO
I/Q Offset | Offset in the original input | OOFFset
I/Q Imbalance | Not for BPSK. | IQIMbalance
Gain Imbalance | Not for BPSK. | GIMBalance
Quadrature Error | Not for BPSK. | QERRor
Amplitude Droop | The decrease of the signal power over time in the transmitter | ADRoop
Power | The power of the measured signal | MPOWer
Parameters for FSK modulation only
Parameter | Description | SCPI parameter
Frequency Error - RMS/Peak | The average (RMS) and peak frequency error in %. The frequency error is thedifference of the measured frequency and the reference frequency.The frequency error is normalized to the estimated FSK deviation. | FSK:DERRor
FSK Deviation Error | The deviation error of FSK modulated signals in Hz. The FSK deviation erroris the difference of the FSK deviation of the measured signal and the FSK referencedeviation you have set. | FDERror
FSK Meas Deviation | The estimated deviation of FSK modulated signals in Hz. | FSK:MDEViation
FSK Ref Deviation | The reference deviation you have set in Hz. | FSK:RDEViation
Carrier Frequency Drift | The mean carrier frequency drift in Hz per symbol. | FSK:CFDRift
Remote command:

CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:<Parameter>?


200Measurement Basics

VSA (R&S FSW-K70) > 200Measurement Basics
200Measurement Basics

Some background knowledge on basic terms and principles used in VSA is provided here for a better understanding of the required configuration settings.

For information on the basic processing of I/Q data in the R&S FSW see the R&S FSW I/Q Analyzer User Manual.

Contents
  • Filters and Bandwidths During Signal Processing
  • Sample Rate, Symbol Rate and I/Q Bandwidth
  • Symbol Mapping
  • Overview of the Demodulation Process
  • Signal Model, Estimation and Modulation Errors
  • Measurement Ranges
  • Display Points vs Estimation Points per Symbol
  • Capture Buffer Display
  • Known Data Files - Dependencies and Restrictions
  • VSA in MSRA/MSRT Operating Mode


Filters and Bandwidths During Signal Processing

VSA (R&S FSW-K70) > 200Measurement Basics > Filters and Bandwidths During Signal Processing
Filters and Bandwidths During Signal Processing

This section describes the used filters in vector signal analysis with an R&S FSW, as well as the bandwidth after each filter.

The relevant filters for vector signal analysis are shown in figure "Block diagram of bandwidth-relevant filters for vector signal analysis".

Block diagram of bandwidth-relevant filters for vector signal analysis
  • After the IF Filter (only for RF input operation): bandwidth = 40 MHz
  • After the digital hardware section:
    The phase and amplitude distortions of the IF filter have been compensated for. Usually, the I/Q data has a usable bandwidth of about:
    0.8 * sample rate
    For details refer to "I/Q Bandwidth".
    The I/Q data's sample rate and bandwidth are automatically adjusted to the set symbol rate. For most modulated signals even the smallest allowed value for the sample rate leads to a sufficient I/Q data bandwidth. The whole spectrum of the input signal is captured, but most adjacent channels and interferers are effectively suppressed. Only for very wide signals (FSK, no TX-filter used) it can be necessary to try higher values for the sample rate (see "Sample Rate, Symbol Rate and I/Q Bandwidth"), increasing the I/Q bandwidth. The I/Q data delivered to the DSP section has no considerable amplitude or phase distortion and a suitable bandwidth.

The "Signal Capture" dialog box ("Data Acquisition" tab) shows the sample rate and the usable I/Q bandwidth achieved for the current settings (see "Usable I/Q Bandwidth").

  • After the optional measurement filter:
    The measurement signal and the reference signal can be filtered by various measurement filters which have different bandwidths.

The filters described above are the ones that directly affect the bandwidth of the captured I/Q data and the final measurement signal and reference signal. Note, however, that several other filters are also involved in the DSP section but are not mentioned above:

  • Receive filter to prevent ISI (intersymbol-interference)
  • filters necessary for various estimators
  • others
Contents
  • I/Q Bandwidth
  • Demodulation Bandwidth (Measurement Bandwidth)
  • Modulation and Demodulation Filters
  • Measurement Filters
  • Customized Filters


I/Q Bandwidth

VSA (R&S FSW-K70) > 200Measurement Basics > Filters and Bandwidths During Signal Processing > I/Q Bandwidth
I/Q Bandwidth

The bandwidth of the I/Q data used as input for the vector signal analysis is filtered as described in "Filters and Bandwidths During Signal Processing". Its flat, usable bandwidth (no considerable amplitude or phase distortion) depends on:

  • the used sample rate, which depends on:
    – the defined "Symbol Rate" (see "Symbol Rate")
    – the defined "Sample Rate" parameter (see "Sample Rate"
  • the type of input used (digital baseband input, RF input, etc)

For details on the maximum usable bandwidth see "Sample Rate, Symbol Rate and I/Q Bandwidth".

The sample rate and the usable I/Q bandwidth achieved for the current settings is displayed in the "Signal Capture" dialog, see "Data Acquisition".


Demodulation Bandwidth (Measurement Bandwidth)

VSA (R&S FSW-K70) > 200Measurement Basics > Filters and Bandwidths During Signal Processing > Demodulation Bandwidth (Measurement Bandwidth)
Demodulation Bandwidth (Measurement Bandwidth)

Some modulation systems do not use a receive filter. In these cases special care should be taken that no interference or adjacent channels occur within the demodulation bandwidth. The "Sample rate" parameter should be set to a low value (see "Sample Rate").

Typical communication systems demand special receive or measurement filters (e.g. root-raised cosine receive filter or EDGE measurement filter).

If no such filtering is performed, care should be taken that neither interfering signals nor adjacent channels fall within the demodulation bandwidth.


Modulation and Demodulation Filters

VSA (R&S FSW-K70) > 200Measurement Basics > Filters and Bandwidths During Signal Processing > Modulation and Demodulation Filters
Modulation and Demodulation Filters

Sample points are required for demodulation in the analyzer, where only information of the current symbol and none of neighbouring symbols is present (symbol points). These points are also called ISI-free points (ISI = intersymbol interference). If the transmitter does not provide an ISI-free signal after the transmit filter (TX filter), this condition can be fulfilled by signal-specific filtering of the analyzer input signal (receive filter or Rx filter). If an RRC (root-raised cosine) filter is used in the transmitter, an RRC filter is also required in the analyzer to obtain ISI-free points.

In many PSK systems, RRC filters are used as transmit, ISI and measurement filters. To determine the I/Q modulation error, the measurement signal must be compared with the corresponding ideal signal. For this purpose a reference filter is required which is calculated by the analyzer by convolving the coefficient of the transmit filter (Tx filter) and the meas filter (see figure "Measurement filter in the block diagram (MSK, PSK, QAM and UserQAM)").

If unfiltered signals have to be measured as well (e.g. to determine nonlinear signal distortions), no measurement filter is switched into the signal path and the reference filter is identical to the Transmit filter (see figure "Measurement filter in the block diagram (MSK, PSK, QAM and UserQAM)").

In the baseband block diagrams (see figure "Measurement filter in the block diagram (MSK, PSK, QAM and UserQAM)"), the system-theoretical transmitter and analyzer filters are shown for PSK and QAM demodulation. For the sake of clearness, RF stages, IF filters and the filter stages of the digital hardware section are not shown.

For a correct demodulation, the following filters have to be accurately specified for the analyzer:

  • Transmit filter: filter characteristic of transmitter
  • Meas filter:
    – PSK, QAM, UserQAM, MSK:
    The I and the Q part of the measurement and the reference signal are filtered with this filter.
    – FSK:
    The instantaneous frequency of the measurement reference signal are filtered.

    In many applications, the measurement filter is identical with the ISI filter.

The receive filter (ISI filter) is configured internally depending on the transmit filter. The goal is to produce intersymbol-interference-free points for the demodulation.

The reference filter synthesizes the ideal transmitted signal (after meas filtering). It is calculated by the analyzer from the above filters (convolution operation Transmit filter * Meas Filter).

Typical combinations of Tx and Meas filters are shown in table "Typical combinations of Tx and Meas filters"; they can be set in the VSA application using "Meas filter = AUTO" (see "Using the Transmit Filter as a Measurement Filter (Auto)"). If RC (raised cosine), RRC (root-raised cosine) and Gaussian filters are used, the Alpha (RC, RRC filters) or BT (Gaussian filters) parameters must be set in addition to the filter characteristic (roll-off factor). Typically the Alpha/BT value of the measurement filter should be the same as that of the transmission filter.


Measurement Filters

VSA (R&S FSW-K70) > 200Measurement Basics > Filters and Bandwidths During Signal Processing > Measurement Filters
Measurement Filters

The measurement filter can be used to filter the following two signals in the same way:

  • the measurement signal (after coarse frequency, phase and timing synchronization have been achieved)
  • the reference signal, i.e the I/Q symbols that have been determined in the demodulator and have already been filtered with the Transmit filter;

For FSK, the measurement filter filters the instantaneous frequency of the signal, not the I/Q signal.

For MSK, PSK, QAM and User QAM the measurement filter filters the real part and imaginary part of these signals (i.e. not the instantaneous frequency or magnitude of the signal).

The VSA application defines the error signal as the difference between the reference signal and the measurement signal. Thus, the measurement filter also shapes the spectrum of the error signal, which is used to calculate the EVM, for example.

In many applications the measurement filter is the same as the RX filter. However, unlike the measurement filter, the RX filter is not relevant for the measurement, but is only required to create the reference signal optimally.

The RX filter and the transmit filter are usually chosen such that their combination results in an Inter-Symbol Interference (ISI) free system (see figure "Measurement filter in the block diagram (MSK, PSK, QAM and UserQAM)" and figure "Modulator with Transmit filter in detail").

Measurement filter in the block diagram (MSK, PSK, QAM and UserQAM)
Modulator with Transmit filter in detail

As the measurement filters of the VSA application have low-pass characteristics, they suppress high frequency distortion components in the Meas/Ref/Error signal. The errors are weighted spectrally. Thus, turning off the measurement filter can have an influence on the numeric and graphical error values. However, the measurement filter should be switched off if non-linear distortions have to be measured (they usually produce high frequency components).

Predefined measurement filters

The most frequently required measurement filters are provided by the VSA application (see "Measurement Filters").

The frequency response of the available standard-specific measurement filters is shown in "Measurement Filter".


Customized Filters

VSA (R&S FSW-K70) > 200Measurement Basics > Filters and Bandwidths During Signal Processing > Customized Filters
Customized Filters

The analytical filter types RC (raised cosine), RRC (root-raised cosine) and GAUSSIAN as well as the most important standard-specific filters are already integrated in the VSA application. In addition, it is possible to use user-defined measurement and transmit filters. Customized filters may be useful for the following purposes:

  • Development of new networks and modulation methods for which no filters are defined yet.
  • Measurements of transmitter characteristics with slightly modified (e.g. shortened) transmitter filters.

An external program ("FILTWIZ") is offered to convert user-defined filters. This program generates filter files (*.vaf) which can be transferred to the analyzer with a USB device, for example. The program can be downloaded together with a detailed description as a precompiled MATLAB® file (MATLAB pcode) on the Internet, at http://www.rohde-schwarz.com (search term "FILTWIZ").

FILTWIZ - filter tool for VSA

It is possible to load customized transmit filters and customized measurement filters. If a customized transmit filter is selected, the internal receive filter coefficients are calculated automatically on the fly.

Note that this is different to the R&S FSQ-K70, where it is necessary to also transfer a user receive filter.

If you upload a customized transmit filter and leave the measurement filter set to "automatic", the internally calculated receive filter will be used as measurement filter. Note that this filter is not necessarily suitable for your specific signal. The filter is optimized such that the intersymbol interference is low. Hence, you will probably be able to see a clear eye diagram and an Vector I/Q diagram with a recognizable constellation. However, a filter that has low intersymbol interference might lead to noise enhancement, which is commonly undesirable for a measurement filter. In order to avoid noise enhancement, it is recommended that you:

  • a) design your own measurement filter and upload it as a user filter
  • b) select a suitable measurement filter from the list
Transferring filter files to the R&S FSW

You can transfer the (.vaf) filter files to the R&S FSW using a USB memory device.


Sample Rate, Symbol Rate and I/Q Bandwidth

VSA (R&S FSW-K70) > 200Measurement Basics > Sample Rate, Symbol Rate and I/Q Bandwidth
Sample Rate, Symbol Rate and I/Q Bandwidth

The "Symbol Rate" defined in the "Signal Description" settings determines how many symbols are captured and demodulated during a certain measurement time. However, for each symbol more than one sample may be captured, so that the sample rate may be higher than the symbol rate.

The "Sample Rate" parameter in the "Data Acquisition" settings defines the number of samples to capture per symbol (not to be confused with the estimation points per symbol or display points per symbol, see "Display Points vs Estimation Points per Symbol"). The resulting sample rate (depending on the "Symbol Rate") is indicated behind the parameter.

The number of samples to capture per symbol was referred to as the "Capture Oversampling" value in previous R&S signal and spectrum analyzers.

The resulting sample rate, also referred to as the user or output sample rate, is the rate at which the I/Q data is demodulated and analyzed. The sample rate also affects the demodulation (measurement) bandwidth (see also "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input"). If the bandwidth is too narrow, the signal is not displayed completely. If the bandwidth is too wide, interference from outside the actual signal to be measured can distort the result. Thus, for signals with a large frequency spectrum (e.g. FSK modulated signals), a higher sample rate may be necessary.

(For further details, see "Filters and Bandwidths During Signal Processing".)

For an indication of the required sample rate, view the "Real/Imag (I/Q)" display of the capture buffer with a "Spectrum" transformation. If the complete signal is displayed and fills the width of the display, the selected value is suitable.

Determining the I/Q bandwidth: Real/Imag (I/Q) display of the capture buffer with a spectrum transformation

If the signal is cut off, increase the sample rate; if it is too small, decrease the sample rate (by changing the "Symbol Rate" defined in the "Signal Description" settings, or the "Sample Rate" parameter in the "Data Acquisition" settings).

As described above, the sample rate is determined by the number of samples to capture per symbol. Thus, the maximum sample rate depends on the maximum number of symbols to be captured (the symbol rate) and vice versa. The maximum sample rate for the R&S FSW is 10 GHz (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input"). Thus, the maximum symbol rate is:

Maximum symbol rate depending on sample rate parameter
Sample rate parameter | Max. symbol rate
4* symbol rate | 2500 MSymbols
8* symbol rate | 1250 MSymbols
16* symbol rate | 625 MSymbols
32* symbol rate | 312.5 MSymbols
Contents
  • Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
  • Sample Rates and Bandwidths for Digital I/Q Data


Sample Rate and Maximum Usable I/Q Bandwidth for RF Input

VSA (R&S FSW-K70) > 200Measurement Basics > Sample Rate, Symbol Rate and I/Q Bandwidth > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
Definitions
  • Input sample rate (ISR): the sample rate of the useful data provided by the connected instrument to the R&S FSW input
  • (User, Output) Sample rate (SR): the sample rate that is defined by the user (e.g. in the "Data Aquisition" dialog box in the "I/Q Analyzer" application) and which is used as the basis for analysis or output
  • Usable I/Q (Analysis) bandwidth: the bandwidth range in which the signal remains undistorted in regard to amplitude characteristic and group delay; this range can be used for accurate analysis by the R&S FSW
  • Record length: Number of I/Q samples to capture during the specified measurement time; calculated as the measurement time multiplied by the sample rate

For the I/Q data acquisition, digital decimation filters are used internally. The passband of these digital filters determines the maximum usable I/Q bandwidth. In consequence, signals within the usable I/Q bandwidth (passband) remain unchanged, while signals outside the usable I/Q bandwidth (passband) are suppressed. Usually, the suppressed signals are noise, artifacts, and the second IF side band. If frequencies of interest to you are also suppressed, you should try to increase the output sample rate, since this increases the maximum usable I/Q bandwidth.

Bandwidth extension options

The maximum usable I/Q bandwidth provided by the R&S FSW in the basic installation can be extended by additional options. These options can either be included in the initial installation (B-options) or updated later (U-options). The maximum bandwidth provided by the individual option is indicated by its number, for example, B40 extends the bandwidth to 40 MHz.

Note that the U-options as of U40 always require all lower-bandwidth options as a prerequisite, while the B-options already include them.

Max. usable I/Q BW

Required B-option

Required U-option(s)

10 MHz

-

-

28 MHz

B28

U28

40 MHz

B40

U28+U40 or

B28+U40

80 MHz

B80

U28+U40+U80 or

B28+U40+U80 or

B40+U80

160 MHz

B160

U28+U40+U80+U160 or

B28+U40+U80+U160 or

B40+U80+U160 or

B80+U160

320 MHz

B320*)

U28+U40+U80+U160+U320 or

B28+U40+U80+U160+U320 or

B40+U80+U160+U320 or

B80+U160+U320 or

B160+U320

500 MHz

B500**)

See data sheet

*) The bandwidth extension option R&S FSW-B320/-U320 requires a reference board revision 3.14 or higher.

**) The bandwidth extension option R&S FSW-B500 requires a reference board (1312.8075.06) revision 4.06 or higher and a motherboard 1313.4180.02 or 1313.7698.02.

As a rule, the usable I/Q bandwidth is proportional to the output sample rate. Yet, when the I/Q bandwidth reaches the bandwidth of the analog IF filter (at very high output sample rates), the curve breaks.

Relationship between sample rate and usable I/Q bandwidth

Up to the maximum bandwidth, the following rule applies:

Usable I/Q bandwidth = 0.8 * Output sample rate

MSRA operating mode

In MSRA operating mode, the MSRA Master is restricted to a sample rate of 600 MHz.

Digital Baseband output

If Digital Baseband output is active (see "Digital Baseband Output") the sample rate is restricted to 200 MHz (max. 160 MHz usable I/Q bandwidth).

The figure "Relationship between maximum usable I/Q bandwidth and output sample rate with and without bandwidth extensions" shows the maximum usable I/Q bandwidths depending on the output sample rates.

R&S FSW without additional bandwidth extension options

sample rate: 100 Hz - 10 GHz

maximum I/Q bandwidth: 10 MHz

Maximum I/Q bandwidth
Sample rate | Maximum I/Q bandwidth
100 Hz to 10 MHz | proportional up to maximum 10 MHz
10 MHz to 10 GHz | 10 MHz
R&S FSW with options B28 or U28 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 28 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 35 MHz | proportional up to maximum 28 MHz
35 MHz to 10 GHz | 28 MHz
R&S FSW with option B40 or U40 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 40 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 50 MHz | proportional up to maximum 40 MHz
50 MHz to 10 GHz | 40 MHz
R&S FSW with option B80 or U80 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 80 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 100 MHz | proportional up to maximum 80 MHz
100 MHz to 10 GHz | 80 MHz
R&S FSW with activated option B160 or U160 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 160 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 200 MHz | proportional up to maximum 160 MHz
200 MHz to 10 GHz | 160 MHz
Relationship between maximum usable I/Q bandwidth and output sample rate with and without bandwidth extensions
Contents
  • Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
  • Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500


Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320

VSA (R&S FSW-K70) > 200Measurement Basics > Sample Rate, Symbol Rate and I/Q Bandwidth > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input > Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
Sample rate | Maximum I/Q bandwidth
100 Hz to 400 MHz | proportional up to maximum 320 MHz
400 MHz to 10 GHz | 320 MHz
Digital Baseband output

If Digital Baseband output is active (see "Digital Baseband Output") the sample rate is restricted to 200 MHz (max. 160 MHz usable I/Q bandwidth).

Relationship between maximum usable I/Q bandwidth and output sample rate for active R&S FSW-B320


Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500

VSA (R&S FSW-K70) > 200Measurement Basics > Sample Rate, Symbol Rate and I/Q Bandwidth > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input > Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500
Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500

The bandwidth extension option R&S FSW-B500 provides measurement bandwidths up to 500 MHz.

Digital Baseband output

Digital Baseband output (see "Digital Baseband Output") is not available for an active R&S FSW-B500 bandwidth extension.

Realtime measurements and MSRT operating mode

Realtime measurements, and thus the entire MSRT operating mode, are not available if the R&S FSW-B500 bandwidth extension option is installed.

Sample rate | Maximum I/Q bandwidth
100 Hz to 600 MHz | proportional up to maximum 500 MHz
600 MHz to 10 GHz | 500 MHz
Relationship between maximum usable I/Q bandwidth and output sample rate for active R&S FSW-B500
MSRA operating mode

In MSRA operating mode with active B500 bandwidth extension, the MSRA Master is restricted to a sample rate of 600 MHz.


Sample Rates and Bandwidths for Digital I/Q Data

VSA (R&S FSW-K70) > 200Measurement Basics > Sample Rate, Symbol Rate and I/Q Bandwidth > Sample Rates and Bandwidths for Digital I/Q Data
Sample Rates and Bandwidths for Digital I/Q Data
Definitions
  • Clock rate: the rate at which data is physically transmitted between the R&S FSW and the connected instrument; both instruments must be able to process data at this rate; the clock rate of the R&S FSW at the output connector is 142.9 MHz; using the Digital I/Q enhanced mode, a data transfer rate of up to 200 Msps is possible
  • Input sample rate (ISR): the sample rate of the useful data provided by the connected instrument to the digital input
  • (User, Output) Sample rate (SR): the sample rate that is defined by the user (e.g. in the "Data Aquisition" dialog box in the "I/Q Analyzer" application) and which is used as the basis for analysis or sent to the digital output
  • Usable I/Q (Analysis) bandwidth: the bandwidth range in which the signal remains unchanged by the digital decimation filter and thus remains undistorted; this range can be used for accurate analysis by the R&S FSW
SlowI/Q measurements

When captured data is transferred and further processed with a slower rate than the rate with which the signal was sampled, this is referred to as a Slow I/Q measurement.

For example, assume an analog signal is sampled by an oscilloscope with a sample rate of 10 GHz. This data is stored in a memory temporarily and then transferred to the R&S FSW via the Digital I/Q Interface with a sample rate of 100R&S FSWMsps. Then the input sample rate on the R&S FSW must be set to 10 GHz so the signal is displayed correctly.

Digital I/Q enhanced mode

As of firmware version 1.80, an enhanced mode for processing data from the Digital Baseband Interface is available. This enhanced mode enables data transfer via the Digital I/Q interface with a data rate of up to 200 Msps (160 MHz bandwidth, compared to the previous 100 Msps/ 80 MHz bandwidth).

The Digital I/Q enhanced mode is automatically used if the following prerequisites are fulfilled:
  • Digital Input: The connected device must support data transfer rates up to 200 Msps.
  • Digital Output:
    – The R&S FSW must supply the required bandwidth, i.e. the bandwidth extension option R&S FSW-B160 or higher must be installed and active.
    – The connected device must support data transfer rates up to 200 Msps.
Restrictions for digital in- and output

The following table describes the restrictions for digital in- and output:

Restrictions for digital in- and output
Parameter | Minimum | Maximum
Record length | 2 complex samples | 220*1024*1024 complex samples
Input sample rate (ISR) | 100 Hz | 10 GHz
Sample Rate (SR) - Digital input | Max(100 Hz; ISR/8388608) | Min(10 GHz; 2*ISR)
Sample Rate (SR) - Digital output | 100 Hz | 200 MHz
Usable I/Q bandwidth (Digital input and filter active) | Min(0.8*SR; 0.8*ISR)
Bandwidths

Depending on the sample rate, the following bandwidths are available:

Bandwidths depending on sample rate for active digital input


Symbol Mapping

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping
Symbol Mapping

Mapping or symbol mapping means that symbol numbers are assigned to constellation points or transitions in the I/Q plane (e.g. PSK and QAM).

In the analyzer, the mapping is required to decode the transmitted symbols from the sampled I/Q or frequency/time data records.

The mappings for all standards used in the analyzer and for all employed modulation modes are described in the following. Unless indicated otherwise, symbol numbers are specified in hexadecimal form (MSB at the left).

Contents
  • Phase Shift Keying (PSK)
  • Rotating PSK
  • Differential PSK
  • Rotating Differential PSK Modulation
  • Offset QPSK
  • Frequency Shift Keying (FSK)
  • Minimum Shift Keying (MSK)
  • Quadrature Amplitude Modulation (QAM)
  • ASK
  • APSK
  • User-defined Modulation


Phase Shift Keying (PSK)

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > Phase Shift Keying (PSK)
Phase Shift Keying (PSK)

With this type of modulation, the information is represented by the absolute phase position of the received signal at the decision points. All transitions in the I/Q diagram are possible. The complex constellation diagram is shown. The symbol numbers are entered in the diagram according to the mapping rule.

BPSK (NATURAL)
Constellation diagram for BPSK including the symbol mapping
QPSK
Constellation diagram for QPSK including the symbol mapping for CDMA2000 FWD and DVB S2
Constellation diagram for QPSK (GRAY) including the symbol mapping
Constellation diagram for QPSK (NATURAL) including the symbol mapping
Constellation diagram for QPSK including the symbol mapping for WCDMA
8PSK
Constellation diagram for 8PSK (GRAY) including the symbol mapping
Constellation diagram for 8PSK (NATURAL) including the symbol mapping
Constellation diagram for 8PSK including the symbol mapping for DVB S2


Rotating PSK

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > Rotating PSK
Rotating PSK

A rotating PSK modulation is basically a PSK modulation in which additional phase shifts occur. These phase shifts depend on the symbol number, e.g. for a π/4-QPSK, the third symbol has an additional phase offset of (3-1)*π/4. This offset has the same effect as a rotation of the basic system of coordinates by the offset angle after each symbol.

The method is highly important in practical applications because it prevents signal transitions through the zeros in the I/Q plane. This reduces the dynamic range of the modulated signal and the linearity requirements for the amplifier.

In practice, the method is used for 3π/8-8PSK, for example, and (in conjunction with phase-differential coding) for π/4-DQPSK.

Symbol mapping

The logical constellation diagram for 3π/8-8PSK comprises 8 points that correspond to the modulation level (see figure "Constellation diagram for 3π/8 8PSK before rotation including the symbol mapping for EDGE"). A counter-clockwise offset (rotation) of 3π/8 is inserted after each symbol transition.

Constellation diagram for 3π/8 8PSK before rotation including the symbol mapping for EDGE
I/Q symbol stream after 3π/8 rotation in I/Q plane if the symbol number "7" is transmitted six times in a row
Constellation diagram for 3π/4 QPSK including the symbol mapping for EDGE
Constellation diagram for π/4 QPSK (Natural) including the symbol mapping


Differential PSK

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > Differential PSK
Differential PSK

With differential PSK, the information is represented in the phase shift between two consecutive decision points. The absolute position of the complex sample value at the decision point does not carry information.

In the physical constellation diagram, the constellation points at the symbol decision points obtained after ISI-free demodulation are shown (as with common PSK methods). This diagram corresponds to the display on the analyzer. The position of the constellation points is standard-specific. For example, some QPSK standards define the constellation points on the diagonals, while other standards define the coordinate axes.

In table "DQPSK (INMARSAT)", the symbols are assigned to phase shifts. The QPSK (INMARSAT) mapping corresponds to simple QPSK with phase-differential coding.

Tables table "D8PSK (NATURAL)" and table "D8PSK (GRAY)" show two types of differential 8PSK modulation.

Differential coding according to VDL is shown in table "D8PSK (VDL)". It can be used for modulation types with 3 bits/symbol, e.g. 8PSK.

Other types of modulation using differential coding method are described in "Rotating Differential PSK Modulation".

Constellation diagram for DQPSK (INMARSAT and NATURAL) including the symbol mapping
DQPSK (INMARSAT)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 00 | 01 | 10 | 11
Phase shift | 0° | -90° | +90° | 180°
Constellation diagram for D8PSK including the symbol mapping for APCO25, APCO25 Phase 2, GRAY, NATURAL and TETRA
D8PSK (NATURAL)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 000 | 001 | 010 | 011 | 100 | 101 | 110 | 111
Phase shift | 0° | 45° | 90° | 135° | 180° | 225° | 270° | 315°
D8PSK (GRAY)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 000 | 001 | 010 | 011 | 100 | 101 | 110 | 111
Phase shift | 0° | 45° | 135° | 90° | 270° | 315° | 225° | 180°
D8PSK (VDL)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 000 | 001 | 010 | 011 | 100 | 101 | 110 | 111
Phase shift | 0° | 45° | 135° | 90° | 315° | 270° | 180° | 225°


Rotating Differential PSK Modulation

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > Rotating Differential PSK Modulation
Rotating Differential PSK Modulation

Phase-differential modulation is frequently combined with an additional phase shift (e.g. π/4 DQPSK = π/4 phase shift modulation + differential modulated 4PSK).

The logical mapping diagram corresponds to the diagram for DPSK.

The physical constellation diagram shows the symbol decision points obtained after ISI-free demodulation.

Constellation diagram for π/4 DQPSK including the symbol mapping for APCO25 Phase 2, NADC, NATURAL, PDC, PHS, TETRA and TFTS; the π/4 rotation is already compensated for
π/4 DQPSK (NADC, PDC, PHS, TETRA)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 00 | 01 | 10 | 11
Phase shift | 0°+45° | 90°+45° | -90°+45° | -180°+45°
π/4 DQPSK (TFTS)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 00 | 01 | 10 | 11
Phase shift | -180°+45° | 90°+45° | -90°+45° | 0°+45°
π/4 DQPSK (Natural)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 00 | 01 | 10 | 11
Phase shift | 0°+45° | 90°+45° | -180°+45° | -90°+45°
π/4 DQPSK (APCO25 and APCO25Phase2)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 00 | 01 | 10 | 11
Phase shift | 0°+45° | 90°+45° | -90°+45° | -180°+45°


Offset QPSK

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > Offset QPSK
Offset QPSK

Offset QPSK differs from "normal" QPSK in the fact that the Q component is delayed by half a symbol period against the I component in the time domain. Hence, the symbol time instants of the I and the Q component do not coincide. The concept of Offset QPSK is illustrated in the diagrams below.

Derivation of OQPSK
I/Q diagram and constellation diagram
QPSK | OQPSK (delayed Q component)
PSK vector diagram with alpha = 0.35 | OQPSK vector diagram with alpha = 0.35

Offset QPSK reduces the dynamic range of the modulated signal (with respect to "normal" QPSK) and, therefore, the demands on amplifier linearity by avoiding zero crossings.

A distinction is made in the analyzer display:

In the Vector I/Q result display of the measurement (or reference) signal, the time delay is not compensated for. The display corresponds to the physical diagram shown in (table "I/Q diagram and constellation diagram")

In the Constellation I/Q result display of the measurement (or reference) signal, the time delay is compensated for. The display corresponds to the logical mapping as in figure "Constellation diagram for OQSK (GRAY) including the symbol mapping".

OQPSK
Constellation diagram for OQSK (GRAY) including the symbol mapping


Frequency Shift Keying (FSK)

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > Frequency Shift Keying (FSK)
Frequency Shift Keying (FSK)

To illustrate symbol mappings for FSK modulations, the symbol numbers are marked in the logical mapping diagram versus the instantaneous frequency. An instantaneous frequency of zero in the baseband corresponds to the input frequency of the analyzer.

2FSK (NATURAL)

With 2FSK, the symbol decision is made by a simple frequency discriminator:

Constellation diagram for 2FSK (NATURAL) including the logical symbol mapping
4FSK

With 4FSK, the symbol decision is made by a frequency discriminator with 3 decision thresholds (-2/3; 0; +2/3) normalized to the FSK reference deviation.

Constellation diagram for 4FSK (NATURAL) including the logical symbol mapping
Constellation diagram for 4FSK (GRAY) including the logical symbol mapping
Constellation diagram for 4FSK for APCO C4FM and APCO Phase 2 including the logical symbol mapping
8FSK (NATURAL)
Constellation diagram for 8FSK (NATURAL) including the logical symbol mapping


Minimum Shift Keying (MSK)

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > Minimum Shift Keying (MSK)
Minimum Shift Keying (MSK)

MSK modulation causes modulation-dependent phase shifts of +/- 90° which can be shown in an Constellation I/Q diagram. As with PSK, demodulation is performed by evaluation of the phase positions.

MSK (NATURAL)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 0 | 1
Phase shift | -90° | +90°
MSK (GSM)
Logical symbol mapping
Modulation symbol (binary indication: MSB, LSB) | 0 | 1
Phase shift | +90° | -90°
MSK (for GSM and NATURAL) and DMSK Constellation Diagram including the symbol mapping

Similar to PSK, differential coding can also be used with MSK. In this case, too, the information is represented by the transition of two consecutive symbols. The block diagram of the coder is shown below.

DMSK: differential encoder in the transmitter

di input symbol {0;1} of differential encoder

di-1 input symbol delayed by the symbol period Ts

d'i output symbol {0;1} of differential encoder

The logical symbol mapping is then performed on the XOR-coded bitstream d'.


Quadrature Amplitude Modulation (QAM)

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > Quadrature Amplitude Modulation (QAM)
Quadrature Amplitude Modulation (QAM)

In the case of QAM the information is represented by the signal amplitude and phase.

The symbols are arranged in a square constellation in the I/Q plane.

To ensure reliable demodulation, symbol numbers should be distributed evenly with respect to the symbol alphabet.

As a rule of thumb, the result length should correspond to at least 8 times the modulation order. For example, with 64 QAM, a result length of at least 8*64 = 512 symbols should be used.

QAM Mappings

The following QAM mappings are obtained from the mapping of the 1st quadrant, which is always rotated by π/2 for the subsequent quadrants and supplemented by a (GRAY-coded) prefix for each quadrant.

Derivation of QAM mappings

In the following diagrams, the symbol mappings are indicated in hexadecimal and binary form.

Constellation diagram for 16QAM (GRAY) including the logical symbol mapping (hexadecimal and binary)
Constellation diagram for 16QAM including the logical symbol mapping for EDGE (hexadecimal and binary)
Constellation diagram for 16QAM including the logical symbol mapping for DVB-C (hexadecimal and binary)
Constellation diagram for 32QAM including the logical symbol mapping for DVB-C (hexadecimal and binary)
Constellation diagram for 64QAM including the logical symbol mapping for DVB-C (hexadecimal and binary); the binary form shows the upper right section of the diagram only.
Constellation diagram for 128QAM including the logical symbol mapping (hexadecimal and binary); the figure shows the upper right sections of the diagram only
Constellation diagram for 256QAM including the logical symbol mapping (hexadecimal); the figure shows the upper right section of the diagram only
Constellation diagram for 512QAM including the logical symbol mapping (hexadecimal); the figure shows the upper right section of the diagram only
Constellation diagram for 1024QAM including the logical symbol mapping (hexadecimal); the figure shows the upper right section of the diagram only


ASK

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > ASK
ASK
2ASK (OOK)

ASK stands for Amplitude Shift Keying, 2ASK (binary) is often also referred to as "On Off Keying" (OOK). With this type of modulation, the information is solely represented by the absolute amplitude of the received signal at the decision points.

Constellation diagram for 2ASK
4ASK

4ASK is a 4-ary Amplitude Shift Keying mapping type. With this type of modulation, the information is solely represented by the absolute amplitude of the received signal at the decision points.

Constellation diagram for 4ASK


APSK

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > APSK
APSK

With Amplitude Phase Shift Keying (APSK) modulation, the information is represented by the signal amplitude and the signal phase.

16APSK
Constellation diagram for 16APSK including the logical symbol mapping for DVB-S2

For DVB-S2 16APSK mappings, the ratio of the outer circle radius to the inner circle radius (γ = R2/R1) depends on the utilized code rate and complies with figure "Constellation diagram for 16APSK including the logical symbol mapping for DVB-S2".

Optimum constellation radius ratio γ (linear channel) for 16APSK
Code Rate | Modulation / coding spectral efficiency | γ
2/3 | 2.66 | 3.15
3/4 | 2.99 | 2.85
4/5 | 3.19 | 2.75
5/6 | 3.32 | 2.70
8/9 | 3.55 | 2.60
9/10 | 3.59 | 2.57
32APSK

For DVB-S2 32APSK mappings, the ratio of the middle circle radius to the inner circle radius (γ1 = R2/R1) and the ratio of the outer circle radius to the inner circle radius (γ2 depend on the utilized code rate and comply with table "Optimum constellation radius ratios γ1 and γ2 (linear channel) for 32APSK".

Optimum constellation radius ratios γ1 and γ2 (linear channel) for 32APSK
Code Rate | Modulation / coding spectral efficiency | γ1 | γ2
2/3 | 3.74 | 2.84 | 5.27
3/4 | 3.99 | 2.72 | 4.87
4/5 | 4.15 | 2.64 | 4.64
5/6 | 4.43 | 2.54 | 4.33
8/9 | 4.49 | 2.53 | 4.30


User-defined Modulation

VSA (R&S FSW-K70) > 200Measurement Basics > Symbol Mapping > User-defined Modulation
User-defined Modulation

In addition to the modulation types defined by the standards, modulation (including symbol mappings) can also be defined according to user requirements. In this case, the mapping is defined and stored in a specific format (*.vam file format) and then loaded to the VSA application. Modulation files in .vam format can be defined using a mapping wizard ("mapwiz"), an auxiliary tool provided by R&S via Internet free of charge. This tool is a precompiled MATLAB® file (MATLAB pcode). To download the tool together with a detailed description see http://www.rohde-schwarz.com (search term "mapwiz").


Overview of the Demodulation Process

VSA (R&S FSW-K70) > 200Measurement Basics > Overview of the Demodulation Process
Overview of the Demodulation Process
Demodulation stages of the vector signal analysis option

The figure "Demodulation stages of the vector signal analysis option" provides an overview of the demodulation stages of the vector signal analysis option. The function blocks of the signal processing kernel can be found at the left (in grey) and their appropriate settings at the right (in blue).

A more detailed description of the most important stages is given in the following sections.

Burst Search

In this stage, the capture buffer is searched for bursts that comply with the signal description. The search itself can be switched on or off via the "Burst Search" dialog (see "Enabling Burst Searches"). A list of the detected bursts is passed on to the next processing stage.

I/Q Pattern Search

The "I/Q Pattern Search" is performed on the capture buffer. This means the VSA application modulates the selected pattern according to the transmit filter (Tx filter) and the modulation scheme. Subsequently, it searches the capture buffer for this I/Q pattern, i.e. the I/Q waveform of the pattern. It is assumed that patterns can only appear within bursts, i.e. the I/Q pattern search range is limited to the bursts detected by the burst search stage. If the burst search is switched off, the whole capture buffer is searched for the I/Q pattern. A list of all detected I/Q patterns is passed on to the next processing stage. It is important to note that the VSA application can only search for one pattern at a time.

The pattern search can be switched on or off via the "Pattern Search" dialog (see "Enabling Pattern Searches").

Detected patterns are indicated by a green background in the symbol table. (If, during demodulation, individual symbols do not match the pattern after all, these symbols are indicated by a red frame.)

Extraction of Result Range

The result range can be aligned to a burst, a pattern or simply the start of the capture buffer (see "Reference"). Within this stage, the result range is cut from the capture buffer starting at a point that is specified by the user, e.g. the start of a detected burst. The VSA application automatically takes into account filter settling times by making the internal buffers sufficiently longer than the selected result range.

Demodulation & Symbol Decisions

This stage operates on the extracted result range and aims at making the correct symbol decisions. Within this stage, a coarse synchronization of the carrier frequency offset, the carrier phase, the scaling and the timing takes place. Furthermore, an automatically selected internal receive filter (Rx filter) is used in order to remove the inter-symbol interference as effectively as possible. The outputs of this stage are the (coarsely) synchronized measurement signal and the symbol decisions (bits). The symbol decisions are later used for the "Pattern Symbol Check" stage and for the "Reference Signal Generation" stage.

Pattern Symbol Check

The "I/Q Pattern Search" stage can only detect whether the similarity between the I/Q pattern and the capture buffer exceeds a certain threshold and, in this way, find the most likely positions where a pattern can be found.

Within this stage, the VSA application checks whether the pattern symbols (bits) really coincide with the symbol decisions at the pre-detected position. For example, if one out of 20 symbols does not coincide, the "I/Q Pattern Search" stage might detect this I/Q pattern, but the "Pattern Symbol Check" stage will decline it.

Note that this stage is only active if the pattern search is switched on.

If individual symbols do not match the pattern, these symbols are indicated by a red frame in the symbol table.

Reference Signal Generation

The ideal reference signal is generated based on the detected symbols and the specifications of the signal model, i.e. the modulation scheme and the transmit filter (Tx filter).

Measurement Filtering

Both the measurement signal and the reference signal are filtered with the specified measurement filter.

Synchronization

In this stage, the measurement signal and the reference signal are correlated. For PSK, QAM and MSK modulated signals, an estimation algorithm is used in order to obtain estimates for the signal amplitude, signal timing, carrier frequency error, phase error, I/Q offset, gain imbalance, quadrature error and the amplitude droop. Alternatively, it is possible to disable the estimation algorithm.

For FSK modulated signals, estimates for the signal amplitude, signal timing, carrier frequency error, FSK deviation error and the carrier frequency drift are calculated. The measurement signal is subsequently corrected with these estimates. Compensation for FSK deviation error and carrier frequency drift can be enabled or disabled.

For more information on synchronization see

  • "Estimation"
  • "Advanced Demodulation (Synchronization)"
Result Display

The selected measurement results are displayed in the window(s). Configuration of the windows can be performed via the "Window Configuration" dialog (see "Display and Window Configuration").

Contents
  • Burst Search
  • I/Q Pattern Search
  • Demodulation and Symbol Decisions
  • Pattern Symbol Check
  • The Equalizer


Burst Search

VSA (R&S FSW-K70) > 200Measurement Basics > Overview of the Demodulation Process > Burst Search
Burst Search

The burst search is performed only if it is switched on. Otherwise, this stage is skipped. It is recommended that you switch the burst search on if the signal is bursted. This ensures that all internal estimators are operated in time ranges where the burst power ramping is up.

In order to eliminate amplitude variations caused by noise or the modulation itself, the instantaneous power of the whole capture buffer is computed and then a moving average filter is applied. The length of this filter is automatically determined with the help of the user settings.

The filtered power of the capture buffer is subsequently compared to an automatically chosen threshold and the rising and falling edges of bursts are identified. With the help of the detected edges and some further processing, it is possible to decide whether the burst "candidates" comply with the user settings.

All bursts must have a length between ("Min Burst Length" – "Search Tolerance") and ("Max Burst Length" + "Search Tolerance") to be accepted. See "Burst Settings" and "Burst Search" for a more detailed description of these parameters.

Burst Search parameters

You can influence the robustness of the burst search directly by entering the correct minimum gap length, minimum burst length and maximum burst length (see "Burst Settings" and "Min Gap Length"). Refer to figure "Burst Search parameters" for an illustration of the three parameters.

The detected bursts in the capture buffer for the current burst search settings are indicated by blue lines in the preview area of the "Burst Search" configuration dialog box (see "Burst Search").

Burst search algorithm


I/Q Pattern Search

VSA (R&S FSW-K70) > 200Measurement Basics > Overview of the Demodulation Process > I/Q Pattern Search
I/Q Pattern Search

The I/Q pattern search is performed only if it is switched on. Otherwise, this stage is skipped. The main benefit of the I/Q pattern search is that it enables an alignment of the result range to the pattern. Furthermore, this stage can function as a filter: If the burst search and I/Q pattern search are switched on, and the parameter "Meas Only If Pattern Symbols Correct" is set to true, only bursts with the correct pattern are demodulated (see "Meas only if Pattern Symbols Correct").

During the I/Q pattern search stage, the capture buffer is searched for an I/Q pattern by trying different time and frequency hypotheses. The I/Q pattern is generated internally, based on the specified symbol number of the pattern and the signal description (i.e. modulation scheme and transmit filter). The I/Q pattern search can also be referred to as the I/Q waveform. An I/Q pattern is considered detected if the correlation metric, i.e. the correlation value between the ideal I/Q pattern and capture buffer, exceeds a specified "I/Q Correlation Threshold" (see "I/Q Correlation Threshold".)

If the burst search is switched on, the I/Q pattern search only searches the I/Q pattern in bursts previously detected by the burst search. Furthermore, it only finds the first I/Q pattern within each burst. If the burst search is switched off, the I/Q pattern search searches for the I/Q pattern in the entire capture buffer.

The first detected pattern in the capture buffer for the current pattern search settings is indicated by a green line in the preview area of the "Pattern Search" configuration dialog box (see "Pattern Search").

Predefined Patterns

Common standards usually have predefined pattern lists with standard-specific patterns. Patterns required for the current measurement can be selected from this list. This list can be extended by patterns that are already available in the instrument. Newly created patterns can also be added to the list.

A number of predefined standards and patterns are provided by the R&S FSW VSA application (see "Predefined Standards and Settings").


Demodulation and Symbol Decisions

VSA (R&S FSW-K70) > 200Measurement Basics > Overview of the Demodulation Process > Demodulation and Symbol Decisions
Demodulation and Symbol Decisions

This stage operates on the result range and aims to make the correct symbol decisions. The algorithm is illustrated in figure "Demodulation and Symbol Decision algorithm" using the example of a QPSK modulation. After timing and scaling recovery, a frequency offset and phase offset estimator is employed.

After this coarse synchronization, the VSA application makes symbol decisions, i.e. recovers which symbols were transmitted by the device under test (DUT).

Typically, the employed estimators are "non-data-aided" (NDA) estimators. This means that they operate on an unknown data sequence. Since the local oscillators (LO) of the transmitter (device under test) and the receiver (R&S FSW) are normally not coupled, their phase offset with respect to each other is unknown. The unknown transmission delay between DUT and R&S FSW adds a further unknown phase offset.

Due to this unknown phase offset, the result of the demodulation can be ambiguous with respect to the absolute phase position because of the rotational symmetry of e.g. a PSK constellation. For example, in the case of non-differential QPSK modulation, the measurement signal, the reference signal and the decided I/Q symbols may have a constant phase offset of {0, π/2, π, or 3π/2}. This offset can only be detected and eliminated if a pattern was successfully detected at symbol level (see also "Pattern Symbol Check").

If modulation types are used where the information is represented by the phase transition, e.g. differential PSK or MSK, the absolute phase position is not an issue. Thus, the ambiguity of the starting phase does not have an influence on the symbol decisions.

If the measurement signal contains a known pattern, it is also possible to use a "data-aided" (DA) estimator at this stage. This means that the estimator operates on a known data sequence, i.e. the pattern. If the signal contains a pattern, it is possible to choose between the above-described non-data-aided estimator and the data-aided estimator with the setting ""Coarse Synchronization": Pattern". If the data-aided estimator is employed, the phase ambiguitiy can be resolved at this stage.

Demodulation and Symbol Decision algorithm


Pattern Symbol Check

VSA (R&S FSW-K70) > 200Measurement Basics > Overview of the Demodulation Process > Pattern Symbol Check
Pattern Symbol Check

This stage performs a bit-by-bit comparison between the selected pattern and the demodulated bits. It is important to note that this comparison is only performed at positions that have been identified by the I/Q pattern search as possible pattern positions. The algorithm and a simple example are illustrated in figure "Pattern Symbol Check algorithm".

First, the pattern candidate bits are extracted from the whole bitstream calculated by the "Demodulation & Symbol Decisions" stage. This means that the symbol stream is cut at the position that has been detected by the "I/Q Pattern Search" as the start of the pattern. The extracted sequence is then compared to the selected pattern.

If the demodulation has been ambiguous with respect to the absolute phase position, the extracted sequence needs to be compared to all possible rotated versions of the selected pattern. For example, in the case of QPSK modulation, the rotational symmetry has the order four, i.e. there are four pattern hypotheses. If the extracted sequence coincides with one of the hypotheses, the pattern is declared as "found" and the absolute phase corresponding to the appropriate hypothesis is passed on. Both the symbol decisions and the I/Q measurement signal are then rotated with this pattern phase (for the whole result range), thus resolving the phase ambiguity.

For more information refer to:

  • "Demodulation and Symbol Decisions"
  • "I/Q Pattern Search"
Pattern Symbol Check algorithm


The Equalizer

VSA (R&S FSW-K70) > 200Measurement Basics > Overview of the Demodulation Process > The Equalizer
The Equalizer

A possible source of high modulation errors of the DUT with PSK and QAM signals is a non-flat frequency response or ripple in frequency response within the modulation bandwidth.

This could be caused by the DUT's:

  • Analog filter sections
  • Digital filter sections, if a shortened filter length is used
  • Digital arithmetic sections, if a shortened bit-length is used
General processing in the modulation- and demodulation stages

An equalizer filter with a reverse frequency response characteristic is able to compensate less distorted frequency responses in order to improve the modulation analysis results (see figure "Compensation of the transfer function's error by inserting an equalizer in the receive path").

Compensation of the transfer function's error by inserting an equalizer in the receive path

For small distortions the reference signal can be determined correctly without pre-equalization. The equalizer can be calculated by comparing the reference signal and the measured signal and is only applied to the measured signal. This is referred to as normal equalizer mode. Note that the resulting equalizer function is not simply the inverted distortion function.

For more complex distortions the reference signal might not be determined correctly due to wrong symbol decisions. Despite the resulting imperfect equalizer calculation, the estimated equalizer is often good enough to improve the reference signal creation in the succeeding sweep. Thus, the new equalizer is improved successively. This processing mode of the equalizer is called tracking mode. After only few sweeps, the results are sufficiently accurate and the learning phase is completed. Then the equalizer can be used without additional calculations as long as the input signal remains stable. If an unstable input has led to an unusable equalizer filter, reset the equalizer with the "Reset" button.

An equalizer filter can be activated in the reference and measurement signal path. The filter coefficients are determined in such a way that the error vector magnitude (EVM) is minimized.

The result range used for equalizer calculation might be quite short leading to unstable equalizer impulse responses. For time-invariant channels the estimation length can be extended using Averaging mode. In this case, the statistics from all previously determined reference signals and measurement signals are averaged to determine the current equalizer function. Thus, the results of previous sweeps are continuously considered to calculate the current equalizer values. Averaging is only restarted when the instrument is switched off or when the user manually resets the equalizer. Obviously, this method requires a stable input signal for the entire duration of the measurement, as otherwise the current equalizer is distorted by previous results.

This process requires extended calculation time so that the measurement update rate of the instrument decreases distinctly. When the distortions are compensated sufficiently, this averaging process can be stopped. The current filter is frozen, that means it is no longer changed.

Keep in mind that in Tracking and Averaging mode for sweep counts > 1 repeated analysis of past result ranges might lead to differing readings.

The equalizer algorithm is limited to PSK and QAM modulation schemes, as the optimization criterion of the algorithm is based on minimizing the mean square error vector magnitude. Thus it cannot be used for FSK modulation.

User-defined equalizers

Instead of tracking equalizer values repeatedly for different input signals, you can store existing values to a file and load them again later. This is useful if signals from the same input source are measured frequently. In this case, you only have to perform a calculation once and can use the same equalizer filter again and again.

Filter length

The length of the equalizer can be defined in symbols. The longer the equalizer the higher the resolution in the frequency domain is and the more distortion can be compensated. The shorter the filter length, the less calculation time is required during the equalizer's tracking or averaging phase.

Estimation points per symbol

You can define how many sample points are used for the equalizer calculation at each symbol ("Estimation points per symbol", see "Display Points vs Estimation Points per Symbol"). Typically, this is one point per symbol (= symbol rate) or a factor of 2.

Channel EVM

The equalizer not only compensates for distortions in the measurement signal, but also improves the accuracy of the estimated ideal reference signal. Thus, it is usually recommendable to enable the equalizer once you have analyzed the original input signal on the R&S FSW. By default, the error results are calculated using the compensated values if the equalizer is enabled. However, you can disable the compensation for channel results in order to analyze the actual error values obtained from the distorted channel.


Signal Model, Estimation and Modulation Errors

VSA (R&S FSW-K70) > 200Measurement Basics > Signal Model, Estimation and Modulation Errors
Signal Model, Estimation and Modulation Errors

This section describes the signal and error models used within the VSA application. The estimation algorithms used to quantify specific modulation errors are then outlined. The descriptions vary depending on the modulation type.

Contents
  • PSK, QAM and MSK Modulation
  • FSK Modulation


PSK, QAM and MSK Modulation

VSA (R&S FSW-K70) > 200Measurement Basics > Signal Model, Estimation and Modulation Errors > PSK, QAM and MSK Modulation
PSK, QAM and MSK Modulation
Contents
  • Error Model
  • Estimation
  • Modulation Errors


Error Model

VSA (R&S FSW-K70) > 200Measurement Basics > Signal Model, Estimation and Modulation Errors > PSK, QAM and MSK Modulation > Error Model
Error Model
Modelling Modulation Errors

The measured signal model for PSK, QAM and MSK modulation is shown in figure "Modelling Modulation Errors" and can be expressed as:

where:

REFI(t) and REFQ(t): the inphase and quadrature component of the reference signal

gI and gQ: the effects of the gain imbalance

cI and cQ: the effects of an I/Q offset

ϑ: the quadrature error

α: the amplitude droop

f0: the carrier frequency offset

φ: the carrier phase offset

Շ: the timing offset

n(t): a disturbing additive noise process of unknown power


Estimation

VSA (R&S FSW-K70) > 200Measurement Basics > Signal Model, Estimation and Modulation Errors > PSK, QAM and MSK Modulation > Estimation
Estimation

The VSA application includes two synchronization stages. The first stage has already been described in the context of the "Demodulation & Symbol Decisions" block (see "Demodulation and Symbol Decisions").

The second stage is realized within the "Synchronization" block. Here, the measurement signal is matched to the reference signal by minimizing the mean square of the error vector magnitude. This is done by selecting the optimum parameter vector [image]:

The minimization takes place at the sample instants specified by the "Estimation Points/Sym" parameter, i.e.

with TE: the sampling period used for estimation

Subsequently, the measurement signal is corrected with the determined parameter vector. Note that with a subset of the parameters, you can enable or disable correction (see "Demodulation - Compensation").

Estimation ranges

The "estimation ranges" are determined internally according to the signal description:

  • For continuous signals, the estimation range corresponds to the entire result range, since it can then be assumed that the signal consists of valid modulated symbols at all time instants.
  • For bursted signals, the estimation range corresponds to the overlapping area of the detected burst and the "Result Range". Furthermore, the Run-In/Run-Out ranges (see "Burst Settings") are explicitly excluded from the estimation range.

In the special case that the signal is indicated as a "burst signal", but is so highly distorted that the burst search cannot detect a burst, the estimation range corresponds to the pattern and (if an offset of the pattern is indicated) the useful part of the burst from its start to the pattern start.


Modulation Errors

VSA (R&S FSW-K70) > 200Measurement Basics > Signal Model, Estimation and Modulation Errors > PSK, QAM and MSK Modulation > Modulation Errors
Modulation Errors
Error vector (EV)
Modulation error: error vector

The error vector is the difference between the measurement signal vector (Meas vector) and the reference signal vector (Ref vector).

Error Vector Magnitude (EVM)
Modulation error: EVM, magnitude error, phase error

The magnitude of the error vector in the diagram is specified as the error vector magnitude (EVM). It is commonly normalized to the mean reference power. The EVM should not be confused with the magnitude error, see below.

Magnitude Error

The magnitude error is defined as the difference between the measurement vector magnitude and the reference vector magnitude (see figure "Modulation error: EVM, magnitude error, phase error").

Phase Error
Modulation error: Phase error, error vector phase

The phase error is the phase difference between the measurement vector and the reference vector.

This measurement parameter is of great importance for MSK modulation measurements.

The phase error should not be confused with the error vector phase. The error vector phase is the absolute phase of the error vector (see figure "Modulation error: Phase error, error vector phase").

The effects of the different modulation errors in the transmitter on the result display of the analyzer are described in the next topics. All diagrams show the equivalent, complex baseband signal.

Modulation Error Ratio (MER)

The modulation error ratio (MER) is closely related to EVM:

where the EVM is normalized to the mean reference power.

Symbol Rate Error (SRE)

The symbol rate error (SRE) describes the difference between the defined (reference) symbol rate and the currently measured symbol rate in relation to the reference symbol rate. The value is given in parts per million (ppm).

Currently, the SRE is only calculated for PSK, QAM and User QAM modulation, and only if compensation for SRE is activated (see "Demodulation - Compensation").

Example:

For a defined symbol rate of SRRef = 1 MHz, and a measured symbol rate of SRMeas = 999.9 kHz, the symbol rate error is:

SRE = [(999.9-1000) / 1000 ] * 1 000 000 ppm = -100 ppm

I/Q Offset (Origin Offset)
Effect of an I/Q or origin offset after demodulation and error compensation

The effect of an I/Q offset in the transmitter is shown in figure "Effect of an I/Q or origin offset after demodulation and error compensation".

The I/Q offset can be compensated for if the corresponding option is selected in the demodulation settings. In this case, the offset does not affect the EVM.

Example:

The following figures compare the results for a compensated I/Q offset of 2.5% and a non-compensated offset.

I/Q Offset compensated for | I/Q Offset NOT compensated for
Gain Imbalance
Effect of gain imbalance

The gain difference in the I and Q channels during signal generation in the transmitter is referred to as gain imbalance. The effect of this error on the constellation diagram and the unit circle are shown in figure "Effect of gain imbalance". In the example, the gain in the I channel is slightly reduced which causes a distortion of coordinates in the I direction. The unit circle of the ideal constellation points has an elliptic shape.

The gain imbalance can be compensated for if the corresponding option is selected in the demodulation settings. In this case, the imbalance does not affect the EVM.

Note that the gain imbalance is not estimated (and cannot be compensated for) in a BPSK signal.

Preconditions for Gain Imbalance and Quadrature Error measurements

The distortions "gain imbalance" and "quadrature error" can only be measured without ambiguity, if the following two conditions are fullfilled:

  • a pattern is detected
  • the modulation is a non-differential, non-rotating QAM or PSK

Otherwise, only the measurement parameter "I/Q Imbalance", which is a combination of the gain imbalance and the quadrature error, is significant.

Quadrature Error
Effect of Quadrature Error

The quadrature error is another modulation error which is shown in figure "Effect of Quadrature Error".

In this diagram, the I and Q components of the modulated carrier are of identical amplitude but the phase between the two components deviates from 90°.

This error also distorts the coordinates. In the example in figure "Effect of Quadrature Error", the Q-axis is shifted.

Note that the quadrature error is not estimated (and cannot be compensated for) in a BPSK signal.

I/Q Imbalance

The effect of quadrature error and gain imbalance are combined to form the error parameter I/Q imbalance.

where gI and gQ are the gain of the inphase and the quadrature component and θ represents the quadrature error.

The I/Q imbalance can be compensated for if the corresponding option is selected in the demodulation settings. In this case, the I/Q imbalance does not affect the EVM.

Note that the I/Q imbalance is not estimated (and cannot be compensated for) in a BPSK signal.

Amplitude Droop

The decrease of the signal power over time in the transmitter is referred to amplitude droop.

Effect of amplitude droop
Gain Distortion
Effect of nonlinear amplitude distortions
Nonlinear distortions: amplitude distortion (transmitter) | Amplitude distortion (analyzer)

The effect of nonlinear amplitude distortions on a 64QAM signal are illustrated in table "Effect of nonlinear amplitude distortions" (only the first quadrant is shown). The transfer function is level-dependent: the highest effects occur at high input levels while low signal levels are hardly affected. The signal is scaled in the analyzer so that the average square magnitude of the error vector is minimized. The second column shows the signal after scaling.

Amplitude transfer functions
Amplitude transfer function (transmitter) | Amplitude transfer function (analyzer)

A logarithmic display of the amplitude transfer functions is shown in table "Amplitude transfer functions". The analyzer trace is shifted against the transmitter trace by this scale factor.

Phase Distortion
Effect of nonlinear phase distortions
Nonlinear distortions: phase distortion (transmitter) | Phase distortion (analyzer)

The effect of nonlinear phase distortions on a 64QAM signal is illustrated in table "Effect of nonlinear phase distortions" (only the first quadrant is shown). The transfer function is level-dependent: the highest effects occur at high input levels while low signal levels are hardly affected. These effects are caused, for instance, by saturation in the transmitter output stages. The signal is scaled in the analyzer so that the average square magnitude of the error vector is minimized. The second column shows the signal after scaling.

Phase transfer functions
Nonlinear distortions: phase distortion (transmitter) | Phase distortions (analyzer)

A logarithmic display of the phase transfer functions is shown in table "Phase transfer functions". The analyzer trace is shifted by the phase described above as against the transmitter trace.

Noise
Additive noise

A 64QAM signal with additive noise is shown in figure "Additive noise" (only the first quadrant is shown). The symbol decision thresholds are also shown.

The noise signal forms a "cloud" around the ideal symbol point in the constellation diagram. Exceeding the symbol decision boundaries leads to wrong symbol decisions and increases the bit error rate.

Similar displays are obtained in case of incorrect transmitter filter settings. When an incorrect filter is selected, crosstalk occurs between neighbouring symbol decision points instead of the ISI-free points. The effect increases the more the filtering deviates from actual requirements.

The two effects described cannot be distinguished in the Constellation I/Q diagram but in statistical and spectral analyses of the error signal.

Channel (transmission) distortion

During transmission, disturbances in the transmission channel may cause distortions in the input signal at the R&S FSW. Such influences are included in the EVM calculation. However, if the ideal (reference) signal can be estimated with sufficent accuracy by the R&S FSW (e.g. using the equalizer), the channel distortions can be compensated for and deducted from the EVM.


FSK Modulation

VSA (R&S FSW-K70) > 200Measurement Basics > Signal Model, Estimation and Modulation Errors > FSK Modulation
FSK Modulation
Signal Model

Frequency shift keying (FSK) involves the encoding of information in the frequency of a transmitted signal. As opposed to other modulation formats such as PSK and QAM, the FSK process is a non-linear transformation of the transmitted data into the transmitted waveform.

A sequence of symbols {si} are modulated using a "frequency pulse" g(t) to form the instantaneous frequency of the transmitted complex baseband waveform, denoted by fREF(t) and defined as:

where fSymb=1/T is the symbol rate and h is a scaling factor, termed the modulation index. The transmitted (or reference) FSK signal is formed by frequency modulation of the instantaneous frequency:

where φREF(t) denotes the phase of the transmitted waveform. In the VSA application a continuous phase FSK signal is assumed, which is ensured by the integral in the expression for REF(t). A graphical depiction of the reference waveform generation is shown below in figure "Reference complex baseband FSK signal generation".

Reference complex baseband FSK signal generation
Reference Deviation

The transmitted symbols {si} are assumed to be chosen from a finite and real-valued constellation of M values; {ς1,ς2,...,ςM}. The maximum absolute constellation point is denoted by ςMAX. The maximum phase contribution of a data symbol is given by:

The reference deviation of the FSK signal is defined as:

In the VSA application the frequency pulse filter is normalized such that:

The constellation for M FSK is assumed to be {±1, ±3, ..., ±(M-1)}, which implies ςMAX = M-1. The expression for the reference deviation in terms of the modulation index is therefore given by:

The above formula provides the necessary calculation for measurement of an FSK signal with known symbol rate and modulation index.

Calculation examples:

The GSM standard describes the transmission of binary data using MSK (i.e. 2FSK) modulation with a modulation index of h=1/2 at a symbol rate of 270.8333 KHz. The reference deviation is therefore given by:

The APCO Project 25 standard (phase 2) defines a H-CPM signal (i.e. 4FSK) with a modulation index of h=1/3 and a symbol rate of 6 KHz. The reference deviation is:

Contents
  • Error Model
  • Estimation
  • Modulation Errors


Error Model

VSA (R&S FSW-K70) > 200Measurement Basics > Signal Model, Estimation and Modulation Errors > FSK Modulation > Error Model
Error Model

The FSK measurement model used assumes that signal distortions in both the magnitude and phase/frequency are present, as well as additive noise. The measured signal model is expressed as:

with

n(t) is a disturbing additive noise process of unknown power,

ADIST(t) is the distorted magnitude model and

φDIST(t) is the distorted phase model.

The magnitude model is given by:

with

K is a constant scaling factor which can be interpreted as the system gain and

⍺ is the amplitude droop in Nepers per second.

The phase model is given by:

with

B is a scaling factor which results in a reference deviation error,

C is a carrier frequency offset in radians per second,

D is a frequency drift in radians per second per second,

τ is a timing offset in seconds and

ϕ is a phase offset in radians.

For the above phase model, an equivalent frequency distortion model may be expressed as:

with

B is the scaling factor which results in a reference deviation error,

f0=C/(2·π) is a carrier frequency offset in Hz,

f0=D/(2·π) is a frequency drift in Hz per second and

τ is the timing offset in seconds.

The measured signal model in terms of the instantaneous frequency and all distortion parameters is given by:


Estimation

VSA (R&S FSW-K70) > 200Measurement Basics > Signal Model, Estimation and Modulation Errors > FSK Modulation > Estimation
Estimation

The estimation of the distortion parameters listed previously is performed separately for the magnitude and phase/frequency distortions, as illustrated in figure "FSK Estimation Strategy". It is noted that the estimation of the timing offset is performed only on the frequency of the signal, as the reference magnitude is assumed to be constant over the estimation range. For details on the estimation range, see "Estimation ranges".

FSK Estimation Strategy

In figure "FSK Estimation Strategy" MEAS(n) denotes the sampled (complex baseband) measured signal waveform. The magnitude samples are denoted AMEAS(n), while the instantaneous frequency samples of the measured and reference signals are denoted by fMEAS(n) and fREF(n) respectively. The dashed outline of the "Meas Filter" block indicates that this operation is optionally (de-) activated based on the corresponding user settings (see "Type" ).

For the estimation of the magnitude parameters, the following least-squares criterion is minimized:

with respect to the model parameters K and ⍺, where TE denotes the sampling period used for estimation (see "Estimation Points/Sym").

For estimation of the frequency parameters, the following least-squares criterion is minimized:

with respect to the model parameters B, f0, fd and τ. The term denotes the reference instantaneous frequency with a (possibly fractional) delay of samples.

For FSK modulation the default sampling period used for estimation is the capture sampling period.


Modulation Errors

VSA (R&S FSW-K70) > 200Measurement Basics > Signal Model, Estimation and Modulation Errors > FSK Modulation > Modulation Errors
Modulation Errors

A 2FSK signal is generated using a GMSK frequency pulse. Examples of carrier drift and reference deviation are shown in figure "The reference and distorted instantaneous frequency of a GMSK signal with a carrier frequency drift" and figure "The reference and measured instantaneous frequency of a GMSK signal with reference deviation error", respectively.

Carrier frequency drift

A carrier frequency drift is modeled as a linear change in the carrier frequency with respect to time. The effect of carrier drift on the instantaneous frequency of an FSK signal is illustrated in figure "The reference and distorted instantaneous frequency of a GMSK signal with a carrier frequency drift".

The reference and distorted instantaneous frequency of a GMSK signal with a carrier frequency drift
FSK deviation error

The FSK deviation error is the difference between the measured frequency deviation and the reference frequency deviation as entered by the user (see "FSK Ref Deviation (FSK only)"). The evidence of a deviation error in the instantaneous frequency of an FSK signal is demonstrated in figure "The reference and measured instantaneous frequency of a GMSK signal with reference deviation error".

The reference and measured instantaneous frequency of a GMSK signal with reference deviation error


Measurement Ranges

VSA (R&S FSW-K70) > 200Measurement Basics > Measurement Ranges
Measurement Ranges

The VSA application contains three measurement ranges that need to be set by the user:

  • Capture Buffer Length
    The length of the capture buffer specifies how many data points are captured during a single VSA measurement.
    For example, if you want to measure a bursted signal, it is recommended that you make the capture length long enough to ensure that in each capture buffer at least one entire burst is included.
    The maximum capture buffer length is 64 000 symbols (for a sample rate of 4) or 256 000 samples.
  • Result Range
    The result range defines the symbols from the capture buffer that are to be demodulated and analyzed together.
    For example, bursted signals have intervals between the bursts that are not of interest when analyzing peaks or overshoots. Thus, the result range usually coincides with the range of the capture buffer in which the burst is located.
    The maximum result range length is the entire capture buffer, which is 64 000 symbols (for a sample rate of 4) or 256 000 samples.
  • Evaluation Range
    The evaluation range defines the symbols from the result range that are to be included in the evaluation of specific parameters, e.g. error vectors.
    For example, while you may want to display the ramps of a burst and thus include them in the result range, they do not contribute to the error vectors or power levels. Thus, you would not include them in the evaluation range.
Schematic overview of Capture Length, Result Range, and Evaluation Range

The determined result and evaluation ranges are included in the result displays (where useful) to visualize the basis of the displayed values and traces.

Contents
  • Result Range
  • Evaluation Range


Result Range

VSA (R&S FSW-K70) > 200Measurement Basics > Measurement Ranges > Result Range
Result Range

The result range defines the symbols from the capture buffer that are to be demodulated and analyzed together.

In some cases, the data in the capture buffer contains parts that are not relevant for the evaluation task at hand. Thus, you can exclude them from the result range (see "Result Range Configuration").

Result range display

The result ranges are indicated by green bars along the time axis of the capture buffer result diagrams.

Result ranges for a burst signal

Result displays whose source is not the capture buffer are based on a single result range, such as the "EVM vs. Time" display or the data in the "Current" column of the Result Summary. In this case, you can use the capture buffer display to navigate through the available result ranges ("Select Result Rng" softkey), and analyze the individual result ranges in separate windows. The currently displayed result range is indicated by a blue bar in the capture buffer display.

You can change the position of the result range quickly and easily by dragging the blue bar representing the result range to a different position in the capture buffer.

Continuous and discrete result ranges

Depending on the type of signal and your result range definition, the result ranges may be continuous or discrete. Bursted signals commonly have several discrete result ranges at the bursts, with intervals during the noise periods which should not be included in the results (see figure "Result ranges for a burst signal").

Continuous signals, on the other hand, have result ranges that cover the entire or a specific part of the capture buffer without intervals.

Result ranges for a continuous signal
Result Range Length

The result range length is defined by the number of symbols that are to be demodulated. All traces over time are displayed over the result range. For example, if you have a burst of 100 symbols and you define the result length as 200 symbols, you can examine the burst ramps in detail (by selecting the alignment "Burst - Center").

The maximum result length is 64 000 symbols (for a sample rate of 4) or 256 000 samples.

Result Range Alignment

By defining the number of the symbol which marks the beginning of the alignment reference source (burst, capture buffer or pattern), you can define an offset of the x-axis (in addition to the one defined for the signal structure, see "Offset").

For example, if you align the result to the center of the pattern and set the "Symbol Number at Pattern Start" to "0", you can easily find the pattern start in the EVM measurement simply by moving a marker to the symbol number "0".

When you define the "Symbol Number at <Reference> Start" remember to take the offset defined for the signal structure into consideration (see "Offset"). If you define an offset of the pattern with respect to the useful part of the burst in the signal description and align the result to the pattern, the "Symbol Number at Pattern Start" refers to the first symbol of the useful part of the burst, not the first symbol of the pattern.

Run-In / Run-Out Time

The parameter Run-In/-Out can be used to influence the range over which the EVM is minimized. The (internal) synchronization range is the overlapping area of the result range and the burst excluding its Run-In/-Out areas. Hence, this parameter also allows for demodulation of bursts with mixed modulations, e.g. Bluetooth, because it can be used to explicitely exclude symbols from influencing the synchronization.

Useful length

The burst excluding its Run-In/-Out areas is sometimes referrred to as the "useful part". The minimum length of the useful part (= Min Length - Run-In - Run-Out) must be ≧10.


Evaluation Range

VSA (R&S FSW-K70) > 200Measurement Basics > Measurement Ranges > Evaluation Range
Evaluation Range

In some scenarios, the result range contains symbols that are not supposed to be considered for the EVM or other calculated parameters that are displayed in the Result Summary.

For example, while you may want to display the ramps of a burst and thus include them in the result range, they do not contribute to the error vectors or power levels. Thus, you would not include them in the evaluation range. (See also "Evaluating the Rising and Falling Edges").

The evaluation range is always equal to or smaller than the result range and defines:

  • The range over which traces that do not have a time axis are displayed, e.g. polar diagrams
  • The range over which the following parameters are calculated for the Result Summary: EVM, MER, Phase Error, Magnitude Error, Power
Evaluation range display

In all displays over time, except for capture buffer displays, the evaluation range is indicated by red lines.

Evaluation lines in absolute magnitude diagram

In symbol tables, the evaluated symbols are indicated by red square brackets.

In other result displays that are based on the evaluation range only, two red vertical lines are displayed in the diagram header to indicate a limited evaluation basis.


Display Points vs Estimation Points per Symbol

VSA (R&S FSW-K70) > 200Measurement Basics > Display Points vs Estimation Points per Symbol
Display Points vs Estimation Points per Symbol
Estimation points per symbol

During synchronization, the measurement signal is matched to the reference signal and various signal parameters are calculated, as well as the optional equalizer. You can define how many sample points are used for this calculation at each symbol. Typically, this is one point per symbol (= symbol rate) or a factor of 4 (= sample rate).

Display points per symbol

The number of points per symbol used for calculation may vary from the number of points used to display the results of the calculation. If more points per symbol are selected than the defined sample rate, the additional points are interpolated for the display. The more points are displayed per symbol, the more detailed the trace becomes, as illustrated in figure "Result display with different numbers of points per symbol: window A = 1; window B = 2; window C = 4; window D = 16;".

Result display with different numbers of points per symbol: window A = 1; window B = 2; window C = 4; window D = 16;

The displayed points per symbol also determine how many values are returned when the trace data is queried by a remote command (see TRACe<n>[:​DATA]).

For results based on the capture buffer, one display point is displayed for each sample taken, i.e. the display points per symbol are always identical to the sample rate.

For the "Result Summary", the number of display points corresponds to the estimation points per symbol. (By default, 1 for QAM and PSK modulated signals and the sample rate for MSK and FSK modulated signals.) This value also controls which samples are considered for the peak and RMS values and the power result.

For all other result displays, the default number of displayed points per symbol is identical to the sample rate.


Capture Buffer Display

VSA (R&S FSW-K70) > 200Measurement Basics > Capture Buffer Display
Capture Buffer Display

In previous firmware versions, the capture length in the R&S FSW VSA application was restricted to 256,000 samples. As of firmware version 2.00, up to 200 million symbols can be captured and processed at a time.

Processing large numbers of samples

If more than 256,000 samples are captured, overlapping result ranges with a size of 256,000 samples each are created.

The maximum number of symbols that can be captured depends on the specified number of samples per symbol; for example, for the default sample rate of 4*symbol rate, the maximum number of symbols to be captured is 50,000,000 (see also "Sample Rate, Symbol Rate and I/Q Bandwidth").

Only one result range at a time can be displayed in the result displays based on the capture buffer (except for the "Magnitude Overview Absolute"). You can scroll through the samples in different ranges. When you scroll in the diagram, the right edge of the current result range is displayed in the center of the next range.

Overview vs. details

While the "Magnitude Absolute" and other result displays based on the capture buffer ("Real/Imag (I/Q)", "Vector I/Q", "Frequency Absolute") can only display a single result range at a time, the "Magnitude Overview Absolute" displays the entire capture buffer at once. However, the overview trace is restricted to 25,000 points. If necessary, the captured samples are mapped to 25,000 display points using an autopeak detector for display in the Magnitude Overview Absolute diagram. Thus, this result display is not suitable to detect transient effects or analyze individual symbols closely. For these purposes, the Magnitude Absolute result display is suited better, where one display point can be displayed for each sample taken.

Since the result ranges are only calculated and processed one after the other after the entire capture process has been completed, the Magnitude Overview Absolute result display is displayed sooner than the Magnitude Absolute display with several ranges. However, for large capture lengths, all result displays based on the capture buffer require some time before results are displayed.

Restrictions

Trace modes that calculate results for several sweeps (Average, MinHold, MaxHold) are applied to the individual ranges in the capture buffer diagrams and thus may not provide useful results. For the Magnitude Overview Absolute result display, these trace modes are not available at all. Furthermore, only one trace can be configured in the Magnitude Overview Absolute result display.

Remote commands:

Remote commands are provided to determine which result range is currently being displayed:

[SENSe:​]DDEMod:​SEARch:​MBURst:​STARt?

DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​STOP?


Known Data Files - Dependencies and Restrictions

VSA (R&S FSW-K70) > 200Measurement Basics > Known Data Files - Dependencies and Restrictions
Known Data Files - Dependencies and Restrictions

For various vector signal analysis functions the measured signal is compared to a defined ideal reference signal. The more precise the reference signal, the more precise the results become. In the best case, the possible data sequences within the signal to analyze are known in advance and can be used to compare the measured data to. This is similar to defining a pattern for the entire result range. Thus, a falsely estimated reference signal (due to false symbol decisions) is avoided and does not influence the error calculation.

You can load xml files containing the possible sequences to the VSA application and use them to compare the measured data to. In particular, you can use known data for the following functions:

  • Fine synchronization during the demodulation process (see figure "Demodulation stages of the vector signal analysis option" and "Fine Synchronization")
  • Calculation of the Bit Error Rate (BER), see "Bit Error Rate (BER)"

For details on working with Known Data files see "How to Manage Known Data Files".

Auxiliary tool to create Known Data files

An auxiliary tool to create Known Data files from data that is already available in the VSA application is provided on the instrument free of charge. See "To create a Known Data file using the recording tool for sequences".

The syntax for Known Data files is described in "Known Data File Syntax Description".

When you use Known Data files as a reference, some dependencies to other settings and restrictions for other functions apply.

Modulation Order

The "Modulation Order" selected in the "Modulation" settings in the VSA application must correspond to the modulation order value specified in the xml file (<ModulationOrder> element).

Demodulation

Demodulation using synchronization to the Known Data may increase the measurement duration, as each detected symbol must be compared to each possible sequence in the data file.

Result Length

The "Result Length" specified in the "Result Range" dialog box in the VSA application must be identical to the length of the specified symbol sequences in the xml file (<ResultLength> element).

Result Range Alignment
  • Bursted signals
    When you align the result range to a bursted signal, due to the uncertainty of the burst search, the determined result range might start up to 2 symbols before or after the actual burst. However, an offset of only one symbol has the effect that none of the predefined symbol sequences in the Known Data file will be found. To avoid this, try one of the following:
    – Align the result range to a pattern instead of the burst.
    – Use a precise external trigger and align the result range to the capture buffer. This requires a very precise trigger timing, otherwise the result range start may be incorrect again.
  • Continuous signals
    For continuous signals without a pattern, the result range is aligned randomly. Thus, a very large number of possible sequences must be predefined.
    Use a precise external trigger and align the result range to the capture buffer. This requires a very precise trigger timing, otherwise the result range start may be incorrect again.


VSA in MSRA/MSRT Operating Mode

VSA (R&S FSW-K70) > 200Measurement Basics > VSA in MSRA/MSRT Operating Mode
VSA in MSRA/MSRT Operating Mode

The R&S FSW VSA application can also be used to analyze data in MSRA and MSRT operating mode. The main difference between the two modes is that in MSRA mode, an I/Q analyzer performs data acquisition, while in MSRT mode, a realtime measurement is performed to capture data.

In MSRA/MSRT operating mode, only the MSRA/MSRT Master actually captures data; the MSRA/MSRT applications receive an extract of the captured data for analysis, referred to as the application data. For the R&S FSW VSA application in MSRA/MSRT operating mode, the application data range is defined by the same settings used to define the signal capture in Signal and Spectrum Analyzer mode. In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the application data for vector signal analysis. The "Capture Buffer" displays show the application data of the VSA application in MSRA/MSRT mode.

Data coverage for each active application

Generally, if a signal contains multiple data channels for multiple standards, separate applications are used to analyze each data channel. Thus, it is of interest to know which application is analyzing which data channel. The MSRA/MSRT Master display indicates the data covered by each application, restricted to the channel bandwidth used by the corresponding standard, by vertical blue lines labeled with the application name. Since the VSA application supports several standards and the standard used by the currently analyzed data is not known, the "Symbol Rate" defined in the "Signal Description" settings is used to approximate the channel bandwidth.

Analysis interval

However, the individual result displays of the application need not analyze the complete data range. The data range that is actually analyzed by the individual result display is referred to as the analysis interval.

In the R&S FSW VSA application the analysis interval is automatically determined according to the evaluation range or result range settings, as in Signal and Spectrum Analyzer mode. The currently used analysis interval (in seconds, related to capture buffer start) is indicated in the window header for each result display.

Exception: Equalizer

In the "Equalizer" displays do not indicate the analysis interval in MSRA/MSRT mode.

Analysis line

A frequent question when analyzing multi-standard signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .


Configuration

VSA (R&S FSW-K70) > Configuration
Configuration

Using the VSA application you can perform vector signal analysis measurements using predefined standard setting files, or independently of digital standards using user-defined measurement settings. Such settings can be stored for recurrent use.

Thus, configuring VSA measurements requires one of the following tasks:

  • Selecting an existing standard settings file and, if necessary, adapting the measurement settings to your specific requirements.
  • Configuring the measurement settings and, if necessary, storing the settings in a file.
VSA application

When you switch the application of a measurement channel to VSA the first time, a set of parameters is passed on from the currently active application (see "Default Settings for Vector Signal Analysis"). After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

VSA in MSRT mode

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for the MSRT Master, or stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, using the "Refresh" functions (see "Refresh"/"Refresh All" ).

For details see "Configuring and Performing Measurements in MSRT Mode" .

When you activate a measurement channel for the VSA application, a VSA measurement for the input signal is started automatically with the default configuration. The "VSA" menu is displayed and provides access to the most important configuration functions.

For a description see
  • "Signal Description"
  • "Input, Output and Frontend Settings"
  • "Signal Capture"
  • "Burst and Pattern Configuration"
  • "Result Range Configuration"
  • "Demodulation Settings"
  • "Measurement Filter Settings"
  • "Display and Window Configuration"

The SPAN, BW, and MARKER FUNCT menus are currently not used.

Automatic refresh of preview and visualization in dialog boxes after configuration changes

The R&S FSW supports you in finding the correct measurement settings quickly and easily - after each change in settings in dialog boxes, the preview and visualization areas are updated immediately and automatically to reflect the changes. Thus, you can see if the setting is appropriate or not before accepting the changes.

Importing and Exporting I/Q Data

The I/Q data to be evaluated in VSA can not only be measured by the VSA application itself, it can also be imported to the application, provided it has the correct format. Furthermore, the evaluated I/Q data from the VSA application can be exported for further analysis in external applications.

The import and export functions are available in the "Save/Recall" menu which is displayed when you select the [image] "Save" or [image] "Open" icon in the toolbar.

For details on importing and exporting I/Q data see "I/Q Data Import and Export".

Contents
  • Default Settings for Vector Signal Analysis
  • Configuration According to Digital Standards
  • Configuration Overview
  • Signal Description
  • Input, Output and Frontend Settings
  • Signal Capture
  • Burst and Pattern Configuration
  • Result Range Configuration
  • Demodulation Settings
  • Measurement Filter Settings
  • Evaluation Range Configuration
  • Adjusting Settings Automatically
  • Meas Menu
  • Span, BW and Marker Func Menus


Default Settings for Vector Signal Analysis

VSA (R&S FSW-K70) > Configuration > Default Settings for Vector Signal Analysis
Default Settings for Vector Signal Analysis

When you switch the application of a measurement channel to VSA the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • signal source and digital I/Q input settings
  • input coupling
  • YIG filter state

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a measurement channel has been set to VSA, or after a "Preset Channel":

Default settings for VSA channels
Parameter | Value
Digital standard | 3G_WCDMA
Sweep mode | CONTINUOUS
Trigger settings | FREE RUN
Trigger offset | 0
Modulation | QPSK, WCDMA mapping
Transmit filter | RRC, α=0.22
Measurement filter | = Transmit filter
Signal type | Continuous, no pattern
Symbol rate | 3.84 MHz
Sample rate | 4* Symbol rate (=15.36 MHz)
Capture length | 8000 symbols
Usable I/Q Bandwidth | 12.228 MHz
Result length | 800 symbols
Result Range alignment | Left at capture buffer start
Evaluation range | Entire result range
Demodulation | Compensation for I/Q offset and amplitude droop Estimation points per symbol: auto (1)
Evaluations | Window 1: Constellation I/Q (Meas & Ref) Window 2: Result Summary Window 3: Magnitude absolute (Capture buffer) Window 4: Symbol table (hexadecimal)
Display points per symbol | = Sample rate (4)

Apart from the "Preset Channel" function (see "Preset Channel"), the following functions are available to restore factory settings to the VSA application (via softkeys in the MEAS menu):

└ Restore Factory Settings
└ Restore Standard Files
└ Restore Pattern Files


Restore Factory Settings

VSA (R&S FSW-K70) > Configuration > Default Settings for Vector Signal Analysis > Restore Factory Settings
Restore Factory Settings

Opens a submenu that allows you to restore all standards and pattern settings on the instrument to the values predefined by Rohde & Schwarz available at the time of delivery.

└ Restore Standard Files
└ Restore Pattern Files


Restore Standard Files

VSA (R&S FSW-K70) > Configuration > Default Settings for Vector Signal Analysis > Restore Factory Settings > Restore Standard Files
Restore Standard Files

Restores the standards predefined by Rohde & Schwarz available at the time of delivery.

Note that this function will overwrite customized standards that have the same name as predefined standards.

Remote command:

[SENSe:​]DDEMod:​FACTory[:​VALue]


Restore Pattern Files

VSA (R&S FSW-K70) > Configuration > Default Settings for Vector Signal Analysis > Restore Factory Settings > Restore Pattern Files
Restore Pattern Files

Restores the pattern files predefined by Rohde&Schwarz available at the time of delivery.

Remote command:

[SENSe:​]DDEMod:​FACTory[:​VALue]


Configuration According to Digital Standards

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards
Configuration According to Digital Standards

Various predefined settings files for common digital standards are provided for use with the VSA application. In addition, you can create your own settings files for user-specific measurements.

For an overview of predefined standards and settings see "Predefined Standards and Settings". For detailed instructions see "How to Perform VSA According to Digital Standards"

Digital standard settings are available via the "Digital Standards" softkey in the MEAS menu.

└ Digital Standards
└ Selecting the Storage Location - Drive/ Path/ Files
└ New Folder
└ File Name
└ Comment
└ Load Standard
└ Save Standard
└ Delete Standard
└ Restore Standard Files


Digital Standards

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards > Digital Standards
Digital Standards

Opens a file selection dialog to manage predefined measurement settings for conventional mobile radio standards.

See "How to Perform VSA According to Digital Standards" for details. For an overview of predefined standards and settings see "Predefined Standards and Settings".

└ Selecting the Storage Location - Drive/ Path/ Files
└ New Folder
└ File Name
└ Comment
└ Load Standard
└ Save Standard
└ Delete Standard
└ Restore Standard Files


Selecting the Storage Location - Drive/ Path/ Files

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards > Digital Standards > Selecting the Storage Location - Drive/ Path/ Files
Selecting the Storage Location - Drive/ Path/ Files

Select the storage location of the settings file on the instrument or an external drive.

The "Drive" indicates the internal (C:) or any connected external drives (e.g. a USB storage device).

The "Path" contains the drive and the complete file path to the currently selected folder.

The "Files" list contains all subfolders and files of the currently selected path.

The default storage location for the standards files is: C:\R_S\Instr\user\vsa\Standards.

Note: Saving instrument settings in secure user mode. In secure user mode all data is stored to volatile memory, and is only available during the current instrument session. As soon as the power is switched off on the R&S FSW, the data is cleared.
To store settings permanently, select an external storage location, such as a USB memory device.
For details see "Protecting Data Using the Secure User Mode" .


New Folder

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards > Digital Standards > New Folder
New Folder

Creates a new folder in the file system in which you can save the settings file.


File Name

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards > Digital Standards > File Name
File Name

Contain the name of the data file without the path or extension.

By default, the name of a settings file consists of a base name followed by an underscore. Multiple files with the same base name are extended by three numbers, e.g. limit_lines_005.

For details on the file name and location see "Storage Location and File Name" .

Note: Secure user mode. In secure user mode, settings that are to be stored on the instrument are stored to volatile memory. To store data permanently, select an external storage location such as a USB memory device.
For details see "Protecting Data Using the Secure User Mode" .


Comment

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards > Digital Standards > Comment
Comment

An optional description for the data file. A maximum of 60 characters can be displayed.

Remote command:

[SENSe:​]DDEMod:​STANdard:​COMMent


Load Standard

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards > Digital Standards > Load Standard
Load Standard

Loads the selected measurement settings file.

See "To load predefined settings files" for details. For an overview of predefined standards and settings see "Predefined Standards and Settings".

Note: When you load a standard, the usage of a known data file, if available, is automatically deactivated.

Remote command:

[SENSe:​]DDEMod:​PRESet[:​STANdard]


Save Standard

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards > Digital Standards > Save Standard
Save Standard

Saves the current measurement settings for a specific standard as a file with the defined name.

See "To store settings as a standard file" for details. For an overview of predefined standards and settings see "Predefined Standards and Settings".

Remote command:

[SENSe:​]DDEMod:​STANdard:​SAVE


Delete Standard

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards > Digital Standards > Delete Standard
Delete Standard

Deletes the selected standard. Standards predefined by Rohde & Schwarz can also be deleted. A confirmation query is displayed to avoid unintentional deletion of the standard.

Note: Restoring predefined standard files. The standards predefined by Rohde & Schwarz available at the time of delivery can be restored using the "Restore Standards" softkey.
(See "Restore Standard Files").

Remote command:

[SENSe:​]DDEMod:​STANdard:​DELete


Restore Standard Files

VSA (R&S FSW-K70) > Configuration > Configuration According to Digital Standards > Digital Standards > Restore Standard Files
Restore Standard Files

Restores the standards predefined by Rohde & Schwarz available at the time of delivery.

Note that this function will overwrite customized standards that have the same name as predefined standards.

Remote command:

[SENSe:​]DDEMod:​FACTory[:​VALue]


Configuration Overview

VSA (R&S FSW-K70) > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Signal Description

    See "Signal Description"

  2. Input and Frontend Settings

    See "Input, Output and Frontend Settings"

  3. Signal Capture (including Triggering)

    See "Signal Capture"

  4. Burst/Pattern Configuration

    See "Burst and Pattern Configuration"

  5. Result Range Definition

    See "Result Range Configuration"

  6. Demodulation Settings

    See "Demodulation Settings"

  7. Measurement Filter Settings

    See "Measurement Filter Settings"

  8. Evaluation Range Definition

    See "Evaluation Range Configuration"

  9. Display Configuration

    The "Display Config" button is only available in the general overview, not in the window-specific overview (see "Specifics for").

    See "Display and Window Configuration"

  10. Analysis

    See "Analysis"

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

For step-by-step instructions on configuring VSA measurements, see "How to Perform Vector Signal Analysis".

└ Preset Channel
└ Specifics for
└ Digital Standards
└ Selecting the Storage Location - Drive/ Path/ Files
└ New Folder
└ File Name
└ Comment
└ Load Standard
└ Save Standard
└ Delete Standard
└ Restore Standard Files


Preset Channel

VSA (R&S FSW-K70) > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

See "Default Settings for Vector Signal Analysis" for details.

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Specifics for

VSA (R&S FSW-K70) > Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

Enable the "Specifics for" option.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.

The indicated data flow is updated for the selected data source.

If the "Specifics for" option is not enabled, the overview displays the default data flow and the general settings independently of the selected window.

Note: The "Display Config" button is only available in the general overview, not in the window-specific overview.


New Folder

VSA (R&S FSW-K70) > Configuration > Configuration Overview > Digital Standards > New Folder
New Folder

Creates a new folder in the file system in which you can save the settings file.


Comment

VSA (R&S FSW-K70) > Configuration > Configuration Overview > Digital Standards > Comment
Comment

An optional description for the data file. A maximum of 60 characters can be displayed.

Remote command:

[SENSe:​]DDEMod:​STANdard:​COMMent


Load Standard

VSA (R&S FSW-K70) > Configuration > Configuration Overview > Digital Standards > Load Standard
Load Standard

Loads the selected measurement settings file.

See "To load predefined settings files" for details. For an overview of predefined standards and settings see "Predefined Standards and Settings".

Note: When you load a standard, the usage of a known data file, if available, is automatically deactivated.

Remote command:

[SENSe:​]DDEMod:​PRESet[:​STANdard]


Save Standard

VSA (R&S FSW-K70) > Configuration > Configuration Overview > Digital Standards > Save Standard
Save Standard

Saves the current measurement settings for a specific standard as a file with the defined name.

See "To store settings as a standard file" for details. For an overview of predefined standards and settings see "Predefined Standards and Settings".

Remote command:

[SENSe:​]DDEMod:​STANdard:​SAVE


Delete Standard

VSA (R&S FSW-K70) > Configuration > Configuration Overview > Digital Standards > Delete Standard
Delete Standard

Deletes the selected standard. Standards predefined by Rohde & Schwarz can also be deleted. A confirmation query is displayed to avoid unintentional deletion of the standard.

Note: Restoring predefined standard files. The standards predefined by Rohde & Schwarz available at the time of delivery can be restored using the "Restore Standards" softkey.
(See "Restore Standard Files").

Remote command:

[SENSe:​]DDEMod:​STANdard:​DELete


Restore Standard Files

VSA (R&S FSW-K70) > Configuration > Configuration Overview > Digital Standards > Restore Standard Files
Restore Standard Files

Restores the standards predefined by Rohde & Schwarz available at the time of delivery.

Note that this function will overwrite customized standards that have the same name as predefined standards.

Remote command:

[SENSe:​]DDEMod:​FACTory[:​VALue]


Signal Description

VSA (R&S FSW-K70) > Configuration > Signal Description
Signal Description

The signal description provides information on the expected input signal, which optimizes burst and pattern detection and allows for the application to calculate an ideal reference signal. The signal description consists of information on the used modulation and on the signal's structure.

Contents
  • Modulation
  • Signal Structure
  • Known Data


Modulation

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation
Modulation

The "Modulation" settings contain modulation and transmit filter settings. A live preview of the Constellation I/Q trace using the currently defined settings is displayed at the bottom of the dialog box to visualize the changes to the settings. The preview area is not editable directly.

The modulation settings vary depending on the selected modulation type; in particular, FSK modulation provides some additional settings.

The "Modulation" settings are displayed when you select the "Signal Description" button in the "Overview" or the "Signal Description" softkey in the main VSA menu.

└ Modulation Type
└ Load User Modulation
└ Modulation Order
└ FSK Ref Deviation (FSK only)
└ Modulation Mapping
└ Symbol Rate
└ Transmit Filter Type
└ Load User Filter
└ Alpha/BT


Modulation Type

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation > Modulation Type
Modulation Type

Defines the modulation type of the vector signal. The following types are available:

  • PSK
  • MSK
  • QAM
  • FSK
  • ASK
  • APSK
  • User Modulation
    Uses the selected user-defined modulation loaded from a file.

For more information on these modulation types see "Symbol Mapping".

Remote command:

[SENSe:​]DDEMod:​FORMat

└ Load User Modulation


Load User Modulation

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation > Modulation Type > Load User Modulation
Load User Modulation

This function is only available if the modulation type "User Modulation" is selected.

Opens a file selection dialog box to select the file that contains the user-defined modulation (*.vam file).

For details on user-defined modulation files see "User-defined Modulation".

Remote command:

SENS:DDEM:FORM UQAM (see [SENSe:​]DDEMod:​FORMat)

[SENSe:​]DDEMod:​USER:​NAME


Modulation Order

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation > Modulation Order
Modulation Order

Depending on the "Modulation Type", various orders of modulation are available:

Type | Available orders
PSK | BPSK | 3Pi/4-QPSK | Pi/8-D8PSK
 | QPSK | 8PSK | DQPSK
 | Offset QPSK | 3Pi/8-8PSK | Pi/4-DQPSK
 | Pi/4-QPSK | D8PSK |
MSK | MSK | DMSK |
QAM | 16QAM | -Pi/4-32QAM | 256QAM
 | Pi/4-16QAM | 64QAM | 512QAM
 | 32QAM | 128QAM | 1024QAM
FSK | 2FSK | 4FSK | 8FSK
ASK | 2ASK | 4ASK |
APSK | 16APSK | 32APSK |

For more information on these modulation types see "Symbol Mapping".

Remote command:

PSK:

[SENSe:​]DDEMod:​PSK:​FORMat

[SENSe:​]DDEMod:​PSK:​NSTate

[SENSe:​]DDEMod:​QPSK:​FORMat

MSK: [SENSe:​]DDEMod:​MSK:​FORMat

QAM:

[SENSe:​]DDEMod:​QAM:​FORMat

[SENSe:​]DDEMod:​QAM:​NSTate

FSK: [SENSe:​]DDEMod:​FSK:​NSTate

ASK: [SENSe:​]DDEMod:​ASK:​NSTate

APSK: [SENSe:​]DDEMod:​APSK:​NSTate


FSK Ref Deviation (FSK only)

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation > FSK Ref Deviation (FSK only)
FSK Ref Deviation (FSK only)

The FSK Reference Deviation sets the deviation to the reference frequency.

In case of 2FSK, it indicates the distance from the reference frequency to the positive /negative deviation frequency and in case of 4FSK, the distance to the outer positive/negative deviation frequency.

To set the deviation as a multiple of the symbol rate (x*SR), select "Relative" mode. To set the deviation as an absolute value in Hz, select "Absolute" mode.

Note that this parameter is available only for FSK modulated signals.

Remote command:

CALCulate<n>:​FSK:​DEViation:​REFerence[:​VALue]

CALCulate<n>:​FSK:​DEViation:​REFerence:​RELative


Modulation Mapping

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation > Modulation Mapping
Modulation Mapping

The available mapping types depend on the "Modulation Type" and "Modulation Order".

For more information on the modulation mapping, refer to "Symbol Mapping"

Remote command:

[SENSe:​]DDEMod:​MAPPing[:​VALue]

[SENSe:​]DDEMod:​MAPPing:​CATalog?


Symbol Rate

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation > Symbol Rate
Symbol Rate

The symbol rate also determines the I/Q bandwidth of the data recording and demodulation. You can change the default rate by entering a value in Hz.

The minimum symbol rate is 25 Hz. The maximum symbol rate depends on the defined "Sample Rate" (see "Sample Rate, Symbol Rate and I/Q Bandwidth").

Remote command:

[SENSe:​]DDEMod:​SRATe


Transmit Filter Type

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation > Transmit Filter Type
Transmit Filter Type

Defines the type of transmit filter

An overview of available transmit filters is provided in "Transmit Filters".

For more information on transmit filters see "Modulation and Demodulation Filters".

Remote command:

[SENSe:​]DDEMod:​TFILter:​NAME

To define the name of the transmit filter to be used.

[SENSe:​]DDEMod:​TFILter[:​STATe]

To switch off the transmit filter.

[SENSe:​]DDEMod:​TFILter:​USER

To select a user-defined filter.

└ Load User Filter


Load User Filter

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation > Transmit Filter Type > Load User Filter
Load User Filter

Opens a file-selection dialog box to select the user-defined transmit filter to be used.

Note: If a user-defined transmit filter is selected and the measurement filter is defined automatically (see "Using the Transmit Filter as a Measurement Filter (Auto)"), a Low-ISI measurement filter according to the selected user filter is calculated and used.

For details see "Customized Filters".

For detailed instructions on working with user-defined filters see "How to Select User-Defined Filters".

Remote command:

[SENSe:​]DDEMod:​TFILter:​USER

[SENSe:​]DDEMod:​TFILter:​NAME


Alpha/BT

VSA (R&S FSW-K70) > Configuration > Signal Description > Modulation > Alpha/BT
Alpha/BT

Defines the roll-off factor (Alpha) or the filter bandwidth (BT).

The roll-off factor and filter bandwidth for transmit filter is available for RC, RRC, Gauss and GMSK filter.

Remote command:

[SENSe:​]DDEMod:​TFILter:​ALPHa


Signal Structure

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure
Signal Structure

The "Signal Structure" settings describe the expected input signal and determine which settings are available for configuration. You can define a pattern to which the instrument can be synchronized, thus adapting the result range.

A visualization of the currently defined signal structure is displayed at the bottom of the dialog box.

The "Signal Structure" settings are displayed when you select the "Signal Description" button in the "Overview" or the "Signal Description" softkey in the main VSA menu and then switch to the "Signal Structure" tab.

└ Signal Type
└ Burst Settings
└ Min Length / Max Length
└ Run-In
└ Run-Out
└ Pattern Settings
└ Name
└ Pattern Configuration
└ Offset


Signal Type

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure > Signal Type
Signal Type

Determines whether the signal is continuous or contains bursts.

Remote command:

[SENSe:​]DDEMod:​SIGNal[:​VALue]


Burst Settings

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure > Burst Settings
Burst Settings

For bursts, further settings are available.

└ Min Length / Max Length
└ Run-In
└ Run-Out


Min Length / Max Length

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure > Burst Settings > Min Length / Max Length
Min Length / Max Length

Shortest and longest expected burst length in symbols (≦15000). The symbols are converted to seconds for reference.

Remote command:

[SENSe:​]DDEMod:​SEARch:​BURSt:​LENGth:​MAXimum

[SENSe:​]DDEMod:​SEARch:​BURSt:​LENGth[:​MINimum]


Run-In

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure > Burst Settings > Run-In
Run-In

The number of symbols before the signal is assumed to have valid modulated symbols.

The symbols are converted to seconds for reference.

Remote command:

[SENSe:​]DDEMod:​SEARch:​BURSt:​SKIP:​RISing


Run-Out

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure > Burst Settings > Run-Out
Run-Out

The number of symbols before the falling edge that do not necessarily need to have a valid modulation.

The symbols are converted to seconds for reference.

Remote command:

[SENSe:​]DDEMod:​SEARch:​BURSt:​SKIP:​FALLing


Pattern Settings

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure > Pattern Settings
Pattern Settings

If the signal is expected to have a specific pattern, enable the "Pattern" option to define the pattern settings.

Note: The pattern search itself must be enabled separately in the "Pattern Search Settings", see "Enabling Pattern Searches". By default, the pattern search is active if the signal description contains a pattern.

└ Name
└ Pattern Configuration
└ Offset


Name

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure > Pattern Settings > Name
Name

Specifies the pattern name from the list of defined patterns. You can also configure new patterns, see "Pattern Configuration".

Remote command:

[SENSe:​]DDEMod:​SIGNal:​PATTern


Pattern Configuration

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure > Pattern Settings > Pattern Configuration
Pattern Configuration

Displays the "Pattern Configuration" dialog box (see "Pattern Configuration").


Offset

VSA (R&S FSW-K70) > Configuration > Signal Description > Signal Structure > Pattern Settings > Offset
Offset

The offset of the pattern is defined with respect to the start of the useful part of the burst (see "Useful length"). If the position of the pattern within the burst is known, it is recommended that you define the offset. That will accelerate the pattern search and enhance the accuracy of the burst search.

Remote command:

[SENSe:​]DDEMod:​STANdard:​SYNC:​OFFSet:​STATe

[SENSe:​]DDEMod:​STANdard:​SYNC:​OFFSet[:​VALue]


Known Data

VSA (R&S FSW-K70) > Configuration > Signal Description > Known Data
Known Data

The "Known Data" settings allow you to load a file that describes the possible data sequences in the input signal (see "How to Manage Known Data Files").

Additional information provided by the loaded file is displayed at the bottom of the dialog box. This information is not editable directly.

The "Known Data" settings are displayed when you select the "Signal Description" button in the "Overview" or the "Signal Description" softkey in the main VSA menu and then switch to the "Known Data" tab.

Auxiliary tool to create Known Data files

An auxiliary tool to create Known Data files from data that is already available in the VSA application is provided on the instrument free of charge. See "To create a Known Data file using the recording tool for sequences".

└ Known Data
└ Load Data File


Known Data

VSA (R&S FSW-K70) > Configuration > Signal Description > Known Data > Known Data
Known Data

Activates or deactivates the use of the loaded data file (if available). When deactivated, the additional information from the previously loaded data file is removed. Any references to the known data in the "Demodulation" dialog box are replaced by the default parameter values (see "Advanced Demodulation (Synchronization)").

Note: When a standard is loaded, the use of a Known Data file is automatically deactivated.

Remote command:

[SENSe:​]DDEMod:​KDATa:​STATe


Load Data File

VSA (R&S FSW-K70) > Configuration > Signal Description > Known Data > Load Data File
Load Data File

If "Known Data" is activated, this function displays a file selection dialog box to select the xml file that contains the known data. Once a file has been selected, any additional information provided by the file is displayed at the bottom of the dialog box.

Tip: An auxiliary tool to create Known Data files from data that is already available in the VSA application is provided on the instrument free of charge. See "To create a Known Data file using the recording tool for sequences".

Remote command:

[SENSe:​]DDEMod:​KDATa[:​NAME]


Input, Output and Frontend Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings
Input, Output and Frontend Settings

The R&S FSW can evaluate signals from different input sources.

The frequency and amplitude settings represent the "frontend" of the measurement setup.

Contents
  • Input Settings
  • Output Settings
  • Digital I/Q Output Settings
  • Frontend Settings
  • Frequency Settings
  • Amplitude and Vertical Axis Configuration


Input Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings
Input Settings

Input settings can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

The "DigiConf" softkey is described in "Digital I/Q Input Settings".

Contents
  • Radio Frequency Input
  • External Mixer Settings
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings
  • Probe Settings


Radio Frequency Input

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is the radio frequency. If no additional options are installed, this is the only available input source.

└ Radio Frequency State
└ Input Coupling
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector
└ Preamplifier (option B24)


Radio Frequency State

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > Radio Frequency State
Radio Frequency State

Activates input from the RF INPUT connector.

Remote command:

INPut:​SELect


Input Coupling

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


High-Pass Filter 1...3 GHz

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the analyzer in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Note:

For the following measurements, the YIG-Preselector is off by default (if available).
  • I/Q Analyzer (and thus in all applications in MSRA operating mode)
  • Realtime (and thus in all applications in MSRT operating mode)
  • Multi-Carrier Group Delay
  • GSM
  • VSA

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Preamplifier (option B24)

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Radio Frequency Input > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


External Mixer Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings
External Mixer Settings

The external mixer is configured in the "External Mixer" tab of the "Input" dialog box which is available when you do one of the following, if the R&S FSW-B21 option is installed:

  • Press the INPUT/OUTPUT key, then select the "External Mixer Config" softkey.
  • From the "Overview", select "Input", then switch to the "External Mixer" tab under "Input Source".

Note that external mixers are not supported in MSRA/MSRT mode.

For more information on using external mixers see "External Mixer (Option -B21)" .

Contents
  • Mixer Settings
  • Basic Settings
  • Managing Conversion Loss Tables
  • Creating and Editing Conversion Loss Tables


Mixer Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings
Mixer Settings

In this tab you configure the band and specific mixer settings.

└ External Mixer State
└ RF Start / RF Stop
└ Handover Freq.
└ Band
└ RF Overrange
└ Preset Band
└ Mixer Type
└ Mixer Settings (Harmonics Configuration)
└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


External Mixer State

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


RF Start / RF Stop

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > RF Start / RF Stop
RF Start / RF Stop

Displays the start and stop frequency of the selected band (read-only).

The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

For details on available frequency ranges see table " Frequency ranges for pre-defined bands".

Remote command:

[SENSe:​]MIXer:​FREQuency:​STARt?

[SENSe:​]MIXer:​FREQuency:​STOP?


Handover Freq.

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Handover Freq.
Handover Freq.

Defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency can be selected freely within the overlapping frequency range.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​FREQuency:​HANDover


Band

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Band
Band

Defines the waveguide band or user-defined band to be used by the mixer.

The start and stop frequencies of the selected band are displayed in the "RF Start" and "RF Stop" fields.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

The mixer settings for the user-defined band can be selected freely. The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND[:​VALue]


RF Overrange

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > RF Overrange
RF Overrange

If enabled, the frequency range is not restricted by the band limits ("RF Start" and "RF Stop"). In this case, the full LO range of the selected harmonics is used.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​RFOVerrange[:​STATe]


Preset Band

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Preset Band
Preset Band

Restores the presettings for the selected band.

Note: changes to the band and mixer settings are maintained even after using the PRESET function. This function allows you to restore the original band settings.

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND:​PRESet


Mixer Type

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Type
Mixer Type

The R&S FSW option B21 supports the following external mixer types:

(See also "Two-port and Three-port Mixers" )

"2 Port" | LO and IF data use the same port
"3 Port" | LO and IF data use separate ports
Remote command:

[SENSe:​]MIXer:​PORTs


Mixer Settings (Harmonics Configuration)

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration)
Mixer Settings (Harmonics Configuration)

The harmonics configuration determines the frequency range for user-defined bands (see "Band").

See also "Frequency Ranges" .

└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


Harmonic Type

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Type
Harmonic Type

Defines if only even, only odd, or even and odd harmonics can be used for conversion. Depending on this selection, the order of harmonic to be used for conversion changes (see "Harmonic Order"). Which harmonics are supported depends on the mixer type.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​TYPE


Range 1/2

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Range 1/2
Range 1/2

Enables the use of a second harmonic to cover the band's frequency range.

For each range you can define which harmonic to use and how the "Conversion loss" is handled.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​HIGH:​STATe


Harmonic Order

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Order
Harmonic Order

Defines which of the available harmonic orders of the LO is used to cover the frequency range.

By default, the lowest order of the specified harmonic type is selected that allows conversion of input signals in the whole band. If due to the LO frequency the conversion is not possible using one harmonic, the band is split.

For the band "USER", the order of harmonic is defined by the user. The order of harmonic can be between 2 and 61, the lowest usable frequency being 26.5 GHz.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic[:​LOW]

[SENSe:​]MIXer:​HARMonic:​HIGH[:​VALue]


Conversion loss

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Conversion loss
Conversion loss

Defines how the conversion loss is handled. The following methods are available:

"Average"

Defines the average conversion loss for the entire range in dB.

"Table"

Defines the conversion loss via the table selected from the list. Predefined conversion loss tables are often provided with the external mixer and can be imported to the R&S FSW. Alternatively, you can define your own conversion loss tables. Imported tables are checked for compatibility with the current settings before being assigned.

Conversion loss tables are configured and managed in the "Managing Conversion Loss Tables" tab.

For details on conversion loss tables, see "Conversion Loss Tables" .

For details on importing tables, see "Import Table".

Remote command:

Average for range 1:

[SENSe:​]MIXer:​LOSS[:​LOW]

Table for range 1:

[SENSe:​]MIXer:​LOSS:​TABLe[:​LOW]

Average for range 2:

[SENSe:​]MIXer:​LOSS:​HIGH

Table for range 2:

[SENSe:​]MIXer:​LOSS:​TABLe:​HIGH


Basic Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings
Basic Settings

The basic settings concern general use of an external mixer. They are only available if the "External Mixer State" is "On".

└ External Mixer State
└ LO Level
└ Signal ID
└ Auto ID
└ Auto ID Threshold
└ Bias Settings
└ Write to <CVL table name>


External Mixer State

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


LO Level

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > LO Level
LO Level

Defines the LO level of the external mixer's LO port. Possible values are from 13.0 dBm to 17.0 dBm in 0.1 dB steps. Default value is 15.5 dB.

Remote command:

[SENSe:​]MIXer:​LOPower


Signal ID

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Signal ID
Signal ID

Activates or deactivates visual signal identification. Two sweeps are performed alternately. Trace 1 shows the trace measured on the upper side band (USB) of the LO (the test sweep), trace 2 shows the trace measured on the lower side band (LSB), i.e. the reference sweep.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

(See also "Automatic Signal Identification" ).

Mathematical functions with traces and trace copy cannot be used with the Signal ID function.

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Auto ID
Auto ID

Activates or deactivates automatic signal identification.

Auto ID basically functions like "Signal ID". However, the test and reference sweeps are converted into a single trace by a comparison of maximum peak values of each sweep point. The result of this comparison is displayed in trace 3 if "Signal ID" is active at the same time. If "Signal ID" is not active, the result can be displayed in any of the traces 1 to 3. Unwanted mixer products are suppressed in this calculated trace.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID Threshold

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Auto ID Threshold
Auto ID Threshold

Defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison ("Auto ID" function). The input range is between 0.1 dB and 100 dB. Values of about 10 dB (i.e. default setting) generally yield satisfactory results.

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​THReshold


Bias Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Bias Settings
Bias Settings

Define the bias current for each range, which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

The trace is adapted to the settings immediately so you can check the results. To store the bias setting in the currently selected conversion loss table, select the "Write to <CVL table name>" button.

Remote command:

[SENSe:​]MIXer:​BIAS[:​LOW]

[SENSe:​]MIXer:​BIAS:​HIGH

└ Write to <CVL table name>


Write to <CVL table name>

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Basic Settings > Bias Settings > Write to <CVL table name>
Write to <CVL table name>

Stores the bias setting in the currently selected "Conversion loss table" for the range (see "Managing Conversion Loss Tables"). If no conversion loss table is selected yet, this function is not available ("CVL Table not selected").

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Managing Conversion Loss Tables

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables
Managing Conversion Loss Tables

In this tab you configure and manage conversion loss tables. Conversion loss tables consist of value pairs that describe the correction values for conversion loss at certain frequencies. The correction values for frequencies between the reference points are obtained via interpolation.

The currently selected table for each range is displayed at the top of the dialog box. All conversion loss tables found in the instrument's C:\r_s\instr\user\cvl\ directory are listed in the "Modify Tables" list.

└ External Mixer State
└ New Table
└ Edit Table
└ Delete Table
└ Import Table


External Mixer State

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


New Table

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > New Table
New Table

Opens the "Edit Conversion loss table" dialog box to configure a new conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Edit Table

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > Edit Table
Edit Table

Opens the "Edit Conversion loss table" dialog box to edit the selected conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Delete Table

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > Delete Table
Delete Table

Deletes the currently selected conversion loss table after you confirm the action.

Remote command:

[SENSe:​]CORRection:​CVL:​CLEAr


Import Table

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Managing Conversion Loss Tables > Import Table
Import Table

Imports a stored conversion loss table from any directory and copies it to the instrument's C:\r_s\instr\user\cvl\ directory. It can then be assigned for use for a specific frequency range (see "Conversion loss").

For details see "Conversion Loss Tables" .


Creating and Editing Conversion Loss Tables

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables
Creating and Editing Conversion Loss Tables

Conversion loss tables can be defined and edited in the "Edit conversion loss table" dialog box which is displayed when you select the "New Table" button in the "External Mixer > Conversion loss table" settings.

A preview pane displays the current configuration of the conversion loss function as described by the position/value entries.

└ File Name
└ Comment
└ Band
└ Harmonic Order
└ Bias
└ Mixer Name
└ Mixer S/N
└ Mixer Type
└ Position/Value
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


File Name

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > File Name
File Name

Defines the name under which the table is stored in the C:\r_s\instr\user\cvl\ directory on the instrument. The name of the table is identical with the name of the file (without extension) in which the table is stored. This setting is mandatory. The .ACL extension is automatically appended during storage.

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Comment

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Comment
Comment

An optional comment that describes the conversion loss table. The comment can be freely defined by the user.

Remote command:

[SENSe:​]CORRection:​CVL:​COMMent


Band

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Band
Band

The waveguide or user-defined band for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

Remote command:

[SENSe:​]CORRection:​CVL:​BAND


Harmonic Order

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Harmonic Order
Harmonic Order

The harmonic order of the range for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​HARMonic


Bias

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Bias
Bias

The bias current which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

Tip: You can also define the bias interactively while a preview of the trace with the changed setting is displayed, see "Bias Settings".

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Mixer Name

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Name
Mixer Name

Specifies the name of the external mixer for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​MIXer


Mixer S/N

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer S/N
Mixer S/N

Specifies the serial number of the external mixer for which the table is to be applied.

This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​SNUMber


Mixer Type

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Type
Mixer Type

Specifies whether the external mixer for which the table is to be applied is a two-port or three-port type. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​PORTs


Position/Value

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Position/Value
Position/Value

Each position/value pair defines the correction value for conversion loss for a specific frequency. The reference values must be entered in order of increasing frequencies. A maximum of 50 reference values can be entered. To enter a new value pair, select the "Position/Value" table, or select the "Insert Value" button.

Correction values for frequencies between the reference values are obtained by interpolation. Linear interpolation is performed if the table contains only two values. If it contains more than two reference values, spline interpolation is carried out. Outside the frequency range covered by the table the conversion loss is assumed to be the same as that for the first and last reference value.

(See "Conversion Loss Tables" .)

The current configuration of the conversion loss function as described by the position/value entries is displayed in the preview pane to the right of the table.

Remote command:

[SENSe:​]CORRection:​CVL:​DATA


Insert Value

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Insert Value
Insert Value

Inserts a new position/value entry in the table.

If the table is empty, a new entry at 0 Hz is inserted.

If entries already exist, a new entry is inserted above the selected entry. The position of the new entry is selected such that it divides the span to the previous entry in half.


Delete Value

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Delete Value
Delete Value

Deletes the currently selected position/value entry.


Shift x

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift x
Shift x

Shifts all positions in the table by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the x-axis.


Shift y

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift y
Shift y

Shifts all conversion loss values by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the y-axis.


Save

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Save
Save

The conversion loss table is stored under the specified name in the C:\r_s\instr\user\cvl\ directory of the instrument.


Digital I/Q Input Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (-B17)" .

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements.

"Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface" .

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes" .

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Probe Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Probe Settings
Probe Settings

Probes are configured in a separate tab on the "Input" dialog box which is displayed when you select the INPUT/OUTPUT key and then "Input Source Config".

For each possible probe connector (Baseband Input I, Baseband Input Q), the detected type of probe, if any, is displayed. The following information is provided for each connected probe:

  • Probe name
  • Serial number
  • R&S part number
  • Type of probe ("Differential", "Single Ended")

For more information on using probes with an R&S FSW, see "Using Probes" .

For general information on the R&S®RTO probes, see the device manuals.

└ Microbutton Action


Microbutton Action

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Input Settings > Probe Settings > Microbutton Action
Microbutton Action

Active R&S probes (except for RT-ZS10E) have a configurable microbutton on the probe head. By pressing this button, you can perform an action on the instrument directly from the probe.

Select the action that you want to start from the probe:

"Run single" | Starts one data acquisition.
"No action" | Prevents unwanted actions due to unintended usage of the microbutton.
Remote command:

[SENSe:​]PROBe<p>:​SETup:​MODE


Output Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Output Settings
Output Settings

The R&S FSW VSA application can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

Digital I/Q Output settings are described in "Digital I/Q Output Settings".

└ IF/Video Output
└ IF Out Frequency


IF/Video Output

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Output Settings > IF/Video Output
IF/Video Output

Defines the type of signal available at the IF OUT connector on the rear panel of the R&S FSW.

For restrictions and additional information see "IF and Video Signal Output" .

"IF 2 GHz Out"

The measured IF value is available at the IF OUT output connector at a frequency of 2 GHz (with a bandwidth of 2 GHz).

This setting is only available for instrument models R&S FSW43/50/67.

Remote command:

OUTPut:​IF:​SBANd?


IF Out Frequency

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Output Settings > IF Out Frequency
IF Out Frequency

If the IF 2 GHZ OUT output is activated, the measured IF value is provided at a fixed frequency of 2 GHz.

For more information see "IF and Video Signal Output" .


Digital I/Q Output Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Digital I/Q Output Settings
Digital I/Q Output Settings

The optional Digital Baseband Interface (R&S FSW-B17) allows you to output I/Q data from any R&S FSW application that processes I/Q data to an external device. The configuration settings for digital I/Q output can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

Digital output is not available if the bandwidth extension option R&S FSW-B500 is active.

For details on digital I/Q output see "Digital Output" .

└ Digital Baseband Output
└ Output Settings Information
└ Connected Instrument


Digital Baseband Output

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Digital I/Q Output Settings > Digital Baseband Output
Digital Baseband Output

Enables or disables a digital output stream to the optional Digital Baseband Interface (R&S FSW-B17), if available.

Note: If digital baseband output is active, the sample rate is restricted to 200 MHz (max. 160 MHz bandwidth).
The only data source that can be used for digital baseband output is RF input.

For details on digital I/Q output see "Digital Output" .

Remote command:

OUTPut:​DIQ


Output Settings Information

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Digital I/Q Output Settings > Output Settings Information
Output Settings Information

Displays information on the settings for output via the Digital Baseband Interface (R&S FSW-B17).

The following information is displayed:

  • Maximum sample rate that can be used to transfer data via the Digital Baseband Interface (i.e. the maximum input sample rate that can be processed by the connected instrument)
  • Sample rate currently used to transfer data via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level")
Remote command:

OUTPut:​DIQ:​CDEVice


Connected Instrument

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Digital I/Q Output Settings > Connected Instrument
Connected Instrument

Displays information on the instrument connected to the Digital Baseband Interface (R&S FSW-B17), if available.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
Remote command:

OUTPut:​DIQ:​CDEVice


Frontend Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frontend Settings
Frontend Settings

Frontend settings affect the signal power or error levels.

To configure the Frontend settings select "Input/Frontend" from the "Overview", then switch to the "Frontend" tab.

└ Center frequency
└ Reference Level
└ Shifting the Display (Offset)
└ Setting the Reference Level Automatically (Auto Level)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)


Center frequency

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frontend Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

span > 0: spanmin/2 ≤ fcenter ≤ fmax – spanmin/2

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Reference Level

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frontend Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display ("OVLD" for analog baseband or digitial baseband input).

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Note that for input from the External Mixer (R&S FSW-B21) the maximum reference level also depends on the conversion loss, see "Reference level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)
└ Setting the Reference Level Automatically (Auto Level)


Shifting the Display (Offset)

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frontend Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Setting the Reference Level Automatically (Auto Level)

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frontend Settings > Reference Level > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is only available for the MSRA/MSRT Master, not for the applications.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

[SENSe:​]ADJust:​LEVel


RF Attenuation

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frontend Settings > RF Attenuation
RF Attenuation

Defines the mechanical attenuation for RF input.

This function is not available for input from the R&S Digital Baseband Interface (option R&S FSW-B17).

└ Attenuation Mode / Value


Attenuation Mode / Value

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frontend Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frontend Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Frequency Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frequency Settings
Frequency Settings

Frequency settings for the input signal can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select the "Frequency" tab in the "Input Settings" dialog box
└ Center frequency
└ Center Frequency Stepsize
└ Frequency Offset


Center Frequency Stepsize

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size of the center frequency. The step size can be set to a predefined value, or it can be manually set to a user-defined value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"Auto"

The step size is set to the default value:

  • using the rotary knob: 100 kHz
  • using the arrow keys: 1 MHz

"Manual"

Defines a user-defined step size for the center frequency. Enter the step size in the "Value" field.

Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP:​AUTO

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the instrument's hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Note: In MSRA/MSRT mode, this function is only available for the MSRA/MSRT Master.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Amplitude and Vertical Axis Configuration

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration
Amplitude and Vertical Axis Configuration

Amplitude and scaling settings allow you to configure the vertical (y-)axis display and for some result displays also the horizontal (x-)axis.

The amplitude settings for Analog Baseband input are described in "Amplitude Settings for Analog Baseband Input".

Contents
  • Amplitude Settings
  • Amplitude Settings for Analog Baseband Input
  • Scaling
  • Units


Amplitude Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings
Amplitude Settings

Amplitude settings affect the signal power or error levels.

To configure the amplitude settings select the AMPT key and then the "Amplitude Config" softkey.

The scaling settings are described in "Scaling".

The amplitude settings for Analog Baseband input are described in "Amplitude Settings for Analog Baseband Input".

Note that amplitude settings are not window-specific, as opposed to the scaling and unit settings.

└ Reference Level
└ Shifting the Display (Offset)
└ Setting the Reference Level Automatically (Auto Level)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)


Input Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling


RF Attenuation

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the mechanical attenuation for RF input.

This function is not available for input from the R&S Digital Baseband Interface (option R&S FSW-B17).

└ Attenuation Mode / Value


Amplitude Settings for Analog Baseband Input

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings for Analog Baseband Input
Amplitude Settings for Analog Baseband Input

The following settings and functions are available to define amplitude settings for input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the AMPT key or in the "Amplitude" tab of the "Input" dialog box.

The input settings provided here are identical to those in the "Input Source" > "Analog Baseband" tab, see "Analog Baseband Input Settings".

For more information see "Processing Data From the Analog Baseband Interface" .

└ Reference Level
└ Shifting the Display (Offset)
└ Setting the Reference Level Automatically (Auto Level)
└ Full Scale Level Mode / Value


Full Scale Level Mode / Value

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings for Analog Baseband Input > Full Scale Level Mode / Value
Full Scale Level Mode / Value

The full scale level defines the maximum power you can input at the Baseband Input connector without clipping the signal.

The full scale level can be defined automatically according to the reference level, or manually.

For manual input, the following values can be selected:

  • 0.25 V
  • 0.5 V
  • 1 V
  • 2 V

If probes are connected, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

For details on probes see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​IQ:​FULLscale:​AUTO

INPut:​IQ:​FULLscale[:​LEVel]


Scaling

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling
Scaling

Depending on the type of display (time, spectrum or statistics), various scaling functions are available to adapt the result display to the current data.

Note that scaling settings are window-specific, as opposed to the amplitude settings.

The scaling settings are displayed when you select the AMPT key and then the "Scale Config" softkey.

For details on the different methods to configure the scaling see "How to Change the Display Scaling".

A visualization of the diagram scaling with the current settings is displayed at the right side of the dialog box.

└ Auto Scale Once/Auto Scale Window
└ Defining Min and Max Values
└ Configuring a Reference Point and Divisions
└ Y-Axis Reference Value
└ Y-Axis Reference Position
└ Range per Division
└ X-Axis Scaling
└ Adjust Settings
└ Default Settings
└ Quantize
└ X-Axis Reference Value
└ X-Axis Reference Position
└ Range per Division


Auto Scale Once/Auto Scale Window

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > Auto Scale Once/Auto Scale Window
Auto Scale Once/Auto Scale Window

If enabled, both the x-axis and y-axis are automatically adapted to the current measurement results (only once, not dynamically) in the selected window.

To adapt the range of all screens together, use the "Auto Scale All" function.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE


Defining Min and Max Values

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > Defining Min and Max Values
Defining Min and Max Values

Indicates the current range borders according to the current settings (for information only).

For statistical evaluations only: defines the displayed range using minimum and maximum values.

Values in the range 1e-9 < value < 0.1 are allowed. The y-axis unit is defined via the "Y-Axis Unit" setting. The distance between max and min value must be at least one decade.

Remote command:

CALCulate<n>:​STATistics:​SCALe:​Y:​UPPer

CALCulate<n>:​STATistics:​SCALe:​Y:​LOWer


Configuring a Reference Point and Divisions

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > Configuring a Reference Point and Divisions
Configuring a Reference Point and Divisions

Defines the displayed range using a reference point and the size of the divisions.

For details on the different methods to configure the scaling see "How to Change the Display Scaling".

└ Y-Axis Reference Value
└ Y-Axis Reference Position
└ Range per Division


Y-Axis Reference Value

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > Configuring a Reference Point and Divisions > Y-Axis Reference Value
Y-Axis Reference Value

Defines a reference value on the y-axis in the current unit. The y-axis is adapted so that the reference value is displayed at the "Y-Axis Reference Position".

For details on the different methods to configure the scaling see "How to Change the Display Scaling".

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RVALue


Y-Axis Reference Position

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > Configuring a Reference Point and Divisions > Y-Axis Reference Position
Y-Axis Reference Position

Defines the position of the "Y-Axis Reference Value" on the y-axis. The position is defined as a percentage value, where 0 % refers to the bottom edge, 100 % refers to the top edge of the screen. The y-axis is adapted so that the reference value is displayed at the reference position.

For details on the different methods to configure the scaling see "How to Change the Display Scaling".

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Range per Division

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > Configuring a Reference Point and Divisions > Range per Division
Range per Division

Defines the value range to be displayed per division. Since the display consists of 10 divisions by default, the displayed range is:

Range = 10 * <Range per Division>

Note: If fewer divisions are displayed (e.g. because the window is reduced in height), the range per division is increased in order to display the same result range in the smaller window. In this case, the per division value does not correspond to the actual display.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​PDIVision


X-Axis Scaling

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > X-Axis Scaling
X-Axis Scaling

For statistics, a histogram is displayed. For these diagrams, the x-axis can be configured, as well.

└ Adjust Settings
└ Default Settings
└ Quantize
└ X-Axis Reference Value
└ X-Axis Reference Position
└ Range per Division


Adjust Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > X-Axis Scaling > Adjust Settings
Adjust Settings

Adjusts the x-axis scaling to the occurring statistical values.

Remote command:

CALCulate<n>:​STATistics:​SCALe:​AUTO ONCE


Default Settings

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > X-Axis Scaling > Default Settings
Default Settings

Resets the x- and y-axis scalings to their preset values for the current measurement window.

Remote command:

CALCulate<n>:​STATistics:​PRESet


Quantize

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > X-Axis Scaling > Quantize
Quantize

Defines the number of bars to be displayed in the graph, i.e. the granularity of classifications.

Remote command:

CALCulate<n>:​STATistics:​SCALe:​X:​BCOunt


X-Axis Reference Value

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > X-Axis Scaling > X-Axis Reference Value
X-Axis Reference Value

Defines a reference value on the x-axis in the current unit.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​RVALue


X-Axis Reference Position

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > X-Axis Scaling > X-Axis Reference Position
X-Axis Reference Position

Defines the position of the "X-Axis Reference Value" on the x-axis. The position is defined as a percentage value, where 0 % refers to the beginning (left side), 100 % refers to the end (right side) of the diagram. The x-axis is adapted so that the reference value is displayed at the reference position.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​RPOSition


Range per Division

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Scaling > X-Axis Scaling > Range per Division
Range per Division

Defines the value range to be displayed per division on the x-axis. Since the display consists of 10 divisions by default, the displayed range is:

Range = 10 * <Range per Division>

Note: If fewer divisions are displayed (e.g. because the window is reduced in width), the range per division is increased in order to display the same result range in the smaller window. In this case, the per division value does not correspond to the actual display.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​PDIVision


Units

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Units
Units

You can configure the units for both axes of the diagrams.

The unit settings are displayed when you do one of the following:

  • Select "Input/Frontend" from the "Overview" and then switch to the "Unit" tab.
  • Select the AMPT key and then the "Unit Config" softkey.

Note that unit settings are window-specific, as opposed to the amplitude settings.

└ X-Axis Unit
└ Y-Axis Unit


X-Axis Unit

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Units > X-Axis Unit
X-Axis Unit

Defines the unit of the x-axis in the current result diagram.

Remote command:

CALCulate<n>:​X:​UNIT:​TIME


Y-Axis Unit

VSA (R&S FSW-K70) > Configuration > Input, Output and Frontend Settings > Amplitude and Vertical Axis Configuration > Units > Y-Axis Unit
Y-Axis Unit

Defines the unit of the y-axis in the current result diagram.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing

For phase diagrams: CALCulate<n>:​UNIT:​ANGLe

For statistics: CALCulate<n>:​STATistics:​SCALe:​Y:​UNIT

For equalizer group delay diagrams: CALCulate<n>:​Y:​UNIT:​TIME


Signal Capture

VSA (R&S FSW-K70) > Configuration > Signal Capture
Signal Capture

The "Signal Capture" settings define how much, how and when data is captured from the input signal.

The "Signal Capture" settings are displayed when you select the "Signal Capture" button from the "Overview" or the "Signal Capture" softkey from the main VSA menu.

The trigger settings are described in "Trigger Settings".

Contents
  • Data Acquisition
  • Trigger Settings
  • Sweep Settings


Data Acquisition

VSA (R&S FSW-K70) > Configuration > Signal Capture > Data Acquisition
Data Acquisition

The "Data Acquisition" settings define how much and how data is captured from the input signal.

A live preview of the signal in the capture buffer with the current settings is displayed in the preview area at the bottom of the dialog box. The preview area is not editable directly.

The "Data Acquisition" settings are displayed when you select the "Signal Capture" button from the "Overview" or the "Signal Capture" softkey from the main VSA menu.

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. The data acquisition settings for the VSA application in MSRA/MSRT mode define the application data extract and analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

└ Capture Length Settings
└ Sample Rate
└ Maximum Bandwidth
└ Usable I/Q Bandwidth
└ Swap I/Q


Capture Length Settings

VSA (R&S FSW-K70) > Configuration > Signal Capture > Data Acquisition > Capture Length Settings
Capture Length Settings

The capture length defines how many symbols are captured during each measurement.

Enable the "Auto" option to define the capture length automatically according to the burst and pattern length settings and the statistics count. Thus, a minimal capture length is used, which improves performance.

If the capture length is not defined automatically, enter the number of symbols or seconds to be captured and select the used unit. The defined number is converted to the alternative unit (seconds/symbols) for reference.

As of firmware version 1.70, up to 64000 symbols can be captured and processed during each measurement (previously 50000).

Remote command:

[SENSe:​]DDEMod:​RLENgth:​AUTO

[SENSe:​]DDEMod:​RLENgth[:​VALue]


Sample Rate

VSA (R&S FSW-K70) > Configuration > Signal Capture > Data Acquisition > Sample Rate
Sample Rate

Defines the number of samples to capture per symbol. The sample rate in MHz is indicated for reference. This parameter affects the demodulation bandwidth and thus the usable I/Q bandwidth.

The maximum sample rate depends on the defined "Symbol Rate" (see "Sample Rate, Symbol Rate and I/Q Bandwidth").

For details on selecting the suitable sample rate, see "Sample Rate, Symbol Rate and I/Q Bandwidth".

Remote command:

[SENSe:​]DDEMod:​PRATe


Maximum Bandwidth

VSA (R&S FSW-K70) > Configuration > Signal Capture > Data Acquisition > Maximum Bandwidth
Maximum Bandwidth

Defines the maximum bandwidth to be used by the R&S FSW for I/Q data acquisition. This setting is only available if the bandwidth extension option R&S FSW-B160/-B320/-B500 is installed. Otherwise the maximum bandwidth is determined automatically.

For details on the maximum bandwidth see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

"Auto"

(Default) All installed bandwidth extension options are activated. The currently available maximum bandwidth is allowed (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

Note that using bandwidth extension options R&S FSW-B160/-B320 may cause more spurious effects (option B500 does not).

"80 MHz"

Restricts the analysis bandwidth to a maximum of 80 MHz.

The bandwidth extension options R&S FSW-B160/-B320/-B500 are deactivated.

"160 MHz"

Restricts the analysis bandwidth to a maximum of 160 MHz. The bandwidth extension option R&S FSW-B320 is deactivated.

(Not available or required if bandwidth extension option R&S FSW-B500 is installed.)

Remote command:

TRACe:​IQ:​WBANd[:​STATe]

TRACe:​IQ:​WBANd:​MBWIDTH


Usable I/Q Bandwidth

VSA (R&S FSW-K70) > Configuration > Signal Capture > Data Acquisition > Usable I/Q Bandwidth
Usable I/Q Bandwidth

Shows the usable I/Q bandwidth which depends on the selected sample rate. For details see "Sample Rate, Symbol Rate and I/Q Bandwidth".

This information is provided for reference only.

Note: In diagrams in the frequency domain (Spectrum transformation, see "Result Type Transformation") the usable I/Q bandwidth is indicated by vertical blue lines.

Remote command:

TRACe<n>:​IQ:​BWIDth?


Swap I/Q

VSA (R&S FSW-K70) > Configuration > Signal Capture > Data Acquisition > Swap I/Q
Swap I/Q

Activates or deactivates the inverted I/Q modulation. If the I and Q parts of the signal from the DUT are interchanged, the R&S FSW can do the same to compensate for it.

On | I and Q signals are interchanged Inverted sideband, Q+j*I
Off | I and Q signals are not interchanged Normal sideband, I+j*Q
Remote command:

[SENSe:​]SWAPiq


Trigger Settings

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings
Trigger Settings

The trigger settings define the beginning of a measurement.

The TRIGGER INPUT/OUTPUT connectors on the R&S FSW can only be used for input in the VSA application, for use as external triggers. No configuration settings are available for trigger input.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. Thus, no trigger settings are available in the VSA application in MSRA/MSRT operating mode. However, a capture offset can be defined with a similar effect as a trigger offset. It defines an offset from the start of the captured data (from the MSRA/MSRT Master) to the start of the application data for vector signal analysis. (See "Capture Offset".)

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ IF Power/BB Power
└ I/Q Power
└ Digital I/Q
└ Trigger Level
└ Trigger Offset
└ Hysteresis
└ Drop-Out Time
└ Slope
└ Trigger Holdoff
└ Capture Offset


Trigger Source

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ IF Power/BB Power
└ I/Q Power
└ Digital I/Q


Free Run

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)" ).

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: in VSA, trigger output is not supported, thus the connector is always configured for input.
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: in VSA, trigger output is not supported, thus the connector is always configured for input.
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


IF Power/BB Power

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Trigger Source > IF Power/BB Power
IF Power/BB Power

Depending on the input source type, this softkey defines triggering of the measurement using:

  • the baseband power (for baseband input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)
  • the third intermediate frequency(RF input)
    The R&S FSW is triggered as soon as the trigger threshold is exceeded around the selected frequency (= start frequency in the frequency sweep). The trigger threshold depends on the defined trigger level, as well as on the RF attenuation and preamplification. A reference level offset, if defined, is also considered. The trigger bandwidth at the intermediate frequency depends on the RBW and sweep type. For details on available trigger levels and trigger bandwidths see the data sheet.

Note: Be aware that in auto sweep type mode, due to a possible change in sweep types, the trigger bandwidth may vary considerably for the same RBW setting.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce

TRIG:SOUR BBP, see TRIGger[:​SEQuence]:​SOURce


I/Q Power

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Trigger Source > I/Q Power
I/Q Power

This trigger source is not available if the optional Digital Baseband Interface (R&S FSW-B17) or Analog Baseband Interface (R&S FSW-B71) is used for input. It is also not available for analysis bandwidths ≥ 160 MHz.

Triggers the measurement when the magnitude of the sampled I/Q data exceeds the trigger threshold.

The trigger bandwidth corresponds to the "Usable I/Q Bandwidth" setting for data acquisition (see "Usable I/Q Bandwidth").

Remote command:

TRIG:SOUR IQP, see TRIGger[:​SEQuence]:​SOURce


Digital I/Q

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Trigger Source > Digital I/Q
Digital I/Q

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available:

Defines triggering of the measurement directly via the LVDS connector. In the selection list you must specify which general purpose bit (GP0 to GP5) will provide the trigger data.

Note: If the Digital I/Q enhanced mode is used, i.e. the connected device supports transfer rates up to 200 Msps, only the general purpose bits GP0 and GP1 are available as a Digital I/Q trigger source.

The following table describes the assignment of the general purpose bits to the LVDS connector pins.

(For details on the LVDS connector see "Description of the LVDS Connector" )

Assignment of general purpose bits to LVDS connector pins
Bit | LVDS pin
GP0 | SDATA4_P - Trigger1
GP1 | SDATA4_P - Trigger2
GP2 *) | SDATA0_P - Reserve1
GP3 *) | SDATA4_P - Reserve2
GP4 *) | SDATA0_P - Marker1
GP5 *) | SDATA4_P - Marker2
*): not available for Digital I/Q enhanced mode
Remote command:

TRIG:SOUR GP0, see TRIGger[:​SEQuence]:​SOURce


Trigger Level

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Trigger Level
Trigger Level

Defines the trigger level for the specified trigger source.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel:​IFPower

TRIGger[:​SEQuence]:​LEVel:​IQPower

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]

For analog baseband (B71) or digital baseband (B17) input only:


Trigger Offset

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

The time may be entered in s or in symbols.

Note: In MSRA/MSRT mode, the trigger offset defines the start of the sweep only for the MSRA/MSRT Master. For MSRA/MSRT applications, use the "Capture Offset" instead.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger) Only possible for zero span (e.g. I/Q Analyzer application) and gated trigger switched off Maximum allowed range limited by the sweep time: pretriggermax = sweep time When using the Digital Baseband Interface (R&S FSW-B17), the maximum range is limited by the number of pretrigger samples. (See table "Restrictions for digital in- and output")
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Hysteresis

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Drop-Out Time

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Note: For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Slope

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Trigger Holdoff

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Capture Offset

VSA (R&S FSW-K70) > Configuration > Signal Capture > Trigger Settings > Capture Offset
Capture Offset

This setting is only available for applications in MSRA or MSRT operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

In MSRT mode, the offset may be negative if a pretrigger time is defined.

For details on the MSRA operating mode see "Applications and Operating Modes" .

For details on the MSRT operating mode see "Applications and Operating Modes" .

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet

[SENSe:​]RTMS:​CAPTure:​OFFSet


Sweep Settings

VSA (R&S FSW-K70) > Configuration > Signal Capture > Sweep Settings
Sweep Settings

The sweep settings define how often data from the input signal is acquired and then evaluated. They are configured via the SWEEP key.

└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Refresh (non-Multistandard mode)
└ Statistic Count
└ Select Result Rng
└ Refresh


Continuous Sweep/RUN CONT

VSA (R&S FSW-K70) > Configuration > Signal Capture > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

After triggering, starts the measurement and repeats it continuously until stopped. This is the default setting.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
If the Sequencer is active in MSRT mode, the "Continuous Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, trace averaging is performed.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

VSA (R&S FSW-K70) > Configuration > Signal Capture > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

After triggering, starts the number of evaluations set in "Statistics Count". The measurement stops after the defined number of evaluations has been performed.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
If the Sequencer is active in MSRT mode, the "Single Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, no trace averaging is performed.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

VSA (R&S FSW-K70) > Configuration > Signal Capture > Sweep Settings > Continue Single Sweep
Continue Single Sweep

After triggering, repeats the number of evaluations set in "Statistics Count", without deleting the trace of the last measurement.

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Refresh (non-Multistandard mode)

VSA (R&S FSW-K70) > Configuration > Signal Capture > Sweep Settings > Refresh (non-Multistandard mode)
Refresh (non-Multistandard mode)

Repeats the evaluation of the data currently in the capture buffer without capturing new data. This is useful after changing settings, for example filters, patterns or evaluation ranges.

Remote command:

INITiate:​REFMeas


Statistic Count

VSA (R&S FSW-K70) > Configuration > Signal Capture > Sweep Settings > Statistic Count
Statistic Count

Defines the number of measurements to be considered for statistical evaluations. The behavior depends on the active sweep mode.

Activate "Description" to display a visualization of the behavior of the current settings.

Note: If the "Statistic Count" is set to 1, trace averaging is not performed; Max Hold and Min Hold, however, remain active, unlike in the Spectrum application.

"Auto" | In single sweep mode: captures the I/Q data once and evaluates it In continuous sweep mode: captures I/Q data continuously; for each evaluation, the average is calculated over the last 10 capture sets (moving average)
"Manual" | In single sweep mode: captures I/Q data until the defined number of evaluations have been performed In continuous sweep mode: captures I/Q data continuously; if trace averaging is selected, the average is calculated over the defined number of capture sets (moving average);
Remote command:

[SENSe:​]SWEep:​COUNt[:​VALue]


Select Result Rng

VSA (R&S FSW-K70) > Configuration > Signal Capture > Sweep Settings > Select Result Rng
Select Result Rng

Selects the result range from the capture buffer that you want to evaluate.

This function is available in single sweep mode only.

By default, the application shows the results over all result ranges that have been captured in the signal capturing process and are in the R&S FSW's memory. By selecting a range number, you can evaluate a specific result range, e.g. a particular burst.

The range depends on the number of result ranges you have captured previously.

For more information refer also to "Measurement Ranges".

Remote command:

[SENSe:​]DDEMod:​SEARch:​MBURst:​CALC


Refresh

VSA (R&S FSW-K70) > Configuration > Signal Capture > Sweep Settings > Refresh
Refresh

This function is only available if the Sequencer is deactivated and only for MSRA or MSRT applications.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

This is useful, for example, after evaluation changes have been made or if a new sweep was performed from another application; in this case, only that application is updated automatically after data acquisition.

Note: To update all active applications at once, use the "Refresh all" function in the "Sequencer" menu.
(See "Refresh All" ).

Remote command:

INITiate:​REFResh


Burst and Pattern Configuration

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration
Burst and Pattern Configuration

Information on known patterns and bursts in the captured signal improve the accuracy of the determined ideal reference signal, and calculation of the signal parameters becomes quicker.

For details on burst and patterns see "Overview of the Demodulation Process".

Contents
  • Burst Search
  • Pattern Search
  • Pattern Configuration
  • Pattern Definition


Burst Search

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Burst Search
Burst Search

The "Burst Search" settings define when a burst is detected in the evaluated signal.

A live preview of the capture buffer with the current settings is displayed in the preview area at the bottom of the dialog box. The blue lines below the trace indicate the detected bursts. The preview area is not editable directly.

The "Burst Search" settings are displayed when you select the "Burst/Pattern" button in the "Overview" or the "Burst/Pattern Search" softkey in the main VSA menu.

For details on burst see "Overview of the Demodulation Process".

└ Enabling Burst Searches
└ Measuring only if burst was found
└ Burst Configuration
└ Search Tolerance
└ Min Gap Length


Enabling Burst Searches

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Burst Search > Enabling Burst Searches
Enabling Burst Searches

Enables or disables burst searches. If "Auto" is selected, burst search is enabled only if the signal structure defines a bursted signal (in the "Signal Structure" tab of the "Modulation & Signal Description" dialog box, see "Signal Type").

Remote command:

[SENSe:​]DDEMod:​SEARch:​BURSt:​AUTO


Measuring only if burst was found

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Burst Search > Measuring only if burst was found
Measuring only if burst was found

If enabled, measurement results are only displayed (and are only averaged) if a valid burst has been found. When measuring bursted signals that are averaged over several measurements, it is recommended that you enable this option so that erroneous measurements do not affect the result of averaging.

Remote command:

[SENSe:​]DDEMod:​SEARch:​BURSt:​MODE


Burst Configuration

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Burst Search > Burst Configuration
Burst Configuration

The conditions under which a burst is detected in the captured data can be configured either manually or automatically according to the defined signal structure settings (see "Burst Settings".

Remote command:

[SENSe:​]DDEMod:​SEARch:​BURSt:​CONFigure:​AUTO

└ Search Tolerance
└ Min Gap Length


Search Tolerance

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Burst Search > Burst Configuration > Search Tolerance
Search Tolerance

Defines the number of symbols that may differ from the burst length without influencing the burst detection. A search tolerance of 5, for example, with a minimum and maximum burst length of 100, will detect bursts that are 95 to 100 symbols long. (The minimum and maximum burst length is defined in the "Signal Structure"settings

Note: Due to the fact that the VSA does not have knowledge of the ramp length, there is an uncertainty in the burst search algorithm. Thus, setting this parameter to "0" will result in a failed burst search for most signals.

Remote command:

[SENSe:​]DDEMod:​SEARch:​BURSt:​TOLerance


Min Gap Length

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Burst Search > Burst Configuration > Min Gap Length
Min Gap Length

Represents the minimum distance (in symbols) between adjacent bursts. The default value is 1 symbol in order to make sure that the burst search finds bursts that are very close to each other. However, in case the capture buffer does not contain very close bursts, it is recommended that you increase the value. This makes the burst search faster and also more robust for highly distorted signals.

Note that this parameter only influences the robustness of the burst search. It should not be used to explicitly exclude certain bursts from the measurement. For example, setting the minimum gap length to 100 symbols does not ensure that the burst search does not find bursts that have a very small gap.

Remote command:

[SENSe:​]DDEMod:​SEARch:​BURSt:​GLENgth[:​MINimum]


Pattern Search

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Search
Pattern Search

The "Pattern Search" settings define when a pattern is detected in the evaluated signal.

A live preview of the capture buffer with the current settings is displayed in the preview area at the bottom of the dialog box. The preview area is not editable directly.

The "Pattern Search" settings are displayed when you select the "Burst/Pattern" button in the "Overview" or the "Burst/Pattern Search" softkey in the main VSA menu and then switch to the "Pattern Search" tab.

For details on patterns see "Overview of the Demodulation Process".

└ Enabling Pattern Searches
└ I/Q Correlation Threshold
└ Meas only if Pattern Symbols Correct
└ Selected Pattern for Search
└ Pattern Found


Enabling Pattern Searches

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Search > Enabling Pattern Searches
Enabling Pattern Searches

Enables or disables pattern searches. If "Auto" is selected, pattern search is enabled only if the signal structure defines a pattern in the signal (in the "Signal Structure" tab of the "Modulation & Signal Description" dialog box, see "Pattern Settings").

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​STATe

[SENSe:​]DDEMod:​SEARch:​SYNC:​AUTO


I/Q Correlation Threshold

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Search > I/Q Correlation Threshold
I/Q Correlation Threshold

The I/Q correlation threshold decides whether a match is accepted or not during a pattern search (see also "I/Q Pattern Search"). If the parameter is set to 100%, only I/Q patterns that match totally with the input signal are found. This is only the case for infinite SNR.

If the threshold "Auto" option is enabled, the default value of 90% is used. As long as the pattern is found, there is no need to change this parameter. However, if the pattern is very short (approximately < 10 symbols) or if the signal is highly distorted, tuning this parameter helps the pattern search to succeed. To define a threshold manually, disable the "Auto" option.

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​IQCThreshold

[SENSe:​]DDEMod:​SEARch:​PATTern:​CONFigure:​AUTO


Meas only if Pattern Symbols Correct

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Search > Meas only if Pattern Symbols Correct
Meas only if Pattern Symbols Correct

If enabled, measurement results are only displayed (and are only averaged) if a valid pattern has been found. When measuring signals that contain a pattern and are averaged over several measurements, it is recommended that you enable this option so that erroneous measurements do not affect the result of averaging.

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​MODE


Selected Pattern for Search

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Search > Selected Pattern for Search
Selected Pattern for Search

Indicates which of the patterns that are assigned to the current standard is selected and will be searched for.

The selected pattern is indicated for information only and cannot be edited here, only in the "Signal Structure" settings, see "Name").

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​SELect


Pattern Found

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Search > Pattern Found
Pattern Found

Indicates whether a pattern was found in the currently captured data.


Pattern Configuration

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration
Pattern Configuration

For common signal standards, the patterns to be searched for in the captured signal are predefined in the VSA application. In addition, new patterns can be defined and assigned to a signal standard manually.

Patterns are configured in the "Advanced Pattern Settings" dialog box which is displayed when you do one of the following:

  • Select the "Pattern Config" softkey in the main VSA menu.
  • In the "Signal Description" dialog box, switch to the "Signal Structure" tab and select the "Pattern Config" button.

For details on patterns see "Overview of the Demodulation Process".

└ Standard Patterns - selecting an assigned pattern
└ Removing patterns from a standard
└ Adding patterns to a standard
└ Displaying available patterns
└ Prefix
└ Show Compatible/ Show All
└ Edit
└ Save As
└ New
└ Delete
└ Pattern details
└ Pattern Search On
└ Meas only if Pattern Symbols Correct


Standard Patterns - selecting an assigned pattern

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Standard Patterns - selecting an assigned pattern
Standard Patterns - selecting an assigned pattern

The "Standard Patterns" are the patterns assigned to the currently selected standard. You can add existing patterns to the standard or remove patterns already assigned to the standard. The highlighted pattern is currently selected for pattern search.

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​SELect


Removing patterns from a standard

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Removing patterns from a standard
Removing patterns from a standard

Removes the assignment of the selected patterns to the standard. The patterns are removed from the "Standard Patterns" list, but not deleted.

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​PATTern:​REMove


Adding patterns to a standard

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Adding patterns to a standard
Adding patterns to a standard

Adds the selected patterns in the list of available patterns ("All Patterns") to the list of assigned patterns ("Standard Patterns").

For details see "To add a predefined pattern to a standard".

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​PATTern:​ADD


Displaying available patterns

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Displaying available patterns
Displaying available patterns

The "All Patterns" list contains the patterns available in the VSA application.

You can assign available patterns to the selected standard, edit existing or define new patterns. For details on managing standard patterns, see "How to Manage Patterns"

The list can be filtered using the following functions:

└ Prefix
└ Show Compatible/ Show All


Prefix

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Displaying available patterns > Prefix
Prefix

Shows only patterns that contain the specified prefix.


Show Compatible/ Show All

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Displaying available patterns > Show Compatible/ Show All
Show Compatible/ Show All

Shows only patterns that are compatible to the selected modulation mode or all patterns (regardless of the selected standard).


Edit

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Edit
Edit

Opens the "Edit Pattern" dialog box to edit the pattern definition. See "Pattern Definition".

For details on defining a pattern, see example "Defining a pattern".

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​NAME

[SENSe:​]DDEMod:​SEARch:​SYNC:​COMMent

[SENSe:​]DDEMod:​SEARch:​SYNC:​DATA

[SENSe:​]DDEMod:​SEARch:​SYNC:​TEXT


Save As

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Save As
Save As

Saves a copy of an existing pattern under a new name.

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​COPY


New

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > New
New

Opens the "Pattern" dialog box to create a new pattern definition. See "Pattern Definition".

For details on defining a pattern, see "How to Define a New Pattern".

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​NAME

[SENSe:​]DDEMod:​SEARch:​SYNC:​COMMent

[SENSe:​]DDEMod:​SEARch:​SYNC:​DATA

[SENSe:​]DDEMod:​SEARch:​SYNC:​TEXT


Delete

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Delete
Delete

Deletes the selected patterns. Any existing assignments to other standards are removed.

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​DELete


Pattern details

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Pattern details
Pattern details

Pattern details for the currently focussed pattern are displayed at the upper right-hand side of the dialog box. You can refer to these details, for example, when you want to add a new pattern to the standard and want to make sure you have selected the correct one.


Pattern Search On

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Pattern Search On
Pattern Search On

If enabled, the VSA application searches for the selected pattern. This setting is identical to the setting in the "Pattern Search" dialog box (see "Enabling Pattern Searches").

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​STATe


Meas only if Pattern Symbols Correct

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Configuration > Meas only if Pattern Symbols Correct
Meas only if Pattern Symbols Correct

If enabled, measurement results are only displayed (and are only averaged) if a valid pattern has been found. When measuring signals that contain a pattern and are averaged over several measurements, it is recommended that you enable this option so that erroneous measurements do not affect the result of averaging.

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​MODE


Pattern Definition

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Definition
Pattern Definition

New patterns can be defined and then assigned to a standard. Patterns are defined in the "New Pattern" dialog box which is displayed when you select the "New" button in the "Advanced Pattern Settings" dialog box.

For details on defining a pattern, see "How to Define a New Pattern".

For details on patterns see "Overview of the Demodulation Process".

└ Name
└ Description
└ Mod. order
└ Symbols
└ Symbol format
└ Adding symbols
└ Removing symbols
└ Comment


Name

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Definition > Name
Name

Pattern name that will be displayed in selection list

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​NAME


Description

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Definition > Description
Description

Optional description of the pattern which is displayed in the pattern details

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​TEXT


Mod. order

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Definition > Mod. order
Mod. order

The order of modulation, e.g. 8 for an 8-PSK.

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​NSTate


Symbols

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Definition > Symbols
Symbols

The pattern definition is a symbol table consisting of one or more symbols. The number of symbols is indicated as the "Size" to the left of the symbol table.

A scrollbar beneath the input area alows you to scroll through the table for long patterns. The numbers beneath the scrollbar indicate the sequential number of the following symbols, from left to right:

  • the first symbol
  • the currently selected symbol
  • the last symbol
Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​DATA

└ Symbol format
└ Adding symbols
└ Removing symbols


Symbol format

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Definition > Symbols > Symbol format
Symbol format

Defines the format in which each symbol is defined: hexadecimal, decimal or binary


Adding symbols

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Definition > Symbols > Adding symbols
Adding symbols

Adds a new symbol in the symbol table to the left of the currently selected symbol.


Removing symbols

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Definition > Symbols > Removing symbols
Removing symbols

Removes the currently selected symbol in the symbol table.


Comment

VSA (R&S FSW-K70) > Configuration > Burst and Pattern Configuration > Pattern Definition > Comment
Comment

Optional comment for the pattern, displayed in the pattern details (kept for compatibility with FSQ)

Remote command:

[SENSe:​]DDEMod:​SEARch:​SYNC:​COMMent


Result Range Configuration

VSA (R&S FSW-K70) > Configuration > Result Range Configuration
Result Range Configuration

The result range determines which part of the capture buffer, burst or pattern is displayed. For more information, see "Measurement Ranges".

A visualization of the result display with the current settings is displayed in the visualization area at the bottom of the dialog box.

The result range settings are displayed when you select the "Cut Result Ranges" button in the "Overview" or the "Range Settings" softkey in the main VSA menu.

The evaluation range settings are described in "Evaluation Range Configuration".

└ Result Length
└ Reference
└ Alignment
└ Offset
└ Symbol Number at <Reference> Start


Result Length

VSA (R&S FSW-K70) > Configuration > Result Range Configuration > Result Length
Result Length

Defines the number of symbols that are to be demodulated. All traces over time are displayed over the result range.

For more information, see "Measurement Ranges".

Remote command:

[SENSe:​]DDEMod:​TIME


Reference

VSA (R&S FSW-K70) > Configuration > Result Range Configuration > Reference
Reference

Defines the reference for the result range alignment.

For more information, see "Measurement Ranges".

The result of the current setting is displayed in the visualization area of the dialog box.

"Capture" | the capture buffer
"Burst" | the detected burst
"Pattern" | the detected pattern
Remote command:

CALCulate<n>:​TRACe<t>:​ADJust[:​VALue]


Alignment

VSA (R&S FSW-K70) > Configuration > Result Range Configuration > Alignment
Alignment

Defines the type of alignment of the result range to the reference source. The result of the current setting is displayed in the visualization area of the dialog box.

For more information, see "Measurement Ranges".

Remote command:

CALCulate<n>:​TRACe<t>:​ADJust:​ALIGnment[:​DEFault]


Offset

VSA (R&S FSW-K70) > Configuration > Result Range Configuration > Offset
Offset

Defines the offset of the result range to the alignment reference. The result of the current setting is displayed in the visualization area of the dialog box.

Note: Note the following restrictions to this parameter:

  • An offset < 0 is not possible if you align the result range to the left border of the capture buffer.
  • An offset that moves the pattern outside the result range is not allowed. For example, if you align the result to the left border of the pattern, only offsets ≦ 0 are allowed. Otherwise, you would never be able to find the pattern within the result range.

For more information, see "Measurement Ranges".

Remote command:

CALCulate<n>:​TRACe<t>:​ADJust:​ALIGnment:​OFFSet


Symbol Number at <Reference> Start

VSA (R&S FSW-K70) > Configuration > Result Range Configuration > Symbol Number at <Reference> Start
Symbol Number at <Reference> Start

Defines the number of the symbol which marks the beginning of the alignment reference source (burst, capture buffer or pattern). The result of the current setting is displayed in the visualization area of the dialog box.

In effect, this setting defines an offset of the x-axis (in addition to the one defined for the signal structure, see "Offset").

Note: When you define the "Symbol Number at <Reference> Start" remember to take the offset defined for the signal structure into consideration (see "Offset"). The "Symbol Number at Pattern Start" refers to the first symbol of the pattern offset, not the first symbol of the pattern.

For more information, see "Measurement Ranges".

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​VOFFset


Demodulation Settings

VSA (R&S FSW-K70) > Configuration > Demodulation Settings
Demodulation Settings

During demodulation of the vector signal some undesired effects that may occur during transmission can be compensated for. Furthermore, you can influence the synchronization process.

The advanced demodulation settings are described in "Advanced Demodulation (Synchronization)".

The measurement filter settings are described in "Measurement Filter Settings".

Contents
  • Demodulation - Compensation
  • Advanced Demodulation (Synchronization)


Demodulation - Compensation

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Demodulation - Compensation
Demodulation - Compensation

During demodulation of the vector signal some undesired effects that may occur during transmission can be compensated for.

Demodulation settings are displayed when you select the "Demodulation" button in the "Overview" or the "Demod/Meas Filter" softkey in the main VSA menu.

A live preview of the constellation with the current settings is displayed in the preview area at the bottom of the dialog box. The preview area is not editable directly.

Demodulation settings depend on the used modulation.

└ Compensate for... (PSK, MSK, ASK, QAM)
└ Compensate for... (FSK)
└ Equalizer Settings
└ State
└ Mode
└ Filter Length
└ Reset Equalizer
└ Store/Load Current Equalizer


Compensate for... (PSK, MSK, ASK, QAM)

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Demodulation - Compensation > Compensate for... (PSK, MSK, ASK, QAM)
Compensate for... (PSK, MSK, ASK, QAM)

If enabled, compensation for various effects is taken into consideration during demodulation. Thus, these distortions are not shown in the calculated error values.

Note: Note that compensation for all the listed distortions can result in lower EVM values.

  • I/Q Offset (default: on)
  • I/Q Imbalance
  • Amplitude Droop (default: on)
  • Symbol Rate Error (required to display the SRE in the Result Summary)
  • Channel (default: on)
    Note that channel distortion can only be determined if the equalizer is on (see "State"). Thus, compensation can only be disabled if the equalizer is on.
    By default, channel compensation is enabled to improve accuracy of the error results. If compensation is disabled, the EVM is calculated from the original input signal with channel distortions.

For details on these effects see "Modulation Errors".

Remote command:

[SENSe:​]DDEMod:​NORMalize:​IQOFfset

[SENSe:​]DDEMod:​NORMalize:​IQIMbalance

[SENSe:​]DDEMod:​NORMalize:​ADRoop

[SENSe:​]DDEMod:​NORMalize:​SRERror

[SENSe:​]DDEMod:​NORMalize:​CHANnel


Compensate for... (FSK)

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Demodulation - Compensation > Compensate for... (FSK)
Compensate for... (FSK)

If enabled, compensation for various effects is taken into consideration during demodulation. Thus, these distortions are not shown in the calculated error values.

Note: Note that compensation for all the listed distortions can result in lower EVM values.

  • Carrier Frequency Drift
  • FSK Deviation Error
  • Symbol Rate Error

For details on these effects see "Modulation Errors".

Remote command:

[SENSe:​]DDEMod:​NORMalize:​CFDRift

[SENSe:​]DDEMod:​NORMalize:​FDERror

[SENSe:​]DDEMod:​NORMalize:​SRERror


Equalizer Settings

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Demodulation - Compensation > Equalizer Settings
Equalizer Settings

The equalizer can compensate for a distorted transmission of the input signal or improve accuracy in estimating the reference signal.

For details see "The Equalizer".

└ State
└ Mode
└ Filter Length
└ Reset Equalizer
└ Store/Load Current Equalizer


State

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Demodulation - Compensation > Equalizer Settings > State
State

Activates or deactivates the equalizer to compensate for a distorted channel.

For details see "The Equalizer".

Remote command:

[SENSe:​]DDEMod:​EQUalizer[:​STATe]


Mode

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Demodulation - Compensation > Equalizer Settings > Mode
Mode

Defines the operating mode of the equalizer.

For details see "The Equalizer".

"Normal" | Determines the filter values from the difference between the ideal (reference) signal and the measured signal. Normal mode is sufficient for small distortions and performance remains high.
"Tracking" | The results of the equalizer in the previous sweep are considered to calculate the new filter until adaquate results are obtained. This "learning" effect allows for powerful removement of larger distortions within a minimum of sweeps. During the tracking phase calculation of the equalizer requires additional processing time.
"Freeze" | The filter is no longer changed, the current equalizer values are used for subsequent sweeps.
"User" | A user-defined equalizer loaded from a file is used.
"Averaging" | The results of the equalizer in all previous sweeps (since the instrument was switched on or the equalizer was reset) are considered to calculate the new filter. To start a new averaging process, select the "Reset Equalizer" button. Calculation of the equalizer requires additional processing time.
Remote command:

[SENSe:​]DDEMod:​EQUalizer:​MODE


Filter Length

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Demodulation - Compensation > Equalizer Settings > Filter Length
Filter Length

Defines the length of the equalizer in symbols. The longer the equalizer, the more accurate the filter becomes and the more distortion can be compensated. However, this requires extended calculation time. The shorter the filter length, the less calculation time is required during the equalizer's tracking or averaging phase.

For details see "The Equalizer".

Remote command:

[SENSe:​]DDEMod:​EQUalizer:​LENGth


Reset Equalizer

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Demodulation - Compensation > Equalizer Settings > Reset Equalizer
Reset Equalizer

Deletes the data of the currently selected equalizer. After deletion, averaging and tracking starts anew.

This is useful in the rare case that calculation takes a wrong symbol decision into consideration and distorts the signal such that the original signal can no longer be determined.

For details see "The Equalizer".

Remote command:

[SENSe:​]DDEMod:​EQUalizer:​RESet


Store/Load Current Equalizer

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Demodulation - Compensation > Equalizer Settings > Store/Load Current Equalizer
Store/Load Current Equalizer

Saves the current equalizer results to a file, or loads a user-defined equalizer.

The equalizer "Mode" must be set to USER in order to load a file.

For details see "The Equalizer".

Remote command:

[SENSe:​]DDEMod:​EQUalizer:​SAVE

[SENSe:​]DDEMod:​EQUalizer:​LOAD


Advanced Demodulation (Synchronization)

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Advanced Demodulation (Synchronization)
Advanced Demodulation (Synchronization)

You can influence the synchronization process and calculation of error values during demodulation.

Advanced demodulation settings are displayed when you select the "Demodulation" button in the "Overview" or the "Demod/Meas Filter" softkey in the main VSA menu and then switch to the "Demodulation - Advanced" tab.

A live preview of the constellation with the current settings is displayed in the preview area at the bottom of the dialog box. The preview area is not editable directly.

└ Normalize EVM to
└ Optimization
└ Estimation Points/Sym
└ Coarse Synchronization
└ Fine Synchronization
└ If SER ≤
└ Offset EVM


Normalize EVM to

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Advanced Demodulation (Synchronization) > Normalize EVM to
Normalize EVM to

Normalizes the EVM to the specified power value.

This setting is not available for MSK or FSK modulation.

  • Max Ref Power
    Maximum power of the reference signal at the symbol instants.
  • Mean Ref Power
    mean power of the reference signal at the symbol instants.
  • Mean Constellation Power
    Mean expected power of the measurement signal at the symbol instants
  • Max Constellation Power
    The maximum expected power of the measurement signal at the symbol instants
Remote command:

[SENSe:​]DDEMod:​ECALc[:​MODE]


Optimization

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Advanced Demodulation (Synchronization) > Optimization
Optimization

Determines the method used to calculate the result parameters. The required method depends on the used standard and is set according to the selected standard by default.

"Minimize RMS Error" | Optimizes calculation such that the RMS of the error vector is minimal.
"Minimize EVM" | Optimizes calculation such that EVM is minimal.
Remote command:

[SENSe:​]DDEMod:​OPTimization


Estimation Points/Sym

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Advanced Demodulation (Synchronization) > Estimation Points/Sym
Estimation Points/Sym

During synchronization, the measurement signal is matched to the reference signal and various signal parameters are calculated. You can define how many sample points are used for this calculation at each symbol.

For more information on estimation points per symbol see "Display Points vs Estimation Points per Symbol".

You can set the estimation points manually or let the VSA application decide how many estimation points to use.

If automatic mode is enabled, the VSA application uses the following settings, depending on the modulation type:

Modulation | Est. Points
PSK, QAM | 1
Offset QPSK | 2
FSK, MSK | Capture Oversampling

For manual mode, the following settings are available:

"1" | the estimation algorithm takes only the symbol time instants into account
"2" | two points per symbol instant are used (required for Offset QPSK)
"Capture Oversampling" | the number of samples per symbol defined in the signal capture settings is used (see "Sample Rate"), i.e. all sample time instants are weighted equally
Remote command:

[SENSe:​]DDEMod:​EPRate:​AUTO

[SENSe:​]DDEMod:​EPRate[:​VALue]


Coarse Synchronization

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Advanced Demodulation (Synchronization) > Coarse Synchronization
Coarse Synchronization

It is not only possible to check whether the pattern is part of the signal, but also to use the pattern for synchronization, in order to obtain the correct reference signal.

For details on synchronization see "Overview of the Demodulation Process".

If "Auto" mode is selected, the detected data is used. In manual mode you can select one of the following settings:

"Data" | (Default): the detected data is used for synchronization, i.e. unknown symbols Use this setting if no pattern is available or if the pattern is short or does not have suitable synchronization properties, e.g. a pattern that consists of only one repeated symbol.
"Pattern" | Known symbols from a defined pattern are used for synchronization Depending on the signal, using the pattern can speed up your measurement considerably and make it more robust against high carrier frequency offsets. Make sure that the pattern is suitable for synchronization, e.g. a GSM pattern.
Remote command:

[SENSe:​]DDEMod:​SEARch:​PATTern:​SYNC:​AUTO

[SENSe:​]DDEMod:​SEARch:​PATTern:​SYNC[:​STATe]


Fine Synchronization

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Advanced Demodulation (Synchronization) > Fine Synchronization
Fine Synchronization

In addition to the coarse synchronization used for symbol decisions, a fine synchronization is available to calculate various results from the reference signal, e.g. the EVM. However, when the signal is known to have a poor transmission quality or has a high noise level, false symbol decisions are more frequent, which may cause spikes in the EVM results.

To improve these calculations the reference signal can be estimated from a smaller area that includes a known symbol sequence in the input signal. In this case, the results for the limited reference area are more precise, at the cost of less accurate results outside this area. Thus, the result range should be set to the length of the reference area. The reference area can be defined either using a pattern or using a known data sequence from a Known Data file. If no predefined data sequences are available for the signal, the detected data is used by default.

For details on synchronization see "Overview of the Demodulation Process".

If "Auto" mode is selected and a Known Data file has been loaded and activated for use, the known data sequences are used. Otherwise, the detected data is used.

Note: You can define a maximum symbol error rate (SER) for the known data in reference to the evaluated data. If the SER of the known data exceeds this limit, the default synchronization using the detected data is performed.

"Known Data" | The reference signal is defined as the data sequence from the loaded Known Data file that most closely matches the measured data.
"Pattern" | The reference signal is estimated from the defined pattern.
"Detected Data" | (Default) The reference signal is estimated from the detected data.
Remote command:

[SENSe:​]DDEMod:​FSYNc:​AUTO

[SENSe:​]DDEMod:​FSYNc[:​MODE]

[SENSe:​]DDEMod:​FSYNc:​RESult?


If SER ≤

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Advanced Demodulation (Synchronization) > If SER ≤
If SER ≤

This setting is only available if "Known Data" is selected for "Fine Synchronization". You can define a maximum symbol error rate for the known data in reference to the evaluated data. Thus, if a wrong file was mistakenly loaded or the file proves to be unsuitable, it is not used for synchronization. Otherwise the results would be strongly distorted. If the SER of the known data exceeds this limit, the default synchronization using the detected data is performed.

Remote command:

[SENSe:​]DDEMod:​FSYNc:​LEVel


Offset EVM

VSA (R&S FSW-K70) > Configuration > Demodulation Settings > Advanced Demodulation (Synchronization) > Offset EVM
Offset EVM

The offset EVM is only available for Offset QPSK modulated signals.

Unlike QPSK modulation, the Q component of Offset QPSK modulation is delayed by half a symbol period against the I component in the time domain. The symbol time instants of the I and the Q component therefore do not coincide.

The offset EVM controls the calculation of all results that are based on the error vector. It affects the EVM, Real/Imag and Vector I/Q result displays as well as the EVM results in the Result Summary (EVM and MER).

You can configure the way the VSA application calculates the error vector results.

If "Offset EVM" is disabled, the VSA application substracts the measured signal from the reference signal to calculate the error vector. This method results in the fact that the error vector contains two symbol instants per symbol period: one that corresponds to the I component and one that corresponds to the Q component.

If "Offset EVM" is enabled, however, the VSA application compensates the delay of the Q component with respect to the I component in the measurement signal as well as the reference signal before calculating the error vector. That means that the error vector contains only one symbol instant per symbol period.

Remote command:

[SENSe:​]DDEMod:​ECALc:​OFFSet


Measurement Filter Settings

VSA (R&S FSW-K70) > Configuration > Measurement Filter Settings
Measurement Filter Settings

The measurement filter can be used to filter both the measured signal and the reference signal, and thus the error vector. You can configure the measurement filter to be used.

For more information on measurement filters see "Measurement Filters".

Measurement filter settings are displayed when you select the "Meas Filter" button in the "Overview" or the "Demod/Meas Filter" softkey in the main VSA menu and then switch to the "Meas Filter" tab.

A live preview of the constellation with the current settings is displayed in the preview area at the bottom of the dialog box. The preview area is not editable directly.

└ Using the Transmit Filter as a Measurement Filter (Auto)
└ Type
└ Load User Filter
└ Alpha/BT


Using the Transmit Filter as a Measurement Filter (Auto)

VSA (R&S FSW-K70) > Configuration > Measurement Filter Settings > Using the Transmit Filter as a Measurement Filter (Auto)
Using the Transmit Filter as a Measurement Filter (Auto)

If the "Auto" option is enabled, the measurement filter is defined automatically depending on the transmit filter specified in the "Modulation" settings (see "Transmit Filter Type").

Note: If a user-defined transmit filter is selected and the measurement filter is defined automatically, a Low-ISI measurement filter according to the selected user filter is calculated and used.

Remote command:

[SENSe:​]DDEMod:​MFILter:​AUTO


Type

VSA (R&S FSW-K70) > Configuration > Measurement Filter Settings > Type
Type

Defines the measurement filter type, if the "Using the Transmit Filter as a Measurement Filter (Auto)" setting is not enabled.

"<Predefined Filter>" | An overview of available measurement filters is provided in "Measurement Filters".
"User" | User-defined filter. Define the filter using the "Load User Filter" function or the [SENSe:​]DDEMod:​MFILter:​USER command. For more information on user-defined filters see "Customized Filters". For detailed instructions on working with user-defined filters see "How to Select User-Defined Filters".
"None" | No measurement filter is used.
Remote command:

[SENSe:​]DDEMod:​MFILter[:​STATe]

To turn off the measurement filter.

[SENSe:​]DDEMod:​MFILter:​USER

To use a user-defined filter.

[SENSe:​]DDEMod:​MFILter:​NAME

To define the name of the measurement filter.

└ Load User Filter
└ Alpha/BT


Load User Filter

VSA (R&S FSW-K70) > Configuration > Measurement Filter Settings > Type > Load User Filter
Load User Filter

Opens a file-selection dialog box to select the user-defined measurement filter to be used.

This setting is only available if "User" is selected as the "Filter Type".

For detailed instructions on working with user-defined filters see "How to Select User-Defined Filters".

Remote command:

[SENSe:​]DDEMod:​MFILter:​USER


Alpha/BT

VSA (R&S FSW-K70) > Configuration > Measurement Filter Settings > Type > Alpha/BT
Alpha/BT

Defines the roll-off factor (Alpha) or the filter bandwidth (BT).

The roll-off factor or filter bandwidth are available for RC, RRC and Gauss filters.

If the measurement mode is automatically selected according to the transmit filter, this setting is identical to the "Alpha/BT" value in the modulation settings (see "Alpha/BT").

Remote command:

Measurement filter: [SENSe:​]DDEMod:​MFILter:​ALPHa

Transmit filter: [SENSe:​]DDEMod:​TFILter:​ALPHa


Evaluation Range Configuration

VSA (R&S FSW-K70) > Configuration > Evaluation Range Configuration
Evaluation Range Configuration

The evaluation range defines which range of the result is to be evaluated - either the entire result range or only a specified part of it. The calculated length of the specified range is indicated beneath the entries.

A visualization of the evaluation range (in relation to the result range) with the current settings is displayed at the bottom of the dialog box. The green bar below the trace indicates the defined result range, indented red lines indicate defined start and stop symbols (see "Evaluation range display"). The visualization is not editable directly.

The evaluation range settings are displayed when you select the "Evaluation Range" button in the "Overview" or the "Range Settings" softkey in the main VSA menu and then switch to the "Evaluation Range" tab.

For details on the evaluation range see "Measurement Ranges".

For an example on setting the evaluation range see "Setting the Evaluation Range".

└ Evaluating the Entire Result Range
└ Start / Stop


Evaluating the Entire Result Range

VSA (R&S FSW-K70) > Configuration > Evaluation Range Configuration > Evaluating the Entire Result Range
Evaluating the Entire Result Range

If enabled, the entire result range is evaluated.

If disabled, you can define a specific part of the result range to be evaluated.

Remote command:

CALCulate<n>:​ELIN<startstop>:​STATe


Start / Stop

VSA (R&S FSW-K70) > Configuration > Evaluation Range Configuration > Start / Stop
Start / Stop

Defines the symbol in the result range at which evaluation is started and stopped. The start and stop symbols themselves are included in the evaluation range.

Note: Note that the start and stop values are defined with respect to the x-axis including an optional offset defined via the "Symbol Number at <Reference> Start" parameter.

Remote command:

CALCulate<n>:​ELIN<startstop>[:​VALue]


Adjusting Settings Automatically

VSA (R&S FSW-K70) > Configuration > Adjusting Settings Automatically
Adjusting Settings Automatically

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings. In order to do so, a measurement is performed. The duration of this measurement can be defined automatically or manually.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

└ Setting the Reference Level Automatically (Auto Level)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis
└ Auto Scale Once/Auto Scale Window
└ Auto Scale All


Resetting the Automatic Measurement Time (Meastime Auto)

VSA (R&S FSW-K70) > Configuration > Adjusting Settings Automatically > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

VSA (R&S FSW-K70) > Configuration > Adjusting Settings Automatically > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

VSA (R&S FSW-K70) > Configuration > Adjusting Settings Automatically > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

VSA (R&S FSW-K70) > Configuration > Adjusting Settings Automatically > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


Auto Scale Once/Auto Scale Window

VSA (R&S FSW-K70) > Configuration > Adjusting Settings Automatically > Auto Scale Once/Auto Scale Window
Auto Scale Once/Auto Scale Window

If enabled, both the x-axis and y-axis are automatically adapted to the current measurement results (only once, not dynamically) in the selected window.

To adapt the range of all screens together, use the "Auto Scale All" function.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE


Auto Scale All

VSA (R&S FSW-K70) > Configuration > Adjusting Settings Automatically > Auto Scale All
Auto Scale All

Adapts the x-axis and y-axis to the current measurement values (only once, not dynamically) in all measurement windows.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​Y[:​SCALe]:​AUTO:​ALL


Meas Menu

VSA (R&S FSW-K70) > Configuration > Meas Menu
Meas Menu
The MEAS menu provides the following functions:
  • "Digital Standards"
  • "Restore Factory Settings"
  • "Display and Window Configuration"


Span, BW and Marker Func Menus

VSA (R&S FSW-K70) > Configuration > Span, BW and Marker Func Menus
Span, BW and Marker Func Menus

The SPAN, BW, and MARKER FUNCT menus are currently not used in the VSA application.


Analysis

VSA (R&S FSW-K70) > Analysis
Analysis

General result analysis settings concerning the trace, markers, windows etc. can be configured via the "Analysis" button in the "Overview". They are identical to the analysis functions in the base unit except for the special window functions.

Window-specific configuration

The settings in the "Analysis" dialog box are specific to the selected window. Thus, the "Analysis" button is only available in the "Overview" if the "Specifics for" option is enabled. To configure the settings for a different VSA window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

The scaling settings for the diagram axes are described in "Amplitude and Vertical Axis Configuration".

Contents
  • Trace Settings
  • Trace Export Settings
  • Markers
  • Modulation Accuracy Limit Lines
  • Display and Window Configuration
  • Zoom Functions
  • Analysis in MSRA/MSRT Mode


Trace Settings

VSA (R&S FSW-K70) > Analysis > Trace Settings
Trace Settings

The trace settings determine how the measured data is analyzed and displayed in the window. Depending on the result display, between 1 and 6 traces may be displayed.

Trace settings can be configured via the TRACE key, in the "Traces" dialog box, or in the vertical "Traces" tab of the "Analysis" dialog box.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box (see "Specifics for").

Trace data can also be exported to an ASCII file for further analysis. For details see "Trace Export Settings".

└ Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
└ Trace Mode
└ Evaluation
└ Predefined Trace Settings - Quick Config
└ Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)


Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

VSA (R&S FSW-K70) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Selects the corresponding trace for configuration. The currently selected trace is highlighted orange.

For details see "How to Configure a Standard Trace" .

For the Magnitude Overview Absolute result display, only one trace is available.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]

Selected via numeric suffix of TRACe<t> commands


Trace Mode

VSA (R&S FSW-K70) > Analysis > Trace Settings > Trace Mode
Trace Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode" .

The available trace modes depend on the selected result display. Not all evaluations support all trace modes.

For the Magnitude Overview Absolute result display, only the trace modes "Clear/Write" and "View" are available. For the Magnitude Absolute result display, the trace modes Average, MinHold, MaxHold are applied to the individual result ranges and thus may not provide useful results.

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is lower than the previous one.
"Average" | The average is formed over several sweeps. The "Statistic Count" determines the number of averaging procedures.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Evaluation

VSA (R&S FSW-K70) > Analysis > Trace Settings > Evaluation
Evaluation

Defines whether the trace displays the evaluation of the measured signal or the reference signal (if "Meas & Ref Signal" is used as the evaluation data source, see "Signal Source").

Remote command:

CALCulate<n>:​TRACe<t>[:​VALue]


Predefined Trace Settings - Quick Config

VSA (R&S FSW-K70) > Analysis > Trace Settings > Predefined Trace Settings - Quick Config
Predefined Trace Settings - Quick Config

Commonly required trace settings have been predefined and can be applied very quickly by selecting the appropriate button.

Function | Trace Settings
Preset All Traces | Trace 1: | Clear Write
 | Traces 2-6: | Blank
Set Trace Mode Max | Avg | Min | Trace 1: | Max Hold
 | Trace 2: | Average
 | Trace 3: | Min Hold
 | Traces 4-6: | Blank
Set Trace Mode Max | ClrWrite | Min | Trace 1: | Max Hold
 | Trace 2: | Clear Write
 | Trace 3: | Min Hold
 | Traces 4-6: | Blank


Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

VSA (R&S FSW-K70) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Displays the "Traces" settings and focuses the "Mode" list for the selected trace.

For the Magnitude Overview Absolute result display, only one trace is available.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]


Trace Export Settings

VSA (R&S FSW-K70) > Analysis > Trace Export Settings
Trace Export Settings

The captured (trace) data can also be exported to an ASCII file. The format of these files can be configured.

For step-by-step instructions on how to export a trace, see "How to Export Trace Data and Numerical Results" .

└ Data Export Mode
└ Header
└ Decimal Separator
└ Trace ASCII Export


Data Export Mode

VSA (R&S FSW-K70) > Analysis > Trace Export Settings > Data Export Mode
Data Export Mode

Defines whether raw I/Q data (as captured) or trace data (evaluated) is stored.

Remote command:

FORMat:​DEXPort:​MODE


Header

VSA (R&S FSW-K70) > Analysis > Trace Export Settings > Header
Header

If enabled, a header with scaling information etc. is included in the file.

Remote command:

FORMat:​DEXPort:​HEADer


Decimal Separator

VSA (R&S FSW-K70) > Analysis > Trace Export Settings > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Trace ASCII Export

VSA (R&S FSW-K70) > Analysis > Trace Export Settings > Trace ASCII Export
Trace ASCII Export

Opens a file selection dialog box and saves the traces of the captured data in ASCII format to the specified file and directory.

Either the traces for the selected window only (see "Specifics for") are exported, or the traces of all windows are exported, one after the other.

For details on the file format see "ASCII File Export Format for VSA Data".

Remote command:

MMEMory:​STORe<n>:​TRACe


Markers

VSA (R&S FSW-K70) > Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display.

Markers are configured in the "Marker" dialog box which is displayed when you do one of the following:

  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.
  • Press the MKR key, then select the "Marker Config" softkey.
Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

Contents
  • Individual Marker Settings
  • Marker Search Settings
  • Marker Positioning Functions


Individual Marker Settings

VSA (R&S FSW-K70) > Analysis > Markers > Individual Marker Settings
Individual Marker Settings

In VSA evaluations, up to 5 markers can be activated in each diagram at any time.

└ Marker 1 / Marker 2 / Marker 3 / Marker 4
└ Selected Marker
└ Marker State
└ X-value
└ Marker Type
└ Assigning the Marker to a Trace
└ All Markers Off
└ Couple Windows


Marker 1 / Marker 2 / Marker 3 / Marker 4

VSA (R&S FSW-K70) > Analysis > Markers > Individual Marker Settings > Marker 1 / Marker 2 / Marker 3 / Marker 4
Marker 1 / Marker 2 / Marker 3 / Marker 4

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 4 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X


Selected Marker

VSA (R&S FSW-K70) > Analysis > Markers > Individual Marker Settings > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

VSA (R&S FSW-K70) > Analysis > Markers > Individual Marker Settings > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


X-value

VSA (R&S FSW-K70) > Analysis > Markers > Individual Marker Settings > X-value
X-value

Defines the position of the marker on the x-axis.

Remote command:

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​MARKer<m>:​X


Marker Type

VSA (R&S FSW-K70) > Analysis > Markers > Individual Marker Settings > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Assigning the Marker to a Trace

VSA (R&S FSW-K70) > Analysis > Markers > Individual Marker Settings > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

The marker can also be assigned to the currently active trace using the "Marker to Trace" softkey in the "Marker" menu.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


All Markers Off

VSA (R&S FSW-K70) > Analysis > Markers > Individual Marker Settings > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


Couple Windows

VSA (R&S FSW-K70) > Analysis > Markers > Individual Marker Settings > Couple Windows
Couple Windows

If enabled, markers in all diagrams with the same x-axis (time or symbols) have coupled x-values (except for capture buffer display), i.e. if you move the marker in one diagram, it is moved in all coupled diagrams.

Remote command:

CALCulate<n>:​MARKer<m>:​LINK


Marker Search Settings

VSA (R&S FSW-K70) > Analysis > Markers > Marker Search Settings
Marker Search Settings

Several functions are available to set the marker to a specific position very quickly and easily. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

These settings are available as softkeys in the "Marker To" menu, or in the "Search" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search" tab.
└ Search Mode for Next Peak
└ Real / Imag Plot
└ Search Limits (Left / Right)


Search Mode for Next Peak

VSA (R&S FSW-K70) > Analysis > Markers > Marker Search Settings > Search Mode for Next Peak
Search Mode for Next Peak

Selects the search mode for the next peak search.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Real / Imag Plot

VSA (R&S FSW-K70) > Analysis > Markers > Marker Search Settings > Real / Imag Plot
Real / Imag Plot

Defines whether marker search functions are performed on the real or imaginary trace of the "Real/Imag" measurement.

Remote command:

CALCulate<n>:​MARKer:​SEARch


Search Limits (Left / Right)

VSA (R&S FSW-K70) > Analysis > Markers > Marker Search Settings > Search Limits (Left / Right)
Search Limits (Left / Right)

If activated, limit lines are defined and displayed for the search. Only results within the limited search range are considered.

For details on limit lines for searches see "Peak search limits" .

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​MARKer:​X:​SLIMits:​LEFT

CALCulate:​MARKer:​X:​SLIMits:​RIGHT


Marker Positioning Functions

VSA (R&S FSW-K70) > Analysis > Markers > Marker Positioning Functions
Marker Positioning Functions

The following functions set the currently selected marker to the result of a peak search. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

└ Select Marker
└ Peak Search
└ Search Next Peak
└ Max |Peak|
└ Search Minimum
└ Search Next Minimum
└ Assigning the Marker to a Trace


Select Marker

VSA (R&S FSW-K70) > Analysis > Markers > Marker Positioning Functions > Select Marker
Select Marker

Selects the subsequent marker (marker 1/2/3/4 or delta marker) to be edited or to be used for a marker function. The currently selected marker number is highlighted.

Remote command:

Marker selected via suffix <m> in remote commands.


Peak Search

VSA (R&S FSW-K70) > Analysis > Markers > Marker Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Next Peak

VSA (R&S FSW-K70) > Analysis > Markers > Marker Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Max |Peak|

VSA (R&S FSW-K70) > Analysis > Markers > Marker Positioning Functions > Max |Peak|
Max |Peak|

Sets the active marker/delta marker to the largest absolute peak value (maximum or minimum) of the selected trace.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​APEak


Search Minimum

VSA (R&S FSW-K70) > Analysis > Markers > Marker Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Search Next Minimum

VSA (R&S FSW-K70) > Analysis > Markers > Marker Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Assigning the Marker to a Trace

VSA (R&S FSW-K70) > Analysis > Markers > Marker Positioning Functions > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

The marker can also be assigned to the currently active trace using the "Marker to Trace" softkey in the "Marker" menu.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


Modulation Accuracy Limit Lines

VSA (R&S FSW-K70) > Analysis > Modulation Accuracy Limit Lines
Modulation Accuracy Limit Lines

The results of a modulation accuracy measurement can be checked for violation of defined limits automatically (see "Modulation Accuracy").

Limits and the limit check are configured in the "Limits" dialog box that is displayed when you press the "ModAcc Limits Config" softkey in the "Lines" menu.

For details on working with limits see "How to Check Limits for Modulation Accuracy".

└ Checking Modulation Accuracy Limits
└ Set to Default
└ Current/Mean/Peak
└ Limit Value
└ Check


Checking Modulation Accuracy Limits

VSA (R&S FSW-K70) > Analysis > Modulation Accuracy Limit Lines > Checking Modulation Accuracy Limits
Checking Modulation Accuracy Limits

Activates or deactivates evaluation of modulation accuracy limits in the result summary.

If limit check is activated and the measured values exceed the limits, those values are indicated in red in the result summary table. If limit check is activated and no values exceed the limits, the checked values are indicated in green.

For details on working with limits see "How to Check Limits for Modulation Accuracy".

Remote command:

CALCulate<n>:​LIMit:​MACCuracy:​STATe


Set to Default

VSA (R&S FSW-K70) > Analysis > Modulation Accuracy Limit Lines > Set to Default
Set to Default

Restores the default limits and deactivates all checks.

Remote command:

CALCulate<n>:​LIMit:​MACCuracy:​DEFault


Current/Mean/Peak

VSA (R&S FSW-K70) > Analysis > Modulation Accuracy Limit Lines > Current/Mean/Peak
Current/Mean/Peak

Defines and activates the limits for the currently measured value, the mean and the peak value on separate tabs. Note that the limits for the current and peak values are always the same.

For details on working with limits see "How to Check Limits for Modulation Accuracy".

└ Limit Value
└ Check


Limit Value

VSA (R&S FSW-K70) > Analysis > Modulation Accuracy Limit Lines > Current/Mean/Peak > Limit Value
Limit Value

Define the limit with which the currently measured, mean or peak value is to be compared. A different limit value can be defined for each result type. Depending on the modulation type, different result types are available.

Result type | Remote command
PSK, MSK, QAM:
EVM RMS | CALCulate<n>:​LIMit:​MACCuracy:​EVM:​RCURrent:​VALue
EVM Peak | CALCulate<n>:​LIMit:​MACCuracy:​EVM:​PCURrent:​VALue
Phase Err Rms | CALCulate<n>:​LIMit:​MACCuracy:​PERRor:​RCURrent:​VALue
Phase Err Peak | CALCulate<n>:​LIMit:​MACCuracy:​PERRor:​PCURrent:​VALue
Magnitude Err Rms | CALCulate<n>:​LIMit:​MACCuracy:​MERRor:​RCURrent:​VALue
Magnitude Err Peak | CALCulate<n>:​LIMit:​MACCuracy:​MERRor:​PCURrent:​VALue
Carr Freq Err | CALCulate<n>:​LIMit:​MACCuracy:​CFERror:​CURRent:​VALue
Rho | CALCulate<n>:​LIMit:​MACCuracy:​RHO:​CURRent:​VALue
IQ Offset | CALCulate<n>:​LIMit:​MACCuracy:​OOFFset:​CURRent:​VALue
FSK modulation only:
Freq Err Rms | CALCulate<n>:​LIMit:​MACCuracy:​FERRor:​RCURrent:​VALue
Freq Err Peak | CALCulate<n>:​LIMit:​MACCuracy:​FERRor:​PCURrent:​VALue
Magnitude Err Rms | CALCulate<n>:​LIMit:​MACCuracy:​MERRor:​RCURrent:​VALue
Magnitude Err Peak | CALCulate<n>:​LIMit:​MACCuracy:​MERRor:​PCURrent:​VALue
FSK Dev Err | CALCulate<n>:​LIMit:​MACCuracy:​FERRor:​PCURrent:​VALue
Carr Freq Err | CALCulate<n>:​LIMit:​MACCuracy:​CFERror:​CURRent:​VALue

For details on working with limits see "How to Check Limits for Modulation Accuracy".


Check

VSA (R&S FSW-K70) > Analysis > Modulation Accuracy Limit Lines > Current/Mean/Peak > Check
Check

Considers the defined limit value in the limit check, if checking is activated.

For details on working with limits see "How to Check Limits for Modulation Accuracy".

Remote command:

CALCulate<n>:​LIMit:​MACCuracy:​<ResultType>:​<LimitType>:​STATe


Display and Window Configuration

VSA (R&S FSW-K70) > Analysis > Display and Window Configuration
Display and Window Configuration

The captured I/Q data can be evaluated using various different methods without having to start a new measurement.

As opposed to the R&S FSW Spectrum application or other applications, in VSA configuring the result display requires two steps:

  1. Display Configuration: In the first step, you select the data source for the evaluation and the window placement in the SmartGrid.

    The SmartGrid mode is activated automatically when you select the "Display Config" softkey from the main VSA menu or the "Display Config" button in the Overview. Note, however, that this button is only displayed in the general Overview, not for window-specific configuration ("Specifics for" must be disabled).

    The default evaluation for the selected data source is displayed in the window.

    Up to 16 result displays can be displayed simultaneously in separate windows. The VSA evaluation methods are described in "Measurements and Result Displays".

    For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

  2. Window Configuration: In a second step, you can select a different evaluation method (result type) for the window, based on the data source selected in the "Display Configuration".

Contents
  • Window Configuration


Window Configuration

VSA (R&S FSW-K70) > Analysis > Display and Window Configuration > Window Configuration
Window Configuration

For each window you can select a different evaluation method (result type), based on the data source selected in the "Display Configuration". Further window settings are available for some result types.

The "Window Configuration" is displayed when you select the "Window Config" softkey from the main VSA menu.

Some settings are only displayed after you select the "More" button in the dialog box. To hide these settings, select the "Less" button.

└ Signal Source
└ Result Type
└ More/Less
└ Result Type Transformation
└ Highlight Symbols
└ Display Points/Sym
└ Oversampling


Signal Source

VSA (R&S FSW-K70) > Analysis > Display and Window Configuration > Window Configuration > Signal Source
Signal Source

Data source as selected in the "Display Configuration" (see "Measurements and Result Displays"). If you change the signal source setting here, the default result type for the new data source is activated for the current window.

Remote command:

LAYout:​ADD[:​WINDow]?


Result Type

VSA (R&S FSW-K70) > Analysis > Display and Window Configuration > Window Configuration > Result Type
Result Type

The result type defines the evaluation method used in the current window.

The available result types in VSA are described in "Result Types in VSA".

Remote command:

CALCulate<n>:​FORMat


More/Less

VSA (R&S FSW-K70) > Analysis > Display and Window Configuration > Window Configuration > More/Less
More/Less

Displays or hides additional display settings for the selected result type.


Result Type Transformation

VSA (R&S FSW-K70) > Analysis > Display and Window Configuration > Window Configuration > Result Type Transformation
Result Type Transformation

For certain result types it is not only possible to see the common "over time" representation of the measurement, but also the spectrum or the statistics (in form of a histogram). These are the transformations of the results.

These settings are not available for symbol evaluation, i.e. the following signal sources:

  • Symbols
  • Modulation Accuracy

"Normal"

Evaluation in time domain

X-axis displays time values.

"Spectrum"

Evaluation in frequency domain

X-axis displays frequency values. The usable I/Q bandwidth is indicated in the display.

"Statistics"

Statistical evaluation (histogram)

X-axis displays former y-values. Y-axis displays statistical information:

  • Trace 1: the probability of occurrence of a certain value is plotted against the value
  • Trace 2: the cumulated probability of occurance is plotted against the value.
Remote command:

CALCulate<n>:​DDEM:​SPECtrum[:​STATe]

CALCulate<n>:​STATistics:​CCDF[:​STATe]


Highlight Symbols

VSA (R&S FSW-K70) > Analysis > Display and Window Configuration > Window Configuration > Highlight Symbols
Highlight Symbols

If enabled, the symbol instants are highlighted as squares in the window for measured and reference signals in time (normal) display, as well as error displays.

Only evaluations that are based on symbols (e.g. constellations or traces) support this function.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​SYMBol


Display Points/Sym

VSA (R&S FSW-K70) > Analysis > Display and Window Configuration > Window Configuration > Display Points/Sym
Display Points/Sym

Defines the number of display points that are displayed per symbol. If more points per symbol are selected than the defined "Sample Rate", the additional points are interpolated for the display. The more points are displayed per symbol, the more detailed the trace becomes.

For more information see "Display Points vs Estimation Points per Symbol"

Note: If the capture buffer is used as the signal source, the "Sample Rate" defines the number of displayed points per symbol; the "Display Points/Sym" parameter is not available.

If "Auto" is enabled, the "Sample Rate" value is used.

Alternatively, select the number of points to be displayed per symbol manually. The available values depend on the source type.

"1" | only the symbol time instants are displayed
"2, 4, 8, 16, 32" | more points are displayed than symbols
"Capture Oversampling" | the number of samples per symbol defined in the signal capture settings are displayed (see "Sample Rate")
Remote command:

DISPlay[:​WINDow<n>]:​PRATe[:​VALue]

DISPlay[:​WINDow<n>]:​PRATe:​AUTO


Oversampling

VSA (R&S FSW-K70) > Analysis > Display and Window Configuration > Window Configuration > Oversampling
Oversampling

Defines the sample basis for statistical evaluation. This setting is only available for the result type transformation "Statistics".

"Symbols only" | Statistics are calculated for symbol instants only
"Infinite" | Statistics are calculated for all trace points (symbol instants and intermediate times)
"Auto" | Oversampling is automatically set to "Symbols only" (Statistics are calculated for symbol instants only).
Remote command:

CALCulate<n>:​STATistics:​MODE


Zoom Functions

VSA (R&S FSW-K70) > Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

VSA (R&S FSW-K70) > Analysis > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

VSA (R&S FSW-K70) > Analysis > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

VSA (R&S FSW-K70) > Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

VSA (R&S FSW-K70) > Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Analysis in MSRA/MSRT Mode

VSA (R&S FSW-K70) > Analysis > Analysis in MSRA/MSRT Mode
Analysis in MSRA/MSRT Mode

The data that was captured by the MSRA/MSRT Master can be analyzed in the VSA application.

The analysis settings and functions available in MSRA/MSRT mode are those described for common Signal and Spectrum Analyzer mode.

See "Analysis".

Analysis line settings

In addition, an analysis line can be positioned. The analysis line is a common time marker for all MSRA/MSRT applications.

To hide or show and position the analysis line, a dialog box is available. To display the "Analysis Line" dialog box, tap the "AL" icon in the toolbar (only available in MSRA/MSRT mode). The current position of the analysis line is indicated on the icon.

└ Position
└ Show Line


Position

VSA (R&S FSW-K70) > Analysis > Analysis in MSRA/MSRT Mode > Position
Position

Defines the position of the analysis line in the time domain. The position must lie within the measurement time of the multistandard measurement.

Remote command:

CALCulate:​MSRA:​ALINe[:​VALue]

CALCulate:​RTMS:​ALINe[:​VALue]


Show Line

VSA (R&S FSW-K70) > Analysis > Analysis in MSRA/MSRT Mode > Show Line
Show Line

Hides or displays the analysis line in the time-based windows. By default, the line is displayed.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Remote command:

CALCulate:​MSRA:​ALINe:​SHOW

CALCulate:​RTMS:​ALINe:​SHOW


I/Q Data Import and Export

VSA (R&S FSW-K70) > I/Q Data Import and Export
I/Q Data Import and Export

Baseband signals mostly occur as so-called complex baseband signals, i.e. a signal representation that consists of two channels; the in phase (I) and the quadrature (Q) channel. Such signals are referred to as I/Q signals. I/Q signals are useful because the specific RF or IF frequencies are not needed. The complete modulation information and even distortion that originates from the RF, IF or baseband domains can be analyzed in the I/Q baseband.

Importing and exporting I/Q signals is useful for various applications:
  • Generating and saving I/Q signals in an RF or baseband signal generator or in external software tools to analyze them with the R&S FSW later
  • Capturing and saving I/Q signals with an RF or baseband signal analyzer to analyze them with the R&S FSW or an external software tool later

For example, you can capture I/Q data using the I/Q Analyzer application, if available, and then perform a VSA measurement on that data later using the R&S FSW VSA application.

As opposed to storing trace data, which may be averaged or restricted to peak values, I/Q data is stored as it was captured, without further processing. The data is stored as complex values in 32-bit floating-point format. Multi-channel data is not supported. The I/Q data is stored in a format with the file extension .iq.tar.

For a detailed description see "I/Q Data File Format (iq-tar)" .

Export only in MSRA mode

In MSRA mode, I/Q data can only be exported to other applications; I/Q data cannot be imported to the MSRA Master or any MSRA applications.

For details on import and export functions see "Import/Export Functions" .


How to Perform Vector Signal Analysis

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis
How to Perform Vector Signal Analysis

Using the VSA option you can perform vector signal analysis measurements using predefined standard setting files, or independently of digital standards using user-defined measurement settings. Such settings can be stored for recurrent use.

Thus, configuring VSA measurements requires one of the following tasks:

  • Selecting an existing standard settings file and, if necessary, adapting the measurement settings to your specific requirements.
  • Configuring the measurement settings and, if necessary, storing the settings in a file.
Contents
  • How to Perform VSA According to Digital Standards
  • How to Perform Customized VSA Measurements
  • How to Analyze the Measured Data


How to Perform VSA According to Digital Standards

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform VSA According to Digital Standards
How to Perform VSA According to Digital Standards

In order to perform vector signal analysis as specified in digital standards, various predefined settings files for common digital standards are provided for use with the VSA option. In addition, you can create your own settings files for user-specific measurements.

For an overview of predefined standards and settings see "Predefined Standards and Settings".

This section provides instructions for the following tasks:

  • "To perform a measurement according to a standard"
  • "To load predefined settings files"
  • "To store settings as a standard file"
  • "To delete standard files"
  • "To restore standard files"
To perform a measurement according to a standard

  1. Press the MODE key on the front panel and select the "VSA" application.

  2. Press the MEAS key and select the "Digital Standards" softkey.

  3. Select the required settings file and then "Load" (see "To load predefined settings files").

    The instrument is adjusted to the stored settings for the selected standard and a measurement is started immediately.

  4. Press the RUN SINGLE key to stop the continuous measurement mode and start a defined number of measurements.

    The measured data is stored in the capture buffer and can be analyzed (see "How to Analyze the Measured Data").

To load predefined settings files

  1. In the "Meas" menu, select the "Digital Standards" softkey.

  2. In the file selection dialog box, select the standard whose settings you want to load.

    To change the path, press the arrow icons at the right end of the "Path" field and select the required folder from the file system.

  3. Press the "Load" button.

    The dialog box is closed and the instrument is adjusted to the stored settings for the selected standard.

To store settings as a standard file

  1. Configure the measurement as required (see "How to Perform Customized VSA Measurements").

  2. In the "Meas" menu, select the "Digital Standards" softkey.

  3. In the "File Name" field, enter the name of the standard for which you want to store settings.

    To change the path, press the arrow icons at the right end of the "Path" field and select the required folder from the file system.

    To insert a new folder, select the "New Folder" button and enter a name in the "New Folder" dialog box.

  4. Press the "Save" button.

    The dialog box is closed and the current measurement settings are stored in a standard file.

To delete standard files

  1. In the "Meas" menu, select the "Digital Standards" softkey.

  2. In the "Manage VSA Standards" file selection dialog box, select the standard whose settings file you want to delete. Standards predefined by Rohde & Schwarz can also be deleted.

    To change the path, press the arrow icons at the right end of the "Path" field and select the required folder from the file system.

  3. Press the "Delete" button.

  4. Confirm the message to avoid unintentionally deleting a standard.

    The standard file is removed from the folder.

To restore standard files

  1. To restore the predefined standard files, do one of the following:

    • In the "Meas" menu, select the "Digital Standards" softkey.
      The "Manage VSA Standards" file selection dialog box is displayed.
    • In the "Meas" menu, select the "Restore Factory Settings" softkey.

  2. Select "Restore Standard Files".

    The standards predefined by Rohde & Schwarz available at the time of delivery are restored to the Standards folder.


How to Perform Customized VSA Measurements

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements
How to Perform Customized VSA Measurements

In addition to performing vector signal analysis strictly according to specific digital standards, you can configure the analysis settings for customized tasks. The general process for a typical VSA measurement is described here.

  1. Press the MODE key on the front panel and select the "VSA" application.

  2. Select the "Overview" softkey to display the "Overview" for VSA.

  3. Select the "Signal Description" button and configure the expected signal characteristics.

    If the input data is largely known in advance, define files with the known data to compare the measured data to (see "How to Manage Known Data Files"). This can improve demodulation significantly.

  4. Select the "Input/Frontend" button to define the input signal's center frequency, amplitude and other basic settings.

  5. Select the "Signal Capture" button and define how much and which data to capture:

    (In MSRA/MSRT mode, define the application data instead, see "VSA in MSRA/MSRT Operating Mode").

    • "Capture length": the duration or number of symbols to be captured
    • "Sample rate": how many points are to be captured for each symbol

  6. Optionally, select the "Trigger" tab and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted.

    (In MSRA/MSRT mode, define a "Capture Offset" instead, see "VSA in MSRA/MSRT Operating Mode").

  7. For bursted signals, select the "Burst/Pattern" button and define the criteria to detect the individual bursts within the input signal (see "How to Perform Pattern Searches").

  8. Select the "Cut Result Ranges" button and define which of the captured data is to be demodulated (see "How to Define the Result Range").

  9. Select the "Demodulation" button to configure and optimize the synchronization process.

  10. Select the "Meas filter" button to select a different or user-defined measurement filter to improve the accuracy of the error vector (see "How to Select User-Defined Filters").

  11. Select the "Evaluation Range" button to define which part of the demodulated data is to be evaluated and displayed.

  12. Press the RUN SINGLE key to stop the continuous sweep and start a new sweep with the new configuration.

    The measured data is stored in the capture buffer and can be analyzed (see "How to Analyze the Measured Data")

Contents
  • How to Select User-Defined Filters
  • How to Perform Pattern Searches
  • How to Manage Known Data Files
  • How to Define the Result Range


How to Select User-Defined Filters

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements > How to Select User-Defined Filters
How to Select User-Defined Filters

The most frequently required measurement and TX filters required for vector signal analysis according to digital standards are provided by the R&S FSW VSA application. However, you can also load user-defined filters.

To load a user measurement filter

  1. In the "Overview", select the "Meas Filter" button.

  2. In the "Meas Filter" tab of the "Demodulation & Measurement Filter"dialog box, select "Type": User.

  3. Select "Load User Filter".

  4. Load your .vaf file from the USB stick.

To load a user transmit (TX) filter

  1. In the "Overview", select the "Signal Description" button.

  2. In the "Modulation" tab of the "Signal Description" dialog box, select "Transmit Filter Type": User.

  3. Select "Load User Filter".

  4. Load your .vaf file from the USB stick.


How to Perform Pattern Searches

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements > How to Perform Pattern Searches
How to Perform Pattern Searches
To configure a pattern search

  1. In the "Overview", select "Signal Description".

  2. Select the "Signal Structure" tab.

  3. Select the "Burst Signal" signal type.

  4. Enable the "Pattern" option.

  5. From the "Name" selection list, select a pattern that is assigned to the currently defined standard.

  6. If the pattern you require is not available, continue with "To add a predefined pattern to a standard" or "How to Define a New Pattern".

  7. Optionally, select the "Offset" option and enter the number of symbols in the signal to be ignored during the pattern search.

  8. Close the "Signal Description" dialog box.

  9. In the "Overview" dialog box, select "Burst / Pattern" and switch to the "Pattern Search" tab.

  10. Select "On" to enable the search.

    To enable a search only if a pattern is part of the signal description, enable the "Auto" option.

    The results of the pattern search with the selected pattern on the current measurement data is displayed in the "Preview" area of the dialog box. Whether a pattern was detected or not is indicated in the "Information" area.

  11. If necessary, adapt the I/Q correlation threshold. If bursts are not detected, reduce the threshold; if false bursts are detected, increase the threshold.

  12. Optionally, enable the "Meas only if pattern symbols correct" option. In this case, measurement results are only displayed if a valid pattern has been detected.

  13. Close the dialog box.

    The selected pattern is used for a pattern search in the next measurement.

Contents
  • How To Assign Patterns to a Standard
  • How to Define a New Pattern
  • How to Manage Patterns


How To Assign Patterns to a Standard

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements > How to Perform Pattern Searches > How To Assign Patterns to a Standard
How To Assign Patterns to a Standard

Only patterns that are assigned to the currently selected VSA standard are available for the pattern search.

To add a predefined pattern to a standard

  1. In the "Overview", select "Signal Description" and switch to the "Signal Structure" tab.

  2. Select "Pattern Config" to display the "Advanced Pattern Settings" dialog box.

  3. In the list of "All Patterns", select the required pattern.

    If the required pattern is not displayed, see "To change the display for the list of patterns".

  4. Select "Add to Standard".

    The selected pattern is inserted in the list of "Standard Patterns".

  5. Select the pattern to be used for the pattern search from the list of "Standard Patterns".

To remove a predefined pattern from a standard

  1. In the "Overview", select "Signal Description" and switch to the "Signal Structure" tab.

  2. Select "Pattern Config" to display the "Advanced Pattern Settings" dialog box.

  3. Select the pattern from the list of "Standard Patterns".

  4. Select "Remove from Standard".

    The pattern is removed from the list of "Standard Patterns" and is no longer assigned to the current standard, but is still available for assignment from the list of "All Patterns".


How to Define a New Pattern

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements > How to Perform Pattern Searches > How to Define a New Pattern
How to Define a New Pattern

  1. In the "Overview", select "Signal Description" and switch to the "Signal Structure" tab.

  2. Select "Pattern Config" to display the "Advanced Pattern Settings" dialog box.

  3. Select the "New" button.

    The pattern definition dialog box is displayed.

  4. Define the following pattern settings:

    Setting

    Description

    Name

    Pattern name that will be displayed in selection list

    Description

    Optional description of the pattern which is displayed in the pattern details

    Modulation order

    Number of values each symbol can represent, e.g. 8 for 8-PSK

    Comment

    Optional comment for the pattern, displayed in the pattern details (kept for compatibility with FSQ)

  5. Define the format used to define the individual symbols of the pattern.

  6. Define the symbols of the pattern.

    1. Select the symbol field you want to define.

      If necessary, add a new symbol field by selecting "Add".

    2. Enter a value using the keyboard. Depending on the "Modulation Order" <n>, the value can be in the range 0 to <n>-1.

    3. Select the next symbol field, or insert a new one, and continue to define the other symbols. To scroll through the fields for long patterns, use the scrollbar beneath the input area. The number beneath the scrollbar at the right end indicates the sequential number of the last symbol field, the number in the center indicates the sequential number of the currently selected symbol field.

      To remove a symbol field, select it and press "Remove".

  7. Select "Save" to save the pattern under the specified name. The pattern is stored on the instrument as an xml file named <Name>.xml under <Installation directory>\vsa\Pattern.

If you copy this file to another location, you can restore the pattern at a later time, e.g. after deletion.

Example: Defining a pattern
Pattern definition


How to Manage Patterns

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements > How to Perform Pattern Searches > How to Manage Patterns
How to Manage Patterns
To change the display for the list of patterns

  1. In the "Overview", select "Signal Description" and switch to the "Signal Structure" tab.

  2. Select "Pattern Config" to display the "Advanced Pattern Settings" dialog box.

  3. To display all available patterns, select "Show All".

    To display all patterns that are compatible to the defined standard, select "Show Compatible".

    To display only patterns that contain a specific prefix, enter the "Prefix" in the edit field.

To edit a predefined pattern

  1. In the "Overview", select "Signal Description" and switch to the "Signal Structure" tab.

  2. Select "Pattern Config" to display the "Advanced Pattern Settings" dialog box.

  3. Select the pattern from the list of "All Patterns".

  4. Press "Edit Pattern".

  5. Change the settings as required as described in "How to Define a New Pattern".

To delete a predefined pattern

  1. In the "Overview", select "Signal Description" and switch to the "Signal Structure" tab.

  2. Select "Pattern Config" to display the "Advanced Pattern Settings" dialog box.

  3. Select the pattern from the list of "All Patterns".

  4. Press "Delete Pattern".

    The pattern is removed from the lists of available and assigned patterns and can no longer be assigned to any standard. Any existing assignments to other standards are removed, as well.

To restore predefined patterns

Default patterns provided by Rohde&Schwarz can be restored.

  1. Press the MEAS key.

  2. Select the "Restore Factory Settings" softkey.

  3. Select the "Restore Pattern Files" softkey.

    The patterns as defined by Rohde & Schwarz at the time of delivery are restored.

Restoring user-defined patterns

User-defined patterns can only be restored if you have a copy of the pattern file created during creation. In this case, copy the file named <Patternname>.xml back to the installation directory of the VSA application under vsa/standards. After a preset or after performing certain operations (e.g. changing the modulation settings) the pattern will be included in the list of "All Patterns" again.


How to Manage Known Data Files

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements > How to Manage Known Data Files
How to Manage Known Data Files

You can load xml files containing the possible sequences to the VSA application and use them to compare the measured data to. In particular, you can use known data for the following functions:

  • Fine synchronization during the demodulation process (see figure "Demodulation stages of the vector signal analysis option" and "Fine Synchronization")
  • Calculation of the Bit Error Rate (BER), see "Bit Error Rate (BER)"
Contents
  • How to Load Known Data Files
  • How to Create Known Data Files


How to Load Known Data Files

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements > How to Manage Known Data Files > How to Load Known Data Files
How to Load Known Data Files

Known Data files are loaded in the "Modulation & Signal Description" settings.

To load an existing Known Data file

  1. In the "Overview", select "Signal Description".

  2. Switch to the "Known Data" tab.

  3. Activate the usage of a Known Data file by enabling the "Known Data" option. This enables the "Load Data File" function.

  4. Select the "Load Data File" button.

    A file selection dialog box is displayed.

  5. Select the xml file which contains the possible data sequences of the input signal. The file must comply with the syntax described in "Known Data File Syntax Description".

    The header information of the xml file is displayed in the dialog box.

    Once a Known Data file has been loaded, the Bit Error Rate result display becomes available.

    If the "Fine Synchronization" setting in the "Demodulation" dialog box is set to "Auto" mode, the known data is also used for synchronization. Otherwise it can be selected manually. Defining a maximum symbol error rate for the known data in reference to the analyzed data avoids using a falsely selected or unsuitable file for synchronization (see also "If SER ≤".


How to Create Known Data Files

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements > How to Manage Known Data Files > How to Create Known Data Files
How to Create Known Data Files

You must create the Known Data files yourself according to the possible data sequences of the input signal. Use any xml editing tool you like, following the rules described in "Known Data File Syntax Description". Before loading the file to the VSA application, make sure the syntax of your file is valid.

Auxiliary tool to create Known Data files

An auxiliary tool to create Known Data files from data that is already available in the VSA application is provided on the instrument free of charge.

To create a Known Data file using the recording tool for sequences

  1. Import or apply input data for which stable demodulation results are available to the VSA application. If necessary, adapt the demodulation settings until the requested results are obtained.

  2. Start the "R&S Recording Tool for Sequences" from the Windows task bar on the R&S FSW, or execute the file RecordingToolforSequences.EXE from the installation directory on the instrument.

    The "R&S Recording Tool for Sequences" window is displayed.

  3. Start a measurement in the VSA application.

  4. In the tool window, select "Run".

    The tool records the demodulated data sequences. The following result information is provided by the tool during recording:

    • Analyzed Sequences: number of data sequences analyzed since the tool was started
    • Different Sequences: number of unique sequences detected in the measured data
    • Last New Sequence Found: time that has passed since the most recent unique sequence was detected
    • Throughput: current data processing speed of the tool

    Note that while the tool is running, the R&S FSW is set to remote mode, i.e. the manual interface is not available. As soon as the tool is closed, the remote mode is automatically deactivated.

  5. When all known possible sequences have been detected, or when a significantly large amount of time has passed so as to assume no more sequences will be detected, stop the tool by selecting "Stop".

    • If the results are acceptable, select "Store for K70" to store a valid xml file with the recorded data sequences on the instrument.
      A file selection dialog box is displayed in which you can select the storage location and file name.
      You can also add an optional comment to the file.
    • Otherwise, reset the tool to start a new recording, possibly after changing the demodulation settings or input data.

  7. Close the tool window to return to normal operation of the VSA application.

The created xml file can now be loaded in the VSA application as described in "How to Load Known Data Files".


How to Define the Result Range

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Perform Customized VSA Measurements > How to Define the Result Range
How to Define the Result Range

You can define which part of the source signal is analyzed ("Result Range") with reference to the captured data, a detected burst or a detected pattern.

(For details on the functions see "Result Range Configuration".)

  1. In the "Overview", select "Range Settings".

  2. Select the "Result Range" tab.

  3. Define the "Result Length", i.e. the number of symbols from the result that are to be analyzed.

    Note that when you use Known Data files as a reference, the "Result Length" specified here must be identical to the length of the specified symbol sequences in the xml file (<ResultLength> element). See "Known Data Files - Dependencies and Restrictions".

  4. Define the "Reference" for the result range, i.e. the source to which the result will be aligned. The reference can be the captured data, a detected burst or a detected pattern.

  5. Define the "Alignment" of the result range to the reference source, i.e. whether the result starts at the beginning of the reference source, ends with the reference source, or is centered with the reference source.

  6. Optionally, define an offset of the result range to the reference source, e.g. to ignore the first few symbols of the captured data.

  7. Optionally, define the number of the symbol which marks the beginning of the reference source to change the scaling of the x-axis. This offset is added to the one defined for the signal description.

The result range is indicated by a green bar along the time axis in capture buffer result displays, see "Measurement Ranges".


How to Analyze the Measured Data

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Analyze the Measured Data
How to Analyze the Measured Data

Once the data has been stored in the capture buffer, the results can be analyzed in numerous ways. The following tasks are meant to make you familiar with the most common VSA application features. For a description of all analysis functions and settings see "Analysis".

  1. Press the MEAS CONFIG key to display the VSA menu.

  2. Select the "Display Config" button in the "Overview" or the "Display Config" softkey and select the data sources for evaluation that are of interest to you (see "Display and Window Configuration").

    Arrange them on the display to suit your preferences.

    For each data source, a window with the default result type for that data source is displayed.

  3. Exit the SmartGrid mode.

  4. Select the "Window Config" softkey to change the result types and other display settings for the selected window. To change the settings in other windows, select a different window from the "Specifics for" list in the "Window Config" dialog box.

  5. Select the "Overview" softkey to display the "Overview".

    Enable the "Specifics for" option to access the analysis functions for the selected window.

  6. Select the "Analysis" button in the "Overview" to configure special analysis settings for the individual result displays, for example:

    • Configure markers and delta markers to determine deviations and offsets within the results, e.g. when comparing errors or peaks.
    • Configure the trace to display the average over a series of measurements. If necessary, increase the "Statistics Count" defined in the "Sweep" menu.

  7. Press the SWEEP key and select the "Selected Result Rng" softkey to select a specific burst to be evaluated.

    The result displays are updated to show the results for the selected burst.

    Tip: You can use a capture buffer display to navigate through the available result ranges, and analyze the individual result ranges in another window. The currently displayed result range is indicated by a blue bar in the capture buffer display.

  8. Optionally, zoom into a diagram to enlarge an area of the displayed data.

  9. Optionally, change the display scaling for diagrams (see "How to Change the Display Scaling").

  10. Optionally, check the modulation accuracy against specified limits (see "How to Check Limits for Modulation Accuracy").

  11. Optionally, export the trace data of the measured signal to a file (see "How to Export the Trace Data to a File").

Contents
  • How to Change the Display Scaling
  • How to Check Limits for Modulation Accuracy
  • How to Export the Trace Data to a File


How to Change the Display Scaling

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Analyze the Measured Data > How to Change the Display Scaling
How to Change the Display Scaling

Depending on the type of display (time, spectrum or statistics), various scaling functions are available to adapt the result display to the current data.

Contents
  • How to Scale Time and Spectrum Diagrams
  • How to Scale Statistics Diagrams


How to Scale Time and Spectrum Diagrams

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Analyze the Measured Data > How to Change the Display Scaling > How to Scale Time and Spectrum Diagrams
How to Scale Time and Spectrum Diagrams

The range of the displayed y-axis for time and spectral diagrams can be defined in the following ways:

  • manually, by defining the range size, reference values and positions
  • automatically, according to the current results
To define the scaling manually using a reference point

With this method, you define a reference value and a position at which this value is to be displayed on the y-axis.

  1. Focus the result window.

  2. Select "AMPT > YScale Config > Y-Axis Reference Value".

  3. Enter a reference value for the y-axis in the current unit.

  4. Select "AMPT > YScale Config > Y-Axis Reference Position" .

  5. Enter the position at which this value is to be displayed on the y-axis. The position is a percentage of the entire length, where 100 % refers to the top edge.

  6. Select "AMPT > YScale Config > Y-Axis Range".

Example:

If you want the to analyze errors greater than 95%, you can define the y-axis range as 5 % and position the y-axis to start at 95%. To do so, enter the reference value 95 % and the reference position 0%.

Defining the y-axis scaling using a reference point
To define the scaling automatically

  1. Focus the result window.

  2. Select "AMPT > Y-Axis Auto Scale".

    The y-axis is adapted to display the current results optimally (only once, not dynamically).


How to Scale Statistics Diagrams

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Analyze the Measured Data > How to Change the Display Scaling > How to Scale Statistics Diagrams
How to Scale Statistics Diagrams

Statistic diagrams show the distribution (i.e. probabilities of occurrence) of the values as a set of bars. You can define the number of bars to be displayed, i.e. the granularity of classifications. Additionally, you can specify whether absolute or percentage values are displayed. For statistics measurements, both the x-axis and the y-axis can be scaled to optimize the display.

The range of the displayed x-axis for statistics diagrams can be defined in the following ways:

  • manually, by defining reference values and positions
  • automatically, according to the current results

The range of the displayed y-axis can be defined in the following ways:

  • manually, by defining the minimum and maximum values to be displayed
  • automatically, according to the current results

After changing the scaling you can restore the default settings.

To define the number of bars

  1. Focus the result window.

  2. Select "AMPT > XScale Config > X-Axis Quantize".

  3. Enter the number of bars to be displayed.

    The diagram is adapted to display the specified number of bars.

To define the x-axis scaling manually using a reference point and divisions

With this method, you define a reference value on the x-axis to be displayed at the "Ref Position" of the y-axis. (The reference value is determined internally according to the displayed data and cannot be changed. The beginning of the diagram is at the position 0%, the end is at 100%.) Additionally, you define the range to be displayed in each of the 10 divisions of the display, which determines the total range to be displayed on the x-axis.

  1. Focus the result window.

  2. Select "AMPT > Scale Config > Reference Value".

  3. Enter a reference value on the x axis in the current unit.

  4. Define the range to be displayed per division (total range/10).

    The x-axis is adapted so that it displays the defined range, with the reference value at the specified position.

Example:

If you want to analyze the probabilities of occurrence for errors greater than 95 %, enter the reference value 95 %.

Defining the x-axis scaling using a reference point
To define the x-axis scaling automatically

  1. Focus the result window.

  2. Select "AMPT > XScale Config > Auto Scale".

    The x-axis is adapted to display the current results optimally (only once, not dynamically).

To define the y-axis range manually

With this method, you define the upper and lower limits of the displayed probability range. Values on the y-axis are normalized which means that the maximum value is 1.0. If the y-axis has logarithmic scale, the distance between max and min value must be at least one decade.

  1. Focus the result window.

  2. Select "AMPT > YScale Config > Y-Axis Min Value".

  3. Enter the lower limit in the current unit.

  4. Select "AMPT > YScale Config > Y-Axis Max Value".

  5. Enter the upper limit in the current unit.

    The y-axis is adapted to display the specified range. Probabilities of occurrence located outside the display area are applied to the bars at the left or right borders of the display.


How to Check Limits for Modulation Accuracy

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Analyze the Measured Data > How to Check Limits for Modulation Accuracy
How to Check Limits for Modulation Accuracy

The results of a modulation accuracy measurement can be checked for violation of defined limits automatically. If limit check is activated and the measured values exceed the limits, those values are indicated in red in the result summary table. If limit check is activated and no values exceed the limits, the checked values are indicated in green.

For details on the limit check functions and settings see "Modulation Accuracy Limit Lines".

To define a limit check

  1. Configure a measurement with "Modulation Accuracy" as the "Source" (see "Display and Window Configuration").

  2. Press the LINES key on the front panel.

  3. Press the "ModAcc Limits Config" softkey in the "Limits" menu.

  4. In the "Current" tab, define limits that the current value should not exceed for any or all of the result types.

    Note: the limits for the current value are automatically also defined for the peak value and vice versa. However, the limit check can be enabled individually for current or peak values.

  5. Enable the "Check" option for each result type to be included in the limit check.

  6. If necessary, define limits and enable the limit check for the mean values of the different result types on the "Mean" tab.

  7. If necessary, enable the limit check for the peak values of the different result types on the "Peak" tab.

  8. To reset the limits to their default values, press "Set to Default".

  9. Enable the "Limit Checking On" option, or press the "ModAcc Limits On" softkey in the "Limits" menu.

    The limit check is performed immediately on the current modulation accuracy measurement results and for all subsequent measurements until it is disabled. The results of the limit check are indicated by red or green values in the result summary.


How to Export the Trace Data to a File

VSA (R&S FSW-K70) > How to Perform Vector Signal Analysis > How to Analyze the Measured Data > How to Export the Trace Data to a File
How to Export the Trace Data to a File

The measured data can be stored to an ASCII file, either as raw data (directly from the capture buffer) or as displayed in the diagrams (evaluated trace data). Optionally, a header can be included with additional information on the used measurement settings.

  1. Press the TRACE key and select the "Trace Export Config" softkey.

  2. Define which type of data to export (raw or trace). By default, trace data is exported.

  3. Optionally, enable the header information to be included.

  4. To export the traces in all windows, select "Export Trace to ASCII File for all Windows".

    To export the traces only for the currently selected window, select "Export Trace to ASCII File for Specific Window". To export the data from another window, select it from the "Specifics for" list, then export again.

    In either case, all traces of the selected window(s) are exported.

  5. Define a file name and storage location and select "OK".

    The data is stored in a file and can be analyzed in an external application.


Measurement Examples

VSA (R&S FSW-K70) > Measurement Examples
Measurement Examples

Some sample measurements for the digital GSM and EDGE standards provide a quick introduction to typical vector analyzer measurements. The individual measurements are in logical order and are meant to familiarize you gradually with the measurements required of general vector signal analysis.

The following equipment is required in addition to the R&S FSW with option R&S FSW-K70:

  • 1 test transmitter (GSM-compatible for Measurement 2), preferably R&S SMU (1141.2005.02), with the digital standard option GSM/EDGE (order number 1160.7609.02)
  • 1 ParData Adapter R&S SMU-Z5 for R&S SMU (1160.4545.02)
  • 1 RF cable with 2 male N connectors
  • 2 RF cable with 2 male BNC connectors
  • 2 power cables

Transmitter operation is only described as far as required for performing the measurements. For more details on the measurements, refer to the test transmitter documentation.

Contents
  • Connecting the Transmitter and Analyzer
  • Measurement Example 1: Continuous QPSK Signal
  • Measurement Example 2: Burst GSM EDGE Signals


Connecting the Transmitter and Analyzer

VSA (R&S FSW-K70) > Measurement Examples > Connecting the Transmitter and Analyzer
Connecting the Transmitter and Analyzer

In order to perform measurements with the R&S FSW-K70, you require a test transmitter to emulate a DUT. For "Measurement Example 2: Burst GSM EDGE Signals", the test transmitter needs to be GSM-compatible.

Connect the RF output of the R&S SMU with the RF input of the R&S FSW.

Connection to a test transmitter (for example R&S SMU)


Measurement Example 1: Continuous QPSK Signal

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 1: Continuous QPSK Signal
Measurement Example 1: Continuous QPSK Signal

In this measurement example a continuous QPSK (Quadrature Phase Shift Keying) signal will be measured and evaluated. QPSK is used in several standards such as DVB-S2, APCO25, WCDMA, CDMA2000, etc. For the description (characterization) of a continuous QPSK signal, the following parameters are the most important:

  • Carrier Frequency
  • Level
  • Symbol Rate
  • Transmit Filter
Contents
  • Transmitter Settings
  • Analyzer Settings
  • Changing the Display Configuration
  • Navigating Through the Capture Buffer
  • Averaging Several Evaluations


Transmitter Settings

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 1: Continuous QPSK Signal > Transmitter Settings
Transmitter Settings

This section summarizes the necessary transmitter settings. It contains a list of the parameters and step-by-step instructions for the R&S SMU. If you are interested in a more detailed description or background information, refer to the user manual of the R&S SMU, which can be downloaded from the Rohde&Schwarz website: www.rohde-schwarz.com/downloads/manuals/smu200A.html.

Frequency | 1 GHz
Level | 0 dBm
Modulation | QPSK
Symbol Rate | 1 Msym/s
Filter | Root Raised Cosine with Roll-Off 0.35
To define the settings for the R&S SMU

  1. Press the PRESET key to start from a defined state.

  2. Press the FREQ key and enter 1 GHz.

  3. Press the LEVEL key and enter 0 dBm.

  4. To define the modulation:

    1. Press the DIAGRAM key.

    2. Select the first block ("Baseband A") in the settings overview and press ENTER.

    3. Select "Custom Digital Mod...".

      R&S SMU: Custom Digital Modulation Dialog

    4. Under "Modulation Type" select "PSK" > "QPSK".

  5. In the "Custom Digital Modulation" dialog box:

    1. Enter the "Symbol Rate" 1 MHz.

    2. Select the "Filter" "Root Cosine".

    3. Enter the "Roll Off Factor" 0.35.

    4. Toggle the "State" to "On" (at the top of the dialog box) to switch modulation on.

  6. Press the RF ON/OFF key to switch the RF transmission on.


Analyzer Settings

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 1: Continuous QPSK Signal > Analyzer Settings
Analyzer Settings

This section helps you get your first valid measurement. It starts with step-by-step instructions and continues with a more detailed description of further functionality.

Frequency | 1 GHz
Ref Level | 4 dBm
Modulation | QPSK
Symbol Rate | 1 MHz
Tx Filter | Root Raised Cosine with Alpha BT 0.35
To define the settings on the R&S FSW

  1. Press the PRESET key to start from a defined state.

  2. Press the FREQ key and enter 1 GHz.

  3. Press the AMPT key, and enter 4 dBm as the reference level. This corresponds approximately to the peak envelope power of the signal.

  4. Start the VSA application by pressing the MODE key and then selecting "VSA".

  5. Select the "Overview" softkey to display the "Overview" for VSA.

  6. Select the "Signal Description" button and configure the expected signal characteristics.

    1. In the "Modulation Settings" section, ensure that the "Type" is "PSK" and that the "Order" is "QPSK". The "Mapping" defines the mapping of the bits to the QPSK symbols. It is relevant if you are interested in a bit stream measurement but does not affect the other measurement results. Hence, you do not need to change it here.

    2. Enter the "Symbol Rate" 1 MHz.

    3. In the "Transmit Filter" section, select "RRC" as "Type" and enter the "Alpha/BT" value 0.35. In the preview area of the dialog you should then see a non-distorted QPSK constellation diagram, as shown in figure " QPSK signal with RRC transmit filter".

      QPSK signal with RRC transmit filter

  7. Close all open dialog boxes. By default, four measurement windows showing different measurement results are displayed.

    Default window layout for Measurement Example 1


Changing the Display Configuration

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 1: Continuous QPSK Signal > Changing the Display Configuration
Changing the Display Configuration

  1. To change the window layout, i.e. the display configuration, do one of the following:

    • Select the "Display Config" softkey in the main VSA menu.
    • Select the "Display Configuration" block in the "Overview" (only if "Specifics for" option is disabled).
    • Select the "SmartGrid" icon from the toolbar.

  2. Replace window 1 by an eye diagram of the inphase component of the measurement signal.

    1. Select the "Meas & Ref" data source from the SmartGrid selection bar and drag it over window 1.

    2. Close the SmartGrid mode by selecting the "Close" icon at the top right corner of the toolbar.

    3. Select the "Window Config" softkey.

    4. Select the result type: "Eye Diagram Real (I)".

  3. Close the dialog to take a look at your new display configuration.


Navigating Through the Capture Buffer

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 1: Continuous QPSK Signal > Navigating Through the Capture Buffer
Navigating Through the Capture Buffer

Using the R&S FSW VSA application you can navigate through the capture buffer, i.e. control which part of the capture buffer is currently analyzed. (Note: In the Spectrum application, this functionality is referred to as "gating".)

  1. In the measurement display, take a closer look at window 3 (magnitude of the capture buffer). The green bar shows how far the current measurement has already proceeded, i.e. how much of the signal has been evaluated.

  2. Press the RUN SINGLE key.

    Since the signal you are currently analyzing is continuous (as opposed to containing bursts), the entire capture buffer is analyzed, and hence will be marked with the green bar. The last evaluated result range (i.e. the currently evaluated result range at the time the measurement stopped) is highlighted in blue.

  3. To go back to a previously evaluated result range within the same capture buffer, press the SWEEP key and then the "Select Result Rng" softkey. By selecting different result ranges (for example using the rotary knob), you can move the highlighted blue area through the capture buffer and choose your currently demodulated result range.

    The results for this range are displayed in the "Current" column in the Result Summary, in the eye diagram and in the symbol table.

    Note: Generally, all Clear/Write traces and the are affected by this selection.


Averaging Several Evaluations

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 1: Continuous QPSK Signal > Averaging Several Evaluations
Averaging Several Evaluations

By default, all measurement windows are displayed with a single trace, which is the Clear/Write trace. This trace displays the result of the current evaluation, i.e. the highlighted blue area from the example in "Navigating Through the Capture Buffer". However, for most real-world measurement tasks, you need to obtain a result that is averaged over a certain number of evaluations, or a worst-case result of a certain number of evaluations. This section explains how to achieve this.

To evaluate EVM vs. Time

  1. Configure window 1 such that it displays the EVM versus time measurement (Source: "Error Vector", Result Type: "EVM", see "Changing the Display Configuration"). Select the window to set the focus on it.

  2. To display the trace averaged over several measurements, or the maximum hold trace over several measurements, press the TRACE key.

  3. Add further traces by pressing the TRACE key and then either using the "Trace 2/3..." or the "Trace Config" softkeys.

    Set the second trace to "Average" and the third trace to "Max Hold".

    Note that the configured traces appear in the window title.

    Several traces in one window

  4. Press RUN SINGLE again.

    The current capture buffer is evaluated for this trace setup. In the channel information bar you can see the number of completed evaluations ("Stat Count").

  5. To change the number of evaluations, press the SWEEP key and select "Statistic Count Config".

    Select "Manual" and enter the desired number of evaluations, e.g. 12. When you press RUN SINGLE, the VSA application will capture I/Q data until 12 evaluations are completed.


Measurement Example 2: Burst GSM EDGE Signals

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 2: Burst GSM EDGE Signals
Measurement Example 2: Burst GSM EDGE Signals

In this measurement example a bursted GSM EDGE signal will be measured and evaluated. The goal of this section is to familiarize you with the VSA application features that are relevant specifically for the analysis of bursted signals.

Contents
  • Transmitter Settings
  • Analyzer Settings
  • Navigating Through the Capture Buffer
  • Evaluating the Rising and Falling Edges
  • Setting the Evaluation Range
  • Comparing the Measurement Signal to the Reference Signal


Transmitter Settings

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 2: Burst GSM EDGE Signals > Transmitter Settings
Transmitter Settings

This section summarizes the necessary transmitter settings. It contains a list of the parameters and step-by-step instructions for the R&S SMU. If you are interested in a more detailed description or background information, refer to the user manual of the R&S SMU, which can be downloaded from the Rohde&Schwarz website: www.rohde-schwarz.com/downloads/manuals/smu200A.html.

Frequency | 1 GHz
Level | 0 dBm
Standard | GSM EDGE Burst with normal symbol rate
To define the settings for the R&S SMU

  1. Press the PRESET key to start from a defined state.

  2. Press the FREQ key and enter 1 GHz.

  3. Press the LEVEL key and enter 0 dBm.

  4. To define the standard:

    1. Press the DIAGRAM key.

    2. Select the first block ("Baseband A") in the settings overview and press ENTER.

    3. Select "GSM/EDGE...".

    4. Highlight the first slot in the frame diagram and press ENTER.

      R&S SMU: GSM/EDGE Frame Configuration Dialog

    5. Select the "Burst Type" "Normal (8PSK / EDGE)".

    6. Close the "GSM/EDGE: Burst@Slot0" dialog box.

  5. Toggle the "State" to "On" (at the top of the "GSM/EDGE" dialog box) to switch the modulation on.

  6. Press the RF ON/OFF key to switch the RF transmission on.


Analyzer Settings

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 2: Burst GSM EDGE Signals > Analyzer Settings
Analyzer Settings

This section helps you get your first valid measurement with a bursted signal. It starts with step-by-step instructions and continues with a more detailed description of further functionality.

Frequency | 1 GHz
Ref Level | 4 dBm
Standard | GSM 8PSK EDGE
To define the settings on the R&S FSW

  1. Press the PRESET key to start from a defined state.

  2. Press the FREQ key and enter 1 GHz.

  3. Press the AMPT key, and enter 4 dBm as the reference level. This corresponds approximately to the peak envelope power of the signal.

  4. Start the VSA application by pressing the MODE key and then selecting "VSA".

  5. Select the "Overview" softkey to display the "Overview" for VSA.

  6. Press the MEAS key, then select the "Digital Standards" softkey.

  7. From the file selection list, select the GSM folder and then the file EDGE_8PSK. Select "Load".

    Predefined settings corresponding to the selected standard are loaded. The VSA application should show good measurement results.

    Default display configuration for GSM 8PSK EDGE

  8. In window 3, you see the currently evaluated burst marked with a green bar.

    To include more bursts in the display you need to increase the capture length.

    1. Press the MEAS CONFIG key and then the "Overview" softkey.

    2. Select "Signal Capture".

    3. Increase the "Capture Length", e.g. to 10000 symbols.

    In the preview area of the dialog box you see that more bursts are now contained in the capture buffer. They are all marked with a green bar, meaning that they are all evaluated.

    Preview of capture buffer


Navigating Through the Capture Buffer

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 2: Burst GSM EDGE Signals > Navigating Through the Capture Buffer
Navigating Through the Capture Buffer

This example describes how to navigate through the capture buffer for a continuous signal. This navigation feature is especially important for bursted signals. Therefore, we provide a further navigation example for the GSM EDGE signal.

  1. In order to see more details in the capture buffer, close window 4.

    1. Press the "Display Config" softkey, or the "Display Configuration" button in the "Overview".

    2. Select the [image] "Delete" icon for window 4.

    3. Close the SmartGrid mode by selecting the "Close" icon at the top right corner of the toolbar.

  2. Press the RUN SINGLE key.

  3. In the "EVM vs. Time" display (window 1), add a maximum hold trace by pressing the TRACE key and then selecting the "Trace Config" softkey (see "Averaging Several Evaluations").

  4. Re-evaluate the whole capture buffer by pressing the SWEEP key and then the "Refresh" softkey.

  5. Use the "Select Result Rng" softkey to navigate through your capture buffer. Thus, you can determine which peak was caused by which burst.

    Navigation through the capture buffer


Evaluating the Rising and Falling Edges

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 2: Burst GSM EDGE Signals > Evaluating the Rising and Falling Edges
Evaluating the Rising and Falling Edges

The "Result Length" is the number of symbols that are to be demodulated and analyzed together. In most common applications, only the parts of the capture buffer containing the bursts need to be analyzed. Hence, for bursted signals the "Result Length" usually coincides with the burst length. However, there are certain scenarios where the rising and falling edge of a burst are also of interest, e.g. checking the power ramping of the device under test. For this measurement task, it is useful to choose a "Result Length" that exceeds the burst length.

  1. In order to include the rising and falling edges of the bursts in the EVM vs Time display (window 1), you need to increase the "Result Length".

    In the "Overview", select "Cut Result Range" and increase the "Result Length" to 200 symbols.

  2. To evaluate the rising and falling edges further, display the absolute magnitude values of the measured signal in window 4 (Source: "Meas&Ref Signal", Result type: "Magnitude Absolute", see "Changing the Display Configuration").

  3. Press RUN SINGLE.

    The rising and falling edges of the burst in the selected result range are displayed in window 4. You could now add an average trace to evaluate the rising and falling edges further.

    Result range that exceeds the burst length


Setting the Evaluation Range

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 2: Burst GSM EDGE Signals > Setting the Evaluation Range
Setting the Evaluation Range

In some scenarios, such as in "Evaluating the Rising and Falling Edges", the result range contains symbols that are not supposed to be considered for the EVM or other calculated parameters that are displayed in the Result Summary. Thus, you would not include them in the evaluation range.

To change the evaluated data

  1. Start from the configuration described in "Evaluating the Rising and Falling Edges".

  2. Display the I/Q constellation diagram of the signal in window 1(Source: "Meas&Ref Signal", Result type: "Constellation I/Q", see "Changing the Display Configuration").

    A clear 8PSK constellation is displayed.

    Evaluation lines properly adjusted

  3. In order to understand the effect of an incorrectly set evaluation range, change the evaluation range to include the entire result range.

    1. In the "Overview", select "Evaluation Range".

    2. Enable the "Entire Result Range" option.

    The displayed constellation diagram is no longer clear, it contains additional points. This is due to the fact that the constellation diagram now displays symbol instants that are beyond the burst.

    Evaluation lines not properly adjusted

All measurement windows that consider the evaluation range are marked with two small red lines in the title bar.


Comparing the Measurement Signal to the Reference Signal

VSA (R&S FSW-K70) > Measurement Examples > Measurement Example 2: Burst GSM EDGE Signals > Comparing the Measurement Signal to the Reference Signal
Comparing the Measurement Signal to the Reference Signal

You have seen that it is possible to add different traces such as maximum hold or average to each window. When evaluating the measurement signal it is also possible to display the ideal reference signal as an additional trace. This can be a significant help when troubleshooting, since it allows for an immediate comparison.

  1. Start from the configuration described in "Evaluating the Rising and Falling Edges".

  2. Select window 4 to set the focus on it.

  3. Press the TRACE key and then the "Trace 2" softkey.

  4. Select "Clear Write" as the "Trace Mode" and "Evaluation: Ref". This adds a second trace to your result display. This trace is the ideal reference signal that can now be compared to the measurement signal (see figure "Zooming").

  5. To view the traces in more detail, enlarge the window using the "Split/Maximize" key ( [image]), and zoom into the display using the [image] icon in the toolbar (see the dotted rectangle in figure "Zooming").

    Zooming

    Now you can compare the measured and the ideal reference signal.


Optimizing and Troubleshooting the Measurement

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, the following tips may help you optimize or troubleshoot the measurement.

Contents
  • Flow Chart for Troubleshooting
  • Explanation of Error Messages
  • Frequently Asked Questions
  • Obtaining Technical Support


Flow Chart for Troubleshooting

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Flow Chart for Troubleshooting
Flow Chart for Troubleshooting

If you experience a concrete measurement problem, you might want to try solving it with the help of the flow chart.

Troubleshooting Overview


Explanation of Error Messages

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages
Explanation of Error Messages

The following section describes error messages and possible causes.

└ Message: 'Burst Not Found'
└ Message: 'Pattern Not Found'
└ Message: 'Result Alignment Failed'
└ Message: 'Pattern Search On, But No Pattern Selected'
└ Message: 'Pattern Not (Entirely) Within Result Range
└ Message: 'Short Pattern: Pattern Search Might Fail'
└ Message: 'Sync Prefers More Valid Symbols'
└ Message: 'Sync Prefers Longer Pattern'
└ Message: 'Result Ranges Overlap'


Message: 'Burst Not Found'

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages > Message: 'Burst Not Found'
Message: 'Burst Not Found'
The "Burst Not Found" error message can have several causes:
  • Burst search is active, but the signal is not bursted
    Example for active burst search with continuous signal

    Solution: Select "Continuous Signal" as the signal type.
    For more information, see
    – "Signal Type".
  • Signal is bursted, but bursts have not been captured completely
    The burst search can only find bursts that start and end within the capture buffer. It ignores bursts that are cut off.
    Example for incomplete burst capture

    Solution: Change the trigger settings and/or enlarge the capture length.
    For more information, see
    – "Signal Capture"
  • The current measurement is being performed on a burst that has not been captured completely.
    Example for measurement on incomplete burst capture
    Example for measurement on complete burst capture

    Solution:
    Change the trigger settings or increase the result length.
    Note, however, that in this case, the results are actually correct and the message can be ignored.
  • The settings do not match the signal
    In order to allow you to select certain bursts, the burst search only searches for bursts that have a length between "Min Length" and "Max Length" (plus a tolerance that you can set in the "Burst Search" Dialog). In case the burst is, e.g. shorter than the "Burst Min Length", the burst search fails.
    Example for a failed burst search due too a burst that is too short
    Solution: try one of the following:
    – Switch on the Magnitude (Capture Buffer) result display. Move a marker to the start of the burst. Move a delta marker to the end of the burst and compare the burst length to the settings in the "Signal Description" dialog.
    – Increase the search tolerance in the "Burst Search" dialog. Keep an eye on the green/red field. If the burst search succeeds, you can see the length of the found bursts.
    – Set the minimum burst length to 50 and the maximum burst length to 5000.
    For more information, see:
    – "Burst Settings"
    – "Burst Configuration"
  • The signal is highly distorted and/or has modulation noise
    One possibility to enhance the robustness of the burst search is to increase the minimum gap length. If the bursts within your capture buffer are not closely spaced, it makes sense to increase the value of this parameter.
    Example for adjusting the minimum gap length

    For more information, see "Min Gap Length"
  • The pattern search is switched on, fails and the alignment is with reference to the pattern.
    In case the pattern search is switched on and the reference for the alignment is the pattern (and not the burst), a non-detected pattern causes the result range to be positioned at the beginning of the capture buffer. Hence, if a the burst does not start right at the beginning of the capture buffer, you will see a "Burst Not Found" Message.
    Solution:
    – Refer to "Message: 'Pattern Not Found'"
    – Switch the pattern search off.
    – Choose "Burst" as the reference for the result range alignment.


Message: 'Pattern Not Found'

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages > Message: 'Pattern Not Found'
Message: 'Pattern Not Found'
The "Pattern Not Found" error message can have several causes:
  • The burst search has failed
    If burst and pattern search are active, the application looks for patterns only within the found bursts. Hence, in case the burst search fails, the pattern search will also fail.
    Solution: Try one of the following:
    – Make sure the burst search is successful.
    – Deactivate the burst search but keep the pattern search active.
    For more information, see
    – "Message: 'Burst Not Found'"
    "Burst Search"
  • The offset of the pattern within the burst is incorrectly set
    It is possible to set a pattern offset to speed up the pattern search. The offset of the pattern would be the offset of the pattern start with respect to the start of the useful part of the burst. However, if the entered offset is not correct (within about 4 symbols of tolerance), the pattern will not be found.
    GSM EDGE burst; Pattern is actually located in the middle of the burst. The correct value for "Offset" here would be 58.
    Solution: Try one of the following:
    – Remove the offset ('unknown').
    – Enter the correct offset (within about 4 symbols of tolerance).
    For more information, see
    – "Offset"
  • The specified pattern does not coincide with the pattern in your signal:
    In the R&S FSQ-K70 it is possible to search for multiple patterns at the same time. For example, in a GSM measurement, the capture buffer can be checked for all TSCs simultaneously. This is not possible in the R&S FSW-K70.
    Solution:
    Make sure that the correct pattern is specified in the "Signal Description" dialog.
    For more information, see
    – "Signal Description"


Message: 'Result Alignment Failed'

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages > Message: 'Result Alignment Failed'
Message: 'Result Alignment Failed'

The result range alignment is not possible for the patricular capture buffer. The result range needs I/Q data that has not been captured.

Example for failed alignment

In this windowshot, the alignment of the long result range to the burst center is not possible because there are not enough samples in the capture buffer before the burst starts. In this scenario, the trigger settings should be changed such that the burst is in the middle of the capture buffer.

Solution: Change the trigger settings and/or enlarge the capture length.

For more information, see:
  • "Signal Capture"


Message: 'Pattern Search On, But No Pattern Selected'

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages > Message: 'Pattern Search On, But No Pattern Selected'
Message: 'Pattern Search On, But No Pattern Selected'
The red circle shows the place where you can specify a pattern

Solution: Select an existing pattern (or create a new pattern) that you expect to be within the signal.

For more information, see
  • "Pattern Settings"
    "How to Perform Pattern Searches"


Message: 'Pattern Not (Entirely) Within Result Range

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages > Message: 'Pattern Not (Entirely) Within Result Range
Message: 'Pattern Not (Entirely) Within Result Range

A pattern can only be found, if it is entirely within the result range. Therefore, this error message always occurs with a "Pattern Not Found" error.

Solution: Choose the pattern as reference of your result range alignment. Then, the pattern will be forcefully part of your result range and the pattern search can succeed.

For more information, see
  • "Result Range Configuration"
  • "How to Define the Result Range"


Message: 'Short Pattern: Pattern Search Might Fail'

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages > Message: 'Short Pattern: Pattern Search Might Fail'
Message: 'Short Pattern: Pattern Search Might Fail'
The R&S FSW performs the pattern search in two stages.
  • Stage 1 involves the generation of an I/Q pattern waveform by modulating the pattern symbol sequence. The I/Q pattern is then correlated with the measured signal. At positions where the correlation metric exceeds the "I/Q Correlation Threshold" the I/Q pattern is found.
  • Stage 2 demodulates the measured signal at the I/Q pattern location and the transmitted symbols are checked for correctness against the pattern symbol sequence.
In case of a very short pattern, i.e. a pattern length in the order of the inter-symbol interference (ISI) duration, a number of issues can arise:
  • False positive
    The I/Q pattern is found at positions where the transmitted symbols differ from the pattern symbols.
    Solution: Try one of the following:
    – Activate "Meas only if Pattern Symbols Correct".
    – Increase the "I/Q Correlation Threshold"
    (see "Pattern Search").
  • False negative
    The I/Q pattern search misses a position where transmitted symbols match the pattern symbols.
    Solution:
    – Decrease the "I/Q Correlation Threshold"
    (see "Pattern Search").

    In case of bursted signals the pattern search finds only the first occurrence of the I/Q pattern within each burst. If a false positive occurs in this situation (cf. case 1.) the use of "Meas only if pattern symbols correct" will not provide a satisfactory solution.
    In this case do the following:
    – Increase the "I/Q Correlation Threshold".
    – Specify the expected position of the pattern within the burst by adjusting the "Offset" parameter.


Message: 'Sync Prefers More Valid Symbols'

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages > Message: 'Sync Prefers More Valid Symbols'
Message: 'Sync Prefers More Valid Symbols'

Note: Note that this message does not necessarily indicate a problem. Its purpose is to inform you that you might have the opportunity to get a more stable demodulation and/or better measurement results by improving your setup.

Synchronization in the VSA application is performed in two stages: coarse synchronization that precedes the reference signal generation and fine synchronization based on the reference signal.

  • The coarse synchronization stage can work data-aided (i.e. based on a known pattern) or non-data-aided (i.e. based on the unknown data symbols). The default is a non-data-aided coarse synchronization. In the case that a pattern is part of signal, the user can switch to data-aided synchronization.
  • The fine synchronization stage always works data-aided.

'Sync Prefers More Valid Symbols' indicates that one of the synchronization stages has too few symbols to ensure that the synchronization is robust.

The message is given if
  • Coarse Synchronization = Non-Data-Aided (User Pattern for Sync = Off):
    Estimation range shorter than 40 symbols
    (see "Estimation")
  • Fine Synchronization:
    Estimation range shorter than 10 symbols
    (see "Estimation")
Solution:
  • If the signal contains a pattern, set "Coarse Synchronization: Pattern".
    (see "Coarse Synchronization").
    Example: measurement of a GSM EDGE pattern that has a length of 26 symbols.
    User Pattern for Sync = Off
    User Pattern for Sync = On
  • Choose a longer "Result Range".
  • If the signal is bursted and the bursts are short:
    – Make sure your "Result Range" comprises the entire burst.
    – Make sure that "Run-In/Out" is not chosen too large, since the "Run-In/Out" ranges are excluded from the synchronization.
  • If the signal is bursted and contains a pattern:
    Only switch off the burst search if absolutely necessary. If you need to switch it off, align your "Result Range" to the pattern, make sure it does not exceed the burst ramps and choose "Continuous Signal" as the "Signal Type" in the "Signal Description" dialog.
For more information, see
  • "Overview of the Demodulation Process"


Message: 'Sync Prefers Longer Pattern'

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages > Message: 'Sync Prefers Longer Pattern'
Message: 'Sync Prefers Longer Pattern'

This message can only occur if the coarse synchronization is data-aided, i.e is based on a known pattern. In case the pattern is very short, pattern-based coarse synchronization might be unstable. If demodulation is stable, e.g. you get a reasonable EVM, there is no need to change anything. Otherwise, you have two options:

  • Switch to the non-pattern-based mode by setting the parameter "Coarse Synchronization: Data"
    (see "Coarse Synchronization"
  • If possible, use a longer pattern.
For more information, see
  • "Overview of the Demodulation Process"


Message: 'Result Ranges Overlap'

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Explanation of Error Messages > Message: 'Result Ranges Overlap'
Message: 'Result Ranges Overlap'

This message does not indicate an error. It is merely displayed to inform you that the defined result ranges in the capture buffer overlap. Thus, some captured data is evaluated more than once. For example, the same peak value may be listed several times if it is included in several result ranges, and averaging is performed on (partially) duplicate values. However, a negative influence on the measurement results is not to be expected.


Frequently Asked Questions

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions
Frequently Asked Questions
└ Problem: The trace is not entirely visible within the measurement window
└ Problem: The trace of the measurement signal is visible in the measurement window; the trace of the reference signal is not
└ Problem: The measurement window does not show average results
└ Problem: The spectrum is not displayed in the logarithmic domain
└ Problem: The Vector I/Q result display and the Constellation I/Q result display look different
└ Problem: The Constellation I/Q measurement result display has a different number of constellation points in the R&S FSQ-K70 and the R&S FSW-K70
└ Problem: the MSK/FSK signal demodulates on the R&S FSQ-K70, but not on the R&S FSW-K70 or: Why do I have to choose different transmit filters in the R&S FSQ-K70 and the R&S FSW-K70?
└ Problem: The EVM trace looks okay, but the EVM in the result summary is significantly different
└ Question: Why isn't the FSK Deviation Error in R&S FSW-K70 identical to the FSK DEV ERROR in R&S FSQ-K70?
└ Problem: The PSK/QAM Signal shows spikes in the Frequency Error result display
└ Question: The y-axis unit for the spectrum of the measurement signal can be chosen to be "dB". What level is this relative to?
└ Question: How can I get the demodulated symbols of all my GSM bursts in the capture buffer in remote control?
└ Question: Why do the EVM results for my FSK-modulated signal look wrong?


Problem: The trace is not entirely visible within the measurement window

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Problem: The trace is not entirely visible within the measurement window
Problem: The trace is not entirely visible within the measurement window
Solution:
  • 1. Select the measurement window.
  • 2. Press the AUTO key.
  • 3. Press the "Y-Axis Auto Scale" softkey.


Problem: The trace of the measurement signal is visible in the measurement window; the trace of the reference signal is not

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Problem: The trace of the measurement signal is visible in the measurement window; the trace of the reference signal is not
Problem: The trace of the measurement signal is visible in the measurement window; the trace of the reference signal is not
Solution:
  • 1.Select the measurement window.
  • 2. Press the TRACE key.
  • 3. Press the "Trace Config" softkey.
  • 4. Select a second trace, choose "Clear Write" as "Trace Mode" and toggle to "Ref" in the "Evaluation" column.


Problem: The measurement window does not show average results

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Problem: The measurement window does not show average results
Problem: The measurement window does not show average results
Solution:
  • 1. Select the measurement window.
  • 2. Press the TRACE key.
  • 3. Press the "Trace Config" softkey.
  • 4. Select a second trace and choose the preferred "Trace Mode", e.g. "Max Hold" or "Average".


Problem: The spectrum is not displayed in the logarithmic domain

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Problem: The spectrum is not displayed in the logarithmic domain
Problem: The spectrum is not displayed in the logarithmic domain
Solution:
  • 1. Select the measurement window.
  • 2. Press the AMPT key.
  • 3. Press the "Unit" softkey.
  • 4. Press the "Y-Axis Unit" softkey.
  • 5. Select dB.


Problem: The Vector I/Q result display and the Constellation I/Q result display look different

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Problem: The Vector I/Q result display and the Constellation I/Q result display look different
Problem: The Vector I/Q result display and the Constellation I/Q result display look different
Reason:
  • The Vector I/Q diagram shows the measurement signal after the measurement filter and synchronization.
  • The Constellation I/Q diagram shows the de-rotated constellation (i.e. for a π/4-DQPSK, 4 instead of 8 points are displayed). The inter-symbol interference has been removed.

In case the measurement filter does not remove the inter-symbol interference, the windows show measurements that are significantly different.


Problem: The Constellation I/Q measurement result display has a different number of constellation points in the R&S FSQ-K70 and the R&S FSW-K70

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Problem: The Constellation I/Q measurement result display has a different number of constellation points in the R&S FSQ-K70 and the R&S FSW-K70
Problem: The Constellation I/Q measurement result display has a different number of constellation points in the R&S FSQ-K70 and the R&S FSW-K70

Reason:

In the FSQ-K70, the Constellation I/Q measurement displays the symbol instants of the Vector I/Q measurement. Hence, this is a rotated constellation, e.g. for a π/4-DQPSK, 8 points are displayed.

In the R&S FSW-K70, the Constellation I/Q diagram shows the de-rotated constellation (i.e. for a π/4-DQPSK, 4 instead of 8 points are displayed). The inter-symbol interference has been removed.

Note: The result display "I/Q Constellation (Rotated)" displays the rotated constellation, as the FSQ-K70 does.

For details on the Constellation I/Q diagram in the R&S FSW-K70, see "Constellation I/Q".

Constellation I/Q and Vector I/Q for pi/4-DQPSK modulation
R&S FSQ-K70 | R&S FSW-K70


Problem: the MSK/FSK signal demodulates on the R&S FSQ-K70, but not on the R&S FSW-K70 or: Why do I have to choose different transmit filters in the R&S FSQ-K70 and the R&S FSW-K70?

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Problem: the MSK/FSK signal demodulates on the R&S FSQ-K70, but not on the R&S FSW-K70 or: Why do I have to choose different transmit filters in the R&S FSQ-K70 and the R&S FSW-K70?
Problem: the MSK/FSK signal demodulates on the R&S FSQ-K70, but not on the R&S FSW-K70 or: Why do I have to choose different transmit filters in the R&S FSQ-K70 and the R&S FSW-K70?

When generating an MSK/FSK reference signal, the R&S FSQ-K70 automatically replaces the Dirac pulses generated by the frequency mapper with square pulses with the length of one symbol. In the R&S FSW-K70, however, this "replacement" is part of the transmit filter routine. Thus, the R&S FSQ and the R&S FSW require different transmit filters for measuring the same FSK/MSK signal.

Example:
  • If your transmit filter for the R&S FSQ-K70 was "NONE", you need to choose "Rectangular" as the transmit filter type in the R&S FSW.
  • If your transmit filter for the R&S FSQ-K70 was "GAUSS", you need to choose "GMSK" as the transmit filter type in the R&S FSW.


Problem: The EVM trace looks okay, but the EVM in the result summary is significantly different

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Problem: The EVM trace looks okay, but the EVM in the result summary is significantly different
Problem: The EVM trace looks okay, but the EVM in the result summary is significantly different
Solution:
  • Make sure that the position of the "Evaluation Lines" is reasonable. The Result Summary only evaluates sample instants that are within the evaluation lines. Hence, in the case the "Result Range" covers the burst ramps, it is important to adjust the "Evaluation Range" appropriately.
    Problem: EVM in result summary does not correspond with trace display
    Solution: Result Summary with correct evaluation range setting
  • Make sure that the same samples are evaluated. By default, the EVM trace displays all sample instants, e.g. if the sample rate is 4, the EVM trace shows 4 samples per symbol. The Result Summary does not automatically evaluate all sample instants. E.g. for a PSK modulation, by default only symbol instants contribute to the EVM result.


Question: Why isn't the FSK Deviation Error in R&S FSW-K70 identical to the FSK DEV ERROR in R&S FSQ-K70?

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Question: Why isn't the FSK Deviation Error in R&S FSW-K70 identical to the FSK DEV ERROR in R&S FSQ-K70?
Question: Why isn't the FSK Deviation Error in R&S FSW-K70 identical to the FSK DEV ERROR in R&S FSQ-K70?

Solution:

The FSK deviation error in the R&S FSW-K70 is calculated as the difference between the measured frequency deviation and the reference frequency deviation as entered by the user (see "FSK Ref Deviation (FSK only)"). What is referred to as the "FSK DEV ERROR" in the R&S FSQ-K70 is calculated differently (see the R&S FSQ-K70 Software Manual) and is comparable to the "Freq Err RMS" in the R&S FSW-K70. However, while the "FSK DEV ERROR" in the R&S FSQ-K70 is given in Hz, the "Freq Err RMS" in the R&S FSW-K70 is given in percent, i.e. relative to the "FSK Meas Deviation".


Problem: The PSK/QAM Signal shows spikes in the Frequency Error result display

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Problem: The PSK/QAM Signal shows spikes in the Frequency Error result display
Problem: The PSK/QAM Signal shows spikes in the Frequency Error result display

Solution:

These spikes are usually uncritical and are caused by zero-transitions in the I/Q Plane.


Question: The y-axis unit for the spectrum of the measurement signal can be chosen to be "dB". What level is this relative to?

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Question: The y-axis unit for the spectrum of the measurement signal can be chosen to be "dB". What level is this relative to?
Question: The y-axis unit for the spectrum of the measurement signal can be chosen to be "dB". What level is this relative to?

Answer:

Spectrum (RealImag, Meas&Ref) calculates the FFT of the result RealImag(Meas&Ref). RealImag(Meas&Ref) has the unit "none". In this case, "none" means the measured signal has been scaled such that it matches the ideal corresponding reference signal as well as possible. The reference signal in turn is scaled such that max(abs(at symbol instants)) = 1.0.


Question: How can I get the demodulated symbols of all my GSM bursts in the capture buffer in remote control?

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Question: How can I get the demodulated symbols of all my GSM bursts in the capture buffer in remote control?
Question: How can I get the demodulated symbols of all my GSM bursts in the capture buffer in remote control?

Answer:

Use the following remote commands:

:SENSe1:DDEMod:PRESet 'GSM_NB'

Load the GSM standard.

:SENSe1:DDEMod:RLENgth 10000 SYM

Enlarge the capture buffer length such that all the bursts you want to demodulate can be seen within the capture buffer.

:INITiate1:CONTinuous OFF

Go to single sweep mode.

:SENSe1:SWEep:COUNt 0

Set the "Statistic Count" to "Auto" mode.

:INITiate1:IMMediate

Do single sweep.

:SENSe1:SWEep:COUNt:CURRent?

Query the number of demodulated bursts within the capture buffer.

For n = 1:NumberOfBursts
        :SENSe1:DDEMod:SEARch:MBURst:CALC n
        :TRACe4? TRACe1 'Query the result symbols in window D
End

Step through all bursts and query the demodulated symbols.


Question: Why do the EVM results for my FSK-modulated signal look wrong?

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Frequently Asked Questions > Question: Why do the EVM results for my FSK-modulated signal look wrong?
Question: Why do the EVM results for my FSK-modulated signal look wrong?

Answer:

For an FSK-modulated signal, the signal processing differs to an PSK/QAM/MSK-modulated signal. The estimation model does not minimize the EVM but the error of the instantaneous frequency (see "Error Model"). Therefore, the measurement value that corresponds to the EVM value for FSK is the the Frequency Error (Absolute/Relative). (Source Type: Modulation Error; Result Type: Frequency Error (Absolute/Relative))


Obtaining Technical Support

VSA (R&S FSW-K70) > Optimizing and Troubleshooting the Measurement > Obtaining Technical Support
Obtaining Technical Support

If problems occur, the instrument generates error messages which in most cases will be sufficient for you to detect the cause of an error and find a remedy.

Error messages are described in "Explanation of Error Messages".

In addition, our customer support centers are there to assist you in solving any problems that you may encounter with your R&S FSW. We will find solutions more quickly and efficiently if you provide us with the information listed below.
  • System Configuration: The "System Configuration" dialog box (in the "Setup" menu) provides information on:
    – Hardware Info: hardware assemblies
    – Versions and Options: the status of all software and hardware options installed on your instrument
    – System Messages: messages on any errors that may have occurred

    An .xml file with information on the system configuration ("device footprint") can be created automatically (using the DIAGnostic:SERVice:SINFo command or as described in "To collect the support information").
  • Error Log: The RSError.log file (in the log directory of the main installation directory) contains a chronological record of errors.
  • Support file: a *.zip file with important support information can be created automatically. The *.zip file contains the system configuration information ("device footprint"), the current eeprom data and a screenshot of the screen display.
To collect the support information

  1. Press the SETUP key.

  2. Select "Service > R&S Support" and then "Create R&S Support Information".

    The file is stored as C:\R_S\instr\user\service.zip.

    Attach the support file to an e-mail in which you describe the problem and send it to the customer support address for your region as listed at the beginning of the R&S FSW Getting Started manual.


Remote Commands for VSA

VSA (R&S FSW-K70) > Remote Commands for VSA
Remote Commands for VSA

The following commands are required to perform measurements in VSA in a remote environment.

It is assumed that the R&S FSW has already been set up for remote control in a network as described in "How to Set Up a Network and Remote Control" .

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

The following tasks specific to VSA are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating Vector Signal Analysis
  • Digital Standards
  • Configuring VSA
  • Performing a Measurement
  • Analysis
  • Configuring the Result Display
  • Retrieving Results
  • Importing and Exporting I/Q Data and Results
  • Status Reporting System
  • Commands for Compatibility
  • Programming Examples


Introduction

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

VSA (R&S FSW-K70) > Remote Commands for VSA > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

VSA (R&S FSW-K70) > Remote Commands for VSA > Common Suffixes
Common Suffixes

In VSA, the following common suffixes are used in remote commands:

Suffix | Value range | Description
<m> | 1..4 | Marker
<n> | 1..16 | Window
<t> | 1..6 | Trace


Activating Vector Signal Analysis

VSA (R&S FSW-K70) > Remote Commands for VSA > Activating Vector Signal Analysis
Activating Vector Signal Analysis

Vector signal analysis requires a special application on the R&S FSW. A measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

VSA (R&S FSW-K70) > Remote Commands for VSA > Activating Vector Signal Analysis > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

This command is not available if the MSRA/MSRT Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

VSA (R&S FSW-K70) > Remote Commands for VSA > Activating Vector Signal Analysis > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

VSA (R&S FSW-K70) > Remote Commands for VSA > Activating Vector Signal Analysis > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

VSA (R&S FSW-K70) > Remote Commands for VSA > Activating Vector Signal Analysis > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

VSA (R&S FSW-K70) > Remote Commands for VSA > Activating Vector Signal Analysis > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

VSA (R&S FSW-K70) > Remote Commands for VSA > Activating Vector Signal Analysis > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

VSA (R&S FSW-K70) > Remote Commands for VSA > Activating Vector Signal Analysis > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType>

Selects the application (channel type) for the current channel.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<ChannelType>
VSA

VSA, R&S FSW-K70


SYSTem:PRESet:CHANnel[:EXECute]

VSA (R&S FSW-K70) > Remote Commands for VSA > Activating Vector Signal Analysis > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Digital Standards

VSA (R&S FSW-K70) > Remote Commands for VSA > Digital Standards
Digital Standards

Various predefined settings files for common digital standards are provided for use with the VSA application. In addition, you can create your own settings files for user-specific measurements.

Manual configuration of digital standards is described in "Configuration According to Digital Standards".

List of Commands
[SENSe:]DDEMod:FACTory[:VALue]
[SENSe:]DDEMod:PRESet[:STANdard]
[SENSe:]DDEMod:STANdard:COMMent
[SENSe:]DDEMod:STANdard:DELete
[SENSe:]DDEMod:STANdard:PREset[:VALue]
[SENSe:]DDEMod:STANdard:SAVE


[SENSe:]DDEMod:FACTory[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Digital Standards > [SENSe:]DDEMod:FACTory[:VALue]
[SENSe:]DDEMod:FACTory[:VALue] <Factory>

This command restores the factory settings of standards or patterns for the VSA application.

Setting parameters:
<Factory>
ALL | STANdard | PATTern
ALL

Restores both standards and patterns.

*RST: ALL
Usage: Setting only
Manual operation: See "Restore Standard Files"
See "Restore Pattern Files"


[SENSe:]DDEMod:PRESet[:STANdard]

VSA (R&S FSW-K70) > Remote Commands for VSA > Digital Standards > [SENSe:]DDEMod:PRESet[:STANdard]
[SENSe:]DDEMod:PRESet[:STANdard] <Standard>

This command selects an automatic setting of all modulation parameters according to a standardized transmission method or a user-defined transmission method. The standardized transmission methods are available in the instrument as predefined standards.

Setting parameters:
<Standard> | string Specifies the file name that contains the transmission method without the extension. For user-defined standards, the file path must be included. Default standards predefined by Rohde&Schwarz do not require a path definition. A list of predefined standards (including short forms) is provided in the annex (see "Predefined Standards and Settings").
Example: | DDEM:PRES 'TETRA_NDDOWN' Switches the predefined digital standard "TETRA_DiscontinuousDownlink" on. DDEM:PRES 'C:\R_S\Instr\usr\standards\USER_GSM' Switches the user-defined digital standard "USER_GSM" on.
Example: | See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".
Manual operation: | See "Load Standard"


[SENSe:]DDEMod:STANdard:COMMent

VSA (R&S FSW-K70) > Remote Commands for VSA > Digital Standards > [SENSe:]DDEMod:STANdard:COMMent
[SENSe:]DDEMod:STANdard:COMMent <Comment>

This command enters the comment for a new standard. The comment is stored with the standard and is only displayed in the selection menu (manual operation). When remote control is used, the string is deleted after the standard has been stored, allowing a new comment to be entered for the next standard. In this case a blank string is returned when a query is made.

Setting parameters:
<Comment> | string
Manual operation: | See "Comment"


[SENSe:]DDEMod:STANdard:DELete

VSA (R&S FSW-K70) > Remote Commands for VSA > Digital Standards > [SENSe:]DDEMod:STANdard:DELete
[SENSe:]DDEMod:STANdard:DELete <FileName>

This command deletes a specified digital standard file in the vector signal analysis. The file name includes the path. If the file does not exist, an error message is displayed

Setting parameters:
<FileName> | string File name including the path for the digital standard file
Usage: | Setting only
Manual operation: | See "Delete Standard"


[SENSe:]DDEMod:STANdard:PREset[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Digital Standards > [SENSe:]DDEMod:STANdard:PREset[:VALue]
[SENSe:]DDEMod:STANdard:PREset[:VALue]

This command restores the default settings of the currently selected standard.

Usage: Event


[SENSe:]DDEMod:STANdard:SAVE

VSA (R&S FSW-K70) > Remote Commands for VSA > Digital Standards > [SENSe:]DDEMod:STANdard:SAVE
[SENSe:]DDEMod:STANdard:SAVE <FileName>

This command stores the current settings of the vector signal analysis as a new user-defined digital standard. If the name of the digital standard is already in use, an error message is output and a new name has to be selected. It is recommended that you define a comment before storing the standard.

Setting parameters:
<FileName> | string The path and file name to which the settings are stored.
Example: | DDEM:STAN:COMM 'GSM_AccessBurst with Pattern' Defines a comment for the settings. DDEM:STAN:SAVE 'C:\R_S\Instr\usr\standards\USER_GSM' Stores the settings in the user-defined digital standard "USER_GSM".
Example: | See "Measurement Example 3: User-Defined Pattern Search and Limit Check".
Usage: | Setting only
Manual operation: | See "Save Standard"


Configuring VSA

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA
Configuring VSA
Contents
  • Signal Description
  • Input, Output and Frontend Settings
  • Signal Capture
  • Triggering Measurements
  • Configuring Sweeps
  • Configuring Bursts and Patterns
  • Defining the Result Range
  • Demodulation Settings
  • Measurement Filter Settings
  • Defining the Evaluation Range
  • Adjusting Settings Automatically


Signal Description

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description
Signal Description

The signal description provides information on the expected input signal, which optimizes pattern and burst detection and the calculation of the ideal reference signal.

Manual configuration of the signal description is described in "Signal Description".

Contents
  • Modulation
  • Signal Structure


Modulation

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation
Modulation

The modulation settings vary depending on the selected modulation type; in particular, FSK modulation provides some additional settings.

List of Commands
CALCulate<n>:FSK:DEViation:REFerence:RELative
CALCulate<n>:FSK:DEViation:REFerence[:VALue]
[SENSe:]DDEMod:APSK:NSTate
[SENSe:]DDEMod:ASK:NSTate
[SENSe:]DDEMod:FILTer:ALPHa
[SENSe:]DDEMod:FILTer[:STATe]
[SENSe:]DDEMod:FORMat
[SENSe:]DDEMod:FSK:NSTate
[SENSe:]DDEMod:MAPPing:CATalog?
[SENSe:]DDEMod:MAPPing[:VALue]
[SENSe:]DDEMod:MSK:FORMat
[SENSe:]DDEMod:PSK:FORMat
[SENSe:]DDEMod:PSK:NSTate
[SENSe:]DDEMod:QAM:FORMat
[SENSe:]DDEMod:QAM:NSTate
[SENSe:]DDEMod:QPSK:FORMat
[SENSe:]DDEMod:SRATe
[SENSe:]DDEMod:TFILter:ALPHa
[SENSe:]DDEMod:TFILter:NAME
[SENSe:]DDEMod:TFILter[:STATe]
[SENSe:]DDEMod:TFILter:USER
[SENSe:]DDEMod:USER:NAME


CALCulate<n>:FSK:DEViation:REFerence:RELative

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > CALCulate<n>:FSK:DEViation:REFerence:RELative
CALCulate<n>:FSK:DEViation:REFerence:RELative <FSKRefDev>

This command defines the deviation to the reference frequency for FSK modulation as a multiple of the symbol rate.

For details see "FSK Ref Deviation (FSK only)".

Setting parameters:
<FSKRefDev>
numeric value
Range: | 0.1 to 15
*RST: | 1
Default unit: | NONE
Manual operation: See "FSK Ref Deviation (FSK only)"


CALCulate<n>:FSK:DEViation:REFerence[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > CALCulate<n>:FSK:DEViation:REFerence[:VALue]
CALCulate<n>:FSK:DEViation:REFerence[:VALue] <FSKRefDevAbsRes>

This command defines the deviation to the reference frequency for FSK modulation as an absolute value in Hz.

Setting parameters:
<FSKRefDevAbsRes>
numeric value
Range: | 10.0 to 64e9
*RST: | 100e3
Default unit: | Hz
Manual operation: See "FSK Ref Deviation (FSK only)"


[SENSe:]DDEMod:APSK:NSTate

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:APSK:NSTate
[SENSe:]DDEMod:APSK:NSTate <APSKNstate>

This command defines the specific demodulation mode for APSK. The following APSK demodulation modes are possible: DDEMod:APSK:NSTate 16 16APSK 32 32APSK

Setting parameters:
<APSKNstate>
numeric value
*RST: 16
Manual operation: See "Modulation Order"


[SENSe:]DDEMod:ASK:NSTate

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:ASK:NSTate
[SENSe:]DDEMod:ASK:NSTate <ASKNstate>

This command defines the specific demodulation mode for ASK. The following ASK demodulation modes are possible: DDEMod:ASK:NSTate 2 OOK 4 4ASK

Setting parameters:
<ASKNstate>
numeric value
*RST: 2
Manual operation: See "Modulation Order"


[SENSe:]DDEMod:FILTer:ALPHa

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:FILTer:ALPHa
[SENSe:]DDEMod:FILTer:ALPHa <MeasFiltAlphaBT>

This command determines the filter characteristic (ALPHA/BT). The resolution is 0.01.

Setting parameters:
<MeasFiltAlphaBT>
numeric value
Range: | 0.1 to 1.0
*RST: | 0.22
Default unit: | NONE


[SENSe:]DDEMod:FILTer[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:FILTer[:STATe]
[SENSe:]DDEMod:FILTer[:STATe] <MeasFilterState>

This command defines whether the input signal that is evaluated is filtered by the measurement filter. This command has no effect on the transmit filter.

Setting parameters:
<MeasFilterState>
ON | OFF | 1 | 0
ON

[SENSe:​]DDEMod:​MFILter:​AUTO is activated.

OFF

The input signal is not filtered. [SENSe:​]DDEMod:​MFILter:​AUTO is deactivated.

*RST: 1


[SENSe:]DDEMod:FORMat

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:FORMat
[SENSe:]DDEMod:FORMat <Group>

This command selects the digital demodulation mode.

Setting parameters:
<Group>
MSK | PSK | QAM | QPSK | FSK | ASK | APSK | UQAM
QPSK

Quad Phase Shift Key

PSK

Phase Shift Key

MSK

Minimum Shift Key

QAM

Quadrature Amplitude Modulation

FSK

Frequency Shift Key

ASK

Amplitude Shift Keying

APSK

Amplitude Phase Shift Keying

UQAM

User-defined modulation (loaded from file, see [SENSe:​]DDEMod:​USER:​NAME)

*RST: PSK
Example: SENS:DDEM:FORM QAM
Example:

See "Measurement Example 1: User-defined Measurement of Continuous QPSK Signal".

Example:

See "Measurement Example 3: User-Defined Pattern Search and Limit Check".

Manual operation: See "Modulation Type"
See "Load User Modulation"


[SENSe:]DDEMod:FSK:NSTate

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:FSK:NSTate
[SENSe:]DDEMod:FSK:NSTate <FSKNstate>

This command defines the demodulation of the FSK modulation scheme.

Setting parameters:
<FSKNstate>
2 | 4 | 8
2

2FSK

4

4FSK

8

8FSK

*RST: 2
Manual operation: See "Modulation Order"


[SENSe:]DDEMod:MAPPing:CATalog?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:MAPPing:CATalog?
[SENSe:]DDEMod:MAPPing:CATalog?

This command queries the names of all mappings that are available for the current modulation type and order. A mapping describes the assignment of constellation points to symbols.

Return values:
<Mappings> | A comma-separated list of strings, with one string for each mapping name.
Example: | :SENSe:DDEMod:MAPPing:CATalog? Result: 'CDMA2K_FWD','DVB_S2','GRAY','NATURAL','WCDMA'
Example: | See "Measurement Example 1: User-defined Measurement of Continuous QPSK Signal".
Usage: | Query only
Manual operation: | See "Modulation Mapping"


[SENSe:]DDEMod:MAPPing[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:MAPPing[:VALue]
[SENSe:]DDEMod:MAPPing[:VALue] <Mapping>

To obtain a list of available symbol mappings for the current modulation type use the [SENSe:​]DDEMod:​MAPPing:​CATalog?? query.

Setting parameters:
<Mapping> | string
Example: | SENS:DDEM:MAPP 'GSM' Sets mapping to GSM.
Example: | See "Measurement Example 1: User-defined Measurement of Continuous QPSK Signal".
Example: | See "Measurement Example 3: User-Defined Pattern Search and Limit Check".
Manual operation: | See "Modulation Mapping"


[SENSe:]DDEMod:MSK:FORMat

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:MSK:FORMat
[SENSe:]DDEMod:MSK:FORMat <MSKformat>

This command defines the specific demodulation order for MSK.

Setting parameters:
<MSKformat>
TYPE1 | TYPE2 | NORMal | DIFFerential
TYPE1 | NORMal

Demodulation order MSK is used.

TYPE2 | DIFFerential

Demodulation order DMSK is used.

*RST: TYPE1
Manual operation: See "Modulation Order"


[SENSe:]DDEMod:PSK:FORMat

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:PSK:FORMat
[SENSe:]DDEMod:PSK:FORMat <PSKformat>

Together with DDEMod:PSK:NST, this command defines the demodulation order for PSK (see also [SENSe:​]DDEMod:​PSK:​NSTate). Depending on the demodulation format and state, the following orders are available:

NSTATe | <Name> | Order
2 | any | BPSK
8 | NORMal | 8PSK
8 | DIFFerential | D8PSK
8 | N3Pi8 | 3pi/8-8PSK (EDGE)
8 | PI8D8PSK | Pi/8-D8PSK
Setting parameters:
<PSKformat>
NORMal | DIFFerential | N3Pi8 | PI8D8PSK
*RST: NORMal
Manual operation: See "Modulation Order"


[SENSe:]DDEMod:PSK:NSTate

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:PSK:NSTate
[SENSe:]DDEMod:PSK:NSTate <PSKNstate>

Together with DDEMod:PSK:FORMat, this command defines the demodulation order for PSK (see also [SENSe:​]DDEMod:​PSK:​FORMat).

Depending on the demodulation format and state, the following orders are available:

<PSKNSTATe> | FORMat | Order
2 | any | BPSK
8 | NORMal | 8PSK
8 | DIFFerential | D8PSK
8 | N3Pi8 | 3pi/8-8PSK (EDGE)
8 | PI8D8PSK | Pi/8-D8PSK
Setting parameters:
<PSKNstate>
2 | 8
*RST: 2
Manual operation: See "Modulation Order"


[SENSe:]DDEMod:QAM:FORMat

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:QAM:FORMat
[SENSe:]DDEMod:QAM:FORMat <QAMformat>

This command defines the specific demodulation order for QAM.

Setting parameters:
<QAMformat>
NORMal | DIFFerential | NPI4 | MNPI4
NORMal

Demodulation order QAM is used.

DIFFerential

Demodulation order DQAM is used.

NPI4

Demodulation order π/4-16QAM is used.

MNPI4

Demodulation order -π/4-32QAM is used.

*RST: NORMal
Manual operation: See "Modulation Order"


[SENSe:]DDEMod:QAM:NSTate

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:QAM:NSTate
[SENSe:]DDEMod:QAM:NSTate <QAMNState>

This command defines the demodulation order for QAM.

<QAMNSTate> | Order
16 | 16QAM
16 | Pi/4-16QAM
32 | 32QAM
32 | Pi/4-32QAM
64 | 64QAM
128 | 128QAM
256 | 256QAM
512 | 512QAM
1024 | 1024QAM
Setting parameters:
<QAMNState>
numeric value
*RST: 16
Manual operation: See "Modulation Order"


[SENSe:]DDEMod:QPSK:FORMat

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:QPSK:FORMat
[SENSe:]DDEMod:QPSK:FORMat <QPSKformat>

This command defines the demodulation order for QPSK.

Setting parameters:
<QPSKformat>
NORMal | DIFFerential | NPI4 | DPI4 | OFFSet | N3PI4
NORMal

Demodulation order QPSK is used.

DIFFerential

Demodulation order DQPSK is used.

NPI4

Demodulation order π/4 QPSK is used.

DPI4

Demodulation order π/4 DQPSK is used.

OFFSet

Demodulation order OQPSK is used.

N3PI4

Demodulation order 3π/4 QPSK is used.

*RST: NORMal
Example: DDEM:FORM QPSK

Switches QPSK demodulation on.

DDEM:QPSK:FORM DPI4

Switches π/4 DQPSK demodulation order on.

Example:

See "Measurement Example 1: User-defined Measurement of Continuous QPSK Signal".

Example:

See "Measurement Example 3: User-Defined Pattern Search and Limit Check".

Manual operation: See "Modulation Order"


[SENSe:]DDEMod:SRATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:SRATe
[SENSe:]DDEMod:SRATe <SymbolRate>

This command defines the symbol rate.

The minimum symbol rate is 25 Hz. The maximum symbol rate depends on the defined "Sample Rate" (see "Sample Rate, Symbol Rate and I/Q Bandwidth").

Setting parameters:
<SymbolRate>
numeric value
Range: | 25 to 250e6
*RST: | 3.84e6
Default unit: | Hz
Example:

See "Measurement Example 1: User-defined Measurement of Continuous QPSK Signal".

Example:

See "Measurement Example 3: User-Defined Pattern Search and Limit Check".

Manual operation: See "Symbol Rate"


[SENSe:]DDEMod:TFILter:ALPHa

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:TFILter:ALPHa
[SENSe:]DDEMod:TFILter:ALPHa <Alpha>

This command determines the filter characteristic (ALPHA/BT). The resolution is 0.01.

Setting parameters:
<Alpha>
numeric value
Range: | 0.1 to 1.0
*RST: | 0.22
Default unit: | NONE
Example:

See "Measurement Example 1: User-defined Measurement of Continuous QPSK Signal".

Manual operation: See "Alpha/BT"
See "Alpha/BT"


[SENSe:]DDEMod:TFILter:NAME

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:TFILter:NAME
[SENSe:]DDEMod:TFILter:NAME <Name>

This command selects a transmit filter and automatically switches it on.

For more information on transmit filters, refer to "Transmit Filters".

Setting parameters:
<Name> | string Name of the Transmit filter; an overview of available transmit filters is provided in "Transmit Filters".
Example: | See "Measurement Example 1: User-defined Measurement of Continuous QPSK Signal".
Manual operation: | See "Transmit Filter Type" See "Load User Filter"


[SENSe:]DDEMod:TFILter[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:TFILter[:STATe]
[SENSe:]DDEMod:TFILter[:STATe] <TXFilterState>

Use this command to switch the transmit filter off. To switch a transmit filter on, use the [SENSe:​]DDEMod:​TFILter:​NAME command.

Setting parameters:
<TXFilterState>
ON | OFF | 1 | 0
OFF

Switches the transmit filter off.

ON

Switches the transmit filter specified by [SENSe:​]DDEMod:​TFILter:​NAME on. However, this command is not necessary, as the [SENSe:​]DDEMod:​TFILter:​NAME command automatically switches the filter on.

*RST: 1
Manual operation: See "Transmit Filter Type"


[SENSe:]DDEMod:TFILter:USER

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:TFILter:USER
[SENSe:]DDEMod:TFILter:USER <FilterName>

This command selects a user-defined transmit filter file.

Setting parameters:
<FilterName> | The name of the transmit filter file.
Manual operation: | See "Transmit Filter Type" See "Load User Filter"


[SENSe:]DDEMod:USER:NAME

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Modulation > [SENSe:]DDEMod:USER:NAME
[SENSe:]DDEMod:USER:NAME <Name>

Selects the file that contains the user-defined modulation to be loaded.

Setting parameters:
<Name> | string Path and file name of the *.vam file
Example: | SENS:DDEM:FORM UQAM Define the use of a user-defined modulation SENS:DDEM:USER:NAME 'D:\MyModulation.vam' Select the file name to be loaded
Manual operation: | See "Load User Modulation"


Signal Structure

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure
Signal Structure

The signal structure commands describe the expected input signal and determine which settings are available for configuration. You can define a pattern to which the instrument can be synchronized, thus adapting the result range.

List of Commands
[SENSe:]DDEMod:SEARch:BURSt:LENGth:MAXimum
[SENSe:]DDEMod:SEARch:BURSt:LENGth[:MINimum]
[SENSe:]DDEMod:SEARch:BURSt:SKIP:FALLing
[SENSe:]DDEMod:SEARch:BURSt:SKIP:RISing
[SENSe:]DDEMod:SEARch:SYNC:CATalog
[SENSe:]DDEMod:SIGNal:PATTern
[SENSe:]DDEMod:SIGNal[:VALue]
[SENSe:]DDEMod:STANdard:SYNC:OFFSet:STATe
[SENSe:]DDEMod:STANdard:SYNC:OFFSet[:VALue]


[SENSe:]DDEMod:SEARch:BURSt:LENGth:MAXimum

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure > [SENSe:]DDEMod:SEARch:BURSt:LENGth:MAXimum
[SENSe:]DDEMod:SEARch:BURSt:LENGth:MAXimum <MaxLength>

This command defines the maximum length of a burst. Only those bursts will be recognized that fall below this length. The default unit is symbols. The value can also be given in seconds.

Setting parameters:
<MaxLength>
numeric value
Range: | 0 to 15000
*RST: | 1600
Default unit: | SYM
Manual operation: See "Min Length / Max Length"


[SENSe:]DDEMod:SEARch:BURSt:LENGth[:MINimum]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure > [SENSe:]DDEMod:SEARch:BURSt:LENGth[:MINimum]
[SENSe:]DDEMod:SEARch:BURSt:LENGth[:MINimum] <UsefulLength>

This command defines the minimum length of a burst. Only those bursts will be recognized that exceed this length. The default unit is symbols. The value can also be given in seconds.

Setting parameters:
<UsefulLength>
numeric value
Range: | 10 to 15000
*RST: | 98
Default unit: | SYM
Manual operation: See "Min Length / Max Length"


[SENSe:]DDEMod:SEARch:BURSt:SKIP:FALLing

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure > [SENSe:]DDEMod:SEARch:BURSt:SKIP:FALLing
[SENSe:]DDEMod:SEARch:BURSt:SKIP:FALLing <RunOut>

This command defines the length of the falling burst edge which is not considered when evaluating the result. The default unit is symbols. The value can also be given in seconds.

Setting parameters:
<RunOut>
numeric value
Range: | 0 to 15000
*RST: | 1
Default unit: | SYM
Manual operation: See "Run-Out"


[SENSe:]DDEMod:SEARch:BURSt:SKIP:RISing

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure > [SENSe:]DDEMod:SEARch:BURSt:SKIP:RISing
[SENSe:]DDEMod:SEARch:BURSt:SKIP:RISing <RunIn>

This command defines the length of the rising burst edge which was not considered when evaluating the result. The default unit is symbols. The value can also be given in seconds

Setting parameters:
<RunIn>
numeric value
Range: | 0 to 15000
*RST: | 1
Default unit: | SYM
Manual operation: See "Run-In"


[SENSe:]DDEMod:SEARch:SYNC:CATalog

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure > [SENSe:]DDEMod:SEARch:SYNC:CATalog
[SENSe:]DDEMod:SEARch:SYNC:CATalog <Patterns>

This command reads the names of all patterns stored on the hard disk. The file names are returned as a comma-separated list of strings, one for each file name (without the file extension).

Setting parameters:
<Patterns>
CURRent | ALL
CURRent

Only patterns that belong to the current standard

ALL

All patterns

*RST: ALL
Example: :DDEM:SEAR:SYNC:CAT? CURR

Result:

'GSM_AB0','GSM_AB1','GSM_AB2','GSM_TSC1'
Example:

See "Measurement Example 3: User-Defined Pattern Search and Limit Check".


[SENSe:]DDEMod:SIGNal:PATTern

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure > [SENSe:]DDEMod:SIGNal:PATTern
[SENSe:]DDEMod:SIGNal:PATTern <PatternedSignal>

This command specifies whether the signal contains a pattern or not.

Setting parameters:
<PatternedSignal>
ON | OFF | 1 | 0
*RST: 0
Example:

See "Measurement Example 3: User-Defined Pattern Search and Limit Check".

Manual operation: See "Name"


[SENSe:]DDEMod:SIGNal[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure > [SENSe:]DDEMod:SIGNal[:VALue]
[SENSe:]DDEMod:SIGNal[:VALue] <SignalType>

This command specifies whether the signal is bursted or continuous.

Setting parameters:
<SignalType>
CONTinuous | BURSted
*RST: CONTinuous
Example:

See "Measurement Example 3: User-Defined Pattern Search and Limit Check".

Manual operation: See "Signal Type"


[SENSe:]DDEMod:STANdard:SYNC:OFFSet:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure > [SENSe:]DDEMod:STANdard:SYNC:OFFSet:STATe
[SENSe:]DDEMod:STANdard:SYNC:OFFSet:STATe <PattOffsState>

This command (de)activates the pattern offset.

Setting parameters:
<PattOffsState>
ON | OFF | 1 | 0
*RST: 0
Example:

See "Measurement Example 3: User-Defined Pattern Search and Limit Check".

Manual operation: See "Offset"


[SENSe:]DDEMod:STANdard:SYNC:OFFSet[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Description > Signal Structure > [SENSe:]DDEMod:STANdard:SYNC:OFFSet[:VALue]
[SENSe:]DDEMod:STANdard:SYNC:OFFSet[:VALue] <PatternOffset>

This command defines a number of symbols which are ignored before the comparison with the pattern starts.

Setting parameters:
<PatternOffset>
numeric value
Range: | 0 to 15000
*RST: | 0
Default unit: | SYM
Example:

See "Measurement Example 3: User-Defined Pattern Search and Limit Check".

Manual operation: See "Offset"


Input, Output and Frontend Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings
Input, Output and Frontend Settings

The R&S FSW can analyze signals from different input sources. The frequency and amplitude settings represent the "frontend" of the measurement setup.

Manual configuration of the input and frontend is described in "Input, Output and Frontend Settings".

Contents
  • RF Input
  • Using External Mixers
  • Configuring Digital I/Q Input and Output
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Setting up Probes
  • Output Settings
  • Frequency
  • Amplitude Settings
  • Attenuation
  • Scaling and Units


RF Input

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:SELect


INPut:ATTenuation:PROTection:RESet

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

(For details on the status register see the R&S FSW User Manual).

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:COUPling

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:SELect

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

DIQ

Digital IQ data (only available with optional Digital Baseband Interface R&S FSW-B17)

For details on I/Q input see "Digital Input" .

AIQ

Analog Baseband signal (only available with optional Analog Baseband Interface R&S FSW-B71)

For details on Analog Baseband input see "Processing Data From the Analog Baseband Interface" .

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Radio Frequency State"
See "Digital I/Q Input State"
See "Analog Baseband Input State"


Using External Mixers

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers
Using External Mixers

The commands required to work with external mixers in a remote environment are described here. Note that these commands require the R&S FSW-B21 option to be installed and an external mixer to be connected to the front panel of the R&S FSW. In MSRA/MSRT mode, external mixers are not supported.

For details on working with external mixers see "Basics on External Mixers" .

Contents
  • Basic Settings
  • Mixer Settings
  • Conversion Loss Table Settings
  • Programming Example: Working with an External Mixer


Basic Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Basic Settings
Basic Settings

The basic settings concern general usage of an external mixer.

List of Commands
[SENSe:]MIXer[:STATe]
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold


[SENSe:]MIXer[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer[:STATe]
[SENSe:]MIXer[:STATe] <State>

Activates or deactivates the use of a connected external mixer as input for the measurement. This command is only available if the R&S FSW-B21 option is installed and an external mixer is connected.

(See "How to Work with External Mixers" ).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX ON
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "External Mixer State"


[SENSe:]MIXer:BIAS:HIGH

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS:HIGH <BiasSetting>

This command defines the bias current for the high (second) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Manual operation: See "Bias Settings"


[SENSe:]MIXer:BIAS[:LOW]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:BIAS[:LOW] <BiasSetting>

This command defines the bias current for the low (first) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Bias Settings"


[SENSe:]MIXer:LOPower

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOPower <Level>

This command specifies the LO level of the external mixer's LO port.

Parameters:
<Level>
numeric value
Range: | 13.0 dBm to 17.0 dBm
Increment: | 0.1 dB
*RST: | 15.5 dBm
Example: MIX:LOP 16.0dBm
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "LO Level"


[SENSe:]MIXer:SIGNal

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:SIGNal
[SENSe:]MIXer:SIGNal <State>

This command specifies whether automatic signal detection is active or not.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

Parameters:
<State>
OFF | ON | AUTO | ALL
OFF

No automatic signal detection is active.

ON

Automatic signal detection (Signal ID) is active.

AUTO

Automatic signal detection (Auto ID) is active.

ALL

Both automatic signal detection functions (Signal ID+Auto ID) are active.

*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Signal ID"
See "Auto ID"


[SENSe:]MIXer:THReshold

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:THReshold
[SENSe:]MIXer:THReshold <Value>

This command defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison (see [SENSe:​]MIXer:​SIGNal).

Parameters:
<Value>
<numeric value>
Range: | 0.1 dB to 100 dB
*RST: | 10 dB
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer"

Manual operation: See "Auto ID Threshold"


Mixer Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings
Mixer Settings

The following commands are required to configure the band and specific mixer settings.

List of Commands
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]


[SENSe:]MIXer:FREQuency:HANDover

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:HANDover <Frequency>

This command defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency for each band can be selected freely within the overlapping frequency range.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Frequency> | numeric value
Example: | MIX ON Activates the external mixer. MIX:FREQ:HAND 78.0299GHz Sets the handover frequency to 78.0299 GHz.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Handover Freq."


[SENSe:]MIXer:FREQuency:STARt?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STARt?

This command queries the frequency at which the external mixer band starts.

Example: | MIX:FREQ:STAR? Queries the start frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:FREQuency:STOP?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:FREQuency:STOP?

This command queries the frequency at which the external mixer band stops.

Example: | MIX:FREQ:STOP? Queries the stop frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:HARMonic:BAND:PRESet

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND:PRESet

This command restores the preset frequency ranges for the selected standard waveguide band.

Note:Changes to the band and mixer settings are maintained even after using the PRESET function. Use this command to restore the predefined band ranges.

Example: | MIX:HARM:BAND:PRES Presets the selected waveguide band.
Usage: | Event
Manual operation: | See "Preset Band"


[SENSe:]MIXer:HARMonic:BAND[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:BAND[:VALue] <Band>

This command selects the external mixer band. The query returns the currently selected band.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Band> | KA | Q | U | V | E | W | F | D | G | Y | J | USER Standard waveguide band or user-defined band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Band"
Frequency ranges for pre-defined bands
Band | Frequency start [GHz] | Frequency stop [GHz]
KA (A) *) | 26.5 | 40.0
Q | 33.0 | 50.0
U | 40.0 | 60.0
V | 50.0 | 75.0
E | 60.0 | 90.0
W | 75.0 | 110.0
F | 90.0 | 140.0
D | 110.0 | 170.0
G | 140.0 | 220.0
J | 220.0 | 325.0
Y | 325.0 | 500.0
USER | 32.18 (default) | 68.22 (default)
*) The band formerly referred to as "A" is now named "KA".


[SENSe:]MIXer:HARMonic:HIGH:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH:STATe <State>

This command specifies whether a second (high) harmonic is to be used to cover the band's frequency range.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX:HARM:HIGH:STAT ON
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Range 1/2"


[SENSe:]MIXer:HARMonic:HIGH[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:HIGH[:VALue] <HarmOrder>

This command specifies the harmonic order to be used for the high (second) range.

Parameters:
<HarmOrder
numeric value
Range: 2 to 61 (USER band); for other bands: see band definition
Example: MIX:HARM:HIGH 2
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:HARMonic:TYPE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic:TYPE <OddEven>

This command specifies whether the harmonic order to be used should be odd, even, or both.

Which harmonics are supported depends on the mixer type.

Parameters:
<OddEven>
ODD | EVEN | EODD
*RST: EVEN
Example: MIX:HARM:TYPE ODD
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Type"


[SENSe:]MIXer:HARMonic[:LOW]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:HARMonic[:LOW] <HarmOrder>

This command specifies the harmonic order to be used for the low (first) range.

Parameters:
<HarmOrder>
numeric value
Range: | 2 to 61 (USER band); for other bands: see band definition
*RST: | 2 (for band F)
Example: MIX:HARM 3
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:LOSS:HIGH

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:HIGH <Average>

This command defines the average conversion loss to be used for the entire high (second) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS:HIGH 20dB
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe:HIGH

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH <FileName>

This command defines the file name of the conversion loss table to be used for the high (second) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL:HIGH 'MyCVLTable'
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe[:LOW]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS:TABLe[:LOW] <FileName>

This command defines the file name of the conversion loss table to be used for the low (first) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL 'mix_1_4' Specifies the conversion loss table mix_1_4.
Example: | See "Configuring a conversion loss table for a user-defined band"
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS[:LOW]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:LOSS[:LOW] <Average>

This command defines the average conversion loss to be used for the entire low (first) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS 20dB
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:PORTs

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:PORTs
[SENSe:]MIXer:PORTs <PortType>

This command specifies whether the mixer is a 2-port or 3-port type.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Mixer Type"


[SENSe:]MIXer:RFOVerrange[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:RFOVerrange[:STATe] <State>

If enabled, the band limits are extended beyond "RF Start" and "RF Stop" due to the capabilities of the used harmonics.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "RF Overrange"


Conversion Loss Table Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings
Conversion Loss Table Settings

The following settings are required to configure and manage conversion loss tables.

List of Commands
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber


[SENSe:]CORRection:CVL:BAND

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BAND <Type>

This command defines the waveguide band for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Band>
K | A | KA | Q | U | V | E | W | F | D | G | Y | J | USER

Standard waveguide band or user-defined band.

Note: The band formerly referred to as "A" is now named "KA"; the input parameter "A" is still available and refers to the same band as "KA".

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

*RST: F (90 GHz - 140 GHz)
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BAND KA

Sets the band to KA (26.5 GHz - 40 GHz).

Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Band"


[SENSe:]CORRection:CVL:BIAS

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:BIAS <BiasSetting>

This command defines the bias setting to be used with the conversion loss table.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<BiasSetting>
numeric value
*RST: | 0.0 A
Default unit: | A
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BIAS 3A
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Write to <CVL table name>"
See "Bias"


[SENSe:]CORRection:CVL:CATAlog?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CATAlog?

This command queries all available conversion loss tables saved in the C:\r_s\instr\user\cvl\ directory on the instrument.

This command is only available with option B21 (External Mixer) installed.

Usage: Query only


[SENSe:]CORRection:CVL:CLEAr

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:CLEAr

This command deletes the selected conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:CLE
Usage: | Event
Manual operation: | See "Delete Table"


[SENSe:]CORRection:CVL:COMMent

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:COMMent <Text>

This command defines a comment for the conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Text> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:COMM 'Conversion loss table for FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Comment"


[SENSe:]CORRection:CVL:DATA

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:DATA <Freq>,<Level>

This command defines the reference values of the selected conversion loss tables. The values are entered as a set of frequency/level pairs. A maximum of 50 frequency/level pairs may be entered. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Freq> | numeric value The frequencies have to be sent in ascending order.
<Level> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:DATA 1MHZ,-30DB,2MHZ,-40DB
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Position/Value"


[SENSe:]CORRection:CVL:HARMonic

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:HARMonic <HarmOrder>

This command defines the harmonic order for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<HarmOrder>
numeric value
Range: 2 to 65
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:HARM 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]CORRection:CVL:MIXer

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:MIXer <Type>

This command defines the mixer name in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Type> | string Name of mixer with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX 'FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer Name"


[SENSe:]CORRection:CVL:PORTs

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:PORTs <PortNo>

This command defines the mixer type in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:PORT 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Mixer Type"


[SENSe:]CORRection:CVL:SELect

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SELect <FileName>

This command selects the conversion loss table with the specified file name. If <file_name> is not available, a new conversion loss table is created.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<FileName> | '<File name>'
Example: | CORR:CVL:SEL 'LOSS_TAB_4'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "New Table" See "Edit Table" See "File Name"


[SENSe:]CORRection:CVL:SNUMber

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:CVL:SNUMber <SerialNo>

This command defines the serial number of the mixer for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<SerialNo> | Serial number with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX '123.4567'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer S/N"


Programming Example: Working with an External Mixer

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Using External Mixers > Programming Example: Working with an External Mixer
Programming Example: Working with an External Mixer

This example demonstrates how to work with an external mixer in a remote environment. It is performed in the Spectrum application in the default layout configuration. Note that without a real input signal and connected mixer, this measurement will not return useful results.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//----------- Configuring basic mixer behavior -------------
//Set the LO level of the mixer's LO port to 15 dBm.
SENS:MIX:LOP 15dBm
//Set the bias current to -1 mA .
SENS:MIX:BIAS:LOW -1mA
//----------- Configuring the mixer and band settings -------------
//Use band "V" to full possible range extent for assigned harmonic (6).
SENS:MIX:HARM:BAND V
SENS:MIX:RFOV ON
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)
//Use a 3-port mixer type
SENS:MIX:PORT 3
//Split the frequency range into two ranges;
//range 1 covers 47.48 GHz GHz to 80 GHz; harmonic 6, average conv. loss of 20 dB
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:LOW  20dB
SENS:MIX:HARM:HIGH 8
SENS:MIX:LOSS:HIGH 30dB
//--------- Activating automatic signal identification functions -----------
//Activate both automatic signal identification functions.
SENS:MIX:SIGN ALL
//Use auto ID threshold of 8 dB.
SENS:MIX:THR 8dB

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data for the input signal without distortions
//(default screen configuration)
TRAC:DATA? TRACE3
Configuring a conversion loss table for a user-defined band
//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//--------------Configuring a new conversion loss table --------------
//Define cvl table for range 1 of band as described in previous example
// (extended V band)
SENS:CORR:CVL:SEL 'UserTable'
SENS:CORR:CVL:COMM 'User-defined conversion loss table for USER band'
SENS:CORR:CVL:BAND USER
SENS:CORR:CVL:HARM 6
SENS:CORR:CVL:BIAS -1mA
SENS:CORR:CVL:MIX 'FS_Z60'
SENS:CORR:CVL:SNUM '123.4567'
SENS:CORR:CVL:PORT 3
//Conversion loss is linear from 55 GHz to 75 GHz
SENS:CORR:CVL:DATA 55GHZ,-20DB,75GHZ,-30DB
//----------- Configuring the mixer and band settings -------------
//Use user-defined band and assign new cvl table.
SENS:MIX:HARM:BAND USER
//Define band by two ranges;
//range 1 covers 47.48 GHz to 80 GHz; harmonic 6, cvl table 'UserTable'
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:TABL:LOW 'UserTable'
SENS:MIX:HARM:HIGH 8

SENS:MIX:LOSS:HIGH 30dB
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data (default screen configuration)
TRAC:DATA? TRACe1


Configuring Digital I/Q Input and Output

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Useful commands for digital I/Q data described elsewhere:
  • INP:SEL DIQ (see INPut:​SELect)
  • TRIGger[:​SEQuence]:​LEVel:​BBPower
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
OUTPut:DIQ
OUTPut:DIQ:CDEVice


INPut:DIQ:CDEVice

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Note: the final user sample rate of the R&S FSW may differ and is defined using SENS:DEM:PRAT (see [SENSe:​]DDEMod:​PRATe).

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Input Sample Rate"


OUTPut:DIQ

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output > OUTPut:DIQ
OUTPut:DIQ <State>

This command turns continuous output of I/Q data to the optional Digital Baseband Interface (R&S FSW-B17) on and off.

Using the digital input and digital output simultaneously is not possible.

If digital baseband output is active, the sample rate is restricted to 100 MHz (200 MHz if enhanced mode is possible; max. 160 MHz bandwidth).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: OUTP:DIQ ON
Example:

See "Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (-B17)" .

Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Digital Baseband Output"


OUTPut:DIQ:CDEVice

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Digital I/Q Input and Output > OUTPut:DIQ:CDEVice
OUTPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q data output to the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<NotUsed>

to be ignored

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<NotUsed>

to be ignored

<Placeholder>

for future use; currently "0"

Example: OUTP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Output Settings Information"
See "Connected Instrument"


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
  • [SENSe:​]SWAPiq
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:FULLscale[:LEVel]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:TYPE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset" .

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption" .

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption" .

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Setting up Probes

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Setting up Probes
Setting up Probes

Probes can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband interface ( option R&S FSW-B71) is installed.

List of Commands
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?


[SENSe:]PROBe<p>:ID:PARTnumber?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:PARTnumber?

Queries the R&S part number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<PartNumber> | Part number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:ID:SRNumber?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:ID:SRNumber?

Queries the serial number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<SerialNo> | Serial number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:SETup:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:MODE <Mode>

Select the action that is started with the micro button on the probe head.

See also: "Microbutton Action".

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Parameters:
<Mode>
RSINgle

Run single: starts one data acquisition.

NOACtion

Nothing is started on pressing the micro button.

*RST: RSINgle
Manual operation: See "Microbutton Action"


[SENSe:]PROBe<p>:SETup:NAME?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:NAME?

Queries the name of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Name> | Name string
Usage: | Query only


[SENSe:]PROBe<p>:SETup:STATe?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:STATe?

Queries if the probe at the specified connector is active (detected) or not active (not detected). To switch the probe on, i.e. activate input from the connector, use INP:SEL:AIQ (see INPut:​SELect).

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Return values:
<State>
DETected | NDETected
*RST: NDETected
Usage: Query only


[SENSe:]PROBe<p>:SETup:TYPE?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]PROBe<p>:SETup:TYPE?

Queries the type of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Type> | String containing one of the following values: – None (no probe detected) – active differential – active single-ended
Usage: | Query only


Output Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Output Settings
Output Settings

The following command is required only if output is provided to the IF OUT connector on the rear panel of the R&S FSW.

List of Commands
OUTPut:IF:SBANd?


OUTPut:IF:SBANd?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Output Settings > OUTPut:IF:SBANd?
OUTPut:IF:SBANd?

This command queries the sideband provided at the IF OUT connector compared to the sideband of the RF signal. The sideband depends on the current center frequency.

Return values:
<SideBand> | NORMal The sideband at the output is identical to the RF signal. INVerted The sideband at the output is the inverted RF signal sideband.
Example: | OUTP:IF IF2 Activates output at the IF OUTPUT (2 GHZ) connector. OUTP:IF:SBAN? Queries the sideband provided at the connector.
Usage: | Query only
Manual operation: | See "IF/Video Output"


Frequency

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Frequency
Frequency
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet


[SENSe:]FREQuency:CENTer

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center Frequency"
See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <LinkMode>

Defines the step width of the center frequency.

Setting parameters:
<LinkMode>
ON | OFF | 1 | 0
ON

Links the step width to the current standard (currently 1 MHz for all standards)

OFF

Sets the step width as defined using the FREQ:CENT:STEP command (see [SENSe:​]FREQuency:​CENTer:​STEP).

*RST: 1
Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:OFFSet

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

See also "Frequency Offset".

Note: In MSRA/MSRT mode, the setting command is only available for the MSRA/MSRT Master. For MSRA/MSRT applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Amplitude Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Amplitude Settings
Amplitude Settings

Amplitude and scaling settings allow you to configure the vertical (y-)axis display and for some result displays also the horizontal (x-)axis.

Useful commands for amplitude settings described elsewhere:
  • INPut:​COUPling
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude settings:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
[SENSe:]DDEMod:PRESet:RLEVel
INPut:GAIN[:VALue]
INPut:GAIN:STATe


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

With a reference level offset ≠ 0, the value range of the reference level is modified by the offset.

Parameters:
<ReferenceLevel>

The unit is variable.

Range: | see datasheet
*RST: | 0 dBm
Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


[SENSe:]DDEMod:PRESet:RLEVel

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Amplitude Settings > [SENSe:]DDEMod:PRESet:RLEVel
[SENSe:]DDEMod:PRESet:RLEVel

This command initiates a measurement that evaluates and sets the ideal reference level for the current measurement. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Usage: Event


INPut:GAIN[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Amplitude Settings > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Amplitude Settings > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off. It requires option R&S FSW-B24.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Attenuation

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Attenuation
Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Scaling and Units

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units
Scaling and Units
Useful commands for scaling described elsewhere:
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE
  • DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​VOFFset
Remote commands exclusive to scaling and units:
List of Commands
CALCulate<n>:STATistics:PRESet
CALCulate<n>:STATistics:SCALe:AUTO ONCE
CALCulate<n>:STATistics:SCALe:X:BCOunt
CALCulate<n>:STATistics:SCALe:Y:LOWer
CALCulate<n>:STATistics:SCALe:Y:UPPer
CALCulate<n>:STATistics:SCALe:Y:UNIT
CALCulate<n>:UNIT:ANGLe
CALCulate<n>:X:UNIT:TIME
CALCulate<n>:Y:UNIT:TIME
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y:SPACing


CALCulate<n>:STATistics:PRESet

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > CALCulate<n>:STATistics:PRESet
CALCulate<n>:STATistics:PRESet

This command sets the x- and y-axis of the statistics measurement to measurement dependent default values.

Usage: | Event
Manual operation: | See "Default Settings"


CALCulate<n>:STATistics:SCALe:AUTO ONCE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > CALCulate<n>:STATistics:SCALe:AUTO ONCE
CALCulate<n>:STATistics:SCALe:AUTO ONCE

This command initiates an automatic scaling of the diagram (x- and y-axis).

To obtain maximum resolution, the level range is set as a function of the measured spacing between peak power and the minimum power for the APD measurement and of the spacing between peak power and mean power for the CCDF measurement. In addition, the probability scale for the number of test points is adapted.

To get valid results, you have to perform a complete sweep with synchronization to the end of the auto range process. This is only possible in single sweep mode.

Parameters:
ONCE |
Example: | CALC:STAT:SCAL:AUTO ONCE;*WAI Adapts the level setting for statistical measurements.
Usage: | Event
Manual operation: | See "Adjust Settings"


CALCulate<n>:STATistics:SCALe:X:BCOunt

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > CALCulate<n>:STATistics:SCALe:X:BCOunt
CALCulate<n>:STATistics:SCALe:X:BCOunt <StatNofColumns>

This command defines the number of columns for the statistical distribution.

Setting parameters:
<StatNofColumns>
numeric value
Range: | 2 to 1024
*RST: | 101
Default unit: | NONE
Manual operation: See "Quantize"


CALCulate<n>:STATistics:SCALe:Y:LOWer

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > CALCulate<n>:STATistics:SCALe:Y:LOWer
CALCulate<n>:STATistics:SCALe:Y:LOWer <Magnitude>

This command defines the lower vertical limit of the diagram.

Parameters:
<Magnitude>

The number is a statistical value and therefore dimensionless.

Range: | 1E-9 to 0.1
*RST: | 1E-6
Example: CALC:STAT:SCAL:Y:LOW 0.001
Example:

See "Programming Example: Measuring Statistics" .

Manual operation: See "Defining Min and Max Values"


CALCulate<n>:STATistics:SCALe:Y:UPPer

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > CALCulate<n>:STATistics:SCALe:Y:UPPer
CALCulate<n>:STATistics:SCALe:Y:UPPer <Magnitude>

This command defines the upper vertical limit of the diagram.

Parameters:
<Magnitude>

The number is a statistical value and therefore dimensionless.

Range: | 1E-5 to 1.0
*RST: | 1.0
Example: CALC:STAT:SCAL:Y:UPP 0.01
Example:

See "Programming Example: Measuring Statistics" .

Manual operation: See "Defining Min and Max Values"


CALCulate<n>:STATistics:SCALe:Y:UNIT

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > CALCulate<n>:STATistics:SCALe:Y:UNIT
CALCulate<n>:STATistics:SCALe:Y:UNIT <Unit>

This command selects the unit of the y-axis.

Parameters:
<Unit>
PCT | ABS
*RST: ABS
Example: CALC:STAT:SCAL:Y:UNIT PCT

Sets the percentage scale.

Example:

See "Programming Example: Measuring Statistics" .

Manual operation: See "Y-Axis Unit"


CALCulate<n>:UNIT:ANGLe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > CALCulate<n>:UNIT:ANGLe
CALCulate<n>:UNIT:ANGLe <Unit>

This command selects the global unit for phase results.

Setting parameters:
<Unit>
DEG | RAD
*RST: RAD
Manual operation: See "Y-Axis Unit"


CALCulate<n>:X:UNIT:TIME

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > CALCulate<n>:X:UNIT:TIME
CALCulate<n>:X:UNIT:TIME <Unit>

This command selects the unit (symbols or seconds) for the x axis.

Setting parameters:
<Unit>
S | SYM
*RST: SYM
Manual operation: See "X-Axis Unit"


CALCulate<n>:Y:UNIT:TIME

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > CALCulate<n>:Y:UNIT:TIME
CALCulate<n>:Y:UNIT:TIME <Unit>

This command selects the unit (symbols or seconds) for the y axis of equalizer group delay measurements.

Setting parameters:
<Unit>
S | SYM
*RST: SYM
Manual operation: See "Y-Axis Unit"


DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:PDIVision

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:PDIVision <PDiv>

This command defines the scaling of the x-axis for statistical result displays.

For all other result displays, this command is only available as a query.

Setting parameters:
<PDiv> | numeric value Defines the range per division (total range = 10*<PDiv>)
Manual operation: | See "Range per Division"


DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RPOSition

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RPOSition <RPos>

This command defines the position of the reference value for the X axis.

Setting the position of the reference value is possible only for statistical result displays. All other result displays support the query only.

Setting parameters:
<RPos> | numeric value <numeric_value>
Example: | DISP:TRAC:X:RPOS 30 PCT The reference value is shifted by 30% towards the left.
Manual operation: | See "X-Axis Reference Position"


DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RVALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RVALue <RVal>

This command defines the reference value for the x-axis for statistical result displays.

For all other result displays, this command is only available as a query.

Setting parameters:
<RVal> | numeric value Reference value for the x-axis
Manual operation: | See "X-Axis Reference Value"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe] <Range>

This command defines the display range of the y-axis.

Example: DISP:TRAC:Y 110dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision <Value>

This remote command determines the grid spacing on the Y-axis for all diagrams, where possible.

Parameters:
<Value>
numeric value WITHOUT UNIT (unit according to the result display)

Defines the range per division (total range = 10*<Value>)

*RST: depends on the result display
Example: DISP:TRAC:Y:PDIV 10

Sets the grid spacing to 10 units (e.g. dB) per division

Manual operation: See "Range per Division"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Y-Axis Reference Position"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

The command defines the power value assigned to the reference position in the grid.

For external generator calibration measurements (requires External Generator Control option R&S FSW-B10), this command defines the power offset value assigned to the reference position.

Parameters:
<Value>
*RST: 0 dBm, coupled to reference level
Example: DISP:TRAC:Y:RVAL -20dBm

Sets the power value assigned to the reference position to -20 dBm

Manual operation: See "Y-Axis Reference Value"


DISPlay[:WINDow<n>]:TRACe:Y:SPACing

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Input, Output and Frontend Settings > Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y:SPACing <ScalingType>

This command selects the scaling of the y-axis.

Parameters:
<ScalingType>
LOGarithmic

Logarithmic scaling.

LINear

Linear scaling in %.

LDB

Linear scaling in the specified unit.

PERCent

Linear scaling in %.

*RST: LOGarithmic
Example: DISP:TRAC:Y:SPAC LIN

Selects linear scaling in %.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Y-Axis Unit"


Signal Capture

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Capture
Signal Capture

The signal capture commands define how much, how and when data is captured from the input signal.

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. The data acquisition settings for the VSA application in MSRA/MSRT mode define the application data extract and analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

The tasks for manual operation are described in "Signal Capture".

List of Commands
[SENSe:]DDEMod:PRATe
[SENSe:]DDEMod:RLENgth:AUTO
[SENSe:]DDEMod:RLENgth[:VALue]
[SENSe:]SWAPiq
TRACe<n>:IQ:BWIDth?
TRACe:IQ:WBANd[:STATe]
TRACe:IQ:WBANd:MBWIDTH


[SENSe:]DDEMod:PRATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Capture > [SENSe:]DDEMod:PRATe
[SENSe:]DDEMod:PRATe <CaptOverSmplg>

Defines the number of samples that are captured per symbol, i.e. the factor by which the symbol rate is multiplied to obtain the sample rate. This parameter also affects the demodulation bandwidth and thus the usable I/Q bandwidth.

The sample rate depends on the defined "Symbol Rate" (see "Sample Rate, Symbol Rate and I/Q Bandwidth").

Setting parameters:
<CaptOverSmplg>
4 | 8 | 16 | 32

The factor by which the symbol rate is multiplied to obtain the sample rate, e.g. 4 samples per symbol:

sample rate = 4*symbol rate

*RST: 4
Manual operation: See "Sample Rate"


[SENSe:]DDEMod:RLENgth:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Capture > [SENSe:]DDEMod:RLENgth:AUTO
[SENSe:]DDEMod:RLENgth:AUTO <RecLengthAuto>

If enabled, the capture length is automatically adapted as required according to the current result length, burst and pattern search settings, and network-specific characteristics (e.g. burst and frame structures).

Setting parameters:
<RecLengthAuto>
ON | OFF | 1 | 0
*RST: 1
Manual operation: See "Capture Length Settings"


[SENSe:]DDEMod:RLENgth[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Capture > [SENSe:]DDEMod:RLENgth[:VALue]
[SENSe:]DDEMod:RLENgth[:VALue] <RecordLength>

This command defines the capture length for further processing, e.g. for burst search. The record length is defined in time (S, default) or symbols (SYM).

Note that the maximum record length depends on the sample rate for signal capture (see [SENSe:​]DDEMod:​PRATe). For the default value =4, the maximum is 64000 symbols. For larger sample rates, the maximum record length (in symbols) can be calculated as:

RecordlengthMAX = 256000/ <points per symbol>

Setting parameters:
<RecordLength>
numeric value
*RST: | 2.083 ms
Default unit: | s (not symbols as in manual operation!)
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard"

Manual operation: See "Capture Length Settings"


[SENSe:]SWAPiq

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Capture > [SENSe:]SWAPiq
[SENSe:]SWAPiq <State>

This command defines whether or not the recorded IQ pairs should be swapped (I<->Q) before being processed. Swapping I and Q inverts the sideband.

This is useful if the DUT interchanged the I and Q parts of the signal; then the R&S FSW can do the same to compensate for it.

For GSM measurements: Try this function if the TSC can not be found.

Parameters:
<State>
ON

I and Q signals are interchanged

Inverted sideband, Q+j*I

OFF

I and Q signals are not interchanged

Normal sideband, I+j*Q

*RST: OFF
Manual operation: See "Swap I/Q"


TRACe<n>:IQ:BWIDth?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Capture > TRACe<n>:IQ:BWIDth?
TRACe<n>:IQ:BWIDth?

This command queries the bandwidth in Hz of the resampling filter ("Usable I/Q Bandwidth").

Usage: | Query only
Manual operation: | See "Usable I/Q Bandwidth"


TRACe:IQ:WBANd[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Capture > TRACe:IQ:WBANd[:STATe]
TRACe:IQ:WBANd[:STATe] <State>

This command determines whether the wideband provided by bandwidth extension options is used or not (if installed).

Parameters:
<State>
ON | OFF
ON

If enabled, installed bandwidth extension options can be used. They are activated for bandwidths > 80 MHz, if the bandwidth is not restricted by the TRACe:​IQ:​WBANd:​MBWIDTH command. Otherwise, the currently available maximum bandwidth is allowed (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

This parameter corresponds to the "Auto" setting in manual operation (with TRACe:​IQ:​WBANd:​MBWIDTH 320 MHZ).

OFF

The bandwidth extension options R&S FSW-B500/-B320/-B160 are deactivated; the maximum analysis bandwidth is restricted to 80 MHz.

This parameter corresponds to the "80 MHz" setting in manual operation.

*RST: ON
Manual operation: See "Maximum Bandwidth"


TRACe:IQ:WBANd:MBWIDTH

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Signal Capture > TRACe:IQ:WBANd:MBWIDTH
TRACe:IQ:WBANd:MBWIDTH <Limit>

Restricts the maximum analysis bandwidth.

Parameters:
<Limit>
80 MHz

Restricts the analysis bandwidth to a maximum of 80 MHz.

The bandwidth extension option R&S FSW-B160/-B320/-B500 is deactivated.

TRACe:​IQ:​WBANd[:​STATe] is set to OFF.

160 MHz

Restricts the analysis bandwidth to a maximum of 160 MHz. The bandwidth extension option R&S FSW-B320 is deactivated.

(Not available or required if bandwidth extension option R&S FSW-B500 is installed.)

TRACe:​IQ:​WBANd[:​STATe] is set to ON.

500 MHz | 320 MHz | MAX

All installed bandwidth extension options are activated. The currently available maximum bandwidth is allowed (see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

TRACe:​IQ:​WBANd[:​STATe] is set to ON.

*RST: | maximum available
Default unit: | Hz
Manual operation: See "Maximum Bandwidth"


Triggering Measurements

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements
Triggering Measurements

The trigger commands define the beginning of a measurement.

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. Thus, no trigger settings are available in the VSA application in MSRA/MSRT operating mode. However, a capture offset can be defined with a similar effect as a trigger offset. It defines an offset from the start of the captured data (from the MSRA/MSRT Master) to the start of the application data for vector signal analysis. (See "Configuring an Analysis Interval and Line (MSRA mode only)".)

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Tasks for manual configuration are described in "Trigger Settings".

List of Commands
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


TRIGger[:SEQuence]:BBPower:HOLDoff

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:BBPower:HOLDoff <Period>

This command defines the holding time before the baseband power trigger event.

The command requires the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Period>
Range: | 150 ns to 1000 s
*RST: | 150 ns
Example: TRIG:SOUR BBP

Sets the baseband power trigger source.

TRIG:BBP:HOLD 200 ns

Sets the holding time to 200 ns.


TRIGger[:SEQuence]:DTIMe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>

The allowed range is 0 s to 30 s.

*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Note: If you perform gated measurements in combination with the IF Power trigger, the R&S FSW ignores the holding time for frequency sweep, FFT sweep, zero span and I/Q data measurements.

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel:BBPower

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower <Level>

This command sets the level of the baseband power trigger.

This command is available for the Digital Baseband Interface (R&S FSW-B17) and the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<Level>
Range: | -50 dBm to +20 dBm
*RST: | -20 dBm
Example: TRIG:LEV:BB -30DBM
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:IFPower

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

For compatibility reasons, this command is also available for the "baseband power" trigger source when using the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:IQPower

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:SLOPe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For all trigger sources except time you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Triggering Measurements > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

IFPower

Second intermediate frequency

Not available for input from the Digital Baseband Interface (R&S FSW-B17). For input from the Analog Baseband Interface (R&S FSW-B71), this parameter is interpreted as BBPower for compatibility reasons.

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

BBPower

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17)

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)

GP0 | GP1 | GP2 | GP3 | GP4 | GP5

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available.

Defines triggering of the measurement directly via the LVDS connector. The parameter specifies which general purpose bit (0 to 5) will provide the trigger data.

The assignment of the general purpose bits used by the Digital IQ trigger to the LVDS connector pins is provided in "Digital I/Q".

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "IF Power/BB Power"
See "I/Q Power"
See "Digital I/Q"


Configuring Sweeps

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Sweeps
Configuring Sweeps

The sweep commands define how often data from the input signal is acquired and then evaluated.

Manual configuration of the sweeps is described in "Sweep Settings".

List of Commands
[SENSe:]DDEMod:SEARch:MBURst:CALC
[SENSe:]SWEep:COUNt[:VALue]
[SENSe:]SWEep:COUNt:CURRent


[SENSe:]DDEMod:SEARch:MBURst:CALC

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Sweeps > [SENSe:]DDEMod:SEARch:MBURst:CALC
[SENSe:]DDEMod:SEARch:MBURst:CALC <SelResRangeNr>

Sets the result range to be displayed after a single sweep (e.g. a burst number).

Setting parameters:
<SelResRangeNr>
numeric value
Range: | 1 to 1000000
*RST: | 1
Default unit: | NONE
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Select Result Rng"


[SENSe:]SWEep:COUNt[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Sweeps > [SENSe:]SWEep:COUNt[:VALue]
[SENSe:]SWEep:COUNt[:VALue] <SweepCount>

This command sets the statistics count.

For more information see "Statistic Count".

Setting parameters:
<SweepCount>
numeric value
0

activates "Auto" mode

numeric value > 0

Activates "Manual" mode and sets the statistics count to the corresponding number.

Range: | 0 to 200000
*RST: | 0
Default unit: | NONE
Usage: SCPI confirmed
Manual operation: See "Statistic Count"


[SENSe:]SWEep:COUNt:CURRent

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Sweeps > [SENSe:]SWEep:COUNt:CURRent
[SENSe:]SWEep:COUNt:CURRent <Counter>

This command queries the current statistics counter value which indicates how many result ranges have been evaluated. For results that use the capture buffer as a source, the number of used capture buffers can be queried.

Setting parameters:
<Counter>
CAPTure | STATistics
STATistics

Returns the number of result ranges that have been evaluated.

CAPTure

Returns the number of used capture buffers evaluated.

*RST: STATistics


Configuring Bursts and Patterns

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns
Configuring Bursts and Patterns

The burst and pattern search settings can be configured, and new patterns can be defined.

Manual configuration of bursts and patterns is described in "Burst and Pattern Configuration".

Contents
  • Burst Search
  • Pattern Searches
  • Configuring Patterns


Burst Search

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Burst Search
Burst Search

The burst search commands define when a burst is detected in the analyzed signal.

List of Commands
[SENSe:]DDEMod:SEARch:BURSt:AUTO
[SENSe:]DDEMod:SEARch:BURSt:CONFigure:AUTO
[SENSe:]DDEMod:SEARch:BURSt:GLENgth[:MINimum]
[SENSe:]DDEMod:SEARch:BURSt:MODE
[SENSe:]DDEMod:SEARch:BURSt:STATe
[SENSe:]DDEMod:SEARch:BURSt:TOLerance


[SENSe:]DDEMod:SEARch:BURSt:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Burst Search > [SENSe:]DDEMod:SEARch:BURSt:AUTO
[SENSe:]DDEMod:SEARch:BURSt:AUTO <AutoBurstSearch>

This command links the burst search to the type of signal. When a signal is marked as bursted, burst search is switched on automatically.

Setting parameters:
<AutoBurstSearch>
AUTO | MANual
*RST: AUTO
Manual operation: See "Enabling Burst Searches"


[SENSe:]DDEMod:SEARch:BURSt:CONFigure:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Burst Search > [SENSe:]DDEMod:SEARch:BURSt:CONFigure:AUTO
[SENSe:]DDEMod:SEARch:BURSt:CONFigure:AUTO <AutoConfigure>

This command sets the search tolerance and the min gap length to their default values.

Setting parameters:
<AutoConfigure>
ON | OFF | 1 | 0
*RST: 1
Manual operation: See "Burst Configuration"


[SENSe:]DDEMod:SEARch:BURSt:GLENgth[:MINimum]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Burst Search > [SENSe:]DDEMod:SEARch:BURSt:GLENgth[:MINimum]
[SENSe:]DDEMod:SEARch:BURSt:GLENgth[:MINimum] <MinGapLength>

This command defines the minimum time between two bursts. A minimum time with decreased level must occur between two bursts. The default unit is symbol. The value can also be given in seconds.

Setting parameters:
<MinGapLength>
numeric value
Range: | 1 to 15000
*RST: | 1
Default unit: | SYM
Manual operation: See "Min Gap Length"


[SENSe:]DDEMod:SEARch:BURSt:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Burst Search > [SENSe:]DDEMod:SEARch:BURSt:MODE
[SENSe:]DDEMod:SEARch:BURSt:MODE <MeasOnlyOnBurst>

This command sets the vector analyzer so that a measurement is performed only if a burst is found. The command is available only if the burst search is activated (see [SENSe:​]DDEMod:​SEARch:​BURSt:​STATe).

Setting parameters:
<MeasOnlyOnBurst>
MEAS | BURS
MEAS

Measurement is always performed

BURS

Measurement is performed only if a burst is found

*RST: MEAS
Manual operation: See "Measuring only if burst was found"


[SENSe:]DDEMod:SEARch:BURSt:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Burst Search > [SENSe:]DDEMod:SEARch:BURSt:STATe
[SENSe:]DDEMod:SEARch:BURSt:STATe <SearchState>

This command switches the search for a signal burst on or off.

Setting parameters:
<SearchState>
ON | OFF | 1 | 0
*RST: 0


[SENSe:]DDEMod:SEARch:BURSt:TOLerance

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Burst Search > [SENSe:]DDEMod:SEARch:BURSt:TOLerance
[SENSe:]DDEMod:SEARch:BURSt:TOLerance <SearchTolerance>

This command controls burst search tolerance.

Setting parameters:
<SearchTolerance>
numeric value
Range: | 0 to 100000
*RST: | 4
Default unit: | SYM
Manual operation: See "Search Tolerance"


Pattern Searches

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Pattern Searches
Pattern Searches

The pattern search commands define when a pattern is detected in the analyzed signal.

List of Commands
[SENSe:]DDEMod:SEARch:PATTern:CONFigure:AUTO
[SENSe:]DDEMod:SEARch:SYNC:AUTO
[SENSe:]DDEMod:SEARch:SYNC:IQCThreshold
[SENSe:]DDEMod:SEARch:SYNC:MODE
[SENSe:]DDEMod:SEARch:SYNC:SELect
[SENSe:]DDEMod:SEARch:SYNC:STATe


[SENSe:]DDEMod:SEARch:PATTern:CONFigure:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Pattern Searches > [SENSe:]DDEMod:SEARch:PATTern:CONFigure:AUTO
[SENSe:]DDEMod:SEARch:PATTern:CONFigure:AUTO <AutoConfigure>

This command sets the IQ correlation threshold to its default value.

Setting parameters:
<AutoConfigure>
ON | OFF | 1 | 0
*RST: 1
Manual operation: See "I/Q Correlation Threshold"


[SENSe:]DDEMod:SEARch:SYNC:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Pattern Searches > [SENSe:]DDEMod:SEARch:SYNC:AUTO
[SENSe:]DDEMod:SEARch:SYNC:AUTO <AutoPattSearch>

This command links the pattern search to the type of signal. When a signal is marked as patterned, pattern search is switched on automatically.

Setting parameters:
<AutoPattSearch>
AUTO | MANual
*RST: AUTO
Manual operation: See "Enabling Pattern Searches"


[SENSe:]DDEMod:SEARch:SYNC:IQCThreshold

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Pattern Searches > [SENSe:]DDEMod:SEARch:SYNC:IQCThreshold
[SENSe:]DDEMod:SEARch:SYNC:IQCThreshold <CorrelationLev>

This command sets the IQ correlation threshold for pattern matching in percent. A high level means stricter matching.

Setting parameters:
<CorrelationLev>
numeric value
Range: | 10.0 to 100.0
*RST: | 90.0
Default unit: | PCT
Manual operation: See "I/Q Correlation Threshold"


[SENSe:]DDEMod:SEARch:SYNC:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Pattern Searches > [SENSe:]DDEMod:SEARch:SYNC:MODE
[SENSe:]DDEMod:SEARch:SYNC:MODE <MeasOnlyOnPatt>

This command sets the vector analyzer so that the measurement is performed only if the measurement was synchronous to the selected sync pattern.

The command is available only if the pattern search is activated (see [SENSe:​]DDEMod:​SEARch:​SYNC:​STATe).

Setting parameters:
<MeasOnlyOnPatt>
MEAS | SYNC
MEAS

The measurement is performed independently of successful synchronization

SYNC

The measured values are displayed and considered in the error evaluation only if the set sync pattern was found. Bursts with a wrong sync pattern (sync not found) are ignored. If an invalid or no sync pattern is found, the measurement waits and resumes running only when a valid sync pattern is found.

*RST: 0
Manual operation: See "Meas only if Pattern Symbols Correct"


[SENSe:]DDEMod:SEARch:SYNC:SELect

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Pattern Searches > [SENSe:]DDEMod:SEARch:SYNC:SELect
[SENSe:]DDEMod:SEARch:SYNC:SELect <Select>

This command selects a predefined sync pattern file.

Setting parameters:
<Select> | string
Example: | See "Measurement Example 3: User-Defined Pattern Search and Limit Check".
Manual operation: | See "Selected Pattern for Search" See "Standard Patterns - selecting an assigned pattern"


[SENSe:]DDEMod:SEARch:SYNC:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Pattern Searches > [SENSe:]DDEMod:SEARch:SYNC:STATe
[SENSe:]DDEMod:SEARch:SYNC:STATe <PatternSearch>

This command switches the search for a sync sequence on or off.

Setting parameters:
<PatternSearch>
ON | OFF | 1 | 0
*RST: 0
Manual operation: See "Enabling Pattern Searches"
See "Pattern Search On"


Configuring Patterns

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns
Configuring Patterns

New patterns can be defined and assigned to a signal standard.

Useful commands for configuring patterns described elsewhere:
  • [SENSe:​]DDEMod:​SEARch:​SYNC:​STATe
  • [SENSe:​]DDEMod:​SEARch:​SYNC:​CATalog
Remote commands exclusive to configuring patterns:
List of Commands
[SENSe:]DDEMod:SEARch:SYNC:COMMent
[SENSe:]DDEMod:SEARch:SYNC:COPY
[SENSe:]DDEMod:SEARch:SYNC:DELete
[SENSe:]DDEMod:SEARch:SYNC:DATA
[SENSe:]DDEMod:SEARch:SYNC:NAME
[SENSe:]DDEMod:SEARch:SYNC:NSTate
[SENSe:]DDEMod:SEARch:SYNC:PATTern:ADD
[SENSe:]DDEMod:SEARch:SYNC:PATTern:REMove
[SENSe:]DDEMod:SEARch:SYNC:TEXT


[SENSe:]DDEMod:SEARch:SYNC:COMMent

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns > [SENSe:]DDEMod:SEARch:SYNC:COMMent
[SENSe:]DDEMod:SEARch:SYNC:COMMent <Comment>

This command defines a comment to a sync pattern. The pattern must have been selected before using [SENSe:​]DDEMod:​SEARch:​SYNC:​NAME.

Setting parameters:
<Comment> | string
Example: | See "Measurement Example 3: User-Defined Pattern Search and Limit Check".
Manual operation: | See "Edit" See "New" See "Comment"


[SENSe:]DDEMod:SEARch:SYNC:COPY

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns > [SENSe:]DDEMod:SEARch:SYNC:COPY
[SENSe:]DDEMod:SEARch:SYNC:COPY <Pattern>

This command copies a pattern file. The pattern to be copied must have been selected before using [SENSe:​]DDEMod:​SEARch:​SYNC:​NAME.

Tip: In manual operation, a pattern can be copied in the editor by storing it under a new name.

Setting parameters:
<Pattern> | string
Example: | :DDEM:SEAR:SYNC:NAME 'GSM_TSC0' Selects the pattern. :DDEM:SEAR:SYNC:COPY 'GSM_PATT' Copies "GSM_TSC0" to GSM_PATT.
Usage: | Setting only
Manual operation: | See "Save As"


[SENSe:]DDEMod:SEARch:SYNC:DELete

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns > [SENSe:]DDEMod:SEARch:SYNC:DELete
[SENSe:]DDEMod:SEARch:SYNC:DELete

This command deletes a sync sequence. The sync sequence to be deleted must have been selected before using [SENSe:​]DDEMod:​SEARch:​SYNC:​NAME.

Usage: | Event
Manual operation: | See "Delete"


[SENSe:]DDEMod:SEARch:SYNC:DATA

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns > [SENSe:]DDEMod:SEARch:SYNC:DATA
[SENSe:]DDEMod:SEARch:SYNC:DATA <Data>

This command defines the sync sequence of a sync pattern. The pattern must have been selected before using [SENSe:​]DDEMod:​SEARch:​SYNC:​NAME.

Important: The value range of a symbol depends on the degree of modulation,e.g. for an 8PSK modulation the value range is from 0 to 7. The degree of modulation belongs to the pattern and is set using the DDEM:SEAR:SYNC:NST command (see [SENSe:​]DDEMod:​SEARch:​SYNC:​NSTate).

Setting parameters:
<Data> | string Four values represent a symbol (hexadecimal format). The value range of a symbol depends on the degree of modulation. With a degree of modulation of 4, all symbols have a value range of: 0000, 0001, 0002, 0003 With a degree of modulation of 8: 0000, 0001, 0002, 0003, 0004, 0005, 0006, 0007
Example: | DDEM:SEAR:SYNC:DATA '00010000FFFF' Defines the pattern data.
Example: | See "Measurement Example 3: User-Defined Pattern Search and Limit Check".
Manual operation: | See "Edit" See "New" See "Symbols"


[SENSe:]DDEMod:SEARch:SYNC:NAME

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns > [SENSe:]DDEMod:SEARch:SYNC:NAME
[SENSe:]DDEMod:SEARch:SYNC:NAME <Name>

This command selects a sync pattern for editing or for a new entry.

Setting parameters:
<Name> | string
Example: | See "Measurement Example 3: User-Defined Pattern Search and Limit Check".
Manual operation: | See "Edit" See "New" See "Name"


[SENSe:]DDEMod:SEARch:SYNC:NSTate

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns > [SENSe:]DDEMod:SEARch:SYNC:NSTate
[SENSe:]DDEMod:SEARch:SYNC:NSTate <NState>

This command selects the degree of modulation (number of permitted states). The pattern must have been selected before using using [SENSe:​]DDEMod:​SEARch:​SYNC:​NAME.

The number of permitted states depends on the modulation mode.

Setting parameters:
<NState> | numeric value
Example: | See "Measurement Example 3: User-Defined Pattern Search and Limit Check".
Manual operation: | See "Mod. order"


[SENSe:]DDEMod:SEARch:SYNC:PATTern:ADD

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns > [SENSe:]DDEMod:SEARch:SYNC:PATTern:ADD
[SENSe:]DDEMod:SEARch:SYNC:PATTern:ADD <AddPattern>

This command adds a pattern to the current standard. Using the DDEM:SEAR:SYNC:SEL command, only those patterns can be selected which belong to the current standard (see [SENSe:​]DDEMod:​SEARch:​SYNC:​SELect).

Setting parameters:
<AddPattern> | string
Example: | See "Measurement Example 3: User-Defined Pattern Search and Limit Check".
Usage: | Setting only
Manual operation: | See "Adding patterns to a standard"


[SENSe:]DDEMod:SEARch:SYNC:PATTern:REMove

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns > [SENSe:]DDEMod:SEARch:SYNC:PATTern:REMove
[SENSe:]DDEMod:SEARch:SYNC:PATTern:REMove

This command deletes one or all patterns from the current standard.

Usage: | Setting only
Manual operation: | See "Removing patterns from a standard"


[SENSe:]DDEMod:SEARch:SYNC:TEXT

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Configuring Bursts and Patterns > Configuring Patterns > [SENSe:]DDEMod:SEARch:SYNC:TEXT
[SENSe:]DDEMod:SEARch:SYNC:TEXT <Text>

This command defines a text to explain the pattern. The text is displayed only in the selection menu (manual control). This text should be short and concise. Detailed information about the pattern is given in the comment (see [SENSe:​]DDEMod:​SEARch:​SYNC:​COMMent).

Setting parameters:
<Text> | string
Example: | See "Measurement Example 3: User-Defined Pattern Search and Limit Check".
Manual operation: | See "Edit" See "New" See "Description"


Defining the Result Range

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Defining the Result Range
Defining the Result Range

The result range determines which part of the capture buffer, burst or pattern is displayed.

Manual configuration of the result range is described in "Result Range Configuration".

Useful commands for result ranges described elsewhere:
  • [SENSe:​]DDEMod:​SEARch:​MBURst:​STARt?
  • DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​STOP?
Remote commands exclusive to defining result ranges:
List of Commands
CALCulate<n>:TRACe<t>:ADJust:ALIGnment[:DEFault]
CALCulate<n>:TRACe<t>:ADJust:ALIGnment:OFFSet
CALCulate<n>:TRACe<t>:ADJust[:VALue]
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:VOFFset
[SENSe:]DDEMod:TIME


CALCulate<n>:TRACe<t>:ADJust:ALIGnment[:DEFault]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Defining the Result Range > CALCulate<n>:TRACe<t>:ADJust:ALIGnment[:DEFault]
CALCulate<n>:TRACe<t>:ADJust:ALIGnment[:DEFault] <Alignment>

This command defines where the reference point is to appear in the result range.

Suffix:
<t>
1..6
Setting parameters:
<Alignment>
LEFT | CENTer | RIGHt
LEFT

The reference point is at the start of the result range.

CENTer

The reference point is in the middle of the result range.

RIGHt

The reference point is displayed at the end of the result range.

*RST: LEFT
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Alignment"


CALCulate<n>:TRACe<t>:ADJust:ALIGnment:OFFSet

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Defining the Result Range > CALCulate<n>:TRACe<t>:ADJust:ALIGnment:OFFSet
CALCulate<n>:TRACe<t>:ADJust:ALIGnment:OFFSet <FitOffset>

This command shifts the display range (relative to the reference time) by the number of given symbols. The resolution is 1 symbol. A value >0 results in a shift towards the right, and a value <0 results in a shift towards the left.

Suffix:
<t>
1..6
Setting parameters:
<FitOffset>
numeric value
Range: | -8000 to 8000
*RST: | 0
Default unit: | SYM
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Offset"


CALCulate<n>:TRACe<t>:ADJust[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Defining the Result Range > CALCulate<n>:TRACe<t>:ADJust[:VALue]
CALCulate<n>:TRACe<t>:ADJust[:VALue] <Reference>

This command defines the reference point for the display.

Suffix:
<t>
1..6
Setting parameters:
<Reference>
TRIGger | BURSt | PATTern
TRIGger

The reference point is defined by the start of the capture buffer.

BURSt

The reference point is defined by the start/center/end of the burst.

PATTern

The instrument selects the reference point and the alignment.

*RST: TRIGger
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Reference"


DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:VOFFset

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Defining the Result Range > DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:VOFFset
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:VOFFset <VOffset>

This command defines an offset to numbering of the symbols (Except capture buffer).

Setting parameters:
<VOffset>
numeric value
Range: | -100000 to 100000
*RST: | 0
Default unit: | NONE
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Symbol Number at <Reference> Start"


[SENSe:]DDEMod:TIME

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Defining the Result Range > [SENSe:]DDEMod:TIME
[SENSe:]DDEMod:TIME <ResultLength>

The command determines the number of displayed symbols (result length).

Setting parameters:
<ResultLength>
numeric value
Range: | 10 to 64000
*RST: | 800
Default unit: | SYM
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Result Length"


Demodulation Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings
Demodulation Settings

During demodulation of the vector signal some undesired effects that may occur during transmission can be compensated for. Furthermore, you can influence the synchronization process.

Manual configuration of the demodulation process is described in "Demodulation Settings".

List of Commands
[SENSe:]DDEMod:ECALc[:MODE]
[SENSe:]DDEMod:ECALc:OFFSet
[SENSe:]DDEMod:EPRate:AUTO
[SENSe:]DDEMod:EPRate[:VALue]
[SENSe:]DDEMod:EQUalizer:LENGth
[SENSe:]DDEMod:EQUalizer:LOAD
[SENSe:]DDEMod:EQUalizer:MODE
[SENSe:]DDEMod:EQUalizer:RESet
[SENSe:]DDEMod:EQUalizer:SAVE
[SENSe:]DDEMod:EQUalizer[:STATe]
[SENSe:]DDEMod:FSYNc:AUTO
[SENSe:]DDEMod:FSYNc:LEVel
[SENSe:]DDEMod:FSYNc:RESult?
[SENSe:]DDEMod:FSYNc[:MODE]
[SENSe:]DDEMod:KDATa:STATe
[SENSe:]DDEMod:KDATa[:NAME]
[SENSe:]DDEMod:NORMalize:ADRoop
[SENSe:]DDEMod:NORMalize:CFDRift
[SENSe:]DDEMod:NORMalize:CHANnel
[SENSe:]DDEMod:NORMalize:FDERror
[SENSe:]DDEMod:NORMalize:IQIMbalance
[SENSe:]DDEMod:NORMalize:IQOFfset
[SENSe:]DDEMod:NORMalize:SRERror
[SENSe:]DDEMod:OPTimization
[SENSe:]DDEMod:SEARch:PATTern:SYNC:AUTO
[SENSe:]DDEMod:SEARch:PATTern:SYNC[:STATe]


[SENSe:]DDEMod:ECALc[:MODE]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:ECALc[:MODE]
[SENSe:]DDEMod:ECALc[:MODE] <EvmCalc>

This command defines the calculation formula for EVM.

Setting parameters:
<EvmCalc>
SIGNal | SYMBol | MECPower | MACPower
SIGNal

Calculation normalized to the mean power of the reference signal at the symbol instants.

SYMBol

Calculation normalized to the maximum power of the reference signal at the symbol instants.

MECPower

Calculation normalized to the mean expected power of the measurement signal at the symbol instants

MACPower

Calculation normalized to the maximum expected power of the measurement signal at the symbol instants

*RST: SIGNal
Manual operation: See "Normalize EVM to"


[SENSe:]DDEMod:ECALc:OFFSet

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:ECALc:OFFSet
[SENSe:]DDEMod:ECALc:OFFSet <EVMOffsetState>

ConfigureS the way the VSA application calculates the error vector results for offset QPSK.

Setting parameters:
<EVMOffsetState>
ON | OFF | 1 | 0
ON

VSA application compensates the delay of the Q component with respect to the I component in the measurement signal as well as the reference signal before calculating the error vector. That means that the error vector contains only one symbol instant per symbol period.

OFF

the VSA application substracts the measured signal from the reference signal to calculate the error vector. This method results in the fact that the error vector contains two symbol instants per symbol period: one that corresponds to the I component and one that corresponds to the Q component.

*RST: 1
Manual operation: See "Offset EVM"


[SENSe:]DDEMod:EPRate:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:EPRate:AUTO
[SENSe:]DDEMod:EPRate:AUTO <LinkMode>

Defines how many sample points are used at each symbol to calculate modulation accuracy results automatically.

If enabled, the VSA application uses the following settings, depending on the modulation type:

Modulation | Est. Points
PSK, QAM | 1
Offset QPSK | 2
FSK, MSK | Sample rate (see [SENSe:​]DDEMod:​PRATe)
Setting parameters:
<LinkMode>
ON | OFF | 1 | 0
*RST: 1
Manual operation: See "Estimation Points/Sym"


[SENSe:]DDEMod:EPRate[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:EPRate[:VALue]
[SENSe:]DDEMod:EPRate[:VALue] <EstOverSmplg>

Defines how many sample points are used at each symbol to calculate modulation accuracy results.

For more information see "Estimation points per symbol".

You can also let the VSA application decide how many estimation points to use, see [SENSe:​]DDEMod:​EPRate:​AUTO.

Setting parameters:
<EstOverSmplg>
1

the estimation algorithm takes only the symbol time instants into account

2

two points per symbol instant are used (required for Offset QPSK)

4 | 8 | 16 | 32

the number of samples per symbol defined in the signal capture settings is used (see [SENSe:​]DDEMod:​PRATe), i.e. all sample time instants are weighted equally

*RST: 1
Manual operation: See "Estimation Points/Sym"


[SENSe:]DDEMod:EQUalizer:LENGth

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:EQUalizer:LENGth
[SENSe:]DDEMod:EQUalizer:LENGth <FilterLength>

This command defines the length of the equalizer in terms of symbols.

Setting parameters:
<FilterLength>
numeric value
Range: | 1 to 256
*RST: | 10
Default unit: | SYM
Example: DDEM:EQU:LENG 101

Sets the equalizer length to 101 symbols.

Manual operation: See "Filter Length"


[SENSe:]DDEMod:EQUalizer:LOAD

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:EQUalizer:LOAD
[SENSe:]DDEMod:EQUalizer:LOAD <Name>

This command selects a user-defined equalizer. The equalizer mode is automatically switched to USER (see [SENSe:​]DDEMod:​EQUalizer:​MODE).

Setting parameters:
<Name> | string Path and file name (without extension)
Example: | DDEM:EQU:LOAD 'D:\MyEqualizer' Selects equalizer named MyEqualizer in directory D.
Manual operation: | See "Store/Load Current Equalizer"


[SENSe:]DDEMod:EQUalizer:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:EQUalizer:MODE
[SENSe:]DDEMod:EQUalizer:MODE <Mode>

Switches between the equalizer modes.

For details see "The Equalizer".

Setting parameters:
<Mode>
NORMal

Switches the equalizer on for the next sweep.

TRACking

Switches the equalizer on; the results of the equalizer in the previous sweep are considered to calculate the new filter.

FREeze

The filter is no longer changed, the current equalizer values are used for subsequent sweeps.

USER

A user-defined equalizer loaded from a file is used.

AVERaging

Switches the equalizer on; the results of the equalizer in all previous sweeps (since the instrument was switched on or the equalizer was reset) are considered to calculate the new filter. To start a new averaging process, use the [SENSe:​]DDEMod:​EQUalizer:​RESet command.

*RST: TRACe
Example: DDEM:EQU:MODE TRAC

Activates the tracking mode of the equalizer.

Manual operation: See "Mode"


[SENSe:]DDEMod:EQUalizer:RESet

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:EQUalizer:RESet
[SENSe:]DDEMod:EQUalizer:RESet

This command deletes the data of the currently selected equalizer. After deletion, training can start again using the command DDEM:EQU:MODE TRA (see [SENSe:​]DDEMod:​EQUalizer:​MODE).

Usage: | Event
Manual operation: | See "Reset Equalizer"


[SENSe:]DDEMod:EQUalizer:SAVE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:EQUalizer:SAVE
[SENSe:]DDEMod:EQUalizer:SAVE <Name>

This command saves the current equalizer results to a file.

Setting parameters:
<Name> | string File name
Example: | DDEM:EQU:SAVE 'D:\MyEqualizer'' Saves the current equalizer results to D:\MyEqualizer.vae.
Manual operation: | See "Store/Load Current Equalizer"


[SENSe:]DDEMod:EQUalizer[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:EQUalizer[:STATe]
[SENSe:]DDEMod:EQUalizer[:STATe] <State>

This command activates or deactivates the equalizer.

For more information on the equalizer see "The Equalizer".

Setting parameters:
<State>
ON | OFF | 1 | 0
*RST: OFF
Example: DDEM:EQU OFF
Manual operation: See "State"


[SENSe:]DDEMod:FSYNc:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:FSYNc:AUTO
[SENSe:]DDEMod:FSYNc:AUTO <FineSyncAuto>

This command selects manual or automatic Fine Sync

Setting parameters:
<FineSyncAuto>
ON | OFF | 1 | 0
*RST: 1
Manual operation: See "Fine Synchronization"


[SENSe:]DDEMod:FSYNc:LEVel

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:FSYNc:LEVel
[SENSe:]DDEMod:FSYNc:LEVel <SERLevel>

This command sets the Fine Sync Level if fine sync works on Known Data

Setting parameters:
<SERLevel>
numeric value
Range: | 0.0 to 100.0
*RST: | 10.0
Default unit: | PCT
Manual operation: See "If SER ≤"


[SENSe:]DDEMod:FSYNc:RESult?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:FSYNc:RESult?
[SENSe:]DDEMod:FSYNc:RESult?

The result of this query is 0 if the fine sync with known data failed, otherwise 1.

Usage: | Query only
Manual operation: | See "Fine Synchronization"


[SENSe:]DDEMod:FSYNc[:MODE]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:FSYNc[:MODE]
[SENSe:]DDEMod:FSYNc[:MODE] <FineSync>

This command defines the fine synchronization mode used to calculate results, e.g. the bit error rate.

Note:You can define a maximum symbol error rate (SER) for the known data in reference to the analyzed data. If the SER of the known data exceeds this limit, the default synchronization using the detected data is performed. See [SENSe:​]DDEMod:​FSYNc:​LEVel.

Setting parameters:
<FineSync>
KDATa | PATTern | DDATa
KDATa

The reference signal is defined as the data sequence from the loaded Known Data file that most closely matches the measured data.

PATTern

The reference signal is estimated from the defined pattern.

This setting requires an activated pattern search, see [SENSe:​]DDEMod:​SEARch:​SYNC:​STATe.

DDATa

(Default) The reference signal is estimated from the detected data.

*RST: DDATa
Manual operation: See "Fine Synchronization"


[SENSe:]DDEMod:KDATa:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:KDATa:STATe
[SENSe:]DDEMod:KDATa:STATe <KnownDataState>

This command selects the Known Data state. The use of known data is a prerequisite for the BER measurement and can also be used for the fine sync.

Setting parameters:
<KnownDataState>
ON | OFF | 1 | 0
*RST: 0
Manual operation: See "Known Data"


[SENSe:]DDEMod:KDATa[:NAME]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:KDATa[:NAME]
[SENSe:]DDEMod:KDATa[:NAME] <FileName>

This command selects the Known Data file

Setting parameters:
<FileName> | string
Manual operation: | See "Load Data File"


[SENSe:]DDEMod:NORMalize:ADRoop

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:NORMalize:ADRoop
[SENSe:]DDEMod:NORMalize:ADRoop <CompAmptDroop>

This command switches the compensation of the amplitude droop on or off.

Setting parameters:
<CompAmptDroop>
ON | OFF | 1 | 0
*RST: 1
Manual operation: See "Compensate for... (PSK, MSK, ASK, QAM)"


[SENSe:]DDEMod:NORMalize:CFDRift

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:NORMalize:CFDRift
[SENSe:]DDEMod:NORMalize:CFDRift <CarrFreqDrift>

This command defines whether the carrier frequency drift is compensated for FSK modulation.

Setting parameters:
<CarrFreqDrift>
ON | OFF | 1 | 0
*RST: 0
Manual operation: See "Compensate for... (FSK)"


[SENSe:]DDEMod:NORMalize:CHANnel

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:NORMalize:CHANnel
[SENSe:]DDEMod:NORMalize:CHANnel <TransmitChannel>

This command switches the channel compensation on or off. (With equalizer only)

Setting parameters:
<TransmitChannel>
ON | OFF | 1 | 0
*RST: 1
Manual operation: See "Compensate for... (PSK, MSK, ASK, QAM)"


[SENSe:]DDEMod:NORMalize:FDERror

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:NORMalize:FDERror
[SENSe:]DDEMod:NORMalize:FDERror <RefDevComp>

This command defines whether the deviation error is compensated for when calculating the frequency error for FSK modulation.

Setting parameters:
<RefDevComp>
ON | OFF | 1 | 0
ON

Scales the reference signal to the actual deviation of the measurement signal.

OFF

Uses the entered nominal deviation for the reference signal.

*RST: 1
Manual operation: See "Compensate for... (FSK)"


[SENSe:]DDEMod:NORMalize:IQIMbalance

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:NORMalize:IQIMbalance
[SENSe:]DDEMod:NORMalize:IQIMbalance <CompIQImbalance>

This command switches the compensation of the IQ imbalance on or off.

Setting parameters:
<CompIQImbalance>
ON | OFF | 1 | 0
*RST: 0
Manual operation: See "Compensate for... (PSK, MSK, ASK, QAM)"


[SENSe:]DDEMod:NORMalize:IQOFfset

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:NORMalize:IQOFfset
[SENSe:]DDEMod:NORMalize:IQOFfset <CompIQOffset>

This command switches the compensation of the IQ offset on or off.

Setting parameters:
<CompIQOffset>
ON | OFF | 1 | 0
*RST: 1
Manual operation: See "Compensate for... (PSK, MSK, ASK, QAM)"


[SENSe:]DDEMod:NORMalize:SRERror

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:NORMalize:SRERror
[SENSe:]DDEMod:NORMalize:SRERror <SymbolClockError>

This command switches the compensation for symbol rate error on or off

Setting parameters:
<SymbolClockError>
ON | OFF | 1 | 0
*RST: 0
Manual operation: See "Compensate for... (PSK, MSK, ASK, QAM)"
See "Compensate for... (FSK)"


[SENSe:]DDEMod:OPTimization

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:OPTimization
[SENSe:]DDEMod:OPTimization <Criterion>

This command determines the optimization criteria for the demodulation. RMSMin Optimization goal is the minimization of RMS of the error vector. EVMMin Optimization goal is the minimization of the EVM.

Setting parameters:
<Criterion>
RMSMin | EVMMin
RMSMin

Optimizes calculation such that the RMS of the error vector is minimal.

EVMMin

Optimizes calculation such that EVM is minimal.

*RST: RMSMin (depends on selected standard)
Manual operation: See "Optimization"


[SENSe:]DDEMod:SEARch:PATTern:SYNC:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:SEARch:PATTern:SYNC:AUTO
[SENSe:]DDEMod:SEARch:PATTern:SYNC:AUTO <UseWfmForSync>

This command selects manual or automatic synchronization with a pattern waveform to speed up measurements.

Setting parameters:
<UseWfmForSync>
AUTO | MANual
*RST: AUTO
Manual operation: See "Coarse Synchronization"


[SENSe:]DDEMod:SEARch:PATTern:SYNC[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Demodulation Settings > [SENSe:]DDEMod:SEARch:PATTern:SYNC[:STATe]
[SENSe:]DDEMod:SEARch:PATTern:SYNC[:STATe] <FastSync>

This command switches fast synchronization on and off, if you manually synchronize with a waveform pattern.

Setting parameters:
<FastSync>
ON | OFF | 1 | 0
*RST: 0
Manual operation: See "Coarse Synchronization"


Measurement Filter Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Measurement Filter Settings
Measurement Filter Settings

You can configure the measurement filter to be used.

Manual configuration of the measurement filter is described in "Measurement Filter Settings".

For more information on measurement filters, refer to "Measurement Filters".

Useful commands for defining measurement filters described elsewhere:
  • [SENSe:​]DDEMod:​FILTer:​ALPHa
  • [SENSe:​]DDEMod:​FILTer[:​STATe]
Remote commands exclusive to configuring measurement filters:
List of Commands
[SENSe:]DDEMod:MFILter:ALPHa
[SENSe:]DDEMod:MFILter:AUTO
[SENSe:]DDEMod:MFILter:NAME
[SENSe:]DDEMod:MFILter[:STATe]
[SENSe:]DDEMod:MFILter:USER


[SENSe:]DDEMod:MFILter:ALPHa

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Measurement Filter Settings > [SENSe:]DDEMod:MFILter:ALPHa
[SENSe:]DDEMod:MFILter:ALPHa <MeasFiltAlphaBT>

This command sets the alpha value of the measurement filter.

Setting parameters:
<MeasFiltAlphaBT>
numeric value
Range: | 0.1 to 1.0
*RST: | 0.22
Default unit: | NONE
Manual operation: See "Alpha/BT"


[SENSe:]DDEMod:MFILter:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Measurement Filter Settings > [SENSe:]DDEMod:MFILter:AUTO
[SENSe:]DDEMod:MFILter:AUTO <MeasFilterAuto>

If this command is set to "ON", the measurement filter is defined automatically depending on the transmit filter (see [SENSe:​]DDEMod:​TFILter:​NAME).

Setting parameters:
<MeasFilterAuto>
ON | OFF | 1 | 0
*RST: ON
Manual operation: See "Using the Transmit Filter as a Measurement Filter (Auto)"


[SENSe:]DDEMod:MFILter:NAME

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Measurement Filter Settings > [SENSe:]DDEMod:MFILter:NAME
[SENSe:]DDEMod:MFILter:NAME <Name>

This command selects a measurement filter and automatically sets its state to "ON".

Setting parameters:
<Name> | Name of the measurement filter or 'User' for a user-defined filter. An overview of available measurement filters is provided in "Measurement Filters".
Manual operation: | See "Type"


[SENSe:]DDEMod:MFILter[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Measurement Filter Settings > [SENSe:]DDEMod:MFILter[:STATe]
[SENSe:]DDEMod:MFILter[:STATe] <MeasFilterState>

Use this command to switch the measurement filter off. To switch a measurement filter on, use the [SENSe:​]DDEMod:​MFILter:​NAME command.

Setting parameters:
<MeasFilterState>
ON | OFF | 1 | 0
OFF

Switches the measurement filter off.

ON

Switches the measurement filter specified by [SENSe:​]DDEMod:​MFILter:​NAME on. However, this command is not necessary, as the [SENSe:​]DDEMod:​MFILter:​NAME command automatically switches the selected filter on.

*RST: 1
Manual operation: See "Type"


[SENSe:]DDEMod:MFILter:USER

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Measurement Filter Settings > [SENSe:]DDEMod:MFILter:USER
[SENSe:]DDEMod:MFILter:USER <FilterName>

This command selects the user-defined measurement filter.

For details on user-defined filters, see "Customized Filters".

Setting parameters:
<FilterName> | Name of the user-defined filter
Example: | SENS:DDEM:MFIL:NAME 'USER' Selects user filter mode for the meas filter ENS:DDEM:MFIL:USER 'D:\MyMeasFilter' Selects the user-defined meas filter
Manual operation: | See "Type" See "Load User Filter"


Defining the Evaluation Range

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Defining the Evaluation Range
Defining the Evaluation Range

The evaluation range defines which range of the result is to be evaluated.

Manual configuration of the evaluation range is described in "Evaluation Range Configuration".

List of Commands
CALCulate<n>:ELIN<startstop>:STATe
CALCulate<n>:ELIN<startstop>[:VALue]


CALCulate<n>:ELIN<startstop>:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Defining the Evaluation Range > CALCulate<n>:ELIN<startstop>:STATe
CALCulate<n>:ELIN<startstop>:STATe <Auto>

This command restricts the evaluation range. The evaluation range is considered for the following display types:

  • eye diagrams
  • constellation diagrams
  • modulation accuracy
  • statistic displays
  • spectrum displays
Suffix:
<startstop>
1..2

irrelevant

Setting parameters:
<Auto>
ON | OFF | 1 | 0
ON

The evaluation range extends from the start value defined by CALC:ELIN1:VAL to the stop value defined by CALC:ELIN2:VAL (see CALCulate<n>:​ELIN<startstop>[:​VALue]).

OFF

The complete result area is evaluated.

*RST: OFF
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Evaluating the Entire Result Range"


CALCulate<n>:ELIN<startstop>[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Defining the Evaluation Range > CALCulate<n>:ELIN<startstop>[:VALue]
CALCulate<n>:ELIN<startstop>[:VALue] <LeftDisp>

Defines the start and stop values for the evaluation range (see CALCulate<n>:​ELIN<startstop>:​STATe).

Suffix:
<startstop>
1..2

1: start value, 2: stop value

Setting parameters:
<LeftDisp>
numeric value
Range: | 0 to 1000000
*RST: | 0
Default unit: | SYM
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Start / Stop"


Adjusting Settings Automatically

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Adjusting Settings Automatically
Adjusting Settings Automatically

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings.

Manual execution of automatic adjustment functions is described in "Adjusting Settings Automatically".

List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:AUTO:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel
[SENSe:]DDEMod:PRESet:RLEVel


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Adjusting Settings Automatically > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: | SCPI confirmed
Manual operation: | See "Auto Scale Once/Auto Scale Window"


DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:AUTO:ALL

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Adjusting Settings Automatically > DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:AUTO:ALL
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:AUTO:ALL

Automatic scaling of the y-axis is performed once in all windows, then switched off again.

Usage: | Event
Manual operation: | See "Auto Scale All"


[SENSe:]ADJust:CONFigure:DURation

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:LEVel

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring VSA > Adjusting Settings Automatically > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel
[SENSe:]DDEMod:PRESet:RLEVel

This command initiates a measurement that evaluates and sets the ideal reference level for the current measurement. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Usage: Event


Performing a Measurement

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement
Performing a Measurement

When the VSA application is activated, a continuous sweep is performed automatically. However, you can stop and start a new measurement any time.

Furthermore, you can perform a sequence of measurements using the Sequencer (see "Multiple Measurement Channels and Sequencer Function").

List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:REFMeas
INITiate:REFResh
INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
SYSTem:SEQuencer


ABORt

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

For a statistics count > 0, this means a restart of the corresponding number of measurements. With trace mode MAXHold, MINHold and AVERage, the previous results are reset on restarting the measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:REFMeas

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > INITiate:REFMeas
INITiate:REFMeas

Repeats the evaluation of the data currently in the capture buffer without capturing new data. This is useful after changing settings, for example filters, patterns or evaluation ranges.

Usage: | Event
Manual operation: | See "Refresh (non-Multistandard mode)"


INITiate:REFResh

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA/MSRT mode, not the MSRA/MSRT Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event
Manual operation: | See "Refresh"


INITiate:SEQuencer:REFResh[:ALL]

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event


INITiate:SEQuencer:ABORt

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


SYSTem:SEQuencer

VSA (R&S FSW-K70) > Remote Commands for VSA > Performing a Measurement > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Analysis

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis
Analysis

General result analysis settings concerning the trace, markers, windows etc. can be configured.

Contents
  • Configuring Traces
  • Working with Markers
  • Configuring Modulation Accuracy Limit Lines
  • Configuring an Analysis Interval and Line (MSRA mode only)
  • Configuring an Analysis Interval and Line (MSRT mode only)
  • Zooming into the Display


Configuring Traces

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Traces
Configuring Traces

The trace settings determine how the measured data is analyzed and displayed on the screen. Depending on the result display, between 1 and 6 traces may be displayed.

Manual configuration of traces is described in "Trace Settings".

Commands for storing trace data are described in "Retrieving Trace Data and Marker Values".

Useful commands for trace configuration described elsewhere:
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]
Remote commands exclusive to trace configuration:
List of Commands
CALCulate<n>:TRACe<t>[:VALue]
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]


CALCulate<n>:TRACe<t>[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Traces > CALCulate<n>:TRACe<t>[:VALue]
CALCulate<n>:TRACe<t>[:VALue] <TrRefType>

This commands selects the measurment or the reference signal as the data source for a trace.

Suffix:
<t>
1..6
Setting parameters:
<TrRefType>
MEAS | REF
*RST: The default for trace 1 is always the measurement signal (MEAS). For all other traces, the default signal type depends on the current measurement.
Usage: SCPI confirmed
Manual operation: See "Evaluation"


DISPlay[:WINDow<n>]:TRACe<t>:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

In case of max hold, min hold or average trace mode, you can set the number of single measurements with [SENSe:​]SWEep:​COUNt[:​VALue]. Note that synchronization to the end of the measurement is possible only in single sweep mode. Depending on the result display, not all trace modes may be available.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

VIEW

The current contents of the trace memory are frozen and displayed.

BLANk

Hides the selected trace.

*RST: Trace 1: WRITe, Trace 2-6: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trace Mode"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6"
See "Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)"


Working with Markers

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers
Working with Markers

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display.

Manual configuration of markers is described in "Markers".

Contents
  • Individual Marker Settings
  • Marker Search and Positioning Settings


Individual Marker Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings
Individual Marker Settings

In VSA evaluations, up to 5 markers can be activated in each diagram at any time.

List of Commands
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:LINK
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<q>:Y?


CALCulate<n>:MARKer<m>:AOFF

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m>:LINK

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:LINK
CALCulate<n>:MARKer<m>:LINK <MarkerCoupling>

With this command markers between several screens can be coupled, i.e. use the same x-value. All screens can be linked with the marker x-value scaled in symbols or time, except those showing the capture buffer. If several capture buffer measurements are visible, their markers are coupled, too.

Setting parameters:
<MarkerCoupling>
ON | OFF | 1 | 0
*RST: 0
Manual operation: See "Couple Windows"


CALCulate<n>:MARKer<m>[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:TRACe

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | 1 to 6 Trace number the marker is assigned to.
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.
Manual operation: | See "Assigning the Marker to a Trace"


CALCulate<n>:MARKer<m>:X

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "X-value"


CALCulate<n>:DELTamarker:AOFF

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:TRACe

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:DELTamarker<m>:X

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Example: | CALC:DELT:X? Outputs the absolute x-value of delta marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4" See "X-value"


CALCulate<n>:DELTamarker<q>:Y?

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<q>:Y?
CALCulate<n>:DELTamarker<q>:Y?

This command moves a marker to a particular coordinate on the x-axis. If necessary, the command activates the marker.

Return values:
<Value> |
Usage: | Query only


Marker Search and Positioning Settings

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings
Marker Search and Positioning Settings

Several functions are available to set the marker to a specific position very quickly and easily. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

Useful commands for positioning markers described elsewhere:
  • CALCulate<n>:​MARKer<m>:​TRACe
  • CALCulate<n>:​DELTamarker<m>:​TRACe
Remote commands exclusive to positioning markers:
List of Commands
CALCulate<n>:DELTamarker<m>:MAXimum:APEak
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:APEak
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer:SEARch
CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits[:STATe]


CALCulate<n>:DELTamarker<m>:MAXimum:APEak

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:APEak
CALCulate<n>:DELTamarker<m>:MAXimum:APEak

This command positions the active marker or deltamarker on the largest absolute peak value (maximum or minimum) of the selected trace.

Usage: Event


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:APEak

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:APEak
CALCulate<n>:MARKer<m>:MAXimum:APEak

sets the marker to the largest absolute peak value (maximum or minimum) of the selected trace.

Usage: | Event
Manual operation: | See "Max |Peak|"


CALCulate<n>:MARKer<m>:MAXimum:LEFT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MINimum:LEFT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:NEXT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:MARKer:SEARch

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer:SEARch
CALCulate<n>:MARKer:SEARch <MarkRealImag>

This command specifies whether the marker search works on the real or the imag trace (for all markers).

Setting parameters:
<MarkRealImag>
REAL | IMAG
*RST: REAL
Manual operation: See "Real / Imag Plot"


CALCulate:MARKer:X:SLIMits:LEFT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:LEFT <SearchLimit>

This command defines the left limit of the marker search range.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<SearchLimit>

The value range depends on the frequency range or sweep time.

The unit is Hz for frequency domain measurements and s for time domain measurements.

*RST: left diagram border
<Limit>
Range: | -1e9 to 1e9
*RST: | 0.0
Example: CALC:MARK:X:SLIM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:LEFT 10MHz

Sets the left limit of the search range to 10 MHz.

Example:

See "Programming Example: Time Domain Power" .

Manual operation: See "Search Limits (Left / Right)"


CALCulate:MARKer:X:SLIMits:RIGHT

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:RIGHT <SearchLimit>

This command defines the right limit of the marker search range.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<Limit>

The value range depends on the frequency range or sweep time.

The unit is Hz for frequency domain measurements and s for time domain measurements.

*RST: right diagram border
<Limit>
Range: | -1e9 to 1e9
*RST: | 800.0
Example: CALC:MARK:X:SLIM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:RIGH 20MHz

Sets the right limit of the search range to 20 MHz.

Example:

See "Programming Example: Time Domain Power" .

Manual operation: See "Search Limits (Left / Right)"


CALCulate:MARKer:X:SLIMits[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Working with Markers > Marker Search and Positioning Settings > CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SLIMits[:STATe] <State>

This command turns marker search limits on and off.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:X:SLIM ON

Switches on search limitation.

Example:

See "Programming Example: Time Domain Power" .

Manual operation: See "Search Limits (Left / Right)"


Configuring Modulation Accuracy Limit Lines

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines
Configuring Modulation Accuracy Limit Lines

The results of a modulation accuracy measurement can be checked for violation of defined limits automatically.

Manual configuration of limit lines is described in "Modulation Accuracy Limit Lines".

Contents
  • General Commands
  • Defining Limits


General Commands

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > General Commands
General Commands

The following commands determine the general behaviour of the limit line check.

List of Commands
CALCulate<n>:LIMit:MACCuracy:DEFault
CALCulate<n>:LIMit:MACCuracy:STATe


CALCulate<n>:LIMit:MACCuracy:DEFault

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > General Commands > CALCulate<n>:LIMit:MACCuracy:DEFault
CALCulate<n>:LIMit:MACCuracy:DEFault

Restores the default limits and deactivates all checks in all windows.

Usage: | Event
Manual operation: | See "Set to Default"


CALCulate<n>:LIMit:MACCuracy:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > General Commands > CALCulate<n>:LIMit:MACCuracy:STATe
CALCulate<n>:LIMit:MACCuracy:STATe <LimitState>

Limits checks for all evaluations based on modulation accuracy (e.g. Result Summary) are enabled or disabled.

Setting parameters:
<LimitState>
ON | OFF | 1 | 0
*RST: 0
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Checking Modulation Accuracy Limits"


Defining Limits

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits
Defining Limits

The following commands are required to define limits for specific results.

List of Commands
CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:STATe
CALCulate<n>:LIMit:MACCuracy:CFERror:MEAN:STATe
CALCulate<n>:LIMit:MACCuracy:CFERror:PEAK:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:PMEan:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:PPEak:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:RCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:RMEan:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:RPEak:STATe
CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent:STATe
CALCulate<n>:LIMit:MACCuracy:FDERror:MEAN:STATe
CALCulate<n>:LIMit:MACCuracy:FDERror:PEAK:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:PMEan:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:PPEak:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:RCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:RMEan:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:RPEak:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:PMEan:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:PPEak:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:RCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:RMEan:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:RPEak:STATe
CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent:STATe
CALCulate<n>:LIMit:MACCuracy:OOFFset:MEAN:STATe
CALCulate<n>:LIMit:MACCuracy:OOFFset:PEAK:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:PMEan:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:PPEak:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:RCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:RMEan:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:RPEak:STATe
CALCulate<n>:LIMit:MACCuracy:RHO:CURRent:STATe
CALCulate<n>:LIMit:MACCuracy:RHO:MEAN:STATe
CALCulate<n>:LIMit:MACCuracy:RHO:PEAK:STATe
CALCulate<n>:LIMit:MACCuracy:<ResultType>:<LimitType>:STATe
CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:CFERror:MEAN:VALue
CALCulate<n>:LIMit:MACCuracy:CFERror:PEAK:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:PMEan:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:PPEak:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:RCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:RMEan:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:RPEak:VALue
CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:FDERror:MEAN:VALue
CALCulate<n>:LIMit:MACCuracy:FDERror:PEAK:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:PMEan:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:PPEak:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:RCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:RMEan:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:RPEak:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:PMEan:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:PPEak:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:RCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:RMEan:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:RPEak:VALue
CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:OOFFset:MEAN:VALue
CALCulate<n>:LIMit:MACCuracy:OOFFset:PEAK:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:PMEan:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:PPEak:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:RCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:RMEan:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:RPEak:VALue
CALCulate<n>:LIMit:MACCuracy:RHO:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:RHO:MEAN:VALue
CALCulate<n>:LIMit:MACCuracy:RHO:PEAK:VALue


CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits > CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:STATe
CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:CFERror:MEAN:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:CFERror:PEAK:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:EVM:PMEan:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:EVM:PPEak:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:EVM:RCURrent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:EVM:RMEan:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:EVM:RPEak:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:FDERror:MEAN:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:FDERror:PEAK:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:FERRor:PMEan:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:FERRor:PPEak:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:FERRor:RCURrent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:FERRor:RMEan:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:FERRor:RPEak:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:MERRor:PMEan:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:MERRor:PPEak:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:MERRor:RCURrent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:MERRor:RMEan:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:MERRor:RPEak:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:OOFFset:MEAN:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:OOFFset:PEAK:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:PERRor:PMEan:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:PERRor:PPEak:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:PERRor:RCURrent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:PERRor:RMEan:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:PERRor:RPEak:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:RHO:CURRent:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:RHO:MEAN:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:RHO:PEAK:STATe <LimitState>
CALCulate<n>:LIMit:MACCuracy:<ResultType>:<LimitType>:STATe <LimitState>

This command switches the limit check for the selected result type and limit type on or off.

Suffix:
<ResultType>

CFERror = Carrier Frequency Error

EVM = Error Vector Magnitude

FERRor = Frequency error (FSK only)

FDERror = Frequency deviation error (FSK only)

MERRor = Magnitude Error

OOFFset = I/Q Offset

PERRor = Phase Error

RHO = Rho

<LimitType>

For CFERor, OOFFset, RHO:

CURRent

MEAN

PEAK

For EVM, FERRor, MERRor, PERRor:

PCURRent = Peak current value

PMEan = Peak mean value

PPEak = Peak peak value

RCURRent = RMS current value

RMEan = RMS mean value

RPEak = RMS peak value

Setting parameters:
<LimitState>
ON | OFF

Activates a limit check for the selected result and limit type.

*RST: OFF
Example: CALC2:FEED 'XTIM:DDEM:MACC'

switch on result summary in screen 2

CALC2:LIM:MACC:CFER:CURR:VAL 100 Hz

define a limit of [-100;100]

CALC2:LIM:MACC:CFER:CURR:STAT ON

switch limit check ON

Manual operation: See "Check"


CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:VALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits > CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:CFERror:MEAN:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:CFERror:PEAK:VALue <LimitValue>

This command defines the limit for the current, peak or mean center frequency error limit. Note that the limits for the current and the peak value are always kept identical.

Setting parameters:
<LimitValue>
numeric value

the value x (x>0) defines the interval [-x; x]

Range: | 0.0 to 1000000
*RST: | 1000.0 (mean: 750.0)
Default unit: | Hz


CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent:VALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits > CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:EVM:PMEan:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:EVM:PPEak:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:EVM:RCURrent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:EVM:RMEan:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:EVM:RPEak:VALue <LimitValue>

This command defines the value for the current, peak or mean EVM (peak or RMS) limit. Note that the limits for the current and the peak value are always kept identical.

Setting parameters:
<LimitValue>
numeric value
Range: | 0.0 to 100
*RST: | 1.5
Default unit: | %


CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent:VALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits > CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:FDERror:MEAN:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:FDERror:PEAK:VALue <LimitValue>

This command defines the lower limit for the current, peak or mean center frequency deviation error. Note that the limits for the current and the peak value are always kept identical.

This command is available for FSK modulation only.

Setting parameters:
<LimitValue>
numeric value
Range: | 0.0 to 1000000
*RST: | 1 kHz
Default unit: | Hz


CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent:VALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits > CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:FERRor:PMEan:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:FERRor:PPEak:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:FERRor:RCURrent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:FERRor:RMEan:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:FERRor:RPEak:VALue <LimitValue>

This command defines the value for the current, peak or mean frequency error (peak or RMS) limit. Note that the limits for the current and the peak value are always kept identical.

This command is available for FSK modulation only.

Setting parameters:
<LimitValue>
numeric value

the value x (x>0) defines the interval [-x; x]

Range: | 0.0 to 100
*RST: | 1.5 (mean: 1.0)
Default unit: | Hz


CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent:VALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits > CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:MERRor:PMEan:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:MERRor:PPEak:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:MERRor:RCURrent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:MERRor:RMEan:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:MERRor:RPEak:VALue <LimitValue>

This command defines the value for the current, peak or mean magnitude error (peak or RMS) limit. Note that the limits for the current and the peak value are always kept identical.

Setting parameters:
<LimitValue>
numeric value

the value x (x>0) defines the interval [-x; x]

Range: | 0.0 to 100
*RST: | 1.5
Default unit: | %


CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent:VALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits > CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:OOFFset:MEAN:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:OOFFset:PEAK:VALue <LimitValue>

This command defines the upper limit for the current, peak or mean I/Q offset. Note that the limits for the current and the peak value are always kept identical.

Setting parameters:
<LimitValue>
numeric value
Range: | -200.0 to 0.0
*RST: | -40.0 (mean: -45.0)
Default unit: | DB


CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent:VALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits > CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:PERRor:PMEan:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:PERRor:PPEak:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:PERRor:RCURrent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:PERRor:RMEan:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:PERRor:RPEak:VALue <LimitValue>

This command defines the value for the current, peak or mean phase error (peak or RMS) limit. Note that the limits for the current and the peak value are always kept identical.

Setting parameters:
<LimitValue>
numeric value

the value x (x>0) defines the interval [-x; x]

Range: | 0.0 to 360
*RST: | 3.5 (RMS: 1.5)
Default unit: | deg


CALCulate<n>:LIMit:MACCuracy:RHO:CURRent:VALue

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring Modulation Accuracy Limit Lines > Defining Limits > CALCulate<n>:LIMit:MACCuracy:RHO:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:RHO:CURRent:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:RHO:MEAN:VALue <LimitValue>
CALCulate<n>:LIMit:MACCuracy:RHO:PEAK:VALue <LimitValue>

This command defines the lower limit for the current, peak or mean Rho limit. Note that the limits for the current and the peak value are always kept identical.

Setting parameters:
<LimitValue>
numeric value
Range: | 0.0 to 1.0
*RST: | 0.999 (mean: 0.9995)
Default unit: | NONE


Configuring an Analysis Interval and Line (MSRA mode only)

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRA mode only)
Configuring an Analysis Interval and Line (MSRA mode only)

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRA applications.

For the VSA application, the commands to define tha analysis interval are the same as those used to define the actual data acquisition (see "Signal Capture". Be sure to select the correct measurement channel before executing these commands.

Useful commands related to MSRA mode described elsewhere:
  • INITiate:​REFResh
  • INITiate:​SEQuencer:​REFResh[:​ALL]
Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:MSRA:ALINe:SHOW

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:MSRA:ALINe[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:MSRA:WINDow<n>:IVAL?

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


[SENSe:]MSRA:CAPTure:OFFSet

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRA mode only) > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Configuring an Analysis Interval and Line (MSRT mode only)

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRT mode only)
Configuring an Analysis Interval and Line (MSRT mode only)

In MSRT operating mode, only the MSRT Master actually captures data; the MSRT applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRT applications.

For the VSA application, the commands to define the analysis interval are the same as those used to define the actual data acquisition (see "Signal Capture". Be sure to select the correct measurement channel before executing these commands.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for vector signal analysis.

Useful commands related to MSRT mode described elsewhere:
  • INITiate:​REFResh
  • INITiate:​SEQuencer:​REFResh[:​ALL]
Remote commands exclusive to MSRT applications

The following commands are only available for MSRT application channels:

List of Commands
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
[SENSe:]RTMS:CAPTure:OFFSet


CALCulate:RTMS:ALINe:SHOW

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRT applications and the MSRT Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:RTMS:ALINe[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRT applications and the MSRT Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time (pretrigger + posttrigger) of the MSRT measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:RTMS:WINDow<n>:IVAL?

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate:RTMS:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRT View or MSRT Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


[SENSe:]RTMS:CAPTure:OFFSet

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Configuring an Analysis Interval and Line (MSRT mode only) > [SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]RTMS:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRT mode, not for the MSRT Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | - [pretrigger time] to min (posttrigger time; sweep time)
*RST: | 0
Manual operation: See "Capture Offset"


Zooming into the Display

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Zooming into the Display
Zooming into the Display
Contents
  • Using the Single Zoom
  • Using the Multiple Zoom


Using the Single Zoom

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Zooming into the Display > Using the Single Zoom
Using the Single Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Single Zoom"


DISPlay[:WINDow<n>]:ZOOM:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.

Manual operation: See "Single Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Using the Multiple Zoom

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Zooming into the Display > Using the Multiple Zoom
Using the Multiple Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area for a multiple zoom.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Suffix:
<zoom>
1...4

Selects the zoom window.

Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Multiple Zoom"


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Analysis > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe <State>

This command turns the mutliple zoom on and off.

Suffix:
<zoom>
1...4

Selects the zoom window.

If you turn off one of the zoom windows, all subsequent zoom windows move up one position.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Multiple Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Configuring the Result Display

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display
Configuring the Result Display

The following commands are required to configure the result display in a remote environment. The tasks for manual operation are described in "Display and Window Configuration".

Contents
  • General Window Commands
  • Working with Windows in the Display
  • VSA Window Configuration


General Window Commands

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:TYPe?


LAYout:ADD[:WINDow]?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Capture Buffer"
See "Measurement & Reference Signal"
See "Symbols"
See "Error Vector"
See "Modulation Errors"
See "Modulation Accuracy"
See "Equalizer"
See "Signal Source"

For a detailed example see "Measurement Example 1: User-defined Measurement of Continuous QPSK Signal".

<WindowType> parameter values for VSA application
Parameter value | Data source (+default result display)
CBUFfer | Capture buffer (Magnitude absolute)
MEAS | Meas & Ref (Magnitude relative)
REF
EQUalizer | Equalizer
EVECtor | Error vector (EVM)
MACCuracy | Modulation Accuracy (Result Summary)
MERRor | Modulation Errors (Magnitude error)
SYMB | Symbols (Hexadecimal)


LAYout:CATalog[:WINDow]?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


LAYout:WINDow<n>:TYPe?

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:TYPe?
LAYout:WINDow<n>:TYPe?

Queries the window type of the window specified by the index <n>. For a list of possible window types see LAYout:​ADD[:​WINDow]?.

Example: | LAY:WIND2:TYPE? Response: MACC Modulation accuracy
Usage: | Query only


VSA Window Configuration

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration
VSA Window Configuration

For each window you can select a different evaluation method (result type), based on the data source selected in the "Display Configuration". Further window settings are available for some result types.

Manual configuration of VSA windows is described in "Window Configuration".

Useful commands for configuring the window described elsewhere:
  • LAYout:​ADD[:​WINDow]?
Remote commands exclusive to configuring VSA windows:
List of Commands
CALCulate<n>:DDEM:SPECtrum[:STATe]
CALCulate<n>:FEED
CALCulate<n>:FORMat
CALCulate<n>:STATistics:CCDF[:STATe]
CALCulate<n>:STATistics:MODE
DISPlay[:WINDow<n>]:ITEM[:LINE][:VALue]
DISPlay[:WINDow<n>]:PRATe:AUTO
DISPlay[:WINDow<n>]:PRATe[:VALue]
DISPlay[:WINDow<n>]:TRACe:SYMBol
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE


CALCulate<n>:DDEM:SPECtrum[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > CALCulate<n>:DDEM:SPECtrum[:STATe]
CALCulate<n>:DDEM:SPECtrum[:STATe] <AddEvaluation>

This command switches the result type transformation to spectrum mode. Spectral evaluation is available for the following result types:

  • MAGNitude
  • PHASe/UPHase
  • FREQuency
  • Real/Imag (RIMAG)

The result types are defined using the CALC:FORM command (see CALCulate<n>:​FORMat).

Setting parameters:
<AddEvaluation>
ON | OFF | 1 | 0
*RST: 0
Example: CALC:FEED 'XTIM:DDEM:MEAS'

Selects the meas signal.

CALC:FORM PHAS

Selects the phase measurement.

CALC:DDEM:SPEC:STAT ON

Selects the spectral display of the phase.

Manual operation: See "Result Type Transformation"


CALCulate<n>:FEED

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > CALCulate<n>:FEED
CALCulate<n>:FEED <Feed>

Selects the signal source (and for the equalizer also the result type) for evaluation.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display"). Only for the "Equalizer Impulse Response" and "Equalizer Frequency Response" this command is required.

Setting parameters:
<Feed>
string
'XTIM:DDEM:MEAS'

Measured signal

'XTIM:DDEM:REF'

Reference signal

'XTIM:DDEM:ERR:VECT'

Error vector

'XTIM:DDEM:ERR:MPH'

Modulation errors

'XTIM:DDEM:MACC'

Modulation accuracy

'XTIM:DDEM:SYMB'

Symbol table

'TCAP'

Capture Buffer

'XTIM:DDEM:IMP'

Equalizer Impulse Response

'XFR:DDEM:RAT'

Equalizer Frequency Response

'XFR:DDEM:IRAT'

Equalizer Channel Frequency Response Group Delay


CALCulate<n>:FORMat

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > CALCulate<n>:FORMat
CALCulate<n>:FORMat <Format>

This command defines the result type of the traces. Which parameters are available depends on the setting for the data source (see LAYout:​ADD[:​WINDow]? and table "Available result types depending on data source").

Whether the result type shows absolute or relative values is defined using the DISP:WIND:TRAC:Y:MODE command (see DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE).

Setting parameters:
<Format> | MAGNitude | PHASe | UPHase | RIMag | FREQuency | COMP | CONS | IEYE | QEYE | FEYE | CONF | COVF | RCONstellation | RSUMmary | BERate | GDELay | MOVerview | NONE MAGNitude Magnitude Absolute MOVerview Magnitude Overview Absolute (entire capture buffer) PHASe Phase Wrap UPHase Phase Unwrap RIMag Real/Imag (I/Q) FREQuency Frequency Absolute COMP Vector I/Q CONS Constellation I/Q IEYE Eye Diagram Real (I) QEYE Eye Diagram Imag (Q) FEYE Eye Diagram Frequency CONF Constellation Frequency COVF Vector Frequency RCONstellation Constellation I/Q (Rotated) RSUMmary Result summary BERate Bit error rate GDELay Frequency Response Group Delay
Example: | See "Measurement Example 1: User-defined Measurement of Continuous QPSK Signal".
Manual operation: | See "Result Type"


CALCulate<n>:STATistics:CCDF[:STATe]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > CALCulate<n>:STATistics:CCDF[:STATe]
CALCulate<n>:STATistics:CCDF[:STATe] <AddEvaluation>

This command switches the measurement of the statistical distribution of magnitude, phase or frequency values on or off.

Setting parameters:
<AddEvaluation>
ON | OFF | 1 | 0
*RST: 0
Manual operation: See "Result Type Transformation"


CALCulate<n>:STATistics:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > CALCulate<n>:STATistics:MODE
CALCulate<n>:STATistics:MODE <StatisticMode>

This command defines whether only the symbol points or all points are considered for the statistical calculations.

Setting parameters:
<StatisticMode>
SONLy | INFinite
SONLy

Symbol points only are used

INFinite

All points are used

*RST: SONLy
Manual operation: See "Oversampling"


DISPlay[:WINDow<n>]:ITEM[:LINE][:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > DISPlay[:WINDow<n>]:ITEM[:LINE][:VALue]
DISPlay[:WINDow<n>]:ITEM[:LINE][:VALue] <SingleValue>
DISPlay[:WINDow<n>]:ITEM[:LINE][:VALue]? <SingleValue>

This commands switches between the whole Result Summary and the diagram showing only a single value, e.g. the EVM RMS value as a bargraph. The same parameters are available as those for which modulation accuracy limits can be defined (see "Limit Value").

Parameters:
<SingleValue>
ALL | EVMR | EVMP | PERM | PEP | MERM | MEP | CFER | RHO | IQOF | FERM | FEP | FDER
ALL

Complete Result Summary

EVMR

RMS EVM

EVMP

Peak EVM

PERM

RMS Phase error

PEP

Peak phase error

MERM

RMS Magnitude error

MEP

Peak magnitude error

CFER

Carrier frequency error

RHO

RHO

IQOF

I/Q offset

FERM

RMS frequency error

FEP

Peak frequency error

FDER

FSK deviation error

*RST: ALL
Manual operation: See "Result Summary - Individual Results"


DISPlay[:WINDow<n>]:PRATe:AUTO

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > DISPlay[:WINDow<n>]:PRATe:AUTO
DISPlay[:WINDow<n>]:PRATe:AUTO <DisplayPPSMode>

Defines the number of display points that are displayed per symbol automatically, i.e. according to [SENSe:​]DDEMod:​PRATe. To define a different number of points per symbol for display, use the MANual parameter and the DISPlay[:​WINDow<n>]:​PRATe[:​VALue] command.

Setting parameters:
<DisplayPPSMode>
AUTO | MANual
*RST: AUTO
Manual operation: See "Display Points/Sym"


DISPlay[:WINDow<n>]:PRATe[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > DISPlay[:WINDow<n>]:PRATe[:VALue]
DISPlay[:WINDow<n>]:PRATe[:VALue] <DisplayPPS>

This command determines the number of points to be displayed per symbol if manual mode is selected (see DISPlay[:​WINDow<n>]:​PRATe:​AUTO).

This command is not available for result displays based on the capture buffer; in this case, the displayed points per symbol are defined by the sample rate ([SENSe:​]DDEMod:​PRATe command).

Setting parameters:
<DisplayPPS>
1, 2, 4, 8,16 or 32
1

only the symbol time instants are displayed

2, 4, 8, 16, 32

more points are displayed than symbols

*RST: 4
Manual operation: See "Display Points/Sym"


DISPlay[:WINDow<n>]:TRACe:SYMBol

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > DISPlay[:WINDow<n>]:TRACe:SYMBol
DISPlay[:WINDow<n>]:TRACe:SYMBol

This command enables the display of the decision instants (time when the signals occurred) as dots on the trace.

Manual operation: See "Highlight Symbols"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Configuring the Result Display > VSA Window Configuration > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE <Mode>

This command selects the type of scaling of the y-axis.

When the display update during remote control is off, this command has no immediate effect.

Parameters:
<Mode>
ABSolute

absolute scaling of the y-axis

RELative

relative scaling of the y-axis

*RST: ABSolute
Example: DISP:TRAC:Y:MODE REL


Retrieving Results

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results
Retrieving Results

The following commands are required to retrieve the calculated VSA parameters.

All results that are not based on the capture buffer data are calculated for a single result range only (see "Result Range"). To retrieve the results for several result ranges, use the [SENSe:​]DDEMod:​SEARch:​MBURst:​CALC command to move from one result range to the next.

Contents
  • Retrieving Trace Data and Marker Values
  • Measurement Results for TRACe<n>[:DATA]? TRACE<n>
  • Retrieving Parameter Values
  • Retrieving Limit Check Results


Retrieving Trace Data and Marker Values

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values
Retrieving Trace Data and Marker Values

In order to retrieve the trace and marker results in a remote environment, use the following commands:

All results that are not based on the capture buffer data are calculated for a single result range only (see "Result Range"). To retrieve the results for several result ranges, use the [SENSe:​]DDEMod:​SEARch:​MBURst:​CALC command to move from one result range to the next.

List of Commands
CALCulate<n>:DELTamarker<m>:X:ABSolute?
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:MARKer<m>:Y?
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STARt?
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STOP?
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:MODE
MMEMory:STORe<n>:TRACe
[SENSe:]DDEMod:SEARch:MBURst:STARt?
TRACe<n>[:DATA]


CALCulate<n>:DELTamarker<m>:X:ABSolute?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > CALCulate<n>:DELTamarker<m>:X:ABSolute?
CALCulate<n>:DELTamarker<m>:X:ABSolute?

This command queries the absolute x-value of the selected delta marker in the specified window. The command activates the corresponding delta marker, if necessary.

Usage: Query only


CALCulate<n>:DELTamarker<m>:X:RELative?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only


CALCulate<n>:MARKer<m>:Y?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only


DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STARt?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STARt?
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STARt?

This command queries the first value of the x-axis in symbols or time, depending on the unit setting for the x-axis.

Note: using the CALCulate<n>:​TRACe<t>:​ADJust:​ALIGnment:​OFFSet command, the burst is shifted in the diagram; the x-axis thus no longer begins on the left at 0 symbols but at a selectable value.

Example: | See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".
Usage: | Query only


DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STOP?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STOP?
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STOP?

This command queries the last value of the x-axis in symbols or time, depending on the unit setting for the x-axis.

Note: If the burst is shifted (using the CALC:TRAC:ALIG commands) the x-axis no longer begins at 0 symbols on the left, but at a user-defined value.

Example: | CALC:TRAC:ADJ BURS Defines the burst as the reference for the screen display CALC:TRAC:ADJ:ALIG CENT Position the burst at the center of the screen DISP:TRAC:X:STOP? Queries the stop value of the x-axis
Usage: | Query only


FORMat:DEXPort:DSEParator

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.

Manual operation: See "Decimal Separator"


FORMat:DEXPort:HEADer

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > FORMat:DEXPort:HEADer
FORMat:DEXPort:HEADer <Header>

This command defines if a file header (including start frequency, sweep time, detector, etc.) is created or not. A small header with the instrument model, the version and the date is always transferred.

Setting parameters:
<Header>
ON | OFF | 1 | 0
*RST: 0
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Header"


FORMat:DEXPort:MODE

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > FORMat:DEXPort:MODE
FORMat:DEXPort:MODE <Mode>

This command defines which data are transferred, raw I/Q data or trace data.

Setting parameters:
<Mode>
RAW | TRACe
*RST: TRACe
Example:

See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".

Manual operation: See "Data Export Mode"


MMEMory:STORe<n>:TRACe

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > MMEMory:STORe<n>:TRACe
MMEMory:STORe<n>:TRACe <Trace>, <FileName>

This command exports trace data from the specified window to an ASCII file.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<Trace> | Number of the trace to be stored
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR1:TRAC 3,'C:\TEST.ASC' Stores trace 3 from window 1 in the file TEST.ASC.
Usage: | SCPI confirmed
Manual operation: | See "Trace ASCII Export"


[SENSe:]DDEMod:SEARch:MBURst:STARt?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > [SENSe:]DDEMod:SEARch:MBURst:STARt?
[SENSe:]DDEMod:SEARch:MBURst:STARt?

This command queries the start of the current result range within the capture buffer.

Return values:
<StartValue>

Symbol or time at which x-axis starts

Example:
INIT:CONT OFF
//switch to single sweep mode
INIT;*WAI
//perform single sweep
SENS:DDEM:SEAR:MBUR:CALC 1
//switch to first result range
SENS:DDEM:SEAR:MBUR:START?
//query start of current (=first) result range
// in the capture buffer
SENS:DDEM:SEAR:MBUR:CALC 2
//switch to second result range
SENS:DDEM:SEAR:MBUR:START?
//query start of current (=second) result range
// in the capture buffer
Usage: Query only


TRACe<n>[:DATA]

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Trace Data and Marker Values > TRACe<n>[:DATA]
TRACe<n>[:DATA] <Trace>

This command queries the trace data.

Which data is returned depends on the result display in the window specified by the suffix <n>.

For details see "Measurement Results for TRACe<n>[:DATA]? TRACE<n>".

Setting parameters:
<Trace>
TRACe1 | TRACe2 | TRACe3 | TRACe4 | TRACe5 | TRACe6 | TRACe1R | TRACe1I | TRACe2R | TRACe2I | TRACe3R | TRACe3I
TRACe1/2/3/4/5/6

The complete data from the corresponding trace.

TRACe1R/TRACe2R/TRACe3R

The real data from the corresponding trace. The parameters are available for the Real/Imaginary result types.

TRACe1I/TRACe2I/TRACe3I

The imaginary data from the corresponding trace. The parameters are available for the Real/Imaginary result types.

Example:

See "Measurement Example 3: User-Defined Pattern Search and Limit Check".


Measurement Results for TRACe<n>[:DATA]? TRACE<n>

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n>
Measurement Results for TRACe<n>[:DATA]? TRACE<n>

The evaluation data source selected by the LAY:ADD:WIND command and the result type selected by the CALCulate<n>:​FORMat command also affect the results of the trace data query (see TRACe<n>[:DATA]? TRACE<n>).

Details on the returned trace data depending on the evaluation data source and result type are provided here.

Contents
  • Capture Buffer Results
  • Cartesian Diagrams
  • Polar Diagrams
  • Symbols
  • Result Summary
  • Equalizer


Capture Buffer Results

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Capture Buffer Results
Capture Buffer Results

For the result displays based on the capture buffer, the command returns the y-axis values of the data that is stored in the capture buffer. The number of returned values depends on the size of the capture buffer and the sample rate. For example, a capture buffer size of 500 symbols in combination with a sample rate of 4 would return 2000 level values.

The scaling of the capture buffer depends on the input source:
  • Scaling is relative to the current reference level for RF input.
  • Scaling is relative to the full scale level for I/Q input.

The unit is dBm.

Note that the trace results return only the values for the currently displayed capture buffer range (see also "Capture Buffer Display"). For the Magnitude Overview Absolute result display, this command returns a maximum of 25,000 values (corresponding to the displayed trace points).

You can query the x-value that relates to the first value of the y-axis using DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​STARt?.


Cartesian Diagrams

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Cartesian Diagrams
Cartesian Diagrams

For cartesian diagrams (magnitude, phase, frequency, real/imag, eye diagrams), the command returns the y-values of the trace. The number of returned values is the product of the "Result Length" and the display points per symbol. The unit depends on the specified unit (see "Scaling and Units").

You can query the x-value that relates to the first value of the y-axis using DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​STARt?.

The eye diagram result displays are the same as the real/imag result display; the results for eye diagrams are merely superimposed in the display.


Polar Diagrams

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Polar Diagrams
Polar Diagrams
For polar diagrams, the command returns a pair of values for each trace point. The first value is the real part, the second value the imaginary part. The number of returned value pairs depends on the result type:
  • Vector I/Q:
    evaluation range length * display points per symbol
  • Constellation I/Q:
    evaluation range length
  • Constellation Frequency and Vector Frequency: one value for each trace point on the y-axis


Symbols

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbols
Symbols

For the symbol table result diagrams, the command returns one value for each number in the table. The command always returns the values in the decimal format. The number of returned values depends on the modulation scheme you have selected.


Result Summary

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Result Summary
Result Summary

For the Result Summary, the command returns all values listed in the result table from top to bottom, i.e.:

<EVM_RMS>,<EVM_Peak>,<MER_RMS>,<MER_Peak>,<Phase Error RMS>,<Phase Error Peak>,<MagError_RMS>,<MagError_Peak>,<Carrier Frequency Error>,<Rho>,<I/Q Offset>,<I/Q Imbalance>,<Gain Imbalance>,<Quadratue Error>,Amplitude Droop>,<Power>,<Symbol Rate Error>

(Note that the "Symbol Rate Error" was appended at the end to provide compatibility to previous versions and instruments.)

For each result type, both the current and statistical values are provided. The order of the results is as follows:

<result1_current>, <result1_mean>, <result1_peak>, <result1_stddev>, <result1_95%ile>,

<result2_current>, <result2_mean>, (...)

Empty cells in the table return nothing. The number of returned values depends on the modulation scheme you have selected. PSK, MSK and QAM modulation returns 85 values, FSK modulation returns 55 values. The unit of each value depends on the particular result.

For more details on the Result Summary see "Result Summary".


Equalizer

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Equalizer
Equalizer
For Equalizer diagrams, the command returns the y-axis values of the equalizer trace. The number of returned values depends on the result type:
  • For impulse response diagrams:
    (filter length * sample rate) +1
  • For frequency response, channel and group delay diagrams: 4096 values

You can query the x-value that relates to the first value of the y-axis using DISPlay[:​WINDow<n>]:​TRACe<t>:​X[:​SCALe]:​STARt?.


Retrieving Parameter Values

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values
Retrieving Parameter Values

For each parameter, the VSA application calculates and shows various statistical values:

  • Current value
  • Mean value
    Calculated as the average of the number of results defined by the "Statistic Count".
  • Peak value
  • Standard deviation
  • 95 percentile
    Unlike the mean value, the 95%ile is a result of all measurement results since the last start of a single or continous sweep, or of all measurements since the last change of a measurement parameter.

For details on the individual parameters see "Common Parameters in VSA" and "Formulae".

All results that are not based on the capture buffer data are calculated for a single result range only (see "Result Range"). To retrieve the results for several result ranges, use the [SENSe:​]DDEMod:​SEARch:​MBURst:​CALC command to move from one result range to the next.

List of Commands
CALCulate<n>:BERate
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ADRoop?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ALL?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:CFERror?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:EVM?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FDERror?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:CFDRift?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:DERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:MDEViation?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:RDEViation?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:GIMBalance?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:IQIMbalance?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MPOWer?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:OOFFset?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:PERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:QERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:RHO?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SNR?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SRERror?


CALCulate<n>:BERate

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:BERate
CALCulate<n>:BERate <Format>

Queries the Bit Error Rate results. The available results are described in "Bit Error Rate (BER)".

Query parameters:
<Format>

Specifies a particular BER result to be queried. If no parameter is specified, the current bit error rate is returned.

The parameters for these results are listed in table "Parameters for BER result values".

Parameters for BER result values
Result | Current | Min | Max | Acc
Bit Error Rate | CURRent | MIN | MAX | TOTal
Total # of Errors | TECurrent | TEMIN | TEMAX | TETotal
Total # of Bits | TCURrent | TMIN | TMAX | TTOTal


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ADRoop?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ADRoop?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ADRoop? <type>

This command queries the results of the amplitude droop error measurement performed for digital demodulation. The output values are the same as those provided in the Modulation Accuracy table (see "Result Summary").

Query parameters:
<type> | <none> Amplitude droop in dB/symbol (for current sweep) AVG Amplitude droop in dB/symbol, evaluating the linear average value over several sweeps RPE Peak value for amplitude droop over several sweeps SDEV Standard deviation of amplitude droop PCTL 95 percentile value of amplitude droop
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ALL?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ALL?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ALL?

The command queries all results of the result summary as shown on the screen.

Usage: Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:CFERror?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:CFERror?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:CFERror? <type>

This command queries the results of the carrier frequency error measurement performed for digital demodulation.

The output values are the same as those provided in the Modulation Accuracy table.

Query parameters:
<type> | <none> Carrier frequency error for current sweep AVG Average carrier frequency error over several sweeps RPE Peak carrier frequency error over several sweeps SDEV Standard deviation of frequency error PCTL 95 percentile value of frequency error
Example: | See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:EVM?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:EVM?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:EVM? <type>

This command queries the results of the error vector magnitude measurement of digital demodulation. The output values are the same as those provided in the Modulation Accuracy table .

Query parameters:
<type> | <none> RMS EVM value of display points of current sweep AVG Average of RMS EVM values over several sweeps PAVG Average of maximum EVM values over several sweeps PCTL 95% percentile of RMS EVM value over several sweeps PEAK Maximum EVM over all symbols of current sweep PPCT 95% percentile of maximum EVM values over several sweeps PSD Standard deviation of maximum EVM values over several sweeps RPE Maximum value of RMS EVM over several sweeps SDEV Standard deviation of EVM values over several sweeps TPE Maximum EVM over all display points over several sweeps
Example: | See "Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard".
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FDERror?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FDERror?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FDERror? <type>

This command queries the results of the FSK deviation error of FSK modulated signals.

Query parameters:
<type> | <none> Deviation error for current sweep. AVG Average FSK deviation error. RPE Peak FSK deviation error. SDEV Standard deviation of FSK deviation error. PCTL 95 percentile value of FSK deviation error.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:CFDRift?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:CFDRift?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:CFDRift? <type>

This command queries the results of the carrier frequency drift for FSK modulated signals.

Query parameters:
<type> | <none> Carrier frequency drift for current sweep. AVG Average FSK carrier frequency drift over several sweeps. RPE Peak FSK carrier frequency drift over several sweeps. SDEV Standard deviation of FSK carrier frequency drift. PCTL 95 percentile value of FSK carrier frequency drift.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:DERRor?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:DERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:DERRor? <type>

This command queries the results of the frequency error of FSK modulated signals.

Query parameters:
<type> | <none> RMS frequency error of display points of current sweep AVG Average of RMS frequency errors over several sweeps PAVG Average of maximum frequency errors over several sweeps PCTL 95% percentile of RMS frequency error over several sweeps PEAK Maximum EVM over all symbols of current sweep PPCT 95% percentile of maximum frequency errors over several sweeps PSD Standard deviation of maximum frequency errors over several sweeps RPE Maximum value of RMS EVM over several sweeps SDEV Standard deviation of frequency errors over several sweeps TPE Maximum EVM over all display points over several sweeps
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:MDEViation?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:MDEViation?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:MDEViation? <type>

This command queries the results of the measurement deviation of FSK modulated signals.

Query parameters:
<type> | <none> Measurement deviation for current sweep. AVG Average FSK measurement deviation over several sweeps. RPE Peak FSK measurement deviation over several sweeps. SDEV Standard deviation of FSK measurement deviation. PCTL 95 percentile value of FSK measurement deviation.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:RDEViation?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:RDEViation?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:RDEViation? <type>

This command queries the results of the reference deviation of FSK modulated signals.

Query parameters:
<type> | <none> Measurement deviation for current sweep. AVG Average FSK measurement deviation over several sweeps. RPE Peak FSK measurement deviation over several sweeps. SDEV Standard deviation of FSK measurement deviation. PCTL 95 percentile value of FSK measurement deviation.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:GIMBalance?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:GIMBalance?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:GIMBalance? <type>

This command queries the results of the Gain Imbalance error measurement of digital demodulation. The output values are the same as those provided in the Modulation Accuracy table .

Query parameters:
<type> | <none> Gain imbalance error for current sweep AVG Average gain imbalance error over several sweeps RPE Peak gain imbalance error over several sweeps SDEV Standard deviation of gain imbalance error PCTL 95 percentile value of gain imbalance error
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:IQIMbalance?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:IQIMbalance?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:IQIMbalance? <type>

This command queries the results of the I/Q imbalance error measurement of digital demodulation.

Query parameters:
<type> | <none> I/Q imbalance error (for current sweep) AVG Average I/Q imbalance error over several sweeps RPE Peak I/Q imbalance error over several sweeps SDEV Standard deviation of I/Q imbalance error PCTL 95 percentile value of I/Q imbalance error
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MERRor?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MERRor? <type>

This command queries the results of the magnitude error measurement of digital demodulation.

Query parameters:
<type> | <none> RMS magnitude error of display points of current sweep AVG Average of RMS magnitude errors over several sweeps PAVG Average of maximum magnitude errors over several sweeps PCTL 95% percentile of RMS magnitude error over several sweeps PEAK Maximum EVM over all symbols of current sweep PPCT 95% percentile of maximum magnitude errors over several sweeps PSD Standard deviation of maximum magnitude errors over several sweeps RPE Maximum value of RMS EVM over several sweeps SDEV Standard deviation of magnitude errors over several sweeps TPE Maximum EVM over all display points over several sweeps
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MPOWer?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MPOWer?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MPOWer? <type>

This command queries the results of the power measurement of digital demodulation.

Query parameters:
<type> | <none> power measurement (for current sweep) AVG Average of power measurement over several sweeps RPE Peak of power measurement over several sweeps SDEV Standard deviation of power measurement PCTL 95 percentile value of power measurement
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:OOFFset?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:OOFFset?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:OOFFset? <type>

This command queries the results of the I/Q offset measurement performed for digital demodulation.

Query parameters:
<type> | <none> Origin offset error (for current sweep) AVG Average origin offset error over several sweeps RPE Peak origin offset error over several sweeps SDEV Standard deviation of origin offset error PCTL 95 percentile value of origin offset error
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:PERRor?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:PERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:PERRor? <type>

This command queries the results of the phase error measurement performed for digital demodulation.

Query parameters:
<type> | <none> RMS phase error of display points of current sweep AVG Average of RMS phase errors over several sweeps PAVG Average of maximum phase errors over several sweeps PCTL 95% percentile of RMS phase error over several sweeps PEAK Maximum EVM over all symbols of current sweep PPCT 95% percentile of maximum phase errors over several sweeps PSD Standard deviation of maximum phase errors over several sweeps RPE Maximum value of RMS EVM over several sweeps SDEV Standard deviation of phase errors over several sweeps TPE Maximum EVM over all display points over several sweeps
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:QERRor?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:QERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:QERRor? <type>

This command queries the results of the Quadratur error measurement performed for digital demodulation.

Query parameters:
<type> | <none> quadrature error (for current sweep) AVG Average quadrature error over several sweeps RPE Peak quadrature error over several sweeps SDEV Standard deviation of quadrature error PCTL 95 percentile value of quadrature error
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:RHO?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:RHO?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:RHO? <type>

This command queries the results of the Rho factor measurement performed for digital demodulation.

Query parameters:
<type> | <none> Rho factor (for current sweep) AVG Average rho factor over several sweeps RPE Peak rho factor over several sweeps SDEV Standard deviation of rho factor PCTL 95 percentile value of rho factor
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SNR?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SNR?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SNR? <type>

This command queries the results of the SNR error measurement performed for digital demodulation.

Query parameters:
<type> | <none> RMS SNR value of display points of current sweep AVG Average of RMS SNR values over several sweeps PAVG Average of maximum SNR values over several sweeps PCTL 95% percentile of RMS SNR value over several sweeps PEAK Maximum EVM over all symbols of current sweep PPCT 95% percentile of maximum SNR values over several sweeps PSD Standard deviation of maximum SNR values over several sweeps RPE Maximum value of RMS EVM over several sweeps SDEV Standard deviation of SNR values over several sweeps TPE Maximum EVM over all display points over several sweeps
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SRERror?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Parameter Values > CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SRERror?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SRERror? <type>

This command queries the symbol rate error

Query parameters:
<type> | PEAK | AVG | SDEV | PCTL | TPEak | RPEak | PAVG | PSDev | PPCTl <none> Symbol rate error (for current sweep) AVG Average symbol rate error over several sweeps RPE Peak symbol rate error over several sweeps SDEV Standard deviation of symbol rate error PCTL 95 percentile value of symbol rate error
Usage: | Query only


Retrieving Limit Check Results

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Limit Check Results
Retrieving Limit Check Results

The modulation accuracy parameters can be checked against defined limits. The following commands are required to query the results of these limit checks.

List of Commands
CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:CFERror:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:CFERror:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:PPEak[:RESUlt]?
CALCulate<n>:LIMit:MACCuracy:EVM:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FDERror:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FDERror:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent[:RESUlt]?
CALCulate<n>:LIMit:MACCuracy:FERRor:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:PPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:PPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:OOFFset:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:OOFFset:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:PPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:RHO:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:RHO:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:RHO:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:<ResultType>:<LimitType>[:RESUlt]


CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent[:RESult]?

VSA (R&S FSW-K70) > Remote Commands for VSA > Retrieving Results > Retrieving Limit Check Results > CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:CFERror:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:CFERror:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:PPEak[:RESUlt]?
CALCulate<n>:LIMit:MACCuracy:EVM:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FDERror:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FDERror:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent[:RESUlt]?
CALCulate<n>:LIMit:MACCuracy:FERRor:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:PPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:PPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:OOFFset:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:OOFFset:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:PPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:RHO:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:RHO:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:RHO:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:<ResultType>:<LimitType>[:RESUlt]

This command queries whether the limit for the specified result type and limit type was violated.

For details on result types and limit types see "Result Summary".

Suffix:
<ResultType>
CFERror | EVM | FDERror | FERRor | MERRor | OOFFset | PERRor | RHO

CFERror = Carrier Frequency Error

EVM = Error Vector Magnitude

FDERror = Frequency deviation error (FSK only)

FERRor = Frequency error (FSK only)

MERRor = Magnitude Error

OOFFset = I/Q Offset

PERRor = Phase Error

RHO = Rho

<LimitType>
CURRent | MEAN | PEAK | PCURRent | PMEan | PPEak | RCURRent | RMEan | RPEak

For CFERor, OOFFset, RHO:

CURRent

MEAN

PEAK

For EVM, FDERror, FERRor, MERRor, PERRor:

PCURRent = Peak current value

PMEan = Peak mean value

PPEak = Peak peak value

RCURRent = RMS current value

RMEan = RMS mean value

RPEak = RMS peak value

Return values:
<LimitResult>
NONE | PASS | FAIL | MARGIN
NONE

No limit check result available yet.

PASS

All values have passed the limit check.

FAIL

At least one value has exceeded the limit.

MARGIN

currently not used

*RST: NONE


Importing and Exporting I/Q Data and Results

VSA (R&S FSW-K70) > Remote Commands for VSA > Importing and Exporting I/Q Data and Results
Importing and Exporting I/Q Data and Results

The I/Q data to be evaluated in the VSA application can not only be measured by the VSA application itself, it can also be imported to the application, provided it has the correct format. Furthermore, the evaluated I/Q data from the VSA application can be exported for further analysis in external applications.

For details on importing and exporting I/Q data see "I/Q Data Import and Export".

List of Commands
MMEMory:LOAD:IQ:STATe
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe


MMEMory:LOAD:IQ:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Importing and Exporting I/Q Data and Results > MMEMory:LOAD:IQ:STATe
MMEMory:LOAD:IQ:STATe 1,<FileName>

This command restores I/Q data from a file.

The file extension is *.iq.tar.

Parameters:
<FileName> | String containing the path and name of the source file.
Example: | MMEM:LOAD:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Loads IQ data from the specified file.
Usage: | Setting only


MMEMory:STORe:IQ:COMMent

VSA (R&S FSW-K70) > Remote Commands for VSA > Importing and Exporting I/Q Data and Results > MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:COMMent <Comment>

This command adds a comment to a file that contains I/Q data.

Parameters:
<Comment> | String containing the comment.
Example: | MMEM:STOR:IQ:COMM 'Device test 1b' Creates a description for the export file. MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores I/Q data and the comment to the specified file.


MMEMory:STORe:IQ:STATe

VSA (R&S FSW-K70) > Remote Commands for VSA > Importing and Exporting I/Q Data and Results > MMEMory:STORe:IQ:STATe
MMEMory:STORe:IQ:STATe 1, <FileName>

This command writes the captured I/Q data to a file.

The file extension is *.iq.tar. By default, the contents of the file are in 32-bit floating point format.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
1 |
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores the captured I/Q data to the specified file.


Status Reporting System

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System
Status Reporting System

The status reporting system stores all information on the current operating state of the instrument, e.g. information on errors or limit violations which have occurred. This information is stored in the status registers and in the error queue. The status registers and the error queue can be queried via IEC bus.

In this section, only the status registers/bits specific to the VSA application are described.

For details and a description of the common R&S FSW status registers see "Status Reporting System" .

*RST does not influence the status registers.

Description of the Status Registers

In addition to the registers provided by the base system, the following registers are used in the VSA application:

  • STATus:QUEStionable:SYNC<n> - contains application-specific information about synchronization errors or errors during burst detection.
  • STATus:QUESTionable:MODulation<n> – provides information on any limit violations that occur after demodulation in one of the 4 windows
  • STATus:QUESTionable:MODulation<n>:EVM - limit violations in EVM evaluation
  • STATus:QUESTionable:MODulation<n>:PHASe - limit violations in Phase Error evaluation
  • STATus:QUESTionable:MODulation<n>:MAGnitude - limit violations in Magnitude Error evaluation
  • STATus:QUESTionable:MODulation<n>:CFRequency - limit violations in Carrier Frequency evaluation
  • STATus:QUESTionable:MODulation<n>:IQRHO - limit violations in I/Q-Offset and RHO evaluation
  • STATus:QUESTionable:MODulation<n>:FSK - limit violations in FSK evaluation

The STATus:QUEStionable register "sums up" the information from all subregisters (e.g. bit 11 sums up the information for all STATus:QUEStionable:SYNC registers). For some subregisters, there may be separate registers for each active channel. Thus, if a status bit in the STATus:QUEStionable register indicates an error, the error may have occurred in any of the channel-specific subregisters. In this case, you must check the subregister of each channel to determine which channel caused the error. By default, querying the status of a subregister always returns the result for the currently selected channel.

The commands to query the contents of the following status registers are described in "Querying the Status Registers".

Overview of VSA-specific status registers
Contents
  • STATus:QUEStionable:SYNC<n> Register
  • STATus:QUEStionable:MODulation<n> Register
  • STATus:QUESTionable:MODulation<n>:EVM Register
  • STATus:QUESTionable:MODulation<n>:PHASe Register
  • STATus:QUESTionable:MODulation<n>:MAGnitude Register
  • STATus:QUESTionable:MODulation<n>:CFRequency Register
  • STATus:QUESTionable:MODulation<n>:IQRHO Register
  • STATus:QUESTionable:MODulation<n>:FSK Register
  • Querying the Status Registers


STATus:QUEStionable:SYNC<n> Register

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > STATus:QUEStionable:SYNC<n> Register
STATus:QUEStionable:SYNC<n> Register

This register contains application-specific information about synchronization errors or errors during burst detection for each window in each VSA channel. It can be queried with commands STATus:​QUEStionable:​SYNC:​CONDition? and STATus:​QUEStionable:​SYNC[:​EVENt]?.

Status error bits in STATus:QUEStionable:SYNC register for R&S FSW-K70
Bit | Definition
0 | Burst not found. This bit is set if a burst could not be detected.
1 | Sync not found This bit is set if the sync sequence (pattern) of the midamble could not be detected.
2 to 14 | Not used.
15 | This bit is always 0.


STATus:QUEStionable:MODulation<n> Register

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > STATus:QUEStionable:MODulation<n> Register
STATus:QUEStionable:MODulation<n> Register

This register comprises information about any limit violations that may occur after demodulation in any of the VSA windows. It can be queried with commands STATus:​QUEStionable:​MODulation<n>:​CONDition? and STATus:​QUEStionable:​MODulation<n>[:​EVENt]?.

The status of the STATus:QUESTionable:MODulation register is indicated in bit 7 of the "STATus:QUESTionable" register. It can be queried using the STATus:QUESTionable:EVENt command.

Bit No | Meaning
0 | Error in EVM evaluation
1 | Error in Phase Error evaluation
2 | Error in Magnitude Error evaluation
3 | Error in Carrier Frequency evaluation
4 | Error in I/Q offset or RHO evaluation
5 | Error in FSK evaluation
6-15 | These bits are not used


STATus:QUESTionable:MODulation<n>:EVM Register

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > STATus:QUESTionable:MODulation<n>:EVM Register
STATus:QUESTionable:MODulation<n>:EVM Register

This register comprises information about limit violations in EVM evaluation. It can be queried with commands STATus:QUEStionable:MODulation<n>:EVM:CONDition and STATus:QUEStionable:MODulation<n>:EVM[:EVENt].

Bit No | Meaning
0 | Error in current RMS value
1 | Error in mean RMS value
2 | Error in peak RMS value
3-4 | These bits are not used
5 | Error in current peak value
6 | Error in mean peak value
7 | Error in peak peak value
8-15 | These bits are not used


STATus:QUESTionable:MODulation<n>:PHASe Register

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > STATus:QUESTionable:MODulation<n>:PHASe Register
STATus:QUESTionable:MODulation<n>:PHASe Register

This register comprises information about limit violations in Phase Error evaluation. It can be queried with commands STATus:QUEStionable:MODulation<n>:PHASe:CONDition and STATus:QUEStionable:MODulation<n>:PHASe[:EVENt].

Bit No | Meaning
0 | Error in current RMS value
1 | Error in mean RMS value
2 | Error in peak RMS value
3-4 | These bits are not used
5 | Error in current peak value
6 | Error in mean peak value
7 | Error in peak peak value
8-15 | These bits are not used


STATus:QUESTionable:MODulation<n>:MAGnitude Register

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > STATus:QUESTionable:MODulation<n>:MAGnitude Register
STATus:QUESTionable:MODulation<n>:MAGnitude Register

This register comprises information about limit violations in Magnitude Error evaluation. It can be queried with commands STATus:QUEStionable:MODulation<n>:MAGNitude:CONDition and STATus:QUEStionable:MODulation<n>:MAGNitude[:EVENt].

Bit No | Meaning
0 | Error in current RMS value
1 | Error in mean RMS value
2 | Error in peak RMS value
3-4 | These bits are not used
5 | Error in current peak value
6 | Error in mean peak value
7 | Error in peak peak value
8-15 | These bits are not used


STATus:QUESTionable:MODulation<n>:CFRequency Register

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > STATus:QUESTionable:MODulation<n>:CFRequency Register
STATus:QUESTionable:MODulation<n>:CFRequency Register

This register comprises information about limit violations in Carrier Frequency evaluation. It can be queried with commands STATus:QUEStionable:MODulation<n>:CFREQuency:CONDition and STATus:QUEStionable:MODulation<n>:CFREQuency[:EVENt].

Bit No | Meaning
0 | Error in current value
1 | Error in mean value
2 | Error in peak value
3-15 | These bits are not used


STATus:QUESTionable:MODulation<n>:IQRHO Register

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > STATus:QUESTionable:MODulation<n>:IQRHO Register
STATus:QUESTionable:MODulation<n>:IQRHO Register

This register comprises information about limit violations in I/Q offset or RHO evaluation. It can be queried with commands STATus:QUEStionable:MODulation<n>:IQRHO:CONDition and STATus:QUEStionable:MODulation<n>:IQRHO[:EVENt].

Bit No | Meaning
0 | Error in current RHO value
1 | Error in mean RHO value
2 | Error in peak RHO value
3-4 | These bits are not used
5 | Error in current I/Q offset value
6 | Error in mean I/Q offset value
7 | Error in peak I/Q offset value
8-15 | These bits are not used


STATus:QUESTionable:MODulation<n>:FSK Register

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > STATus:QUESTionable:MODulation<n>:FSK Register
STATus:QUESTionable:MODulation<n>:FSK Register

This register comprises information about limit violations in FSK evaluation. It can be queried with commands STATus:QUEStionable:MODulation<n>:FSK:CONDition and STATus:QUEStionable:MODulation<n>:FSK[:EVENt].

Bit No | Meaning
0 | Error in current Frequency Error RMS value
1 | Error in mean Frequency Error RMS value
2 | Error in peak Frequency Error RMS value
3-4 | These bits are not used
5 | Error in current Frequency Error peak value
6 | Error in mean Frequency Error peak value
7 | Error in peak Frequency Error peak value
8-9 | These bits are not used
10 | Error in current Frequency Deviation value
11 | Error in mean Frequency Deviation value
12 | Error in peak Frequency Deviation value
13-15 | These bits are not used


Querying the Status Registers

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > Querying the Status Registers
Querying the Status Registers

The following commands query the contents of the individual status registers.

List of Commands
STATus:QUEStionable:ACPLimit:CONDition?
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:FREQuency:CONDition?
STATus:QUEStionable:LIMit<m>:CONDition?
STATus:QUEStionable:LMARgin<m>:CONDition?
STATus:QUEStionable:MODulation<n>:CONDition?
STATus:QUEStionable:MODulation<n>:CFRequency:CONDition?
STATus:QUEStionable:MODulation<n>:EVM:CONDition?
STATus:QUEStionable:MODulation<n>:FSK:CONDition?
STATus:QUEStionable:MODulation<n>:IQRHo:CONDition?
STATus:QUEStionable:MODulation<n>:MAGNitude:CONDition?
STATus:QUEStionable:MODulation<n>:PHASe:CONDition?
STATus:QUEStionable:POWer:CONDition?
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:ACPLimit[:EVENt]?
STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:FREQuency[:EVENt]?
STATus:QUEStionable:LIMit<m> [:EVENt]?
STATus:QUEStionable:LMARgin<m>[:EVENt]?
STATus:QUEStionable:MODulation<n>[:EVENt]?
STATus:QUEStionable:MODulation<n>:CFRequency[:EVENt]?
STATus:QUEStionable:MODulation<n>:EVM[:EVENt]?
STATus:QUEStionable:MODulation<n>:FSK[:EVENt]?
STATus:QUEStionable:MODulation<n>:IQRHo[:EVENt]?
STATus:QUEStionable:MODulation<n>:MAGNitude[:EVENt]?
STATus:QUEStionable:MODulation<n>:PHASe[:EVENt]?
STATus:QUEStionable:POWer[:EVENt]?
STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable:ACPLimit:ENABle
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:FREQuency:ENABle
STATus:QUEStionable:LIMit<m>:ENABle
STATus:QUEStionable:LMARgin<m>:ENABle
STATus:QUEStionable:MODulation<n>:ENABle
STATus:QUEStionable:MODulation<n>:CFRequency:ENABle
STATus:QUEStionable:MODulation<n>:EVM:ENABle
STATus:QUEStionable:MODulation<n>:FSK:ENABle
STATus:QUEStionable:MODulation<n>:IQRHo:ENABle
STATus:QUEStionable:MODulation<n>:MAGNitude:ENABle
STATus:QUEStionable:MODulation<n>:PHASe:ENABle
STATus:QUEStionable:POWer:ENABle
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:ACPLimit:NTRansition
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:FREQuency:NTRansition
STATus:QUEStionable:LIMit<m>:NTRansition
STATus:QUEStionable:LMARgin<m>:NTRansition
STATus:QUEStionable:MODulation<n>:NTRansition
STATus:QUEStionable:MODulation<n>:CFRequency:NTRansition
STATus:QUEStionable:MODulation<n>:EVM:NTRansition
STATus:QUEStionable:MODulation<n>:FSK:NTRansition
STATus:QUEStionable:MODulation<n>:IQRHo:NTRansition
STATus:QUEStionable:MODulation<n>:MAGNitude:NTRansition
STATus:QUEStionable:MODulation<n>:PHASe:NTRansition
STATus:QUEStionable:POWer:NTRansition
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:ACPLimit:PTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:FREQuency:PTRansition
STATus:QUEStionable:LIMit<m>:PTRansition
STATus:QUEStionable:LMARgin<m>:PTRansition
STATus:QUEStionable:MODulation<n>:PTRansition
STATus:QUEStionable:MODulation<n>:CFRequency:PTRansition
STATus:QUEStionable:MODulation<n>:EVM:PTRansition
STATus:QUEStionable:MODulation<n>:FSK:PTRansition
STATus:QUEStionable:MODulation<n>:IQRHo:PTRansition
STATus:QUEStionable:MODulation<n>:MAGNitude:PTRansition
STATus:QUEStionable:MODulation<n>:PHASe:PTRansition
STATus:QUEStionable:POWer:PTRansition
STATus:QUEStionable:SYNC:PTRansition


STATus:QUEStionable:ACPLimit:CONDition?

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > Querying the Status Registers > STATus:QUEStionable:ACPLimit:CONDition?
STATus:QUEStionable:ACPLimit:CONDition? <ChannelName>
STATus:QUEStionable:DIQ:CONDition? <ChannelName>
STATus:QUEStionable:FREQuency:CONDition? <ChannelName>
STATus:QUEStionable:LIMit<m>:CONDition? <ChannelName>
STATus:QUEStionable:LMARgin<m>:CONDition? <ChannelName>
STATus:QUEStionable:MODulation<n>:CONDition?? <ChannelName>
STATus:QUEStionable:MODulation<n>:CFRequency:CONDition?? <ChannelName>
STATus:QUEStionable:MODulation<n>:EVM:CONDition?? <ChannelName>
STATus:QUEStionable:MODulation<n>:FSK:CONDition?? <ChannelName>
STATus:QUEStionable:MODulation<n>:IQRHo:CONDition?? <ChannelName>
STATus:QUEStionable:MODulation<n>:MAGNitude:CONDition?? <ChannelName>
STATus:QUEStionable:MODulation<n>:PHASe:CONDition?? <ChannelName>
STATus:QUEStionable:POWer:CONDition? <ChannelName>
STATus:QUEStionable:SYNC:CONDition? <ChannelName>

This command reads out the CONDition section of the status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:ACPLimit[:EVENt]?

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > Querying the Status Registers > STATus:QUEStionable:ACPLimit[:EVENt]?
STATus:QUEStionable:ACPLimit[:EVENt]? <ChannelName>
STATus:QUEStionable:DIQ[:EVENt]? <ChannelName>
STATus:QUEStionable:FREQuency[:EVENt]? <ChannelName>
STATus:QUEStionable:LIMit<m> [:EVENt]? <ChannelName>
STATus:QUEStionable:LMARgin<m>[:EVENt]? <ChannelName>
STATus:QUEStionable:MODulation<n>[:EVENt]?? <ChannelName>
STATus:QUEStionable:MODulation<n>:CFRequency[:EVENt]?? <ChannelName>
STATus:QUEStionable:MODulation<n>:EVM[:EVENt]?? <ChannelName>
STATus:QUEStionable:MODulation<n>:FSK[:EVENt]?? <ChannelName>
STATus:QUEStionable:MODulation<n>:IQRHo[:EVENt]?? <ChannelName>
STATus:QUEStionable:MODulation<n>:MAGNitude[:EVENt]?? <ChannelName>
STATus:QUEStionable:MODulation<n>:PHASe[:EVENt]?? <ChannelName>
STATus:QUEStionable:POWer[:EVENt]? <ChannelName>
STATus:QUEStionable:SYNC[:EVENt]? <ChannelName>

This command reads out the EVENt section of the status register.

The command also deletes the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:ACPLimit:ENABle

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > Querying the Status Registers > STATus:QUEStionable:ACPLimit:ENABle
STATus:QUEStionable:ACPLimit:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:DIQ:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:FREQuency:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:LIMit<m>:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:LMARgin<m>:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:CFRequency:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:EVM:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:FSK:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:IQRHo:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:MAGNitude:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:PHASe:ENABle <BitDefinition>, <ChannelName>
STATus:QUEStionable:POWer:ENABle <BitDefinition>
STATus:QUEStionable:SYNC:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:ACPLimit:NTRansition

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > Querying the Status Registers > STATus:QUEStionable:ACPLimit:NTRansition
STATus:QUEStionable:ACPLimit:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:DIQ:NTRansition <BitDefinition>,<ChannelName>
STATus:QUEStionable:FREQuency:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:LIMit<m>:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:LMARgin<m>:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:CFRequency:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:EVM:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:FSK:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:IQRHo:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:MAGNitude:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:PHASe:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:POWer:NTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:SYNC:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:ACPLimit:PTRansition

VSA (R&S FSW-K70) > Remote Commands for VSA > Status Reporting System > Querying the Status Registers > STATus:QUEStionable:ACPLimit:PTRansition
STATus:QUEStionable:ACPLimit:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:DIQ:PTRansition <BitDefinition>,<ChannelName>
STATus:QUEStionable:FREQuency:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:LIMit<m>:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:LMARgin<m>:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:CFRequency:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:EVM:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:FSK:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:IQRHo:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:MAGNitude:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:MODulation<n>:PHASe:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:POWer:PTRansition <BitDefinition>, <ChannelName>
STATus:QUEStionable:SYNC:PTRansition <BitDefinition>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Commands for Compatibility

VSA (R&S FSW-K70) > Remote Commands for VSA > Commands for Compatibility
Commands for Compatibility

The following commands are maintained for compatibility reasons with previous R&S analyzers only. Use the specified alternative commands for new remote control programs.

List of Commands
CALCulate<n>:FSK:DEViation:COMPensation
[SENSe:]DDEMod:NORMalize[:VALue]
[SENSe:]DDEMod:SBANd


CALCulate<n>:FSK:DEViation:COMPensation

VSA (R&S FSW-K70) > Remote Commands for VSA > Commands for Compatibility > CALCulate<n>:FSK:DEViation:COMPensation
CALCulate<n>:FSK:DEViation:COMPensation <RefDevComp>

This command defines whether the deviation error is compensated for when calculating the frequency error for FSK modulation.

Note that this command is maintained for compatibility reasons only. For newer remote programs, use [SENSe:​]DDEMod:​NORMalize:​FDERror.

Setting parameters:
<RefDevComp>
ON | OFF | 1 | 0
ON

Scales the reference signal to the actual deviation of the measurement signal.

OFF

Uses the entered nominal deviation for the reference signal.

*RST: 1


[SENSe:]DDEMod:NORMalize[:VALue]

VSA (R&S FSW-K70) > Remote Commands for VSA > Commands for Compatibility > [SENSe:]DDEMod:NORMalize[:VALue]
[SENSe:]DDEMod:NORMalize[:VALue] <Normalize>

This command switches the compensation of the IQ offset and the compensation of amplitude droop on or off.

Note that this command is maintained for compatibility reasons only. Use the more specific [SENSe:]DDEMod:NORMalize commands for new remote control programs (see "Demodulation Settings").

Setting parameters:
<Normalize>
ON | OFF | 1 | 0
OFF

No compensation for amplitude droop nor I/Q offset

ON

Compensation for amplitude droop and I/Q offset enabled

*RST: 1


[SENSe:]DDEMod:SBANd

VSA (R&S FSW-K70) > Remote Commands for VSA > Commands for Compatibility > [SENSe:]DDEMod:SBANd
[SENSe:]DDEMod:SBANd <SidebandPos>

This command selects the sideband for the demodulation.

Note that this command is maintained for compatibility reasons only. Use the SENS:SWAP:IQ command for new remote control programs (see [SENSe:​]SWAPiq).

Setting parameters:
<SidebandPos>
NORMal | INVerse
NORMal

Normal (non-inverted) position

INVerse

Inverted position

*RST: NORMal


Programming Examples

VSA (R&S FSW-K70) > Remote Commands for VSA > Programming Examples
Programming Examples

The following examples demonstrate how to perform vector signal analysis in a remote environment.

These examples are meant to demonstrate the use of the most common remote commands for vector signal analysis. Note that not all commands executed here are actually necessary, as they may reflect default settings.

Contents
  • Measurement Example 1: User-defined Measurement of Continuous QPSK Signal
  • Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard
  • Measurement Example 3: User-Defined Pattern Search and Limit Check


Measurement Example 1: User-defined Measurement of Continuous QPSK Signal

VSA (R&S FSW-K70) > Remote Commands for VSA > Programming Examples > Measurement Example 1: User-defined Measurement of Continuous QPSK Signal
Measurement Example 1: User-defined Measurement of Continuous QPSK Signal

The following example describes a scenario similar to the one for manual operation described in "Measurement Example 1: Continuous QPSK Signal".

//-----------Configuring the measurement ------------

*RST
//Reset the instrument
FREQ:CENT 1GHz
//Set the center frequency.
DISP:TRAC:Y:RLEV 4dBm
//Set the reference level
INST:CRE:NEW DDEM,'MyVSA'
//Create new measurement channel for vector signal analysis named "MyVSA"

//--------- Configuring the expected input signal ---------------

DDEM:FORM QPSK
//Set the modulation type
DDEM:QPSK:FORM NORM
//Set the modulation order
DDEM:MAPP:CAT?
//Query the available symbol mappings for QPSK modulation
DDEM:MAPP 'WCDMA'
//Set the symbol mapping to WCDMA
DDEM:SRAT 1 MHz
//Set the symbol rate
DDEM:TFIL:NAME 'RRC'
DDEM:TFIL:ALPH 0.35
//Select the RRC transmit filter

//--------- Configuring an averaged EVM vs Time result display ---------

LAY:ADD? '1',RIGH,EVEC
//Create new window to the right of I/Q constellation (window 1) with
//error vector as data type
//Result: '5'
CALC5:FORM MAGN
//Set result type for window 5 to magnitude = EVM
DISPlay:WINDow5:TRACe2:MODE AVER
//Add a second trace in average mode
DISPlay:WINDow5:TRACe3:MODE MAXH
//Add a third trace in max hold mode
SWE:COUN 10
//Calculate an average over 10 sweeps

//--------------Performing the measurement-----

INIT:CONT OFF
//Select single sweep mode.
INIT;*WAI
//Initiate a new measurement and wait until the 10 sweeps have finished.

//-----Storing the Constellation I/Q diagram to a file ------

DISP:WIND1:SIZE LARG
//Display the I/Q Constellation result display (window 1) in full screen.
HCOP:DEST 'MMEM'
//Define the destination of the screenshot as a file.
HCOP:DEV:LANG BMP
//Select bmp as the file format.
MMEM:NAME 'C:\R_S\INST\USER\IQConstellation.bmp'
//Select the file name for the printout.
HCOP:ITEM:ALL
//Print all screen elements
HCOP
//Store the printout in a file called 'IQConstellation.bmp'.
DISP:WIND5:SIZE SMAL
//Restore the I/Q Constellation result display to one subwindow.

//------------Storing the EVM trace data to a file---------------

FORM:DEXP:HEAD ON
//Include a header in the trace export file
FORM:DEXP:MODE TRAC
//Export the trace data, not raw I/Q data
MMEM:STOR4:TRAC 1,'AverageEVM'
//Save the detected symbol values (x-values are not exported with trace data)
//Results:
MMEM:STOR5:TRAC 1,'AverageEVM'
//Save the  EVM values (window 5) to an ascii file.
//Results:
//


Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard

VSA (R&S FSW-K70) > Remote Commands for VSA > Programming Examples > Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard
Measurement Example 2: GSM EDGE Burst Measurement Based on a Digital Standard

The following example describes a scenario similar to the one for manual operation described in "Measurement Example 2: Burst GSM EDGE Signals" "Measurement Example 1: Continuous QPSK Signal".

Note that although this example uses the settings from a predefined digital standard, the configuration is changed to demonstrate the possibilities of the VSA application. A measurement that is performed strictly according to the standard requires much less programming efforts.

The rising and falling edges of a GSM burst are analyzed using the following result range settings:

//-----------Configuring the measurement ------------

*RST
//Reset the instrument
FREQ:CENT 1GHz
//Set the center frequency.
DISP:TRAC:Y:RLEV 4dBm
//Set the reference level
INST:CRE:NEW DDEM,'VSA'
//Create new measurement channel for vector signal analysis named "VSA"

//-------Loading the required digital standard -----------------

DDEM:PRES 'EDGE_NB'
//Loads the GSM EDGE_8PSK standard file and the settings defined there

//------Changing data acquisition settings --------------------

DDEM:RLEN 10000 sym

//-------- Defining the result range ---------------
DDEMod:TIME 200
//Defines the result length as 200 symbols.
CALC:TRAC:ADJ BURS
//Defines the burst as the reference for the result range
CALC:TRAC:ADJ:ALIG LEFT
//Aligns the result range to the left edge of the burst
CALC:TRAC:ADJ:ALIG:OFFS -10
//Defines an offset of 10 symbols from the burst start
DISP:TRAC:X:VOFF 10
//Defines the symbol number 10 as the result range start

//----------Defining the evaluation range ---------

CALC:ELIN:STAT ON
CALC:ELIN1 10
CALC:ELIN2 190
//Evaluation range starts at symbol 10 and ends at symbol 190

//--------- Changing the result display ---------

LAY:WIND4:REM
//Close symbol table display (window 4)
DISPlay:WINDow1:TRACe2:MODE MAXH
//Add a second trace in max hold mode to EVM vs Time display (window 1)
LAY:ADD? '3',RIGH,MEAS
//Create new window to the right of capture buffer (window 3) with
//measurement signal as data type
//Result: '4'
CALC4:FORM MAGN
//Set result type for window 4 to magnitude
DISPlay:WINDow4:TRACe2:MODE WRIT
CALC4:TRAC2 REF
//Add a second trace in clear/write mode for the reference signal

//-------- Activating limit checks for modulation accuracy ---------

CALC:LIM:MACC:STAT ON
//Activates limit checks for all values in the Result Summary

//--------------Performing the measurement -----

INIT:CONT OFF
//Select single sweep mode.
INIT;*WAI
//Initiate a new measurement and wait until the 10 sweeps have finished.

//----- Retrieving Results ------

CALC2:MARK:FUNC:DDEM:STAT:EVM? AVG
CALC:LIM:MACC:EVM:RCUR?
//Query the value and check the limit for the EVM RMS value in the
//result summary for the current evaluation range
//Result:
CALC2:MARK:FUNC:DDEM:STAT:EVM? PAVG
CALC:LIM:MACC:EVM:PPE?
//Query the value and check the limit for the largest error vector magnitude
//in the measurement.
//Result:
CALC2:MARK:FUNC:DDEM:STAT:CFER? AVG
CALC:LIM:MACC:CFER:MEAN?
//Query the value and check the limit for the mean carrier frequency offset
//in the result summary for the current evaluation range
//Result:

//------- Storing trace data to a file ---------------

FORM:DEXP:HEAD ON
//Include a header in the trace export file
FORM:DEXP:MODE TRAC
//Export the trace data, not raw I/Q data
DISP:WIND1:TRAC2:X:STAR?
//Query the first value of the x-axis for the current result range
//(x-values are not exported with trace data)
//Result:
MMEM:STOR4:TRAC 1,'Measurement signal'
//Save the measurement signal values (trace 1 in window 4) to an ascii file.
//Results:
//
MMEM:STOR4:TRAC 2,'Reference signal'
//Save the reference signal values (trace 2 in window 4) to an ascii file.
//Results:
//
MMEM:STOR2:TRAC 1,'Result Summary'
//Save the result summary values (window 2)  for the current result range
//to an ascii file.
//Results:
//

//-------- Retrieving results for further result ranges -------->

DDEM:SEAR:MBUR:CALC?
//Query the number of result ranges (current is last)
//Use variable <x> to determine number of previous result range
//DDEM:SEAR:MBUR:CALC <x>
//Move to next result range and repeat section "retrieving results" for
//range-specific results


Measurement Example 3: User-Defined Pattern Search and Limit Check

VSA (R&S FSW-K70) > Remote Commands for VSA > Programming Examples > Measurement Example 3: User-Defined Pattern Search and Limit Check
Measurement Example 3: User-Defined Pattern Search and Limit Check

In this example a user-defined pattern is used to detect bursts and the calculated measurement results are checked against defined limits. The configuration settings are stored as a user-defined standard.

//-----------Configuring the measurement ------------

*RST
//Reset the instrument
FREQ:CENT 1GHz
//Set the center frequency.
DISP:TRAC:Y:RLEV 4dBm
//Set the reference level
INST:CRE:NEW DDEM,'VSA'
//Create new measurement channel for vector signal analysis named "VSA"

//----------------- Creating a pattern ------------------

DDEM:SEAR:SYNC:NAME 'EDGE_TSC_CUST'
//Create new pattern
DDEM:SEAR:SYNC:NST 4
DDEM:SEAR:SYNC:DATA '00030001000000000003000200020001000300010001'
DDEM:SEAR:SYNC:COMM 'Customized pattern'
DDEM:SEAR:SYNC:TEXT 'Special edge normal Burst'
DDEM:SEAR:SYNC:NAME 'EDGE_TSC_CUST'
//Store customized pattern
DDEM:SEAR:SYNC:PATT:ADD 'EDGE_TSC_CUST'
//Add new pattern to current standard

//--------- Configuring the expected input signal ---------------
DDEM:FORM QPSK
//Set the modulation type
DDEM:QPSK:FORM NORM
//Set the modulation order
DDEM:MAPP:CAT?
//Query the available symbol mappings for QPSK modulation
DDEM:MAPP 'WCDMA'
//Set the symbol mapping to WCDMA
DDEM:SRAT 1 MHz
//Set the symbol rate

DDEM:SIGN BURS
//Define input signal as burst signal
DDEM:SIGN:PATT ON
//Enable pattern search
DDEM:SEAR:SYNC:CAT? CURR
//Query the names of all defined patterns assigned to the current standard
DDEM:SEAR:SYNC:SEL 'EDGE_TSC_CUST'
//Select a pattern
DDEM:STAN:SYNC:OFFS 10
//Ignore the first 10 symbols of the signal before comparing pattern
DDEM:STAN:SYNC:OFFS:STAT ON
DDEM:SEAR:SYNC:STAT ON

//------ Storing the new settings as a user-defined standard -------------

DDEM:STAN:SAVE 'C:\TEMP\CustomizedBurstMeas'

//--------------Performing the measurement -----

INIT:CONT OFF
//Select single sweep mode.
INIT;*WAI
//Initiate a new measurement and wait until it has finished.

//----- Retrieving Results ------
TRAC3:DATA? TRACE1
//Query the trace results of the capture buffer display.
//Results:
//
TRAC2:DATA? TRACE1
//Query the results of the result summary.
//Results:
//


Annex

VSA (R&S FSW-K70) > Annex
Annex

The following sections are provided for reference purposes and include detailed information such as formulae and abbreviations.

Contents
  • Abbreviations
  • Predefined Standards and Settings
  • Predefined Measurement and Tx Filters
  • ASCII File Export Format for VSA Data
  • Known Data File Syntax Description
  • Formulae


Abbreviations

VSA (R&S FSW-K70) > Annex > Abbreviations
Abbreviations

The following abbreviations are commonly used in the description of the R&S FSW-K70 option.

Abbreviation | Meaning | See section
FSK | Frequency Shift Keying Modulation mode for which the information is encrypted in the frequency. | Frequency Shift Keying (FSK)
ISI | Inter-symbol Interference |
ISI-free demodulation | Demodulation structure in which the signal is no longer influenced by adjacent symbols at the decision instants after signal-adapted filtering. | System-Theoretical Modulation and Demodulation Filters
MEAS filter | Measurement Filter Weighting filter for the measurement. | System-Theoretical Modulation and Demodulation Filters
MSK | Minimum Shift Keying Modulation mode. | Minimum Shift Keying (MSK)
NDA Demodulator | Non Data Aided Demodulator Demodulation without any knowledge of the sent data contents. | Demodulation and Algorithms
PSK | Phase Shift Keying Modulation mode for which the information lies within the phase or within the phase transitions. | Phase Shift Keying (PSK)
QAM | Quadrature Amplitude Modulation Modulation mode for which the information is encrypted both in the amplitude and phase. | Quadrature Amplitude Modulation (QAM)
RMS | Root Mean Square | Averaging RMS Quantities
RX filter | Receive Filter Baseband filter in analyzer used for signal-adapted filtering. | System-Theoretical Modulation and Demodulation Filters
Transmit filter | Transmitter Filter Digital impulse shaping filter in signal processing unit of transmitter. | System-Theoretical Modulation and Demodulation Filters
VSA | Vector Signal Analysis Measurement at complex modulated RF carriers. |


Predefined Standards and Settings

VSA (R&S FSW-K70) > Annex > Predefined Standards and Settings
Predefined Standards and Settings

In the "Digital Standards" menu, predefined basic settings for standards can be selected and user-defined standards stored (see "Configuration According to Digital Standards").

The most common measurements are predefined as standard settings for a large number of mobile radio networks. The instrument comes prepared with the following settings for those standards:

  • Capture length and result length
  • Signal description
  • Modulation
  • Transmit filter and measurement filter
  • Burst/Pattern search configuration
  • Result range alignment
  • Evaluation range settings
  • Display configuration

The standard settings are grouped in folders to facilitate selecting a standard.

List of predefined standards and settings
Folder | Standard (SCPI *) | Modulation Mapping | Symbol rate | Transmit Filter Meas.Filter | Alpha/BT | Search for Burst | Search for Pattern | Pattern | Result length | Alignment | Evaluation Range
GSM | GSM_NormalBurst (GSM) | DMSK GSM | 270.83333 kHz | GMSK NONE | 0.3 | ✓ | ✓ | GSM_TSC0 (...) GSM_TSC7 | 148 | Pattern to Center | 0.5 - 147.25
 | GSM_SynchronizationBurst (GSM_SB) | DMSK GSM | 270.83333 kHz | GMSK NONE | 0.3 | ✓ | ✓ | GSM_SB0 (...) GSM_SB2 | 148 | Pattern to Center | 3 - 144
 | GSM_FrequencyBurst (GSM_FB) | DMSK GSM | 270.83333 kHz | GMSK NONE | 0.3 | ✓ | ✓ | GSM_FB0 GSM_FB01 | 148 | Pattern to Center | 3 - 144
 | GSM_AccessBurst (GSM_AB) | DMSK GSM | 270.83333 kHz | GMSK NONE | 0.3 | ✓ | ✓ | GSM_AB0 (...) GSM_AB2 | 88 | Pattern to Center | 8 - 85
 | EDGE_8PSK (EDGE_NB, EDGE_Normalburst) | 3π/8-8PSK EDGE | 270.833 kHz | Linearized GMSK EDGE_NSR | - | ✓ | ✓ | EDGE_TSC0 (...) EDGE_TS7 | 148 | Pattern to Center | 3-144.75
 | EDGE_16QAM | π/4-16QAM EDGE | 270.833 kHz | Linearized GMSK EDGE_NSR | - | ✓ | ✓ | 16QAM_EDGE_TSC0 (...) 16QAM_EDGE_TS7 | 148 | Pattern to Center | 3-144.75
 | EDGE_32QAM | π/4-32QAM EDGE | 270.833 kHz | Linearized GMSK EDGE_NSR | - | ✓ | ✓ | 32QAM_EDGE_TSC0 (...) 32QAM_EDGE_TS7 | 148 | Pattern to Center | 3-144.75
 | EDGE_QPSK_HSR_NarrowPulse | 3π/4-QPSK EDGE | 325 kHz | EDGE Narrow Pulse Shape EDGE HSR (Narrow Pulse) | - | ✓ | ✓ | EDGE_HSR_QPSK_TSC0 (...) EDGE_HSR_QPSK_TSC1..7 | 177 | Pattern to Center | 4- 172.75
 | EDGE_QPSK_HSR_WidePulse | 3π/4-QPSK EDGE | 325 kHz | EDGE Wide Pulse Shape EDGE HSR (Wide Pulse) | - | ✓ | ✓ | EDGE_HSR_QPSK_TSC0 (...) EDGE_HSR_QPSK_TSC1..7 | 177 | Pattern to Center | 4- 172.75
 | EDGE_16QAM_HSR_NarrowPulse | π/4-16QAM EDGE | 325 kHz | EDGE Narrow Pulse Shape EDGE HSR (Narrow Pulse) | - | ✓ | ✓ | EDGE_HSR_16QAM_TSC0 (...) EDGE_HSR_16QAM_TSC1..7 | 177 | Pattern to Center | 4- 172.75
 | EDGE_16QAM_HSR_WidePulse | π/4-16QAM EDGE | 325 kHz | EDGE Wide Pulse Shape EDGE HSR (Wide Pulse) | - | ✓ | ✓ | EDGE_HSR_16QAM_TSC0 (...) EDGE_HSR_16QAM_TSC1..7 | 177 | Pattern to Center | 4- 172.75
 | EDGE_32QAM_HSR_NarrowPulse | -π/4-32QAM EDGE | 325 kHz | EDGE Narrow Pulse Shape EDGE HSR (Narrow Pulse) | - | ✓ | ✓ | EDGE_HSR_32QAM_TSC0 (...) EDGE_HSR_32QAM_TSC1..7 | 177 | Pattern to Center | 4- 172.75
 | EDGE_32QAM_HSR_WidePulse | -π/4-32QAM EDGE | 325 kHz | EDGE Wide Pulse Shape EDGE HSR (Wide Pulse) | - | ✓ | ✓ | EDGE_HSR_32QAM_TSC0 (...) EDGE_HSR_32QAM_TSC1..7 | 177 | Pattern to Center | 4- 172.75
TETRA | TETRA_DiscontinuousDownlink (TETRA_NDDOWN) | π/4-DQPSK TETRA | 18 kHz | RRC RRC | 0.35 | ✓ | - | TETRA_S1 ... TETRA_S3 | 246 | Burst to Center | 0 - 244
 | TETRA_ContinuousDownlink (TETRA_NCDOWN) | π/4-DQPSK TETRA | 18 kHz | RRC RRC | 0.35 | ✓ | - | TETRA_E TETRA_S | 255 | Burst to Center | 0 - 244
3GPP | 3G_WCDMA (3G_WCDMA_FWD, 3G_WCDMA_REV) | QPSK WCDMA | 3.84 MHz | RRC RRC | 0.22 | - | - | - | 800 | Capture/Left | -
CDMA | CDMA2000_1X_FWD (F1CD, CDMA2K_1X_FWD) | QPSK CDMA2K_FWD | 1.2288 MHz | CDMA 2000 1X FWD Low ISI Meas Filter | - | - | - | - | 800 | Capture/Left | -
 | CDMA2000_1X_REV (R1CD) | Offset QPSK Gray | 1.2288 MHz | CDMA 2000 1X Reverse Low ISI Meas Filter | - | - | - | - | 800 | Capture/ Left | -
APCO25 | APCO25_CQPSK | π/4 DQPSK APCO25 | 4.8 kHz | RC NONE | 0.2 - | - | - | - | 200 | Capture/Left | -
 | APCO25_C4FM | 4FSK APCO25 | 4.8 kHz | APCO25 C4FM Rectangular | - | - | - | - | 200 | Capture/ Left | -
 | APCO_P2_H-CDM | 4FSK APCO_25_Phase_2 | 6 kHz | APCO2 5 H-CPM Rectangular | - | ✓ | - | - | 168 | Burst/ Center | entire result range
 | APCO_P2_H-DQPSK | 4FSK APCO_25_Phase_2 | 6 kHz | NONE Rectangular | - | - | - | - | 180 | Capture/ Left | entire result range
Bluetooth | Bluetooth_DH1 | 2FSK Natural | 1 MHz | GMSK None | 0.5 | ✓ | - | - | 366 | Burst to Center | 2 - 363.75
 | Bluetooth_DH3 | 2FSK Natural | 1 MHz | GMSK None | 0.5 | ✓ | - | - | 1622 | Burst to Center | 2 - 1619.75
 | Bluetooth_DH5 | 2FSK Natural | 1 MHz | GMSK None | 0.5 | ✓ | - | - | 2870 | Burst to Center | 2 - 2867.75
 | Bluetooth_Low Energy | 2FSK Natural | 1 MHz | GMSK None | 0.5 | ✓ | - | - | 376 | Burst to Center | 60 - 347.75
DECT | DECT_P32_FixedPart (DECT_FP) | 2FSK Natural | 1.152 MHz | GMSK None | 0.5 | ✓ | ✓ | DECT_PP DECT_PP_Prolonged | 424 | Capture Left | 0 - 799.75
 | DECT_P32_PortablePart | 2FSK Natural | 1.152 MHz | GMSK None | 0.5 | ✓ | ✓ | DECT_FP DECT_FP_Prolonged | 424 | Capture Left | -
DVB-S2 | DVB_S2_8PSK | 8PSK DVB_S2_8PSK | 20 MHz | RRC RRC | 0.35 | - | - | - | 90 | Capture Left | -
 | DVB_S2_16APSK | UserQAM 16ary DVB_S2_16APSK_34 | 20 MHz | RRC RRC | 0.35 | - | - | - | 180 | Capture Left | -
 | DVB_S2_32APSK | UserQAM 32ary DVB_S2_32APSK_34 | 20 MHz | RRC RRC | 0.35 | - | - | - | 270 | Capture Left | -
 | DVB_S2_QPSK | QPSK DVB_S2_QPSK | 20 MHz | RRC RRC | 0.35 | - | - | - | 90 | Capture Left | -
ZIGBEE | ZIGBEE_BPSK_868M_300K | BPSK Natural | 300 kHz | RC None | 1.0 | ✓ | - | - | 1000 | Busrt to Center | -
 | ZIGBEE_BPSK_915M_600K | BPSK Natural | 600 kHz | RC None | 1.0 | ✓ | - | - | 1000 | Burst to Center | -
 | ZIGBEE_OQPSK_2450M_1M | Offset-QPSK Gray | 1 MHz | Half Sine - | - | ✓ | - | - | 1000 | Burst to Center | -
*) The SCPI parameter for remote commands is provided where it differs from the standard name or a short form is available.


Predefined Measurement and Tx Filters

VSA (R&S FSW-K70) > Annex > Predefined Measurement and Tx Filters
Predefined Measurement and Tx Filters

The most frequently required measurement and TX filters required for vector signal analysis according to digital standards are provided by the R&S FSW VSA application.

For general information on the use of these filters see "Filters and Bandwidths During Signal Processing".

Contents
  • Transmit Filters
  • Measurement Filters
  • Typical Combinations of Tx and Measurement Filters


Transmit Filters

VSA (R&S FSW-K70) > Annex > Predefined Measurement and Tx Filters > Transmit Filters
Transmit Filters

The transmit filters required for common standards are predefined in the VSA application.

Overview of predefined Transmit filters
RC | Raised cosine
RRC | Root raised cosine
Gauss | Gauss filter
GMSK | Gauss filter convolved with a rectangular filter; typically used for MSK
Linearized GMSK | Standard-specific filter for GSM EDGE (3GPP TS 45.004), normal symbol rate
EDGE Narrow Pulse Shape | Standard-specific filter for GSM EDGE (higher symbol rate)
EDGE Wide Pulse Shape | Standard-specific filter for GSM EDGE (higher symbol rate)
Half Sine | Half Sine filter
APCO25 C4FM | Filter for the APCO25 C4FM standard.
APCO25 H-CPM | Filter for the APCO25 Phase 2 standard.
APCO25 H-DQPSK | Filter for the APCO25 Phase 2 standard.
APCO25 H-D8PSK Narrow | Filter for the APCO25 Phase 2 standard.
APCO25 H-D8PSK Wide | Filter for the APCO25 Phase 2 standard.
CDMA2000 1X Forward | Filter for CDMA ONE forward link (TIA/EIA/IS-95-A May 1995) and CDMA2000 1X forward link (http://www.3gpp2.org/Public_html/specs/C.S0002-C_v1.0.pdf 28/05/2002)
CDMA2000 1X Reverse | Filter for CDMA ONE forward link (TIA/EIA/IS-95-A May 1995) and CDMA2000 1X reverse link (http://www.3gpp2.org/Public_html/specs/C.S0002-C_v1.0.pdf 28/05/2002)
Rectangular | Rectangular filter in the time domain with a length of 1 symbol period
None | No filter is used.
USER | User-defined filter. Define the filter using the [SENSe:​]DDEMod:​TFILter:​USER command.


Measurement Filters

VSA (R&S FSW-K70) > Annex > Predefined Measurement and Tx Filters > Measurement Filters
Measurement Filters

The most frequently required measurement filters are predefined in the VSA application.

Overview of predefined measurement filters

EDGE NSR

Measurement filter required for the "EDGE, Normal Symbol Rate" standard. (see 3GPP TS 45.005, chapter 4.6 Modulation Accuracy). The resulting system is NOT inter-symbol interference free.

EDGE HSR (Narrow Pulse)

Measurement filter required for the "EDGE, High Symbol Rate, Narrow Pulse" standard.

EDGE HSR (Wide Pulse)

Measurement filter required for the "EDGE, High Symbol Rate, Wide Pulse" standard.

Gauss

Classic Gauss filter with an adjustable BT

Low ISI Meas Filter

Measurement filter implemented to retain a low intersymbol inferference. Best suited for eye diagrams or I/Q vector diagrams. Not necessarily suited for EVM evaluation due to amplification in the pass band.

Low Pass (Narrow)

Pass band up to Fsymbol/2

Stop band starts at Fsymbol (-40dB)

Low Pass (Wide)

Pass band up to Fsymbol

Stop band starts at 1.5*Fsymbol (-40dB)

Rectangular

Rectangular filter in the time domain with a length of 1 symbol period; integrate and dump effect

RRC

Root Raised Cosine Filter. The roll-off parameter "Alpha" is set according to the Transmit filter if the "Auto (according to Transmit filter)" option is enabled (see "Using the Transmit Filter as a Measurement Filter (Auto)"). Otherwise it must be set manually.

If the Transmit filter is also a Root Raised Cosine filter with the same roll-off parameter, the resulting system is inter-symbol interference free.

USER

User-defined filter.

Define the filter using the "Load User Filter" function or the [SENSe:​]DDEMod:​MFILter:​USER command.

For details see "How to Select User-Defined Filters".

NONE

No measurement filter is used.

The frequency response of the available standard-specific measurement filters is shown in "Measurement Filter".


Typical Combinations of Tx and Measurement Filters

VSA (R&S FSW-K70) > Annex > Predefined Measurement and Tx Filters > Typical Combinations of Tx and Measurement Filters
Typical Combinations of Tx and Measurement Filters

Typical combinations of Tx and Meas filters are shown in table "Typical combinations of Tx and Meas filters"; they can be set in the VSA application using "Meas filter = AUTO" (see "Using the Transmit Filter as a Measurement Filter (Auto)").

Typical combinations of Tx and Meas filters
Transmit filter | Measurement filter (analyzer) | Remarks
RC (raised cosine) | - | filter combination without intersymbol interference (ISI)
RRC (root raised cosine) | RRC | filter combination without ISI
GMSK | - | filter combination with low ISI
Linearized GMSK | EDGE NSR | standard specific filter; filter combination with ISI
Gauss | - | filter combination with low ISI
Rectangular | - | filter combination without ISI
Half Sine | - | filter combination without ISI
CDMA2000 1X FORWARD | Low ISI Meas Filter | filter combination without ISI
CDMA2000 1X REVERSE | Low ISI Meas Filter | filter combination without ISI
APCO25 C4FM | Rectangular | filter combination without ISI
APCO25 H-CPM | Rectangular | filter combination without ISI
APCO25 H-DQPSK | Low ISI Meas Filter | filter combination without ISI
APCO25 H-D8PSK Narrow | Low ISI Meas Filter | filter combination without ISI
APCO25 H-D8PSK Wide | Low ISI Meas Filter | filter combination without ISI
EDGE Narrow Pulse Shape | EDGE HSR (Narrow Pulse) | standard specific filter; filter combination with ISI
EDGE Wide Pulse Shape | EDGE HSR (Wide Pulse) | standard specific filter; filter combination with ISI
User | Low ISI Meas Filter | filter combination with low ISI


ASCII File Export Format for VSA Data

VSA (R&S FSW-K70) > Annex > ASCII File Export Format for VSA Data
ASCII File Export Format for VSA Data

The data of the file header consist of three columns, each separated by a semicolon: parameter name; numeric value; basic unit. The data section starts with the keyword "Trace <n>" (<n> = number of stored trace), followed by the measured data in one or several columns (depending on the result type) which are also separated by a semicolon.

If several traces in several windows are exported to one file, the data for each window is listed subsequently. Within the data for a single window, the data for the individual traces is listed subsequently.

For details on which data is stored for which result display, see TRACe<n>[:​DATA].

ASCII file format for VSA trace data export
File contents | Description
Header
Type;FSW; | Instrument model
Version;1.40; | Firmware version
Date;01.Apr 2012; | Date of data set storage
Header section for individual window
Screen;1; | Window name
Points per Symbol;4; | Points per symbol
x Axis Start;-13;sym; | Start value of the x axis
x Axis Stop;135;sym; | Stop value of the x axis
y per div;0.22000000000000003; | Y axis range per division
Ref value y axis;-10.00;dBm; | Y axis reference value
Ref value position;100;%; | Y axis reference position
Header section for individual trace
Trace; 1; | First trace
Meas Result;IQ; | Result type
Meas Signal;Meas; | Data source (measurement or reference data)
Demodulator;Offset QPSK; | Demodulation type
ResultMode;Trace; | Result mode
x unit;sym; | Unit of the x axis
y unit;dBm; | Unit of the y axis
Trace Mode;Clear Write; | Trace mode
Values;800; | Number of measurement points
Data section for individual trace
10000;-10.3;-15.7 10130;-11.5;-16.9 10360;-12.0;-17.4 ...;...; | Measured values: <x value>, <y1>, <y2>; <y2> is only available with detector AUTOPEAK and contains the smallest of the two measured values for a measurement point
Header section for individual trace
Trace; 2; | Next trace in same window
Meas Result;IQ; | Result type
Meas Signal;Meas; | Data source (measurement or reference data)
Demodulator;Offset QPSK; | Demodulation type
ResultMode;Trace; | Result mode
x unit;sym; | Unit of the x axis
y unit;dBm; | Unit of the y axis
Trace Mode;Clear Write; | Trace mode
Values;800; | Number of measurement points
Data section for individual trace
... |
Header section for individual window
Screen;2; | Name of next window
... |
Header section for individual trace
Trace; 1; | First trace in second window
Data section for individual trace
... |


Known Data File Syntax Description

VSA (R&S FSW-K70) > Annex > Known Data File Syntax Description
Known Data File Syntax Description

When you load a Known Data file, the R&S FSW-K70 application checks whether the file complies with the following syntax:

Known Data File Syntax
Syntax | Possible Values | Description
<RS_VSA_KNOWN_DATA_FILE Version="01.00"> | as specified | File Header
<Comment></Comment> | arbitrary | Optional file description
<Base></Base> | 2 | 16 | The base used to specify the <Data> values (binary or hexadecimal) For <ModulationOrder> values ≥32, use binary (2).
<ModulationOrder></ModulationOrder> | 2 | 4 | 8 | 16 | 32 | 64 | 128 | 256 | Number of values each symbol can represent (order of modulation), e.g. 8 for 8-PSK For <ModulationOrder> values ≥32, use <Base> = 2.
<ResultLength></ResultLength> | 1 ... up to 2000*) | Number of symbols in each <Data> element The number must be identical to the "Result Length" setting in the "Result Range" dialog box, i.e. the number of symbols to be demodulated.
<Data></Data> | One character per symbol in the sequence Possible characters are: 0 to n-1, where n is the <ModulationOrder> Spaces, tabs and line breaks are ignored | One possible sequence of symbols that can be demodulated from the input signal Up to 6000*) different sequences, i.e. <Data>-elements, can be defined in total
</RS_VSA_KNOWN_DATA_FILE> | as specified | File End
*) the exact number also depends on available memory space
Sample xml file for known data
<RS_VSA_KNOWN_DATA_FILE Version="01.00">

<Comment>  Standard EDGE_8PSK  </Comment>
<Base>             16          </Base>
<ModulationOrder>   8          </ModulationOrder>
<ResultLength>    148          </ResultLength>

<Data>    777 511 727 242 206 341 366 632 073 607
          770 173 705 631 011 235 507 476 330 522
          177 177 171 117 777 177 717 717 111 615
          527 046 104 004 106 047 125 415 723 344
          241 264 773 111 337 446 514 600 677 7       </Data>

<Data>     77 511 727 242 206 341 366 632 073 607
          770 173 705 631 011 235 507 476 330 522
          177 177 171 117 777 177 717 717 111 615
          527 046 104 004 106 047 125 415 723 344
          241 264 773 111 337 446 514 600 677 7    7  </Data>

<Data>      7 511 727 242 206 341 366 632 073 607
          770 173 705 631 011 235 507 476 330 522
          177 177 171 117 777 177 717 717 111 615
          527 046 104 004 106 047 125 415 723 344
          241 264 773 111 337 446 514 600 677 7    77 </Data>

<Data>  7 777 511 727 242 206 341 366 632 073 607
          770 173 705 631 011 235 507 476 330 522
          177 177 171 117 777 177 717 717 111 615
          527 046 104 004 106 047 125 415 723 344
          241 264 773 111 337 446 514 600 677        </Data>

<Data> 77 777 511 727 242 206 341 366 632 073 607
          770 173 705 631 011 235 507 476 330 522
          177 177 171 117 777 177 717 717 111 615
          527 046 104 004 106 047 125 415 723 344
          241 264 773 111 337 446 514 600 67         </Data>
</RS_VSA_KNOWN_DATA_FILE>


Formulae

VSA (R&S FSW-K70) > Annex > Formulae
Formulae
Contents
  • Trace-based Evaluations
  • Result Summary Evaluations
  • Statistical Evaluations for the Result Summary
  • Trace Averaging
  • Analytically Calculated Filters
  • Standard-Specific Filters


Trace-based Evaluations

VSA (R&S FSW-K70) > Annex > Formulae > Trace-based Evaluations
Trace-based Evaluations

The trace-based evaluations all take place at the sample rate defined by the "Display Points Per Symbol" parameter (see "Display Points/Sym"). The sampling instants at this rate are referred to as "t" here, i.e.

t=n*TD

where TD equals the duration of one sampling period at the sample rate defined by the "Display Points Per Symbol" parameter.

Test parameter | Formula
Error vector |
Error Vector Magnitude (EVM) | with the normalization contant C depends on your setting. By default C² is the mean power of the reference signal.
Magnitude |
Phase |
Frequency |
Magnitude error |
Phase error |
Frequency error |
FSK Modulation

The trace based results for FSK signals are the same as those available for linear modulation types. However, as the signal processing for FSK signals is performed on the magnitude and instantaneous frequency, the I/Q based results first require a reconstruction of the reference and measured I/Q waveforms, as illustrated in figure "Reconstruction of the reference and measured I/Q waveforms for FSK modulation".

The dashed outline of the "compensate" blocks indicate that these operations are optionally (de-)activated depending on the corresponding user settings. With respect to FSK measurements, the optional compensation parameters are:

  • FSK Reference deviation
  • Carrier frequency drift
Reconstruction of the reference and measured I/Q waveforms for FSK modulation

Note that a reference deviation error is corrected in the reference frequency trace. This ensures that the frequency deviation in the measured frequency trace corresponds to that of the originally measured signal. With respect to the I/Q reconstruction, the measured magnitude is timing compensated using the timing offset estimated from the measured instantaneous frequency. This ensures that the measured magnitude and frequency remain synchronized in the reconstructed I/Q waveform.


Result Summary Evaluations

VSA (R&S FSW-K70) > Annex > Formulae > Result Summary Evaluations
Result Summary Evaluations

The evaluations for the result summary take place at the sample rate defined by the "Display Points Per Symbol" parameter (see "Display Points/Sym"). This value can be one of the following:

  • "1": only the symbol instant contributes to the result
  • "2": two samples per symbol instant contribute to the result (required for offset QPSK)
  • the "Sample rate" defined for data acquisition (see "Sample Rate"): all samples contribute to the result equally

The results are determined by the evaluation range.

The sampling instants at this rate are referred to as "t" here, i.e.

t=n*TD

where TD equals the duration of one sampling period at the sample rate defined by the "Display Points Per Symbol" parameter

Contents
  • PSK, QAM and MSK Modulation
  • FSK Modulation


PSK, QAM and MSK Modulation

VSA (R&S FSW-K70) > Annex > Formulae > Result Summary Evaluations > PSK, QAM and MSK Modulation
PSK, QAM and MSK Modulation

For PSK, QAM and MSK modulation the estimation model is described in detail in chapter "PSK, QAM and MSK Modulation". The parameters of the PSK, QAM and MSK-specific result summary table can be related to the distortion model parameters as follows:

Evaluation of results in the PSK, QAM and MSK result summary
EVM | RMS
 | Peak
Modulation error | RMS
 | Peak
Magnitude error | RMS
 | Peak
Phase error | RMS
 | Peak
RHO (correlation coefficient) |
IQ Offset C |
IQ Imbalance B |
Gain Imbalance G |
Quadrature Error Ɵ |
Amplitude Droop A |


FSK Modulation

VSA (R&S FSW-K70) > Annex > Formulae > Result Summary Evaluations > FSK Modulation
FSK Modulation

For FSK modulation the estimation model is described in detail in section "FSK Modulation". The parameters of the FSK-specific result summary table can be related to the distortion model parameters as follows:

Evaluation of results in the FSK result summary
Frequency Error | RMS |
 | Peak |
Magnitude Error | RMS |
 | Peak |
FSK Deviation Error |  | Estimated FSK deviation error [Hz].
FSK Measurement Deviation |  | Estimated FSK deviation of the meas signal [Hz].
FSK Reference Deviation |  | FSK reference deviation as entered by the user [Hz].
Carrier Frequency Error |  | The carrier frequency error of the measured signal [Hz].
Carrier Frequency Drift |  | The drift in the carrier frequency of the measured signal [Hz/Sym].


Statistical Evaluations for the Result Summary

VSA (R&S FSW-K70) > Annex > Formulae > Statistical Evaluations for the Result Summary
Statistical Evaluations for the Result Summary

The statistical evaluations in the result summary are based on the measurement results that are displayed in the "Current" column. Hence, the index "m" here represents the current evaluation, "M" is the total number of evaluations. In single sweep mode, M coresponds to the statistics count.

If the measurement values are represented in the logarithmic domain, the linear values are averaged. The result is then subsequently converted back into logarithmic domain. The linear values are indicated by the subscript [lin] in "PSK, QAM and MSK Modulation".

 | Mathematical expression | Calculation in R&S FSW
Mean |  | with
Peak | with | with
StdDev σM | with | with
95%ile | Pr() denotes the probability | Sorting the values and giving the 95%ile.


Trace Averaging

VSA (R&S FSW-K70) > Annex > Formulae > Trace Averaging
Trace Averaging

The index "m" represents the current evaluation, "M" is the total number of evaluations. In single sweep mode, M coresponds to the statistics count. The index "s" represents the sth sample within the trace.

If the measurement results are represented in logarithmic domain, the average operation is performed on the linear values. The result is then subsequently converted back into logarithmic domain.

Measurements

Calculation in R&S FSW

RMS Average

  • Error Vector Magnitude (EVM)
  • Meas/Ref magnitude
  • Capture Buffer magnitude

Linear Average

All measurements where trace averaging is possible except for the measurements listed for RMS averaging


Analytically Calculated Filters

VSA (R&S FSW-K70) > Annex > Formulae > Analytically Calculated Filters
Analytically Calculated Filters

The following filters are calculated during runtime of the unit and as a function of the operating parameter Alpha or BT.

Filter Type | Setting Parameter | Impulse Response
Raised cosine (RC) | Alpha (⍺) |
Root raised cosine (RRC) | Alpha (⍺) |
Gaussian filter (Gauss) ETSI TS 100 959 (V8.3.0) | BT | with


Standard-Specific Filters

VSA (R&S FSW-K70) > Annex > Formulae > Standard-Specific Filters
Standard-Specific Filters
Contents
  • Transmit filter
  • Measurement Filter


Transmit filter

VSA (R&S FSW-K70) > Annex > Formulae > Standard-Specific Filters > Transmit filter
Transmit filter
EDGE Tx filter ETSI TS 300 959 (V8.1.2) (Linearized GMSK)

c0(t) is the impulse response of the EDGE transmit filter


Measurement Filter

VSA (R&S FSW-K70) > Annex > Formulae > Standard-Specific Filters > Measurement Filter
Measurement Filter
Contents
  • EDGE Measurement filters
  • Low-ISI Filters


EDGE Measurement filters

VSA (R&S FSW-K70) > Annex > Formulae > Standard-Specific Filters > Measurement Filter > EDGE Measurement filters
EDGE Measurement filters

RC filter, Alpha = 0.25, single-side-band 6 dB bandwith = 90 kHz Windowing by multiplying the impulse response according to the following equation:

The following figure shows the frequency response of the standard-specific measurement filters.


Low-ISI Filters

VSA (R&S FSW-K70) > Annex > Formulae > Standard-Specific Filters > Measurement Filter > Low-ISI Filters
Low-ISI Filters

The following frequency responses are obtained when using a low-ISI measurment filter and the Transmit filter indicated in the title of each diagram.


List of Remote Commands (VSA)

VSA (R&S FSW-K70) > List of Remote Commands (VSA)
List of Remote Commands (VSA)
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber
[SENSe:]DDEMod:APSK:NSTate
[SENSe:]DDEMod:ASK:NSTate
[SENSe:]DDEMod:ECALc:OFFSet
[SENSe:]DDEMod:ECALc[:MODE]
[SENSe:]DDEMod:EPRate:AUTO
[SENSe:]DDEMod:EPRate[:VALue]
[SENSe:]DDEMod:EQUalizer:LENGth
[SENSe:]DDEMod:EQUalizer:LOAD
[SENSe:]DDEMod:EQUalizer:MODE
[SENSe:]DDEMod:EQUalizer:RESet
[SENSe:]DDEMod:EQUalizer:SAVE
[SENSe:]DDEMod:EQUalizer[:STATe]
[SENSe:]DDEMod:FACTory[:VALue]
[SENSe:]DDEMod:FILTer:ALPHa
[SENSe:]DDEMod:FILTer[:STATe]
[SENSe:]DDEMod:FORMat
[SENSe:]DDEMod:FSK:NSTate
[SENSe:]DDEMod:FSYNc:AUTO
[SENSe:]DDEMod:FSYNc:LEVel
[SENSe:]DDEMod:FSYNc:RESult?
[SENSe:]DDEMod:FSYNc[:MODE]
[SENSe:]DDEMod:KDATa:STATe
[SENSe:]DDEMod:KDATa[:NAME]
[SENSe:]DDEMod:MAPPing:CATalog?
[SENSe:]DDEMod:MAPPing[:VALue]
[SENSe:]DDEMod:MFILter:ALPHa
[SENSe:]DDEMod:MFILter:AUTO
[SENSe:]DDEMod:MFILter:NAME
[SENSe:]DDEMod:MFILter:USER
[SENSe:]DDEMod:MFILter[:STATe]
[SENSe:]DDEMod:MSK:FORMat
[SENSe:]DDEMod:NORMalize:ADRoop
[SENSe:]DDEMod:NORMalize:CFDRift
[SENSe:]DDEMod:NORMalize:CHANnel
[SENSe:]DDEMod:NORMalize:FDERror
[SENSe:]DDEMod:NORMalize:IQIMbalance
[SENSe:]DDEMod:NORMalize:IQOFfset
[SENSe:]DDEMod:NORMalize:SRERror
[SENSe:]DDEMod:NORMalize[:VALue]
[SENSe:]DDEMod:OPTimization
[SENSe:]DDEMod:PRATe
[SENSe:]DDEMod:PRESet:RLEVel
[SENSe:]DDEMod:PRESet:RLEVel
[SENSe:]DDEMod:PRESet[:STANdard]
[SENSe:]DDEMod:PSK:FORMat
[SENSe:]DDEMod:PSK:NSTate
[SENSe:]DDEMod:QAM:FORMat
[SENSe:]DDEMod:QAM:NSTate
[SENSe:]DDEMod:QPSK:FORMat
[SENSe:]DDEMod:RLENgth:AUTO
[SENSe:]DDEMod:RLENgth[:VALue]
[SENSe:]DDEMod:SBANd
[SENSe:]DDEMod:SEARch:BURSt:AUTO
[SENSe:]DDEMod:SEARch:BURSt:CONFigure:AUTO
[SENSe:]DDEMod:SEARch:BURSt:GLENgth[:MINimum]
[SENSe:]DDEMod:SEARch:BURSt:LENGth:MAXimum
[SENSe:]DDEMod:SEARch:BURSt:LENGth[:MINimum]
[SENSe:]DDEMod:SEARch:BURSt:MODE
[SENSe:]DDEMod:SEARch:BURSt:SKIP:FALLing
[SENSe:]DDEMod:SEARch:BURSt:SKIP:RISing
[SENSe:]DDEMod:SEARch:BURSt:STATe
[SENSe:]DDEMod:SEARch:BURSt:TOLerance
[SENSe:]DDEMod:SEARch:MBURst:CALC
[SENSe:]DDEMod:SEARch:MBURst:STARt?
[SENSe:]DDEMod:SEARch:PATTern:CONFigure:AUTO
[SENSe:]DDEMod:SEARch:PATTern:SYNC:AUTO
[SENSe:]DDEMod:SEARch:PATTern:SYNC[:STATe]
[SENSe:]DDEMod:SEARch:SYNC:AUTO
[SENSe:]DDEMod:SEARch:SYNC:CATalog
[SENSe:]DDEMod:SEARch:SYNC:COMMent
[SENSe:]DDEMod:SEARch:SYNC:COPY
[SENSe:]DDEMod:SEARch:SYNC:DATA
[SENSe:]DDEMod:SEARch:SYNC:DELete
[SENSe:]DDEMod:SEARch:SYNC:IQCThreshold
[SENSe:]DDEMod:SEARch:SYNC:MODE
[SENSe:]DDEMod:SEARch:SYNC:NAME
[SENSe:]DDEMod:SEARch:SYNC:NSTate
[SENSe:]DDEMod:SEARch:SYNC:PATTern:ADD
[SENSe:]DDEMod:SEARch:SYNC:PATTern:REMove
[SENSe:]DDEMod:SEARch:SYNC:SELect
[SENSe:]DDEMod:SEARch:SYNC:STATe
[SENSe:]DDEMod:SEARch:SYNC:TEXT
[SENSe:]DDEMod:SIGNal:PATTern
[SENSe:]DDEMod:SIGNal[:VALue]
[SENSe:]DDEMod:SRATe
[SENSe:]DDEMod:STANdard:COMMent
[SENSe:]DDEMod:STANdard:DELete
[SENSe:]DDEMod:STANdard:PREset[:VALue]
[SENSe:]DDEMod:STANdard:SAVE
[SENSe:]DDEMod:STANdard:SYNC:OFFSet:STATe
[SENSe:]DDEMod:STANdard:SYNC:OFFSet[:VALue]
[SENSe:]DDEMod:TFILter:ALPHa
[SENSe:]DDEMod:TFILter:NAME
[SENSe:]DDEMod:TFILter:USER
[SENSe:]DDEMod:TFILter[:STATe]
[SENSe:]DDEMod:TIME
[SENSe:]DDEMod:USER:NAME
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold
[SENSe:]MIXer[:STATe]
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]SWAPiq
[SENSe:]SWEep:COUNt:CURRent
[SENSe:]SWEep:COUNt[:VALue]
ABORt
CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate<n>:BERate
CALCulate<n>:DDEM:SPECtrum[:STATe]
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MAXimum:APEak
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:ABSolute?
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<q>:Y?
CALCulate<n>:ELIN<startstop>:STATe
CALCulate<n>:ELIN<startstop>[:VALue]
CALCulate<n>:FEED
CALCulate<n>:FORMat
CALCulate<n>:FSK:DEViation:COMPensation
CALCulate<n>:FSK:DEViation:REFerence:RELative
CALCulate<n>:FSK:DEViation:REFerence[:VALue]
CALCulate<n>:LIMit:MACCuracy:<ResultType>:<LimitType>:STATe
CALCulate<n>:LIMit:MACCuracy:<ResultType>:<LimitType>[:RESUlt]
CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:STATe
CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:CFERror:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:CFERror:MEAN:STATe
CALCulate<n>:LIMit:MACCuracy:CFERror:MEAN:VALue
CALCulate<n>:LIMit:MACCuracy:CFERror:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:CFERror:PEAK:STATe
CALCulate<n>:LIMit:MACCuracy:CFERror:PEAK:VALue
CALCulate<n>:LIMit:MACCuracy:CFERror:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:DEFault
CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:PCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:PMEan:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:PMEan:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:PPEak:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:PPEak:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:PPEak[:RESUlt]?
CALCulate<n>:LIMit:MACCuracy:EVM:RCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:RCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:RMEan:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:RMEan:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:EVM:RPEak:STATe
CALCulate<n>:LIMit:MACCuracy:EVM:RPEak:VALue
CALCulate<n>:LIMit:MACCuracy:EVM:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent:STATe
CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:FDERror:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FDERror:MEAN:STATe
CALCulate<n>:LIMit:MACCuracy:FDERror:MEAN:VALue
CALCulate<n>:LIMit:MACCuracy:FDERror:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FDERror:PEAK:STATe
CALCulate<n>:LIMit:MACCuracy:FDERror:PEAK:VALue
CALCulate<n>:LIMit:MACCuracy:FDERror:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:PCURrent[:RESUlt]?
CALCulate<n>:LIMit:MACCuracy:FERRor:PMEan:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:PMEan:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:PPEak:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:PPEak:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:PPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:RCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:RCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:RMEan:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:RMEan:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:FERRor:RPEak:STATe
CALCulate<n>:LIMit:MACCuracy:FERRor:RPEak:VALue
CALCulate<n>:LIMit:MACCuracy:FERRor:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:PCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:PMEan:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:PMEan:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:PPEak:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:PPEak:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:PPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:RCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:RCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:RMEan:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:RMEan:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:MERRor:RPEak:STATe
CALCulate<n>:LIMit:MACCuracy:MERRor:RPEak:VALue
CALCulate<n>:LIMit:MACCuracy:MERRor:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent:STATe
CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:OOFFset:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:OOFFset:MEAN:STATe
CALCulate<n>:LIMit:MACCuracy:OOFFset:MEAN:VALue
CALCulate<n>:LIMit:MACCuracy:OOFFset:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:OOFFset:PEAK:STATe
CALCulate<n>:LIMit:MACCuracy:OOFFset:PEAK:VALue
CALCulate<n>:LIMit:MACCuracy:OOFFset:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:PCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:PMEan:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:PMEan:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:PMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:PPEak:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:PPEak:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:PPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:RCURrent:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:RCURrent:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:RCURrent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:RMEan:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:RMEan:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:RMEan[:RESult]?
CALCulate<n>:LIMit:MACCuracy:PERRor:RPEak:STATe
CALCulate<n>:LIMit:MACCuracy:PERRor:RPEak:VALue
CALCulate<n>:LIMit:MACCuracy:PERRor:RPEak[:RESult]?
CALCulate<n>:LIMit:MACCuracy:RHO:CURRent:STATe
CALCulate<n>:LIMit:MACCuracy:RHO:CURRent:VALue
CALCulate<n>:LIMit:MACCuracy:RHO:CURRent[:RESult]?
CALCulate<n>:LIMit:MACCuracy:RHO:MEAN:STATe
CALCulate<n>:LIMit:MACCuracy:RHO:MEAN:VALue
CALCulate<n>:LIMit:MACCuracy:RHO:MEAN[:RESult]?
CALCulate<n>:LIMit:MACCuracy:RHO:PEAK:STATe
CALCulate<n>:LIMit:MACCuracy:RHO:PEAK:VALue
CALCulate<n>:LIMit:MACCuracy:RHO:PEAK[:RESult]?
CALCulate<n>:LIMit:MACCuracy:STATe
CALCulate<n>:MARKer:SEARch
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ADRoop?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:ALL?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:CFERror?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:EVM?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FDERror?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:CFDRift?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:DERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:MDEViation?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:FSK:RDEViation?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:GIMBalance?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:IQIMbalance?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:MPOWer?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:OOFFset?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:PERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:QERRor?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:RHO?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SNR?
CALCulate<n>:MARKer<m>:FUNCtion:DDEMod:STATistic:SRERror?
CALCulate<n>:MARKer<m>:LINK
CALCulate<n>:MARKer<m>:MAXimum:APEak
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:STATistics:CCDF[:STATe]
CALCulate<n>:STATistics:MODE
CALCulate<n>:STATistics:PRESet
CALCulate<n>:STATistics:SCALe:AUTO ONCE
CALCulate<n>:STATistics:SCALe:X:BCOunt
CALCulate<n>:STATistics:SCALe:Y:LOWer
CALCulate<n>:STATistics:SCALe:Y:UNIT
CALCulate<n>:STATistics:SCALe:Y:UPPer
CALCulate<n>:TRACe<t>:ADJust:ALIGnment:OFFSet
CALCulate<n>:TRACe<t>:ADJust:ALIGnment[:DEFault]
CALCulate<n>:TRACe<t>:ADJust[:VALue]
CALCulate<n>:TRACe<t>[:VALue]
CALCulate<n>:UNIT:ANGLe
CALCulate<n>:X:UNIT:TIME
CALCulate<n>:Y:UNIT:TIME
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
DISPlay:FORMat
DISPlay[:WINDow<n>]:ITEM[:LINE][:VALue]
DISPlay[:WINDow<n>]:PRATe:AUTO
DISPlay[:WINDow<n>]:PRATe[:VALue]
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:SYMBol
DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STARt?
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:STOP?
DISPlay[:WINDow<n>]:TRACe<t>:X[:SCALe]:VOFFset
DISPlay[:WINDow<n>]:TRACe<t>:Y[:SCALe]:AUTO:ALL
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:MODE
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFMeas
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:TYPe?
MMEMory:LOAD:IQ:STATe
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe
MMEMory:STORe<n>:TRACe
OUTPut:DIQ
OUTPut:DIQ:CDEVice
OUTPut:IF:SBANd?
STATus:QUEStionable:ACPLimit:CONDition?
STATus:QUEStionable:ACPLimit:ENABle
STATus:QUEStionable:ACPLimit:NTRansition
STATus:QUEStionable:ACPLimit:PTRansition
STATus:QUEStionable:ACPLimit[:EVENt]?
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:FREQuency:CONDition?
STATus:QUEStionable:FREQuency:ENABle
STATus:QUEStionable:FREQuency:NTRansition
STATus:QUEStionable:FREQuency:PTRansition
STATus:QUEStionable:FREQuency[:EVENt]?
STATus:QUEStionable:LIMit<m> [:EVENt]?
STATus:QUEStionable:LIMit<m>:CONDition?
STATus:QUEStionable:LIMit<m>:ENABle
STATus:QUEStionable:LIMit<m>:NTRansition
STATus:QUEStionable:LIMit<m>:PTRansition
STATus:QUEStionable:LMARgin<m>:CONDition?
STATus:QUEStionable:LMARgin<m>:ENABle
STATus:QUEStionable:LMARgin<m>:NTRansition
STATus:QUEStionable:LMARgin<m>:PTRansition
STATus:QUEStionable:LMARgin<m>[:EVENt]?
STATus:QUEStionable:MODulation<n>:CFRequency:CONDition?
STATus:QUEStionable:MODulation<n>:CFRequency:ENABle
STATus:QUEStionable:MODulation<n>:CFRequency:NTRansition
STATus:QUEStionable:MODulation<n>:CFRequency:PTRansition
STATus:QUEStionable:MODulation<n>:CFRequency[:EVENt]?
STATus:QUEStionable:MODulation<n>:CONDition?
STATus:QUEStionable:MODulation<n>:ENABle
STATus:QUEStionable:MODulation<n>:EVM:CONDition?
STATus:QUEStionable:MODulation<n>:EVM:ENABle
STATus:QUEStionable:MODulation<n>:EVM:NTRansition
STATus:QUEStionable:MODulation<n>:EVM:PTRansition
STATus:QUEStionable:MODulation<n>:EVM[:EVENt]?
STATus:QUEStionable:MODulation<n>:FSK:CONDition?
STATus:QUEStionable:MODulation<n>:FSK:ENABle
STATus:QUEStionable:MODulation<n>:FSK:NTRansition
STATus:QUEStionable:MODulation<n>:FSK:PTRansition
STATus:QUEStionable:MODulation<n>:FSK[:EVENt]?
STATus:QUEStionable:MODulation<n>:IQRHo:CONDition?
STATus:QUEStionable:MODulation<n>:IQRHo:ENABle
STATus:QUEStionable:MODulation<n>:IQRHo:NTRansition
STATus:QUEStionable:MODulation<n>:IQRHo:PTRansition
STATus:QUEStionable:MODulation<n>:IQRHo[:EVENt]?
STATus:QUEStionable:MODulation<n>:MAGNitude:CONDition?
STATus:QUEStionable:MODulation<n>:MAGNitude:ENABle
STATus:QUEStionable:MODulation<n>:MAGNitude:NTRansition
STATus:QUEStionable:MODulation<n>:MAGNitude:PTRansition
STATus:QUEStionable:MODulation<n>:MAGNitude[:EVENt]?
STATus:QUEStionable:MODulation<n>:NTRansition
STATus:QUEStionable:MODulation<n>:PHASe:CONDition?
STATus:QUEStionable:MODulation<n>:PHASe:ENABle
STATus:QUEStionable:MODulation<n>:PHASe:NTRansition
STATus:QUEStionable:MODulation<n>:PHASe:PTRansition
STATus:QUEStionable:MODulation<n>:PHASe[:EVENt]?
STATus:QUEStionable:MODulation<n>:PTRansition
STATus:QUEStionable:MODulation<n>[:EVENt]?
STATus:QUEStionable:POWer:CONDition?
STATus:QUEStionable:POWer:ENABle
STATus:QUEStionable:POWer:NTRansition
STATus:QUEStionable:POWer:PTRansition
STATus:QUEStionable:POWer[:EVENt]?
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC[:EVENt]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe:IQ:WBANd:MBWIDTH
TRACe:IQ:WBANd[:STATe]
TRACe<n>:IQ:BWIDth?
TRACe<n>[:DATA]
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


Legal Notice

R&S®FSW-K70
Vector Signal Analysis
Version:
2.10 and higher

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.